Chapter 3
Using Styles and Templates
Copyright

This document is Copyright © 2005–2010 by its contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Jean Hollis Weber
Michele Zarri
Agnes Belzunce
Daniel Carrera
Peter Hillier-Brook
Peter Kupfer
Gary Schnabl
Janet Swisher

Feedback

Please direct any comments or suggestions about this document to: authors@documentation.openoffice.org

Publication date and software version

Published 15 November 2010. Based on OpenOffice.org 3.3.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows/Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>OpenOffice.org &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click</td>
<td>Open context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open Styles &amp; Formatting window</td>
</tr>
</tbody>
</table>

You can download an editable version of this document from http://oooaauthors.org/english/userguide3/published/
# Contents

Copyright.................................................................................................................... 2  
Note for Mac users........................................................................................................ 2  
What is a template?....................................................................................................... 5  
What are styles?............................................................................................................. 5  
Applying styles............................................................................................................. 6  
  Using the Styles and Formatting window............................................................... 6  
  Using Fill Format mode......................................................................................... 7  
  Using the Apply Style list...................................................................................... 7  
  Using keyboard shortcuts...................................................................................... 8  
Modifying styles.......................................................................................................... 8  
  Changing a style using the Style dialog............................................................... 9  
  Updating a style from a selection......................................................................... 9  
  Using AutoUpdate................................................................................................. 9  
  Updating styles from a document or template.................................................... 9  
Creating new (custom) styles.................................................................................... 10  
  Creating a new style using the Style dialog....................................................... 10  
  Creating a new style from a selection.................................................................. 10  
  Dragging and dropping to create a style............................................................ 11  
Copying and moving styles....................................................................................... 11  
  Using the Template Management dialog......................................................... 11  
  Loading styles from a template or document..................................................... 12  
Deleting styles........................................................................................................ 13  
Using a template to create a document.................................................................. 14  
Creating a template.................................................................................................. 15  
  Creating a template from a document............................................................. 15  
  Creating a template using a wizard...................................................................... 16  
Editing a template..................................................................................................... 17  
  Updating a document from a changed template............................................... 17  
Adding templates using the Extension Manager.................................................... 18  
Setting a default template....................................................................................... 19  
  Setting a custom template as the default......................................................... 19  
  Resetting the default template........................................................................... 20  
Associating a document with a different template............................................... 20  
Organizing templates............................................................................................... 21  
  Creating a template folder.................................................................................. 21  
  Deleting a template folder.................................................................................. 21  
  Moving a template............................................................................................... 21  
  Deleting a template.............................................................................................. 22  
  Importing a template............................................................................................ 22  
  Exporting a template............................................................................................ 22
Examples of style use........................................................................................................................................... 22
Defining a different first page for a document................................................................................................. 22
Dividing a document into chapters.................................................................................................................. 23
Changing page orientation within a document.................................................................................................. 23
Different headers on right and left pages........................................................................................................... 23
Controlling page breaks automatically............................................................................................................... 24
Compiling an automatic table of contents......................................................................................................... 24
Defining a sequence of styles............................................................................................................................. 24
What is a template?

A *template* is a model that you use to create other documents. For example, you can create a template for business reports that has your company’s logo on the first page. New documents created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

All documents in OpenOffice.org (OOo) are based on templates. You can create a specific template for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template when you start a new document, then the document is based on the default template for that type of document. If you have not specified a default template, OOo uses the blank template for that type of document that is installed with OOo. See “Setting a default template” on page 19 for more information.

What are styles?

A *style* is a set of formats that you can apply to selected pages, text, frames, and other elements in your document to quickly change their appearance. When you apply a style, you apply a whole group of formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other parts of their documents without paying any attention to styles. They are used to writing documents according to physical attributes. For example, you might specify the font family, font size, and any formatting such as bold or italic.

Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New Roman, bold, centered”, and you start saying “Title” because you have defined the “Title” style to have those characteristics. In other words, styles means that you shift the emphasis from what the text (or page, or other element) looks like, to what the text is.

Styles help improve consistency in a document. They also make major formatting changes easy. For example, you may decide to change the indentation of all paragraphs, or change the font of all titles. For a long document, this simple task can be prohibitive. Styles make the task easy.

In addition, styles are used by OpenOffice.org for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents. Some common examples of style use are given in “Examples of style use” on page 22.

OpenOffice.org supports the following types of styles:

- **Page styles** include margins, headers and footers, borders and backgrounds. In Calc, page styles also include the sequence for printing sheets.
- **Paragraph styles** control all aspects of a paragraph’s appearance, such as text alignment, tab stops, line spacing, and borders, and can include character formatting.
- **Character styles** affect selected text within a paragraph, such as the font and size of text, or bold and italic formats.
- **Frame styles** are used to format graphic and text frames, including wrapping type, borders, backgrounds, and columns.
• **Numbering styles** apply similar alignment, numbering or bullet characters, and fonts to numbered or bulleted lists.

• **Cell styles** include fonts, alignment, borders, background, number formats (for example, currency, date, number), and cell protection.

• **Graphics styles** in drawings and presentations include line, area, shadowing, transparency, font, connectors, dimensioning, and other attributes.

• **Presentation styles** include attributes for font, indents, spacing, alignment, and tabs.

Different styles are available in the various components of OOo, as listed in Table 1.

OpenOffice.org comes with many predefined styles. You can use the styles as provided, modify them, or create new styles, as described in this chapter.

### Table 1. Styles available in OOo components

<table>
<thead>
<tr>
<th>Style Type</th>
<th>Writer</th>
<th>Calc</th>
<th>Draw</th>
<th>Impress</th>
</tr>
</thead>
<tbody>
<tr>
<td>Page</td>
<td>X</td>
<td></td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Paragraph</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Character</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Frame</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Numbering</td>
<td>X</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cell</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Presentation</td>
<td>X</td>
<td>X</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Graphics</td>
<td>(included in Frame styles)</td>
<td></td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

### Applying styles

OpenOffice.org provides several ways for you to select styles to apply.

#### Using the Styles and Formatting window

1) Click the **Styles and Formatting** icon located at the left-hand end of the object bar, or click **Format > Styles and Formatting**, or press *F11*. The Styles and Formatting window shows the types of styles available for the OOo component you are using. Figure 1 shows the window for Writer, with Page Styles visible.

You can move this window to a convenient position on the screen or dock it to an edge (hold down the *Ctrl* key and drag it by the title bar to where you want it docked).

2) Click on one of the icons at the top left of the Styles and Formatting window to display a list of styles in a particular category.

3) To apply an existing style (except for character styles), position the insertion point in the paragraph, frame, or page, and then double-click on the name of the style in one of these lists. To apply a character style, select the characters first.
Tip
At the bottom of the Styles and Formatting window is a dropdown list. In Figure 1 the window shows Automatic, meaning the list includes only styles applied automatically by OOo. You can choose to show all styles or other groups of styles, for example only custom styles.

![Styles and Formatting window](image)

**Figure 1**: The Styles and Formatting window for Writer, showing paragraph styles

### Using Fill Format mode

Use Fill Format to apply a style to many different areas quickly without having to go back to the Styles and Formatting window and double-click every time. This method is quite useful when you need to format many scattered paragraphs, cells, or other items with the same style.

1. Open the Styles and Formatting window and select the style you want to apply.
2. Click the **Fill Format mode** icon.
3. To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or frame and click. To apply a character style, hold down the mouse button while selecting the characters. Clicking on a word applies the character style for that word. Repeat step 3 until you made all the changes for that style.
4. To quit Fill Format mode, click the **Fill Format mode** icon again or press the **Esc** key.

**Caution**
When this mode is active, a right-click anywhere in the document undoes the last Fill Format action. Be careful not to accidentally right-click and thus undo actions you want to keep.

### Using the Apply Style list

After you have used a style at least once in a document, the style name appears on the Apply Style list at the left-hand end of the Formatting toolbar, next to the Styles and Formatting icon.
You can open this list and click once on the style you want, or you can use the up and down arrow keys to move through the list and then press Enter to apply the highlighted style.

**Tip** Select More... at the bottom of the list to open the Styles and Formatting window.

![Apply Style list on the Formatting toolbar](image)

*Figure 2: The Apply Style list on the Formatting toolbar*

**Using keyboard shortcuts**

Some keyboard shortcuts for applying styles are predefined. For example, in Writer Control+0 applies the Text body style, Control+1 applies the Heading 1 style, and Control+2 applies the Heading 2 style. You can modify these shortcuts and create your own; see Chapter 14 (Customizing OpenOffice.org) for instructions.

**Modifying styles**

OpenOffice.org provides several ways to modify styles (both the predefined styles and custom styles that you create):

- Changing a style using the Style dialog
- Updating a style from a selection
- Use AutoUpdate (paragraph and frame styles only)
- Load or copy styles from another document or template

**Tip** Any changes you make to a style are effective only in the current document. To change styles in more than one document, you need to change the template or copy the styles into the other documents as described on page 11.
Changing a style using the Style dialog
To change an existing style using the Style dialog, right-click on the required style in the Styles and Formatting window and select Modify from the pop-up menu.

The Style dialog displayed depends on the type of style selected. Each style dialog has several tabs. See the chapters on styles in the user guides for details.

Updating a style from a selection
To update a style from a selection:

1) Open the Styles and Formatting window.
2) In the document, select an item that has the format you want to adopt as a style.

Caution Make sure that there are unique properties in this paragraph. For example, if there are two different font sizes or font styles, that particular property will remain the same as before.

3) In the Styles and Formatting window, select the style you want to update (single-click, not double-click), then long-click on the arrow next to the New Style from Selection icon and click on Update Style.

Using AutoUpdate
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a paragraph or frame using this style in your document automatically updates the style itself.

Tip If you are in the habit of manually overriding styles in your document, be sure that AutoUpdate is not enabled.

Updating styles from a document or template
You can update styles by copying or loading them from a template or another document. See “Copying and moving styles” on page 11.
Creating new (custom) styles

You may want to add some new styles. You can do this in two ways:

- Creating a new style using the Style dialog
- Creating a new style from a selection

Creating a new style using the Style dialog

To create a new style using the Style dialog, right-click in the Styles and Formatting window and select **New** from the pop-up menu.

If you want your new style to be linked with an existing style, first select that style and then right-click and select **New**.

If you link styles, then when you change the base style (for example, by changing the font from Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you want; other times you do not want the changes to apply to all the linked styles. It pays to plan ahead.

The dialogs and choices are the same for defining new styles and for modifying existing styles. See the chapters on styles in the user guides for details.

Creating a new style from a selection

You can create a new style by copying an existing manual format. This new style applies only to this document; it will not be saved in the template.

1) Open the Styles and Formatting window and choose the type of style you want to create.

2) In the document, select the item you want to save as a style.

3) In the Styles and Formatting window, click on the **New Style from Selection** icon.

4) In the Create Style dialog, type a name for the new style. The list shows the names of existing custom styles of the selected type. Click **OK** to save the new style.

![Create Style dialog](image)

*Figure 4: Naming a new style created from a selection*
Dragging and dropping to create a style

You can drag and drop a text selection into the Styles and Formatting window to create a new style.

**Writer**
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are active, the paragraph style will be added to the list. If Character Styles are active, the character style will be added to the list.

**Calc**
Drag a cell selection to the Styles and Formatting window to create cell styles.

**Draw/Impress**
Select and drag drawing objects to the Styles and Formatting window to create graphics styles.

Copying and moving styles

You can copy or move styles from one template or document into another template or document, in two ways:

- Using the Template Management dialog
- Loading styles from a template or document

Using the Template Management dialog

To copy or move styles using the Template Management dialog:

1. Click **File > Templates > Organize**.
2. In the Template Management dialog (Figure 5), set the lists at the bottom to either Templates or Documents, as needed. The default is Templates on the left and Documents on the right.

**Tip**
To copy styles from a file that is not open, click the **File** button. When you return to this dialog, both lists show the selected file as well as all the currently open documents.

3. Open the folders and find the templates from and to which you want to copy. Double-click on the name of the template or document, and then double-click the Styles icon to show the list of individual styles (Figure 6).
4. To copy a style, hold down the *Ctrl* key and drag the name of the style from one list to the other.

**Caution**
If you do not hold down the *Control* key when dragging, the style will be moved from one list to the other. The style will be deleted from the list you are dragging it from.

5. Repeat for each style you want to copy. If the receiving template or document has many styles, you may not see any change unless you scroll down in the list. When you are finished, click **Close**.
Loading styles from a template or document

You can copy styles by loading them from a template or another document:

1) Open the document you want to copy styles into.
2) In the Styles and Formatting window, long-click on the arrow next to the New Style from Selection icon, and then click on Load Styles (see Figure 3).
3) On the Load Styles dialog (Figure 7), find and select the template you want to copy styles from.
4) Select the categories of styles to be copied. Select **Overwrite** if you want the styles being copied to replace any styles of the same names in the document you are copying them into.

5) Click **OK** to copy the styles. You will not see any change on screen.

---

**Note**
To copy the styles from another document, click the **From File** button to open a window from which you can select the required document.

---

**Caution**
If your document has a table of contents, and if you have used custom styles for headings, the heading levels associated with outline levels (in **Tools > Outline Numbering**) will revert to the defaults of Heading 1, Heading 2, and so on when you load styles this way. You will need to change these back to your custom heading styles. This is a bug.

---

### Deleting styles

You cannot remove (delete) any of OOo’s predefined styles from a document or template, even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make sure the styles are not in use. If an unwanted style is in use, you will want to replace it with a substitute style.

To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting window and click **Delete** on the pop-up menu.

If the style is in use, you receive a warning message.

---

**Caution**
Make sure the style is not in use before deletion. Otherwise, all objects with that style will return to the default style and retain their formatting as manual formatting. This can be a problem in a long document.

If the style is not in use, you receive a confirmation message; click **Yes**.
Using a template to create a document

To use a template to create a document:

1) From the main menu, choose **File > New > Templates and Documents.** The Templates and Documents dialog opens.

2) In the box on the left, click the **Templates** icon if it is not already selected. A list of template folders appears in the center box.

3) Double-click the folder that contains the template that you want to use. A list of all the templates contained in that folder appears in the center box.

4) Select the template that you want to use. You can preview the selected template or view the template’s properties:

   • To preview the template, click the **Preview** icon. A preview of the template appears in the box on the right.
   • To view the template’s properties, click the **Document Properties** icon. The template’s properties appear in the box on the right.

5) Click **Open.** The Templates and Documents dialog closes and a new document based on the selected template opens in OOo. You can then edit and save the new document just as you would any other document.

![Figure 8: Templates and Documents window](image-url)
Creating a template

You can create your own templates in two ways: from a document, and using a wizard.

Creating a template from a document

To create a template from a document:

1) Open a new or existing document of the type you want to make into a template (text document, spreadsheet, drawing, presentation).
2) Add the content and styles that you want.
3) From the main menu, choose File > Templates > Save. The Templates dialog opens (see Figure 9).
4) In the New template field, type a name for the new template.
5) In the Categories list, click the category to which you want to assign the template. The category you choose has no effect on the template itself; it is simply the folder in which you save the template. Choosing an appropriate category makes it easier to find the template when you want to use it. For example, you might save Impress templates under the Presentations category.
   To learn more about template folders, see “Organizing templates” on page 21.
6) Click OK to save the new template.

Any settings that can be added to or modified in a document can be saved in a template. For example, below are some of the settings (although not a full list) that can be included in a Writer document and then saved as a template for later use:

- Printer settings: which printer, single sided / double sided, and paper size, and so on
- Styles to be used, including character, page, frame, numbering and paragraph styles
- Format and settings regarding indexes, tables, bibliographies, table of contents

Templates can also contain predefined text, saving you from having to type it every time you create a new document. For example, a letter template may contain your name, address and salutation.
You can also save menu and toolbar customizations in templates; see Chapter 14 (Customizing OpenOffice.org) for more information.

**Creating a template using a wizard**

You can use wizards to create templates for letters, faxes, agendas, presentations, and Web pages.

For example, the Fax Wizard guides you through the following choices:

- Type of fax (business or personal)
- Document elements like the date, subject line (business fax), salutation, and complementary close
- Options for sender and recipient information (business fax)
- Text to include in the footer (business fax)

To create a template using a wizard:

1. From the main menu, choose **File > Wizards > [type of template required]**.

   ![](image)

   *Figure 10. Creating a template using a wizard*

2. Follow the instructions on the pages of the wizard. This process is slightly different for each type of template, but the format is very similar.

3. In the last section of the wizard, you can specify the name and location for saving the template. The default location is your user templates directory, but you can choose a different location if you prefer.

4. Finally, you have the option of creating a new document from your template immediately, or manually changing the template. For future documents, you can re-use the template created by the wizard, just as you would use any other template.
Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to documents that were created from that template. (Note that you can only reapply styles. You cannot reapply content.)

To edit a template:

1) From the main menu, choose File > Templates > Edit. A standard file browser window opens.

2) Select the template that you want to edit.

3) Edit the template just as you would any other document. To save your changes, choose File > Save from the main menu.

Updating a document from a changed template

The next time you open a document that was created from the changed template, the following message appears.

![Figure 11. Update styles message](image)

Click Update Styles to apply the template’s changed styles to the document. Click Keep Old Styles if you do not want to apply the template’s changed styles to the document (but see Caution notice below).

If you choose Keep Old Styles in the message box shown in Figure 11, that message will not appear again the next time you open the document after changing the template it is based on. You will not get another chance to update the styles from the template, although you can use the macro given in the Note below to re-enable this feature.

If you are using Writer, you can also use the Template Changer extension (see page 20) to re-activate the template.

Caution

If you choose Keep Old Styles in the message box shown in Figure 11, that message will not appear again the next time you open the document after changing the template it is based on. You will not get another chance to update the styles from the template, although you can use the macro given in the Note below to re-enable this feature.
Note

To re-enable updating from a template:

1) Use **Tools > Macros > Organize Macros > OpenOffice.org Basic**. Select the document from the list, click the expansion symbol (+ or triangle), and select Standard. If Standard has an expansion symbol beside it, click that and select a module.

2) If the **Edit** button is active, click it. If the Edit button is not active, click **New**.

3) In the Basic window, enter the following:

   ```vba
   Sub FixDocV3
   ' set UpdateFromTemplate
   oDocSettings = ThisComponent.createInstance( _
   "com.sun.star.document.Settings"
   )
   oDocSettings.UpdateFromTemplate = True
   End Sub 'FixDocV3
   ```

4) Click the **Run BASIC** icon, then close the Basic window.

5) Save the document.

Next time when you open this document you will have the update from template feature back.

Adding templates using the Extension Manager

The Extension Manager provides an easy way to install collections of templates, graphics, macros, or other add-ins that have been “packaged” into files with a .OXT extension. See Chapter 14 (Customizing OpenOffice.org) for more about the Extension Manager.

This Web page lists many of the available extensions: [http://extensions.services.openoffice.org/](http://extensions.services.openoffice.org/).

To install an extension, follow these steps:

1) Download an extension package and save it anywhere on your computer.

2) In OOo, select **Tools > Extension Manager** from the menu bar. In the Extension Manager dialog, click **Add**.

3) A file browser window opens. Find and select the package of templates you want to install and click **Open**. The package begins installing. You may be asked to accept a license agreement.

4) When the package installation is complete, the templates are available for use through **File > New > Templates and Documents** and the extension is listed in the Extension Manager.
If you create a document by choosing **File > New > Text Document** (or **Spreadsheet**, **Presentation**, or **Drawing**) from the main menu, OOo creates the document from the Default template for that type of document. You can, however, set a custom template to be the default. You can reset the default later if you choose.

### Setting a custom template as the default

You can set any template to be the default, as long as it is in one of the folders displayed in the Template Management dialog.

To set a custom template as the default:

1. From the main menu, choose **File > Templates > Organize**. The Template Management dialog opens.
2. In the box on the left, select the folder containing the template that you want to set as the default, then select the template.
3. Click the **Commands** button and choose **Set As Default Template** from the drop-down menu.

The next time that you create a document by choosing **File > New**, the document will be created from this template.

Although many important settings can be changed in the Options dialog (see Chapter 2), for example default fonts and page size, more advanced settings (such as page margins) can only be changed by replacing the default template with a new one.
Resetting the default template

To re-enable OOo’s Default template for a document type as the default:

1) In the Template Management dialog, click any folder in the box on the left.
2) Click the **Commands** button and choose **Reset Default Template** from the drop-down menu.

The next time that you create a document by choosing **File > New**, the document will be created from OOo’s Default template for that document type.

Associating a document with a different template

At times you might want to associate a document with a different template, or perhaps you are working with a document that did not start from a template.

One of the major advantages of using templates is the ease of updating styles in more than one document, as described on page 17. If you update styles by loading a new set of styles from a different template (as described on page 12), the document has no association with the template from which the styles were loaded—so you cannot use this method. What you need to do is associate the document with the different template.

You can do this in two ways. In both cases, for best results the names of styles should be the same in the existing document and the new template. If they are not, you will need to use Search and Replace to replace old styles with new ones. See Chapter 4 (Getting Started with Writer) for more about replacing styles using Search and Replace.

**Method 1**

This method includes any graphics and wording (such as legal notices) that exists in the new template, as well as including styles. If you do not want this material, you need to delete it.

1) Use **File > New > Templates and Documents**. Choose the template you want. If the template has unwanted text or graphics in it, delete them.
2) Open the document you want to change. (It opens in a new window.) Press **Control+A** to select everything in the document. Paste into the blank document created in step 1.
3) Update the table of contents, if there is one. Save the file.

**Method 2 (Writer only)**

This method does not include any graphics or text from the new template; it simply includes styles from the new template and establishes an association between the template and the document.

1) Download the Template Changer extension from [http://extensions.services.openoffice.org/](http://extensions.services.openoffice.org/) and install it as described on page 18.
2) Close and reopen OpenOffice.org. Now the **File > Templates** menu has two new choices in Writer: **Assign Template (current document)** and **Assign Template (folder)**. In Calc, Impress, and Draw, only the **Assign Template (folder)** choice is available.
3) Open the document whose template you want to change. Choose **File > Templates > Assign Template (current document)**.
4) In the Select Template window, find and select the required template and click Open.
5) Save the document. If you now look in File > Properties, you will see the new template listed at the bottom of the General page.

Organizing templates

OOo can only use templates that are in OOo template folders. You can create new OOo template folders and use them to organize your templates. For example, you might have one template folder for report templates and another for letter templates. You can also import and export templates.

To begin, choose File > Templates > Organize from the main menu. The Template Management dialog opens.

Note: All the actions made by the Commands button in the Template Management dialog can be made as well by right-clicking on the templates or the folders.

Creating a template folder

To create a template folder:

1) In the Template Management dialog, click any folder.
2) Click the Commands button and choose New from the drop-down menu. A new folder called Untitled appears.
3) Type a name for the new folder, and then press Enter. OOo saves the folder with the name that you entered.

Deleting a template folder

You cannot delete template folders supplied with OOo or installed using the Extension Manager; you can only delete template folders that you have created.

To delete a template folder that you have created:

1) In the Template Management dialog, select the folder that you want to delete.
2) Click the Commands button and choose Delete from the drop-down menu. A message box appears and asks you to confirm the deletion. Click Yes.

Moving a template

To move a template from one template folder to another template folder:

1) In the Template Management dialog, double-click the folder that contains the template you want to move. A list of the templates contained in that folder appears underneath the folder name.
2) Click the template that you want to move and drag it to the desired folder. If you do not have the authority to delete templates from the source folder, this action copies the template instead of moving it.
Deleting a template

You cannot delete templates supplied with OOo or installed using the Extension Manager; you can only delete templates that you have created or imported.

To delete a template:

1) In the Template Management dialog, double-click the folder that contains the template you want to delete. A list of the templates contained in that folder appears underneath the folder name.
2) Click the template that you want to delete.
3) Click the Commands button and choose Delete from the drop-down menu. A message box appears and asks you to confirm the deletion. Click Yes.

Importing a template

If the template that you want to use is in a different location, you must import it into an OOo template folder.

To import a template into a template folder:

1) In the Template Management dialog, select the folder into which you want to import the template.
2) Click the Commands button and choose Import Template from the drop-down menu. A standard file browser window opens.
3) Find and select the template that you want to import and click Open. The file browser window closes and the template appears in the selected folder.
4) If you want, type a new name for the template, and then press Enter.

Exporting a template

To export a template from a template folder to another location:

1) In the Template Management dialog, double-click the folder that contains the template you want to export. A list of the templates contained in that folder appears underneath the folder name.
2) Click the template that you want to export.
3) Click the Commands button and choose Export Template from the drop-down menu. The Save As window opens.
4) Find the folder into which you want to export the template and click Save.

Examples of style use

The following examples of common use of page and paragraph styles are taken from Writer. There are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document

Many documents, such as letters and reports, have a first page that is different from the other pages in the document. For example, the first page of a letterhead typically has a different header, or the first page of a report might have no header or footer, while the other pages do. With OOo, you can define the page style for the first page and specify the style for the following pages to be applied automatically.
As an example, we can use the *First Page* and *Default* page styles that come with OOo. Figure 13 shows what we want to happen: the first page is to be followed by the default page, and all the following pages are to be in the *Default* page style. Details are in Chapter 4 (Formatting Pages) in the *Writer Guide*.

![Figure 13: Flow of page styles](image)

**Dividing a document into chapters**

In a similar way, you can divide a document into chapters. Each chapter might start with the *First Page* style, with the following pages using the *Default* page style, as above. At the end of the chapter, insert a manual page break and specify the next page to have the *First Page* style to start the next chapter, as shown in Figure 14.

![Figure 14: Dividing a document into chapters using page styles](image)

**Changing page orientation within a document**

A Writer document can contain pages in more than one orientation. A common scenario is to have a landscape page in the middle of a document, whereas the other pages are in a portrait orientation. This can also be done with page breaks and page styles.

**Different headers on right and left pages**

Page styles can be set up to have the facing left and right pages *mirrored* or only right (first pages of chapters are often defined to be right-page only) or only left. When you insert a header on a page style set up for mirrored pages or right-and-left pages, you can have the contents of the header be the same on all pages or be different on the right and left pages. For example, you can put the page number on the left-hand edge of the left pages and on the right-hand edge of the right pages, put the document title on the right-hand page only, or make other changes.
**Controlling page breaks automatically**

Writer automatically flows text from one page to the next. If you do not like the default settings, you can change them. For example, you can require a paragraph to start on a new page or column and specify the style of the new page. A typical use is for chapter titles to always start on a new right-hand (odd-numbered) page.

**Compiling an automatic table of contents**

To compile an automatic table of contents, first apply styles to the headings you want to appear in the contents list, then use **Tools > Outline Numbering** to tell Writer which styles go with which level in the table of contents. See Chapter 4 for more information.

**Defining a sequence of styles**

You can set up one paragraph style so that when you press *Enter* at the end of that paragraph, the following paragraph automatically has the style you wish applied to it. For example, you could define a *Heading 1* paragraph to be followed by a *Text Body* paragraph. A more complex example would be: *Title* followed by *Author* followed by *Abstract* followed by *Heading 1* followed by *Text Body*. By setting up these sequences, you can avoid manually applying styles in most cases.