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What is Draw?
Draw is a vector graphics drawing program. It offers a series of 
powerful tools that enable you to quickly create all sorts of graphics. 
Vector graphics store and display an image as vectors (two points and 
a line) rather than a collections of pixels (dots on the screen). Vector 
graphics allow for easier storage and scaling of the image.

Draw is perfectly integrated into the OpenOffice.org suite, and this 
makes exchanging graphics with all components of the suite very easy. 
For example, if you create an image in Draw, reusing it in a Writer 
document is as simple as copying and pasting. You can also work with 
drawings directly from within Writer and Impress, using a subset of the 
functions and tools from Draw.

Draw’s functionalities are very extensive and complete. Although it 
was not designed to rival high-end graphics applications, Draw 
possesses more functions than the majority of drawing tools that are 
integrated into office productivity suites.

A few examples of drawing functions might whet your appetite: layer 
management, magnetic grid point system, dimensions and 
measurement display, connectors for making organization charts, 3D 
functions enabling small three-dimensional drawings to be created 
(with texture and lighting effects), drawing and page style integration, 
and Bézier curves, to name a few.

This chapter introduces some of Draw’s features, but it does not 
attempt to cover all of them. See the Draw Guide and the application 
Help for more information.

The Draw workspace
The main components of the Draw workspace are shown in Figure 1.

You can surround the drawing area with toolbars and information 
areas. The number and position of the visible tools vary with the task 
at hand or user preferences. Therefore, your setup may appear a little 
different. For example, many people put the main Drawing toolbar on 
the left-hand side of the workspace, not at the bottom as shown here.

You can split drawings in Draw over several pages. Multipage drawings 
are used mainly for presentations. The Pages pane, on the left side of 
the Draw window in Figure 1 gives an overview of the pages that you 
create. If the Pages pane is not visible on your setup,you can enable it 
from the View menu (View > Page Pane).
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Figure 1. Initial Draw window

Rulers
You should see rulers (bars with 
numbers) on the upper and left-hand 
side of the workspace. These show 
the size of a selected object on the 
page (see the gray double lines, 
highlighted in Figure 2). When no 
object is selected, they show the 
location of the mouse pointer, which 
helps to accurately position drawing 
objects. You can also use the rulers 
to manage object handles and guide lines, making it easier to position 
objects. The page margins in the drawing area are also represented on 
the rulers. You can change the margins directly on the rulers by 
dragging them with the mouse.
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To modify the units of measurement of 
the rulers, right-click on one of the 
rulers (Figure 3). The two rulers can 
have different units.

Status bar
The Status bar (Figures 4 and 5) is located at the bottom of the 
workspace. In addition to fields common to several OOo components, it 
includes several Draw-specific fields. For details on the contents and 
use of these fields, see Chapter 1 (Introducing OpenOffice.org) in this 
book and Chapter 1 (Introducing Draw) in the Draw Guide.

Note

The sizes are given in the current measurement unit (not to be 
confused with the ruler units). This unit is defined in Tools > 
Options > OpenOffice.org Draw > General, where you can 
also change the scale of the page. Another way to change the 
scale is to double-click on the number shown in the status bar.

Figure 4: Left end of the Draw status bar

Figure 5: Right end of Draw status bar

Toolbars
You can display or hide the various Draw toolbars according to your 
needs.

To display or hide a toolbar, click View > Toolbars. On the menu that 
appears, choose which toolbars you want to display.
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You can also select the icons that you wish to appear on the 
corresponding toolbar. On the View > Toolbars menu, choose 
Customize, click on the Toolbars tab, select the toolbar you want to 
change, and then select the desired icons for that toolbar.

Many toolbar icons are marked with a small arrow. The arrow indicates 
that this icon has additional functions. Click this arrow and a submenu 
or a toolbar appears, showing its additional functions (see Figure 6). 

Most icons marked with a small arrow can become floating toolbars. To 
make a submenu into a floating toolbar, click the area at the top of the 
submenu, drag it across the screen, and then release the mouse 
button. Floating toolbars can be docked on an edge of the screen or 
within one of the existing toolbar areas at the top of the screen, as 
described in Chapter 1.

Figure 6. An arrow next to a button 
indicates additional functions

Click the arrow on the title bar of a floating toolbar to display 
additional functions (see Figure 7).

Figure 7. An arrow on a floating toolbar indicates 
additional functions
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The tools available in the various toolbars are explained in the 
following sections. The appearance of the toolbar icons may vary with 
your operating system and the selection of icon size and style in Tools 
> Options > OpenOffice.org > View.

Standard toolbar
The Standard toolbar looks like this:

It is the same for all parts of OpenOffice.org.

Line and Filling toolbar
The Line and Filling toolbar lets you modify the main properties of a 
drawing object. See page 28 for details.

If the selected object is text, the toolbar changes to the one shown 
below, which is similar to the Formatting toolbar in Writer.

Drawing toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains 
all the necessary functions for drawing various geometric and freehand 
shapes and organizing them on the page.

Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The 
toolbar then appears at the bottom of the workspace.

This toolbar lets you rapidly choose the color of the objects in your 
drawing. The first box in the panel corresponds to transparency (no 
color).

You can access several specialized color palettes in Draw, as well as 
change individual colors to your own taste. This is done using the Area 
dialog, reached by choosing Format > Area or the pouring can icon on 
the Line and Filling toolbar.

On the Area dialog, choose the tab marked Colors (Figure 8).
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Figure 8. Changing the color palette

To load another palette, click on the Load Color List button (circled). 
The file selector dialog asks you to choose one of the standard OOo 
palettes (files bearing the file extension *.soc). For example, web.soc 
is a color palette that is adapted to creating drawings that are going to 
appear in Web pages. The colors will correctly display on workstations 
with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by 
modifying the numerical values in the fields provided to the right of the 
color palette. You can use the color schemes known as CMYK (Cyan, 
Magenta, Yellow, Black), and RGB (Red, Green, Blue).

Clicking on the Edit button opens a special dialog to allow setting 
individual colors (see Figure 9). Many more input possibilities are 
available in this dialog.

In the lower area you can enter values in the RGB and CMYK models 
as well as in the HSB (Hue, Saturation and Brightness) model.

The two color fields at lower right show the value of the color as 
selected (left) and the new value from the chosen color value fields 
(right).

For a more detailed description of color palettes and their options, see 
Chapter 8 (Tips and Tricks) in the Draw Guide.
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Figure 9. Defining color schemes

Options toolbar
The Options toolbar lets you activate or deactivate various drawing 
aids. The Options toolbar is not displayed by default. To display it, 
select View > Toolbars > Options. The functions of the various icons 
are described in Table 1.

Figure 10: Options toolbar

Table 1: Functions on the Options toolbar

Icon Function

Rotation mode after clicking object

Display (or hide) the grid

Display (or hide) the guides

Display (or hide) guides when moving

Snap to grid

Snap to guides

Snap to page margins

Snap to object borders

Snap to object points

The Draw workspace 11
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Icon Function

Allow quick editing

Select text area only

Double-click to edit text

Simple handles

Large handles

Positioning objects with snap functions
In Draw, objects can be positioned to grid points, to special snap points 
and lines, to object frames, to single object points, or to page edges. 
This function is known as Snap. In this manner objects can be very 
accurately positioned in a drawing.

If you want to use the snap function, it is much easier to work with the 
highest practical zoom value. It is possible to use two different snap 
functions at the same time, for example snap to a guide line and to the 
page edge. It is best, however, to activate only those functions that you 
really need.

This section describes the snap-to-grid function. For more information 
about this and the other snap functions, see Chapter 8 (Tips and 
Tricks) and Chapter 10 (Advanced Draw Techniques) in the Draw 
Guide.

Snap to grid
Use this function to move an object exactly to a grid point (see Figure
11). This function can be switched on and off with View > Grid > 

Snap to Grid and on the Options toolbar with the icon .

Figure 11: With snap to grid, objects align to the grid precisely.
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Showing the grid
Make the grid visible under View > Grid > Display Grid. 
Alternatively turn the grid on and off with the icon  on the Options 
toolbar.

Configuring the grid
The color, spacing, and resolution of the grid points can be individually 
chosen for each axis. The spacing between the lines is defined in the 
Grid options dialog under the Drawing area of the OOo options (Tools 
> Options > OpenOffice.org Draw > Grid). 

Figure 12. Setting grid options

In the dialog shown in Figure 12, you can set the following parameters:

• Vertical and horizontal spacing of the dots in the grid. You can 
also change the unit of measurement used in the general Draw 
options (Tools > Options > OpenOffice.org Draw > General).

• The resolution is the size of the squares or rectangles in the grid. 
If the resolution is Horizontal 1 cm, Vertical 2 cm, the grid 
consists of rectangles 2 cm high and 1 cm wide.

• Subdivisions are additional points that appear along the sides of 
each rectangle or square in the grid. Objects snap to subdivisions 
as well as to the corners of the grid.

Positioning objects with snap functions 13



• The pixel (pix element) size of the snap area defines how close 
you need to bring an object to a snap point or line before it will 
snap to it.

Changing the color of the grid points
The default grid dots are light gray, which can be hard to see. To 
improve visibility, go to Tools > Options, then OpenOffice.org > 
Appearance (Figure 13).

Figure 13: Changing the grid color

In the Drawing / Presentation section, you can change the color of the 
grid points. On the Color Settings pulldown menu, select a more 
suitable/visible color, for example black.

Positioning objects with helper lines
To simplify the positioning of objects it is possible to make visible 
guiding lines—extensions of the edges of the object—while it is being 
moved. These guiding lines have no snap function.

The guiding lines can be activated or deactivated under Tools > 
Options > OpenOffice.org Draw > View > Guides when moving, 

or by clicking on the  icon on the Options toolbar.
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The basic drawing shapes
Draw provides a wide range of shapes, located in palettes accessed 
from the Drawing Toolbar. This chapter describes only a few of the 
basic shapes; see the Draw Guide for a complete description of the 
shapes available. These shapes include rectangles and squares; circles, 
ellipses, and arcs; 3D objects; curves; lines and arrows; text; and 
connectors.

When you draw a basic shape or select one for editing, the Info field at 
the left side in the status bar changes to reflect the present action: 
Line created, Text frame xxyy selected, and so on.

Figure 14 shows part of the Drawing toolbar with the icons needed in 
the following sections. The Text icon is also included.

Figure 14: Part of the Drawing toolbar

Drawing a straight line
Let’s start by drawing the simplest of shapes: a straight line. Click on 
the Line icon  on the Drawing Toolbar and place the mouse pointer 
where you want to start the line. Drag the mouse while keeping the 
button pressed. Release the mouse button when you want to end the 
line.

A blue or green selection handle appears at each end of the line, 
showing that this is the currently selected object. The colors depend on 
the selection mode (green for simple selection and blue when in point 
edit mode). This effect is easily apparent if on the Options toolbar both 
Simple Handles and Large Handles are switched on.

Figure 15: Drawing a straight line
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Hold down the Shift key while drawing the line to restrict the angle of 
the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

Hold down the Control key (Ctrl in PCs) to snap the end of the line to 
the nearest grid point.

Note

The effect of the Ctrl key depends on the settings of the Snap to 
Grid option on the View > Grid menu:
Snap to Grid on: Ctrl deactivates the snap option for this 
activity.
Snap to Grid off: Ctrl activates the snap option for this activity.

The spacing (resolution) of the grid points can be adjusted under Tools 
> Options > OpenOffice.org Draw > Grid. See also Chapter 8 (Tips 
and Tricks) in the Draw Guide.

Hold down the Alt key to extend the line symmetrically outward from 
the start point (the line extends to each side of the start point equally). 
This lets you draw straight lines by starting from the middle of the line.

The line just drawn has all the default attributes, such as color and line 
type. To change the line attributes, click on the line to select it and 
then use the tools in the Line and Filling toolbar; or for more control, 
right-click on the line and choose Line to open the Line dialog.

Drawing an arrow
Arrows are drawn like lines. Draw classifies arrows as a subgroup of 
lines: Lines with arrowheads. They are shown in the information field 
on the status bar only as lines. Click on the Line Ends with Arrow 
icon  to draw an arrow.

Drawing lines and arrows

Click on the small black triangle on the Lines and Arrows  icon to 
open a floating toolbar with ten tools for drawing lines and arrows 
(Figure 16). Alternatively, you can click directly on the symbol to 
repeat the last-used command chosen from this toolbar. In both cases, 
the last-used command will be stored on the toolbar to make it quicker 
to call it up again.
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Figure 16: Lines and Arrows toolbar

Drawing a rectangle or square
Drawing rectangles is similar to drawing straight lines, except that you 
use the Rectangle icon   from the Drawing Toolbar. The (imaginary) 
line drawn with the mouse corresponds to the diagonal of the 
rectangle. In addition, the outline of the future rectangle changes 
shape as you drag the mouse around. The outline is shown as a dashed 
line until you release the mouse button, when the rectangle is drawn.

Figure 17: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to 
draw a rectangle starting from its center. To combine the effects, hold 
down both the Shift and Alt keys simultaneously.

Drawing a circle or ellipse
To draw an ellipse (also called an oval) or a circle, use the Ellipse icon 

 from the Drawing Toolbar. (A circle is simply an ellipse where the 
two axes are the same length.) The ellipse drawn is the largest ellipse 
that would fit inside the (imaginary) rectangle drawn with the mouse.

The basic drawing shapes 17
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Figure 18: Drawing an ellipse

There are three other ways to draw an ellipse or circle:
• Hold down the Shift key while drawing to force the ellipse to be a 

circle.
• Hold down the Alt key to draw a symmetrical ellipse or circle 

from the center instead of dragging corner to corner.
• Hold down the Control key while drawing to snap the ellipse or 

circle to grid lines.

Note

If you first press and hold the Control key and then click on one 
of the icons (Line, Rectangle, Ellipse, or Text), an object is 
drawn automatically in the work area; the size, shape, and color 
are all standard values. These attributes can be changed later, 
if desired.

Drawing curves
The tools for drawing curves or polygons are on the toolbar that 
appears when you click the Curve icon  on the Drawing toolbar. 
This toolbar contains eight tools (Figure 19).

Note
Hovering the mouse over this icon gives a tooltip of Curve. If 
you convert the icon to a floating toolbar, however, the title is 
Lines, as shown in Figure 19.

Figure 19: Floating Curves toolbar (incorrectly titled “Lines”)
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If you move the mouse cursor over one of the icons, a tooltip pops up 
with a description of the function. For a more detailed description of 
the handling of Bézier curves (curves and filled curves), see Chapter 
10 (Advanced Draw Techniques) in the Draw Guide.

Polygons
Draw the first line from the start point with the left mouse button 
held down. As soon as you release the mouse button, a first corner 
point is drawn, and you can move the mouse to see how the second 
line will look. Every mouse click sets another corner point. A double-
click ends the drawing. A filled polygon automatically joins the last 
point to the first point to close off the figure and fills it with the 
current standard fill color. A polygon without filling will not be 
closed at the end of the drawing.

Polygon 45°
Just as with ordinary polygons, these will be formed from lines but 
with angles of 45 or 90 degrees between them.

Freeform Line
With this tool you can draw just like with a pencil. Press and hold 
the left mouse button and move the mouse. It is not necessary to end 
the drawing with a double-click. Just release the mouse button and 
the drawing is completed. If you have selected Freeform Line, Filled, 
the end point is joined automatically to the start point and the object 
is filled with the appropriate color.

Writing text
Use the Text tool  to write text and select the font, color, size, and 
other attributes. Click on an empty space in the workspace to write the 
text at that spot or drag an area to write inside the dragged frame. 
Press Enter to drop to the next line.

When you have finished typing text, click outside the text frame. 
Double-click on the text at any time to edit it.

When you type text, the upper toolbar includes the usual paragraph 
attributes: indents, first line, and tab stops.

You can change the style of all or part of the text. The Styles and 
Formatting window also works here (select Format > Styles and 
Formatting or press F11 to launch), so you can create Graphics styles 
that you can reuse for other text frames. Graphics styles affect all of 
the text within a text frame. To style parts of the text, use direct 
formating with the toolbar.
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Text frames can also have fill colors, shadows, and other attributes, 
just like any other Draw object. You can rotate the frame and write the 
text at any angle. These options are available by right-clicking on the 
object.

Use the Callout tool, located on the Drawing toolbar, to create callouts 
(also known as captions or figure labels).

If you double-click on an object or press F2 (or the Text icon in the 
Drawing toolbar) when an object is selected, text is written in the 
center of the object and remains within the object. Nearly any kind of 
object contains such an additional text element. These texts have slight 
differences to those in text frames concerning position and 
hyphenation.

For more about text, see Chapter 2 (Drawing Basic Shapes) and 
Chapter 10 (Advanced Draw Techniques) in the Draw Guide.

Gluepoints and connectors
All Draw objects have associated invisible gluepoints, which become 
visible when you choose any of the connectors under the Connectors 
icon  on the Drawing toolbar and then move the mouse pointer over 
the object. 

Most objects have four gluepoints, as shown in Figure 20. You can add 
more gluepoints, and customize gluepoints, using the toolbar under the 
Gluepoint icon  on the Drawing toolbar.

Figure 20: Four gluepoints

Gluepoints are different from handles (the small blue or green squares 
around an object). Use the handles to move or resize an object; use the 
gluepoints to attach connectors to an object.

Connectors are a type of line or arrow whose ends dock to glue points 
on other objects. When you move the other object, the connector 
moves with it. Connectors are particularly useful for making 
organizational charts. You can reorganize the blocks of your chart and 
all the connected objects stay connected.

20 Getting Started with Draw



Figure 21 shows two Draw objects and a connector.

Figure 21: A connector between two objects

Draw has a range of advanced connector functions. You can change 
connector types by opening the floating Connectors toolbar (click on 
the Connector icon ) and modify various attributes of a selected 
connector by right-clicking and choosing Connector from the pop-up 
menu. For more about connectors and gluepoints, see Chapter 9 
(Organization Charts, Flow Diagrams, and More) in the Draw Guide.

Drawing geometric shapes
Geometric shapes include basic shapes, symbol shapes, block arrows, 
flowcharts, callouts, and stars.

Figure 22 shows part of the Drawing toolbar with the icons referred to 
in the following sections. Clicking on the arrow next to the icon opens 
a floating toolbar with the relevant work tools. The use of all these 
tools is similar to that of the Rectangle tool, even though they produce 
different geometric shapes.

Figure 22: Part of the main Drawing toolbar

Basic shapes
The Basic Shapes icon  makes available the 
range of tools for drawing basic shapes.

If you choose the rectangle tool from this 
toolbar, it looks the same as a rectangle drawn 
using the Rectangle tool on the Drawing 
toolbar. The only differences you will see are in 
the information field in the status bar (for 
example: shape selected).
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Symbol shapes
The Symbol Shapes icon  brings you to an 
array of tools for drawing the various symbol 
shapes.

Block arrows
The Block Arrows icon  opens the Block Arrows 
toolbar.

Flowcharts
The tools for drawing flowcharts are accessed by 
clicking on the Flowcharts icon .

The creation of flowcharts, organization charts, and 
similar planning tools are described in Chapter 9 
(Organization Charts, Flow Diagrams, and More) in 
the Draw Guide.

Callouts
Use the Callouts icon  to open the Callouts 
toolbar.

Stars and banners
These tools are associated with the Stars icon 

.

You can add text to all these shapes. See Chapter 2 (Drawing Basic 
Shapes) and Chapter 10 (Advanced Draw Techniques) in the Draw 
Guide for details.
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Selection modes
There are three selection modes: moving and changing size, rotating, 
and editing points.

The default mode for selecting objects depends on whether the Points 

button on the Drawing toolbar is active (appears lit)  or not inactive 
(appears dark or dimmed) .

In standard mode (when you begin a new drawing), 
the Points button is not active, and the default mode 
is for selections to be moved or changed in size; these 
selections are indicated by small green squares.

When the Points button is active, the default mode is 
for selections to be edited; these selections are 
indicated by blue squares. Some objects will have one 
or more extra handles, which are larger or colored 
differently. This is explained in more detail in the 
Draw Guide.

Selections for rotating objects are indicated by small 
red circles and a symbol representing the center of 
rotation. To choose these selections, click on the 
Effects drop-down button   from the Drawing 
toolbar.

Changing the selection mode
To go from one mode to another, you can do one of the following:

• Toggle the Points button on the Drawing toolbar to switch from 

the simple selection mode to the Points mode . You can also use 
the keyboard shortcut F8 (Points).

• Choose the Effects drop-down button from the Drawing toolbar 
 to activate the Rotation mode for a selected object.

• If you often work in Rotation mode, you can choose the Rotation 
Mode after Clicking Object button  from the Options bar, you 
can cycle through normal and rotation modes just by clicking on 
the object. This can be more convenient than clicking the object, 
then clicking the Rotate button from the Drawing Toolbar.

• To stop working in Rotation mode, click the Rotation Mode after 
Clicking Object button  again.
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Selecting objects

Direct selection
To select an object, the easiest way is to click directly on it. For objects 
that are not filled, click directly on the object's outline to select it.

Selection by framing
You can select several objects by using the mouse to 
drag a large rectangle around the objects, as shown. 
For this to work, the Select  icon on the Drawing 
toolbar must be active. Only objects that lie entirely 
within the rectangle are selected.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still 
be selected. To select an object that is covered by another object, hold 
down the Alt key and click the object. To select an object that is 
covered by several objects, hold down the Alt key and click through the 
objects until you reach the required underlying object. To cycle 
through the objects in reverse order, hold down the Alt+Shift keys 
when you click. To help in making accurate selections, you can check 
the number and type of the selected objects, shown at the left of the 
status bar.

Note

There may be some variation in the use of the Alt key on 
different operating systems. If the Alt key on your system does 
not operate as described above, use the Tab key method 
described below.

To select an object that is covered by another object using the 
keyboard, press Tab to cycle through the objects, stopping at the 
object you wish to select. To cycle through the objects in reverse order, 
press Shift+Tab. This may not be practical if you have a large number 
of objects in your drawing.
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When you click on the selected object, its outline 
appears briefly through the objects on top of the 
selected object.

In the illustration to the right, the square located 
beneath the circle was selected in this way (the circle 
was made transparent in order to see the square).

Arranging objects
In a complex drawing, you may have objects stacked up, one on top of 
the other, with the result that a particular object is hidden by one or 
more other objects above it. You can rearrange the stacking order of 
objects (move an object to the front or to the back of the stack) by 
selecting the object, clicking Modify > Arrange and selecting the 
appropriate Bring Forward or Send Backward option, or by right-
clicking the object and selecting Arrange from the context menu, then 
selecting from the list of Bring Forward or Send Backward options.

On the Drawing toolbar, the Arrange tear-off menu on the  button 
contains the above options. A keyboard shortcut is Shift+Ctrl++ to 
bring an object to the top, and Shift+Ctrl+− to send an object to the 
bottom.

Draw also provides tools for aligning multiple objects; details are given 
in the Draw Guide.

Selecting several objects
To select or deselect several objects one by one, press the Shift key 
and click on the various objects to be selected or deselected. One click 
on an object selects it; a second click deselects it.

Moving and dynamically adjusting an 
object’s size
There are several ways of moving or changing the size of an object. 
The method described here will be called dynamic in the sense that it 
is carried out using the mouse.

When you dynamically change an object, remember to check the 
central area of the status bar at the bottom of your screen. This area 
shows detailed information about the ongoing manipulation. This 
information changes when the mouse is moved.
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Dynamic movement of objects
To move an object, select it and then click within 
the object’s border and hold down the left mouse 
button while moving the mouse. To drop the 
object at its new location, release the mouse 
button.

During movement, the shape of the object 
appears as dotted lines to help with 
repositioning.

If you have selected Guides when moving in 
Tools > Options > OpenOffice.org Draw > 
View, then during movement, dotted lines 
appear, to help with repositioning.

Dynamic size modification of objects
To change the size of an object (or group of 
selected objects) with the mouse, you need to move 
one of the handles located around the selection. As 
shown in the following illustration, the outline of 
the resulting new object appears as a dotted line.

The results differ depending on which handle you use. If you choose a 
corner handle, you will resize the object along two axes at the same 
time. If you use a side handle, the objects will only be resized along 
one axis.

Note

If you press the Shift key at the same time as you carry out the 
resizing operation, the size change will be carried out 
symmetrically with respect to the two axes; this enables you to 
keep the aspect (height/length) ratio of the object.

Rotation
Rotating an object lets you move the object around an axis. To do this 
dynamically, use the red handles, as you do when changing the size of 
the object.
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Note

Rotation works in a slightly different way for 3D objects 
because the rotation occurs in 3D space and not in one plane. 
See Chapter 7 (Working with 3D Objects) in the Draw Guide 
regarding rotation when Edit Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle 
points of the selection with the mouse. The mouse cursor takes the 
shape of an arc of a circle with an arrow at each end. A dotted outline 
of the object being rotated appears and the current angle of rotation is 
dynamically shown in the status bar.

Rotations are made about an axis which is displayed as a small symbol. 
You can move the axis of rotation with the mouse, as shown in 
Figure 23.

If you hold down the Shift key during the rotation, the operation will be 
carried out in increments of 15°.

Figure 23: Rotating an object

Inclination and perspective
To slant or shear objects, use the red handles located at the midpoint 
of an edge of the selected objects. The mouse pointer changes to a  
when the pointer hovers over one of these midpoint handles. Not every 
object can be slanted. Basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be 
used for shearing the object. This point stays fixed in location; the 
other sides and edges move in relation to it as the mouse is dragged 
(make sure that the  handle icon is showing before dragging).

As with rotation, you can set the inclination to occur as steps of 15° by 
pressing the Shift key while moving the handle.
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Editing objects
To change an object’s attributes (such as color, border width, among 
others) you can use the Line and Filling toolbar or the context menu.

If the Line and Filling toolbar (Figure 24) is not visible, you can display 
it using View > Toolbars > Line and Filling. From here you can edit 
the most common object attributes. You can also open the Line dialog 
by clicking on the Line  icon and the Area dialog by clicking on the 
Area  icon to see more options.

1  Styles and Formatting
2  Line
3  Arrow Style

4  Line Style
5  Line Width
6  Line Color

7      Area
8–9  Area Style / Filling
10    Shadow

Figure 24: Line and Filling toolbar

When you select text, this toolbar changes to show text formatting 
options.

The context menu
When an object is selected, you can right-click on the object to bring 
up a context menu, which provides additional access to the options 
shown above and another way to change an object’s attributes. The 
entries with a small arrow on the right-hand side contain a submenu.

Editing lines and borders
Lines (like arrows) and the borders of an 
object are managed through the same dialog. 
An object’s border is just another type of line.
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You can change some properties from the Line and Filling toolbar. To 
see more options, select the object and click on the Line  icon or 
right-click on the object and choose Line from the context menu. This 
opens the Line dialog.

Common line properties
In most cases the property you want to change is the line’s style (solid, 
dashed, invisible, and so on), its color, or its width. These options are 
all available from the Line and Filling toolbar (Figure 24).

You can also edit these properties from the Line dialog, where you can 
also change the line’s transparency. Figure 25 illustrates different 
degrees of transparency.

Figure 25: The vertical lines have different  
levels of transparency (0%, 25%, and 50%).

Drawing arrows
Arrowheads (and other line endings, usually referred to 
collectively as arrows) are a line property. Select a line and 
click on the Arrow Style  icon from the Line and Filling 
toolbar. This opens the Arrowheads menu.

Several types of arrowheads are available. Each end of the 
line can have a different arrowhead (or no arrowhead).

Arrowheads are only applicable to lines. They have no 
effect on an object’s border.

Customizing line and arrow styles
You can modify the line and arrow styles and create your own. See 
Chapter 4 (Changing Object Attributes) in the Draw Guide for details.

Editing the inside (fill) of an object
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The OpenOffice.org term for the inside of an object is Area fill. The 
area fill of an object can be a uniform color, a gradient, a hatching, or a 
pattern from an image. It can be made partly or fully transparent and 
can throw a shadow.

In most cases, you will choose one of the standard fill options, which 
are all available from the Line and Filling toolbar. You can also define 
your own area fills; see Chapter 4 of the Draw Guide for details.

Adding a shadow
In Draw, shadows are considered as an area 
property. Click on the Shadow  icon on the Line 
and Filling toolbar.

You can customize the position, distance, color, 
and transparency of shadows using Format > 
Area > Shadow or by right-clicking on the 
selected object and choosing Area > Shadow.

Adding transparency
You can make objects partly or fully transparent, or even with a 
varying degree of transparency (as a gradient).

Using styles
Suppose that you want to apply the same area fill, line thickness, and 
border to a set of objects. This repetitive process can be greatly 
simplified by the use of styles. Styles allow you to define a formatting 
template (a style) and then to apply that style to multiple objects. For 
more information about styles, see Chapter 3 (Using Styles and 
Templates).
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Special effects
With Draw, you can apply many special effects to objects and groups of 
objects. This section describes a few of these effects. Others include 
distorting, shadows, and transparency. See the Draw Guide for 
examples of the many effects available.

Flip an object
Select an object and click on the Flip icon . You will 
see a dashed line through the middle of the object.

This dashed line is the axis of symmetry. The object 
will be reflected about this line. Move one or both 
ends of the line with your mouse to set the axis.

Then, grab any one of the eight green handles and 
move it across to the other side of the dashed line. 
The new position of the figure is shown dashed until 
the mouse is released.

Note
If you hold down the Shift key while moving the line, the line will 
rotate in 45-degree increments.

Mirror copies
Officially, this useful command does not (yet) exist in Draw. It can, 
however, be easily emulated. 

Move the axis of symmetry to the desired location of the mirror axis. 
Copy the object to the clipboard. Flip the object, then click on an 
empty area of the Draw screen in order to deselect the object. Paste 
from the clipboard to put a copy of the object in its original location 
and now you have a mirror copy.
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Distorting an image
There are three tools on the Effects menu that let you drag the 
corners and edges of an object to distort the image.

The Distort tool distorts an object in perspective, the Set to Circle 
(slant) and Set in Circle (perspective) tools both create a pseudo 
three-dimensional effect. See Chapter 4 of the Draw Guide for details.

Dynamic gradients
You can control transparency gradients in the same manner as color 
gradients. Both types of gradient can be used together. With a 
transparency gradient, the direction and degree of an object’s fill color 
changes from opaque to transparent (in a regular gradient, the fill 
changes from one color to another, but the degree of transparency 
remains the same). See Chapter 4 of the Draw Guide for details.

Duplication
Duplication makes copies of an object while applying a set of changes 
(such as color or rotation) to the duplicates. The result of a duplication 
is a new group.

To start duplication, click on an object or group and choose Edit > 
Duplicate. The dialog shown in Figure 26 appears.

Figure 26: Duplicating an object

The options chosen in 
Figure 26 applied to a 
blue rectangle produce 
the following result.
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Cross-fading
Cross-fading transforms a shape from one form to another, with 
OpenOffice.org handling all of the intermediate transitions. The result 
is a new group of objects including the two end points and the 
intermediate steps.

To carry out a cross-fade, select both objects (hold the Shift key while 
selecting each object in turn) and then choose Edit > Cross-fading 
On the Cross-fading dialog, choose the number of increments 
(transition steps). You probably want to have Cross-fade attributes and 
Same orientation both checked. The end result is shown in Figure 28.

Figure 27: Choosing cross-fading settings

Figure 28: Cross-fading example

Combining multiple objects
Using Draw, you can combine drawing objects together in two distinct 
ways: grouping and combining. These two methods allow you to treat 
multiple objects as one unit, or to merge objects to form a new shape.

Grouping is like putting objects in a container. You can move them as a 
group and apply global changes to them. A group can always be 
undone and the objects that make up the group can always be 
manipulated separately.

A combination is a permanent fusion of objects leading to a new object. 
The original objects are no longer available as individual entities and 
the operation is not reversible.
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Grouping by common selection
When several objects are selected, any operations you carry out are 
applied to all of the objects. For example, you can rotate a group of 
objects in its entirety. Groups obtained through common selection of 
several objects are undone as soon as you click outside the group. 
However, you can group objects and keep those selected objects 
grouped together.

Maintaining groups and undoing groups
To group selected objects, right-click and choose Group from the pop-
up menu. You can also use the keyboard shortcut Control+Shift+G or 
choose Modify > Group from the menu bar.

When objects are grouped, any editing operations carried out on that 
group are applied to all members of the group. If you click on one 
member of the group, the whole group is selected.

The objects of a group retain their own individual properties. To undo a 
group, right-click and choose Ungroup from the pop-up menu, use the 
keyboard shortcut Control+Alt+Shift+G or choose Modify > 
Ungroup from the menu bar.

You can edit a member of a group individually without breaking the 
group. To do this, right-click and choose Enter group or double-click 
on the group.

Combining objects
In contrast to grouping functions, combinations create a new object; 
subsequent “un-combining” in the same manner as ungrouping is not 
possible. Select a collection of objects, then right-click and choose 
Combine from the pop-up menu.

After you have selected more than one object, the Merge, Subtract, 
and Intersect functions can be reached in the Modify > Shapes menu 
or though the group’s right-click menu under the heading Shapes.
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Aids for positioning objects
Draw has various tools to help you arrange the objects with respect to 
each other:

• Moving an object to the front or to the back
• Aligning objects with respect to each other
• Distributing the distance and space between objects

See Chapter 5 (Combining Multiple Objects) in the Draw Guide for 
more information.

Inserting and editing pictures
Draw contains a number of functions for editing raster graphics 
(bitmaps)—for example, photos and scanned images—including import 
and and export as well as conversion from one format to another. Draw 
can read in all the usual range of graphic file formats.
You can add pictures from several sources:

• The Gallery—see Chapter 11 (Graphics, the Gallery, and 
Fontwork)

• Directly from a scanner (Insert > Picture > Scan)
• Images created by another program, including photographs from 

a digitial camera (Insert > Picture > From File)

Draw provides tools for working with bitmap images: the Picture 
toolbar and the bitmap image management palette. However, it does 
not have the same capabilities as the specialized raster graphics 
programs like Adobe Photoshop or The Gimp. See Chapter 6 (Editing 
Pictures) in the Draw Guide for details and examples.

Working with 3D objects
Although Draw does not match the functionality of the leading drawing 
programs, it does offer a wide array of tools and methods to produce 
and edit very good 3D drawings.

Draw offers two types of 3D objects: the ones carried forward from 
OOo version 1, 3D bodies, and the ones introduced in version 2, 3D 
shapes. Depending on which type you choose, there are different 
possibilities for further editing of the object (rotation, illumination, 
perspective). Setting up and editing 3D objects is simpler with 3D 
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shapes than with 3D bodies, but 3D bodies currently allow for more 
customizing than 3D shapes.

See Chapter 7 (Working with 3D Objects) in the Draw Guide for details.

Exporting graphics
To save a Draw image in a foreign format, use File > Export. Draw 
can save to many graphic file formats, as listed in Appendix B 
(Background Information). You can export the entire file or selected 
objects.

You can also export Draw files to HTML, PDF, or Flash. PDF export is 
the same as for any part of OpenOffice.org, as described in Chapter 10 
(Printing, E-mailing, and Exporting). Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web 
pages as there are pages in your Draw document. You can optionally 
choose to display the pages in frames with a navigator and can set an 
index page. For more information, see Chapter 12 (Creating Web 
Pages: Saving Documents as HTML Files).

Adding comments to a drawing
Starting with OOo 3.2, Draw supports comments (formerly called 
notes) similar to those in Writer and Calc. 

Choose Insert > Comment from the menu bar. A small box containing 
your initials appears in the upper left-hand corner of the Draw page, 
with a larger text box beside it. Draw has automatically added your 
name and the date at the bottom of this text box.
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Type or paste your comment into the text box. You can optionally apply 
some basic formatting to parts of the text by selecting it, right-clicking, 
and choosing from the pop-up menu. (From this menu, you can also 
delete the current comment, all the comments from the same author, 
or all the comments in the document.)

You can move the small comment markers to anywhere you wish on the 
page. Typically you might place it on or near an object you refer to in 
the comment.

To show or hide the comment markers, choose View > Comments.

Select Tools > Options > User Data to configure the name you want 
to appear in the Author field of the comment, or to change it.

If more than one person edits the document, each author is 
automatically allocated a different background color.
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