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What is Math?

Math is OpenOffice.org (0O0o0)’s component for writing mathematical
equations. It is most commonly used as an equation editor for text
documents, but it can also be used with other types of documents or
stand-alone. When used inside Writer, the equation is treated as an
object inside the text document.

The equation editor is for writing equations in symbolic form, as
Note in equation 1. If you want to evaluate a numeric value, see the
Calc Guide.

df(x)=ln(x)+tan_l(x2) (1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating
Formula Elements window (called “Selection” before Math 3.2) may
appear. You will also see a small box with a gray border in your
document, where the formula will be displayed, as shown in Figure 1.

iz Untitled 1 - OpenOffice.org Writer g@
File Edit Wiew Format Tools Window Help

E-BEH= &B& B o .

g Formula Eleme | X
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a-b % azb a/b avb
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Figure 1. Equation Editor, Formula Elements window, and
location of resulting equation.
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Entering a formula

The equation editor uses a markup language to represent formulas. For
example, %beta creates the Greek character beta (). This markup is
designed to read similar to English whenever possible. For example, a

. a
over b produces a fraction: 7

You can enter a formula in three ways:
« Select a symbol from the Formula Elements window.

« Right-click on the equation editor and select the symbol from the
context menu.

« Type markup in the equation editor.
The context menu and the Formula Elements window insert the

markup corresponding to a symbol. This provides a convenient way to
learn the OO0 Math markup.

Click on the document body to exit the formula editor.

Note Double-click on a formula to enter the formula editor again.

The Formula Elements window

The simplest method for entering a formula is the Formula Elements
window, shown in Figure 1.

rE Formula Elemm“

ﬂEb ash Ix) 2a

i & (8) ﬁ;./; Categories

+4 -4 x4 +4 -4

a+b a-b axb axb aab

Symbols

a—b % azb a/b avb

aeb

Figure 2. Symbols are divided into categories

In OO0 Math before V3.2.0, the Formula Elements window was

Note . ;jled the Selection window.
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The Formula Elements window is divided into two main parts.
« The top shows the symbol categories. Click on these to change

the list of symbols.

« The bottom shows the symbols available in the current category.

Tip

You can hide or show the Formula Elements window with View
> Formula Elements.

Example 1: 5x4

For this example we will enter a simple formula: 5x4. On the Formula
Elements window (Figure 3):

1) Select the top-left button of the categories (top) section.
2) Click on the multiplication symbol.

Unary/binary
operators

Multiplication s,

rE Formula Elemmﬁ

ﬂsb ach flx) 2a

i & @&

Figure 3. Selecting the multiplication symbol

When you select the multiplication symbol on the Formula Elements

window, two things happen:

« The equation editor shows the markup: <?> times <?>
« The body of the document shows a gray box like this: 0xO

4

=

<

<?> times <?= |

Figure 4. Result of selecting the multiplication symbol
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The <?> symbols shown in Figure 4 are placeholders that you can
replace by other text, for example 5 and 4. The equation will update
automatically, and the result should resemble Figure 5.

ELSE

23 £ B3 E

% *

5 times 4 L]

ka
* ¥

Figure 5. Result of entering 5 and 4 next to the times operator

To keep the equation from updating automatically, select View
Tip >AutoUpdate display. To update a formula manually, press F9
or select View > Update.

Right-click menu

Another way to access mathematical symbols is to right-click on the
equation editor. This pops up the menu shown in Figure 6. The items in
this menu correspond exactly to those in the Formula Elements
window.

1 ~
o times 4 Unary/Binary Operators » +a

Relations -a
< £ Set Operations +-a »
Functions -+a I
Operators
Attributes
Erackets
Formats
Others

a+b

a-b

acdot b
atimes b

a*b [}
aoverb

advb

afb

acirch

*r v ¥ ¥ ¥ ¥ w* ¥

awideslash b
a widebslash b

neg a
aandb
aorb

Figure 6. Right-click menu
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Markup

You can type the markup directly in the equation editor. For example,
you can type 5 times 4 to obtain 5x4. If you know the markup, this
can be the fastest way to enter a formula.

Ti The formula markup resembles the way the formula reads in
P English.

Below is a short list of common equations and their corresponding
markup.

Display Command Display Command
a=b a=>b Ja sqrt {a}
a’ a2 a, an
J" f(x)dx int f(x) dx Z a, sum a n
a<b a<=Db o0 infinity
axb a times b Xy x cdoty

Greek characters

Greek characters («,B,y,0, etc) are common in mathematical
formulas. These characters are not available in the Formula Elements
window or the right-click menu. Fortunately, the markup for Greek
characters is simple: Type a % sign followed the name of the character,
in English.
- To write a lowercase character, type the name of the character in
lowercase.

« To write an uppercase character, type the name of the character
in uppercase.

See the table below for some examples.

Lowercase Uppercase

%alpha —» « SALPHA — 4
Sbeta — 8 %SBETA — B
%gamma — vy %GAMMA — T
%psi - Y %PSI - ¥
Sphi — ¢ SPHI — &
stheta —» 0 STHETA — ©
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Note A complete table of Greek characters is provided on page 28.

Another way to enter Greek characters is by using the Symbols catalog
window. Choose Tools > Catalog. This window is shown in Figure 7.
Under Symbol set, select Greek and double-click on a Greek letter
from the list.

rﬁ Symbols

Symbaol set [ Insert

Greek e

[ Close

vm E X H®
bwop [

E I Z F C A AT K
0nx e “ § vy w o 0 a

—  —E

Edit...

=

=

o
= T 4|
-~ o T

x

Y € o

]

Figure 7. Symbols catalog - used for entering Greek characters

Example 2: ™ =~ 3.14159
For this example we will suppose that:

« We want to enter the above formula (the value of pi rounded to 5
decimal places).

« We know the name of the Greek character (pi).
« But we do not know the markup associated with the ~ symbol.

Step 1: Type % followed by the text pi. This displays the Greek
character .

Step 2: Open the Formula Elements window (View > Formula
Elements).

Step 3: The = symbol is a relation, so we click on the Relations
button. If you hover the mouse over this button you see the tooltip
Relations (Figure 8).

Figure 9 shows the Selection window after clicking the Relations
button. The symbol we want is circled.
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F— "
= | Formula ElemE| ﬁ Formula Elemm-

artg ash () 3a o !m £ Sa

4 Reistons]l8) &2 (2) B

+4 -0 *a Fa -a a=b a=b amb alb atb
a+b a-b axb axb anb a<b a>b||b alb
a-b % azb a/b avb asb azb a~b a=b
ash a<b a=b aeb a-=b

l:l<=b ﬂwb ﬂ=¢-b

Figure 8. Tooltip indicates
the Relations button.

Figure 9. After selecting Relations.

Step 4: Click on the a ~ b symbol. The equation editor now shows the
markup %pi<?> simeq <7>.

Step 5: Delete the <?> text and add 3.14159 at the end of the
equation. We end up with the markup %pi simeq 3.14159. The result
is shown in Figure 10.

¥

En=3.:141595

2 £ B3

£ *

I%pi simeq 3.14159 -

£ ]

Figure 10. Final result

Customizations

Formula editor as a floating window

The formula editor can cover a large part of the Writer window. To turn
the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 11.
2) Hold down the Control key and double-click.
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E=m 2

IE'=|T| ()

Figure 11. Hold down the Control key and
double-click on the border of the math editor
to turn it into a floating window.

Figure 12 shows the result. You can dock the floating window again by
using the same steps. Hold down the Control key and double-click the

window frame.

(%5 Commands % |
= K

E=mc 2| a

e
4 *

Figure 12. Equation editor as a floating window.

How can | make a formula bigger?

This is one of the most common questions people ask about OOo Math.
The answer is simple, but not intuitive:

1) Start the formula editor and choose Format > Font size.

iZ) Untitled 1 - OpenoOffice.org Writer

File Edit View Farmat Tools Window Help

Fonts... 5 H =
Font gjze... e —
Spacing...
Alignment...

—

Lesne Text Mode

L4

Figure 13. Changing the font size for a formula.
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2) Select a larger font size under Base size (top-most entry), as
shown in Figure 13.

rﬁ Font Sizes

)

Base size
Relative sizes
Text
Indexes
Eunctions
Operators

Limits

16pt| v
100% -
60% o
100% -
100% >

50%

L

(]9 l

Cancel l

Default l

Figure 14. Edit Base size (top) to make a formula bigger.

The result of this change is illustrated in Figure 14.

Betfore:

After:

m=3.141359

m=3.14159

Figure 15. Result of changing the base font size.

Formula layout

The most difficult part of using OOo Math comes when writing
complicated formulas. This section provides some advice.

Brackets are your friends

OO0 Math knows nothing about order of operation. You must use
brackets to state the order of operations explicitly. Consider the

following example.

Markup Result

2 over x + 1

2 over {x + 1}

2

X

241

x+1

12
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Equations over more than one line

Suppose you want to type an equation covering more than one line. For
x=3

y=1

Your first reaction would be to simply press the Enter key. However, if
you press the Enter key, though the markup goes to a new line, the
resulting equation does not. You must type the newline command
explicitly. This is illustrated in the table below.

Markup Result

example:

X =3

y =1 x=3y=
X = 3 newline x=3

y =1 y=1

How do | add limits to my sum/integral?

The sum and int commands can (optionally) take the parameters from
and to. These are used for lower and upper limits respectively. These
parameters can be used singly or together. Limits for integrals are
usually treated as subscripts and superscripts.

Markup Result

sum from k =1 to n a_k Zak
k=1

int from 0 to x f(t) dt
or
int 07°x f(t) dt

jf(t)dt or [ f(t)ar

int from Re f ff

R

sum to infinity 2°{-n} iz‘”

Note For more details on integrals and sums, see page 22.
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Brackets with matrices look ugly!
For background, we start with an overview of the matrix command.

Markup Result

matrix { a # b # c # d } az
C

Rows are separated by two #’s and entries within each row are

Note separated by one #.

The first problem people have with matrices is that brackets do not
scale with the matrix:

Result

( matrix { a# b #t c #d } )

OOo Math provides scalable brackets. That is, the brackets grow in
size to match the size of their contents. Use the commands Ileft( and
right) to make scalable brackets.

Result

a b

left( matrix { a # b ## c # d } right) J
C

Tip Use left[ and right] to obtain square brackets.

How do | make a derivative?

Making derivatives essentially comes down to one trick: Tell OOo it’s a
fraction.
In other words, you have to use the over command. Combine this with

either the letter d (for a total derivative) or the partial command (for a
partial derivative) to achieve the effect of a derivative.

Notice that we have to use braces (squiggly brackets) to make

Note the derivative.
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Markup Result

{df} over {dx}

{partial f} over {partial y}

{partial”2 f} over {partial t"2}

af
dx
of
oy
of
ot

How do | align my equations at the equals sign?

OOo Math does not have a command for aligning equations on a

particular character, but you can use a matrix to do this, as shown

below.

Markup Result

matrix{
alignr x+y # {}={} # alignl 2 ##
alignr x # {}={} # alignl 2-y
}

xX+y
X

2
2—y

The empty braces around = are necessary because = is a binary
operator and thus needs an expression on each side.

You can reduce the spacing around = if you change the inter-column

spacing of the matrix:

1) With the equation editor open, choose Format > Spacing from

the menu bar.

rﬁ Spacing w
Matrix oK
Line spacing |3% |:|
Cancel
Column spacing p% B [ﬂHC ]
Category ~
Default
Figure 16: Changing spacing in a matrix formula
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2) In the Spacing dialog (Figure 16), click the Category button and
select Matrices in the drop-down menu.

3) Enter 0% for Column spacing and click OK.

Numbering equations

Equation numbering is one of OO0 Math’s best hidden features. The
steps are simple, but obscure:

1) Start a new line.
2) Type fn and then press F3.

The fn is replaced by a numbered formula:
E=mc’ (2)

Now you can double-click on the formula to edit it. For example, here
is the Riemann Zeta function:

C(Z)=iiz 3)

n=1 N

You can reference an equation (“as shown in Equation (2)”) with these
steps:

1) Choose Insert > Cross-reference from the menu bar.

2) On the Cross-references tab (Figure 17), under Type, select Text.
3) Under Selection, select the equation number.

4) Under Format, select Reference.

Click Insert.

Done! If you later add more equations to the paper before the
referenced equation, all the equations will automatically renumber and
the cross-references will update.
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Fields

Cocurnent [Cross-references | Functions | DocInformation | Variables || Database

Tvpe Selection
Set Reference §!
Insert Reference el
Headings (3
Murmbered Paragraphs

Texk

Figure

Bookmarks

Insert reference to

Page (2
Chapter

Feference

Above)Below

A= Page Skyle

Cateqaory and Mumber

Capkion Texk

mumbering

[ Insert H Close ][ Help ]

Figure 17. Inserting a cross-reference to an equation number

Tip To insert the equation number without parenthesis around it,
choose Numbering instead of Reference under Format.

Numbering equations
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Math commands - Reference

Unary / binary operators

Operation Command Display
+sign +1 +1
-sign -1 =]
+/- sign +-1 +1
-/+ sign —t1 F1
Boolean not neg a ~a
Addition + a+b a+b
Dot product a cdotb a-b
Multiplication (X) a times b axb
Multiplication (asterisk) a*b ax*b
Boolean ‘and’ aandb aAb
Subtraction (-) a-b a—b
Division (as a fraction) aoverb %
Division (as an operator) adivb a+h
Division (with a slash) al/b alb
Boolean ‘or’ aorb avb
Concatenation acirc b aob
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Relational operators

Operation

Is equal

Is not equal
Approximately

Divides

Does not divide

Less than

Greater than

Similar to or equal
Parallel

Orthogonal to

Less than or equal to
Greater than or equal to
Similar to

Congruent

Less than or equal to
Greater than or equal to
Proportional

Toward

Arrow left

Arrow right

Double arrow left and right

Command
a=D>b
a<>Db

a approx 2
a divides b
a ndivides b
a<?2

a>?2

a simeq b

a parallel b
a ortho b

a leslant b
a geslant b
asimb

a equiv b
a<=Db
a>=Dhb
apropb

a toward b
a dlarrow b
a dlrarrow b

a drarrow b

Display

alb
a<sbh

a=b

Math commands - Reference
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Set operations

Operation

Is in

Is not in

Owns

Empty set
Intersection

Union

Difference

Quotient

Aleph

Subset

Subset or equal to
Superset

Superset or equal to
Not subset

Not subset or equal
Not superset

Not superset or equal
Set of natural numbers
Set of integers

Set of rational numbers

Set of real numbers

Set of complex numbers

Command
ain B

a notin B
Aownsb
emptyset

A intersection B
A union B

A setminus B
A slash B
aleph

A subset B

A subseteq B
A supset B

A supseteq B
A nsubset B

A nsubseteq B
A nsupset B

A nsupseteq B
setN

setZ

setQ

setR

setC

Display

20
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Functions

Operation
Exponential

Natural logarithm
Exponential function
Logarithm

Power

Sine

Cosine

Tangent

Cotangent

Square root

Arcsine

Arc cosine
Arctangent

Arc cotangent

n' root

Hyperbolic sine
Hyperbolic cosine
Hyperbolic tangent
Hyperbolic cotangent
Absolute value

Arc hyperbolic sine
Arc hyperbolic cosine
Arc hyperbolic tangent
Arc hyperbolic cotangent

Factorial

Command
func e™{a}
In(a)

exp(a)
log(a)
a™~{b}
sin(a)
cos(a)
tan(a)
cot(a)
sqrt{a}
arcsin(a)
arccos(a)
arctan(a)
arccot(a)
nroot{a}{b}
sinh(a)
cosh(a)
tanh(a)
coth(a)
abs{a}
arsinh(a)
arccosh(a)
arctanh(a)
arccoth(a)
fact{a}

Display

arcsin(a)
arccos(a)
arctan (a)
arccot (a)
b

sinh (a)

arsinh (a )
arcosh (a)
artanh (a)
arcoth (a)

al

Math commands - Reference
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Operators

All operators can be used with the limit functions (“from” and “to”).

Operation
Limit
Sum

Product
Coproduct

Upper and lower bounds
shown with integral

Integral
Double integral

Triple integral

Lower bound shown with
summation symbol

Contour integral
Double curved integral
Triple curved integral

Upper bound shown with
product symbol

Command
lim{a}
sum{a}
prod{a}
coprod{a}

int from {r 0} to {r t} a
int{a}

iint{a}

iiint{a}

sum from{3}b

lint a
llint a

lllint a

prod to{3}r

Display

lima

22
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Attributes

Operation Command Display

Acute accent
Grave accent
Reverse circumflex
Breve

Circle

Vector arrow
Tilde

Circumflex

Line above

Dot

Wide vector arrow
Wide tilde

Wide circumflex
Double dot

Line over

Line under

Line through
Triple dot

Transparent (useful to get a
placeholder of a given size)

Bold font

Italic fontl

Resize font

Following item in sans serif font2

Following item in serif font

Following item in fixed font

acute a

grave a
check a
breve a

circle a

vec a

tilde a

hat a

bar a

dot a
widevec abc
widetilde abc
widehat abc
ddot a
overline abc
underline abc
overstrike abc
dddot a

phantom a
bold a
ital “a”
size 16 qv

font sans qv
font serif qv

font fixed qv

a

Qo Q¢ K«

INY)

qv
qv
qv
qv

1 Unquoted text that is not a command is considered to be a variable. Variables are, by

default, italicized.

2 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed

(non-proportional). To change the actual fonts used for custom fonts and the fonts
used for variables (unquoted text), numbers and functions, use Format > Fonts.

Math commands - Reference
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Operation Command Display

Make color of following text cyan3 color cyan qv qv
Make color of following text yellow color yellow qv

Make color of following text white color white qv

Make color of following text green color green qv qv
Make color of following text blue color blue qv qv
Make color of following text red color red qv qv
Make color green returns to default

color black color green X qv X qv
Brace items to change color of more color green {X qv} Xqv

than one item

3 For all coloring, the color will apply only to the text immediately following the
command until the next space is encountered. In order to have the color apply to
more characters, place the text you want in color in curly brackets.
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Miscellaneous

Operation
Infinity

Partial

Nabla

There exists
For all

H bar

Lambda bar
Real part
Imaginary part
Weierstrass p
Left arrow
Right arrow
Up arrow
Down arrow
Dots at bottom
Dots at middle
Dots vertical

Dots diagonal upward

Dots diagonal downward

Command
infinity
partial
nabla
exists
forall

hbar
lambdabar
re

im

wp
leftarrow
rightarrow
uparrow
downarrow
dotslow
dotsaxis
dotsvert
dotsup

dotsdown

Display

8 > S g W g

I T 3 @

— -

Math commands - Reference
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Brackets

Operation

Round Brackets

Square Brackets
Double Square Brackets
Single line

Double line

Braces

Angle Brackets
Operator Brackets

Group brackets (used for
program control)

Scalable round brackets
(add the word “left” before
a left bracket and “right”
before a right bracket)

Square brackets scalable
(as above)

Double square brackets
scalable

Line scalable
Double line scalable
Brace scalable

Angle bracket scalable

Operator brackets scalable
Over brace scalable

Under brace scalable

Command

(a)

[b]

ldbracket ¢ rdbracket
lline a rline

ldline a rdline

Ibrace w rbrace
langle d rangle

langle a mline b rangle

{a}

left ( stack{a # b # z}
right )

left [ stack{ x # y} right ]

left ldbracket c right
rdbracket

left lline a right rline
left 1dline d right rdline
left lbrace e right rbrace
left langle f right rangle

left langle g mline h right
rangle

{The brace is above}
overbrace a

{the brace is
below}underbrace {f}

Display

a

—

The braceis above

the braceis below
f

26
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Formats

Operation

Left superscript
Center superscript

Right superscript
Left subscript

Center subscript

Right subscript

Align character to left (text
is aligned center by default)

Align character to center
Align character to right

Vertical stack of 2

Vertical stack, more than 2

Matrix

Equations aligned at '='
(using 'matrix')

Equations aligned at '='
(using 'phantom’')

New line

Small gap (grave)

Large gap (tilde)

Command
a lsup{b}

a csup{b}
a”~{b}

a Isub{b}
a csub{b}

a_{b}

stack { Hello world # alignl
(a) }

stack{Hello world #
alignc(a)}

stack { Hello world #
alignr(a) }

binom{a}{b}

stack{a # b # z}

matrix{
a#b##
c#d

}

matrix{

a # "=" # alignl{b} ##

{} # "=" # alignl{c+1}

}

stack{

alignl{a} = b #
alignl{phantom{a} = c+1}
}

asldkfjo newline sadkfj

stuff " stuff
stuff~stuff

Helloworld

(a)

Helloworld
(a)

Helloworld
(a)

<

SN S

N

asldkfio
sadkfj

stuff stuff
stuff  stuff

Math commands - Reference
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Characters - Greek

%ALPHA A| %YBETA B | %CHI X | %DELTA A | EPSILON E
%ETA H| %GAMMA I' | %I0TA I | %KAPPA K| %LAMBDA A
%MU M| %NU N| %OMEGA Q| %OMICRON O | %PHI o)
%PI IT| %PSI ¥ | %RHO P | %SIGMA Y | %THETA C)
%UPSILON Y | %XI E | %ZETA Z

%alpha « | Yobeta B | %chi X | %delta 5 | %epsilon €
%eta n | %gamma y | %iota ¢ | %kappa k | %lambda A
Y%omu %nu v | Y%oomega w | Yoomicron o | %phi b
%pi 7t | %rho p | %sigma o | %tau T | %theta 0
%upsilon v | %varepsilon ¢ | %varphi @ | Yovarpi w | Y%varrho 0
%varsigma ¢ | %vartheta 9 | Yoxi g | %ozeta C
Characters - Special

%and A %angle < %element € %identical =
%infinite o %noelement & %notequal # %or V

%perthousand %o

%strictlygreaterthan >

%strictlylessthan <

%tendto —
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