
Apache OpenOffice

Version 4.1

Getting Started

AOO Documentation Team

 | 1



Copyright
This document is Copyright © 2023 by The Apache Software Foundation. You may 
distribute it and/or modify it under the terms of the Creative Commons Attribution 
License, version 3.0 or later (https://creativecommons.org/licenses/by/3.0/).

Apache, Apache OpenOffice, and OpenOffice.org are trademarks of the Apache 
Software Foundation. Used with permission. .

Acknowledgments
This book is updated from Taming Apache OpenOffice 3.4 (by Jean Hollis Weber), 
which was adapted from Getting Started with OpenOffice.org 3.3 (by the OOoAuthors 
team) with additional material adapted from Getting Started with LibreOffice 3.4 (by 
the ODF Authors Team).

Publication date and software version
Published 19 April 2023. Based on Apache OpenOffice 4.1.

https://creativecommons.org/licenses/by/3.0/


Contents
Chapter 2 
Using Styles and Templates.............................................................................................................5

What Is a Template?....................................................................................................................5
What Are Styles?.........................................................................................................................5

Using Styles Is Highly Recommended.....................................................................................5
Type of Styles in Apache OpenOffice......................................................................................6

Applying Styles............................................................................................................................7
Using the Styles Deck in the Sidebar......................................................................................7
Using Fill Format Mode...........................................................................................................8
Using the Apply Style List in Writer.........................................................................................8
Using Keyboard Shortcuts.......................................................................................................9

Modifying Styles...........................................................................................................................9
Changing a Style Using the Style Dialog.................................................................................9
Updating a Style from a Selection.........................................................................................10
Using AutoUpdate (Writer)....................................................................................................10
Updating Styles from a Document or Template.....................................................................10

Creating New (Custom) Styles...................................................................................................10
Creating a New Style Using the Style Dialog.........................................................................11
Creating a New Style from a Selection..................................................................................11
Dragging and Dropping to Create a Style (Writer and Calc)..................................................11

Copying and Moving Styles.......................................................................................................12
Using the Template Management Dialog..............................................................................12
Loading Styles from a Template or Document......................................................................13

Deleting Styles...........................................................................................................................14
Using a Template to Create a Document...................................................................................14
Creating a Template..................................................................................................................15

Creating a Template from a Document..................................................................................15
Creating a Template Using a Wizard.....................................................................................16

Adding Templates Using the Extension Manager......................................................................17
Editing a Template.....................................................................................................................18

Updating a Document from a Changed Template.................................................................18
Changing the Template Assigned to a Document......................................................................19
Setting a Default Template........................................................................................................19

Setting a Template as the Default.........................................................................................19
Resetting the Default Template.............................................................................................19

Organizing Templates................................................................................................................20
Creating a Template Folder...................................................................................................20
Deleting a Template Folder...................................................................................................20
Moving a Template................................................................................................................20
Deleting a Template..............................................................................................................20
Importing a Template............................................................................................................21
Exporting a Template............................................................................................................21

Examples of Style Use...............................................................................................................21
Defining a Different First Page for a Document.....................................................................21
Dividing a Document into Chapters.......................................................................................22
Changing Page Orientation Within a Document....................................................................22
Different Headers on Right and Left Pages...........................................................................22
Controlling Page Breaks Automatically..................................................................................23
Compiling an Automatic Table of Contents...........................................................................23
Defining a Sequence of Styles..............................................................................................23

Chapter 2 
Using Styles and Templates | 3



Chapter 2 
Using Styles and Templates

What Is a Template?

A template is a model document that you use to create other documents. For 
example, you can create a template for business reports that has your company’s logo 
on the first page and has the fonts, paragraph layout, footer content and any other 
details needed to meet corporate requirements. New documents created from this 
template will have a consistent and compliant appearance automatically.

Templates can contain anything that regular documents can contain, such as text, 
graphics, a set of styles, and user-specific setup information such as measurement 
units, language, the default printer, and toolbar and menu customization.

All documents in Apache OpenOffice are based on templates. You can create, or 
download and install, as many templates as you wish, and you can specify a template 
as the default for each type of document (text, spreadsheet, drawing, presentation). If 
you do not choose a template when you start a new document, then the new 
document is based on the default template for that type of document. If you have not 
specified a default template, Apache OpenOffice uses the blank template for that type 
of document that is installed with Apache OpenOffice. See “Setting a Default 
Template” on page 18 for more information.

What Are Styles?

A style is a set of formats that you can apply to selected elements such as pages, 
paragraphs, characters, frames, cells, and other elements in a document to quickly 
set or change their appearance. When you apply a style, you apply a whole group of 
formats at the same time.

Many people manually format paragraphs, words, tables, page layouts, and other 
parts of their documents without paying any attention to styles. For example, they 
might specify the font family, font size, and any formatting such as bold or italic.

Using styles means that instead of applying “font size 14pt, Times New Roman, bold, 
centered”, you can apply (for example) a “Title” style, if you have defined the “Title” 
style to have those characteristics. In other words, using styles means that you shift 
the emphasis from what the text (or page, or other element) looks like, to what the 
text is.

Using Styles Is Highly Recommended
Apache OpenOffice is a styles-based program. Using styles effectively requires some 
planning, but the time spent in planning can save time and effort over the longer 
term.
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Because styles apply whole groups of formats at the same time, you can easily format 
a document consistently and change the formatting of an entire document with 
minimal effort. For example, the font family, size, and color of the headings in this 
document are set with a style. If you want to change those characteristics, editing the 
style takes a few seconds. If those headings had been formatted manually, changing 
them would require selecting every heading and applying the new settings. In 
addition, styles are used by Apache OpenOffice for many processes, even if you are 
not aware of them. For example, Writer relies on heading styles (or other styles you 
specify) when it compiles a table of contents. Some common examples of style use 
are given in “Examples of Style Use” on page 20.

Type of Styles in Apache OpenOffice
Apache OpenOffice supports the following types of styles:

• Page styles include margins, headers and footers, borders and backgrounds. In 
Calc, page styles also include the sequence for printing sheets.

• Paragraph styles control all aspects of a paragraph’s appearance, such as text 
alignment, tab stops, line spacing, and borders, and can include character 
formatting. 

• Character styles affect selected text within a paragraph, such as the font and 
size of text, or bold and italic formats.

• Frame styles are used to format graphic and text frames, including wrapping 
type, borders, backgrounds, and columns.

• Numbering styles apply similar alignment, numbering or bullet characters, and 
fonts to numbered or bulleted lists.

• Cell styles include fonts, alignment, borders, background, number formats (for 
example, currency, date, number), and cell protection.

• Graphics styles in drawings and presentations include line, area, shadowing, 
transparency, font, connectors, dimensioning, and other attributes.

• Presentation styles include attributes for font, indents, spacing, alignment, and 
tabs.

Different styles are available in the various components of Apache OpenOffice, as 
listed in Table 1.

Apache OpenOffice comes with many predefined styles. You can use the styles as 
provided, modify them, or create new styles, as described in this chapter.
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Table 1. Styles available in Apache OpenOffice components

Style Type Writer Calc Draw Impress

Page X X

Paragraph X

Character X

Frame X

Numbering X

Cell X

Presentation X X

Graphics (included in 
Frame styles)

X X

Applying Styles

Apache OpenOffice provides several ways for you to apply styles:

• Styles and Formatting deck in the Sidebar

• Fill Format Mode

• Apply Style list on the Formatting toolbar (Writer)

• Keyboard shortcuts

Using the Styles Deck in the Sidebar
1) You can open the Styles and Formatting deck on the Sidebar in several 

ways: click the icon on the Sidebar, or choose Format > Styles and 
Formatting from the Menu bar, or press F11, or click the Styles and 

Formatting icon  located at the left-hand end of the Formatting toolbar. 
Some of these methods will bring up the Styles and Formatting deck as a 
floating toolbar even if the sidebar is docked.
The Styles and Formatting deck shows the types of styles available for the 
Apache OpenOffice component you are using. Figure 1 shows the window for 
Writer, with Page Styles visible.

2) Click on one of the icons at the top left of the Styles and Formatting deck to 
display a list of styles in that category.

3) To apply an existing style (except for character styles), position the insertion 
point in the paragraph, frame, or page, and then double-click on the name of 
the style in one of these lists. To apply a character style, select the characters 
first.

Tip

At the bottom of the Styles and Formatting deck is a dropdown list. 
In Figure 1 the deck shows Automatic, meaning the list includes only 
styles applied automatically by Apache OpenOffice. You can choose 
to show all styles or other groups of styles, for example only custom 
styles.
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Figure 1: The Styles and Formatting window for Writer, showing 
paragraph styles

Using Fill Format Mode
Use Fill Format to apply a style to many areas quickly without having to go back to 
the Styles and Formatting deck and double-click every time. This method is quite 
useful when you need to format many scattered paragraphs, cells, or other items with 
the same style.

1) Open the Styles and Formatting deck and select the style you want to apply.

2) Click the Fill Format mode icon . The cursor shape will change to 
resemble the icon.
To apply a paragraph, page, or frame style, hover the mouse over the 
paragraph, page, or frame and click. 
To apply a character style, hold down the mouse button while selecting the 
characters. Clicking on a word applies the character style to that word. 

3) Repeat step 2 until you made all the changes for that style.
4) To quit Fill Format mode, click the Fill Format mode icon again or press the 

Esc key.

Using the Apply Style List in Writer
In Writer, after you have used a style at least once in a document, the style name 
appears on the Apply Style list at the left-hand end of the Formatting toolbar, next to 
the Styles and Formatting icon.

You can open this list and click once on the style you want, or you can use the up and 
down arrow keys to move through the list and then press Enter to apply the 
highlighted style.

Tip Select More… at the bottom of the list to open the Styles and 
Formatting window.
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Figure 2: The Apply Style list on the Formatting toolbar

Using Keyboard Shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer 
Ctrl+0 applies the Text body style, Ctrl+1 applies the Heading 1 style, and Ctrl+2 
applies the Heading 2 style. You can modify these shortcuts and create your own; see 
Chapter 11 (Setting up and Customizing Apache OpenOffice) for instructions.

Modifying Styles

Apache OpenOffice provides several ways to modify styles (both the predefined styles 
and custom styles that you create):

• Change a style using the Style dialog

• Update a style from a selection

• Use AutoUpdate (paragraph and frame styles only)

• Load or copy styles from another document or template

Tip
Any changes you make to a style are effective only in the current 
document. To change styles in more than one document, you need to 
change the template or copy the styles into the other documents as 
described on page 11.

Changing a Style Using the Style Dialog
To change an existing style using the Style dialog, right-click on the required style in 
the Styles and Formatting deck and select Modify from the pop-up menu. In Writer, 
you can also right-click in a paragraph and choose Edit Paragraph Style from the 
context menu.

The Style dialog displayed depends on the type of style selected. Each style dialog 
has several tabs. For example, in Writer the Paragraph Style dialog includes tabs for 
Indents & Spacing, Font, Borders, Background, Outline & Numbering, and others.
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Updating a Style from a Selection
To update a style from a selection:

1) Open the Styles and Formatting deck in the Sidebar.
2) In the document, select an item that has the format you want to adopt as a 

style.

Caution Make sure that there are unique properties in this paragraph. For 
example, if there are two different font sizes or font styles, that 
particular property will remain the same as before.

3) In the Styles and Formatting deck, select the style you want to update (single-
click, not double-click), then click on the arrow next to the New Style from 
Selection icon and click on Update Style.

Figure 3: Updating a style from a selection

Using AutoUpdate (Writer)
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is 
selected on the Organizer page of the Paragraph Style or Frame Style dialog, 
applying direct formatting to a paragraph or frame using this style in your document 
automatically updates the style itself.

Tip If you are in the habit of manually overriding styles in your 
document, be sure that AutoUpdate is not enabled.

Updating Styles from a Document or Template
You can update styles by copying or loading them from a template or another 
document. See “Copying and Moving Styles” on page 11.

Creating New (Custom) Styles

You may want to add some new styles. You can do this in two ways:

• Using the Style dialog

• From a selection
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Creating a New Style Using the Style Dialog
To create a new style using the Style dialog, open the Sidebar Styles and Formatting 
deck and select the category of the style you wish to create by clicking one of the 
icons at the top of the deck. Then right-click and select New from the pop-up menu. 
If you want the new style to be linked with an existing style, first select that style and 
then right-click and select New.

If you link styles, the new style will inherit characteristics from the style that you 
selected. If you later change the base style (for example, by changing the font from 
Times to Helvetica), all the linked styles will change as well. Sometimes this is 
exactly what you want; other times you do not want the changes to apply to all the 
linked styles. It pays to plan ahead.

The dialog and choices are the same for defining new styles and for modifying 
existing styles.

Creating a New Style from a Selection
You can create a new style by copying an existing manual format. This new style 
applies only to this document; it will not be saved in the template.

1) Open the Styles and Formatting window and choose the type of style you want 
to create.

2) In the document, select the item you want to save as a style.
3) In the Styles and Formatting window, click on the New Style from Selection 

icon.
4) In the Create Style dialog, type a name for the new style. The list shows the 

names of existing custom styles of the selected type. Click OK to save the new 
style.

Figure 4: Naming a new style created from a selection

Dragging and Dropping to Create a Style (Writer and Calc)
You can drag and drop a text selection into the Styles and Formatting deck to create 
a new style.

Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph 
Styles are active, the paragraph style will be added to the list. If Character Styles 
are active, the character style will be added to the list.
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Calc
Drag a cell selection to the Styles and Formatting deck to create cell styles.

Copying and Moving Styles

You can copy or move styles from one template or document into another template or 
document, in two ways:

• Using the Template Management dialog

• Loading styles from a template or document

Using the Template Management Dialog
To copy or move styles using the Template Management dialog:

1) Click File > Templates > Organize.
2) In the Template Management dialog (Figure 5), set the lists at the bottom to 

either Templates or Documents, as needed. The default is Templates on the left 
and Documents on the right.

Tip
To copy styles from a file that is not open, click the File button. When 
you return to this dialog, both lists show the selected file and all the 
currently open documents.

Figure 5: Choosing to copy styles from a document, not a template

3) Open the folders and find the templates from and to which you want to copy. 
Double-click on the name of the template or document, and then double-click 
the Styles icon to show the list of individual styles (Figure 6).

4) To copy a style, hold down the Ctrl key and drag the name of the style from one 
list to the other.
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Caution If you do not hold down the Ctrl key when dragging, the style will 
be moved from one list to the other. The style will be deleted from 
the list you are dragging it from.

5) Repeat for each style you want to copy. If the receiving template or document 
has many styles, you may not see any change unless you scroll down in the list. 
When you are finished, click Close.

Figure 6: Copying a style from one document to another

Loading Styles from a Template or Document
You can copy styles by loading them from a template or another document:

1) Open the document you want to copy styles into.
2) In the Styles and Formatting deck, click on the arrow next to the New Style 

from Selection icon, and then click on Load Styles (see Figure 3).
3) On the Load Styles dialog (Figure 7), find and select the template you want to 

copy styles from.

Figure 7. Copying styles from a template into the open document
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4) Select the categories of styles to be copied. Select Overwrite if you want the 
styles being copied to replace any styles of the same names in the document 
you are copying them into.

5) Click OK to copy the styles. You will not see any change on screen.

Note To copy the styles from another document, click the From File button 
to open a window from which you can select the required document.

Deleting Styles

You cannot remove (delete) any of Apache OpenOffice’s predefined styles from a 
document or template, even if they are not in use.

You can remove any user-defined (custom) styles; but before you do, you should make 
sure the styles are not in use. If an unwanted style is in use, you will want to replace 
it with a substitute style.

To delete unwanted styles, right-click on them (one at a time) in the Styles and 
Formatting window and click Delete on the pop-up menu.

If the style is in use, you receive a warning message.

If the style is not in use, you receive a confirmation message; click Yes.

Using a Template to Create a Document

To use a template to create a document:
1) From the main menu, choose File > New > Templates and Documents. The 

Templates and Documents dialog (Figure 8) opens.
2) In the box on the left, click the Templates icon if it is not already selected. A 

list of template folders appears in the center box.
3) Double-click the folder that contains the template that you want to use. A list 

of all the templates contained in that folder appears in the center box.
4) Select the template that you want to use. You can preview the selected 

template or view the template’s properties using the icons just below the title 
bar and slightly to the right of center:

• To preview the template, click the Preview icon . A preview of the 
template appears in the box on the right.

• To view the template’s properties, click the Document Properties icon 

. The template’s properties appear in the box on the right.

5) Click Open. The Templates and Documents dialog closes and a new document 
based on the selected template opens in Apache OpenOffice.
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Figure 8: Templates and Documents window

Creating a Template

You can create your own templates in two ways: from a document or (in Writer) by 
using a wizard.

Creating a Template from a Document
In addition to formatting, any settings that can be added to or modified in a 
document can be saved in a template. For example, below are some settings 
(although not a full list) that can be included in a Writer document and then saved as 
a template for later use:

• Printer settings: which printer, single sided / double-sided, and paper size, and 
so on

• Styles to be used, including character, page, frame, numbering, and paragraph 
styles

• Format and settings regarding indexes, tables, bibliographies, table of 
contents

Templates can also contain predefined text, saving you from having to type it every 
time you create a new document. For example, a letter template may contain your 
name, address, and salutation.

You can also save menu and toolbar customizations in templates; see Chapter 11 
(Setting Up and Customizing Apache OpenOffice) for more information.

To create a template from a document:
1) Open a new or existing document of the type you want to make into a template 

(text document, spreadsheet, drawing, presentation).
2) Add the content and styles that you want.
3) From the main menu, choose File > Templates > Save. The Templates dialog 

opens (see Figure 9).
4) In the New template field, type a name for the new template.
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5) In the Categories list, click the category to which you want to assign the 
template. The category you choose has no effect on the template itself; it is 
simply the folder in which you save the template. 

6) Selecting an appropriate category makes it easier to find the template when 
you want to use it. For example, you might save Impress templates under the 
Presentations category.

7) To learn more about template folders, see “Organizing Templates” on page 19.
8) Click OK to save the new template.

Figure 9: Saving a new template

Creating a Template Using a Wizard
In Writer, you can use wizards to create templates for letters, faxes, agendas, 
presentations, and Web pages.

For example, the Letter Wizard guides you through the following choices:

• Type of letter (business, formal personal or personal)

• Document elements like the return address, subject line (business letter), 
salutation, and complimentary close

• Options for sender and recipient information (business letter)

• Text to include in the footer (business letter)

To create a template using a wizard:
1) From the main menu, choose File > Wizards > [type of template required] 

(see Figure 10).
2) Follow the instructions on the pages of the wizard. This process is slightly 

different for each type of template, but the format is very similar.
3) In the last section of the wizard, you can specify the name and location for 

saving the template. The default location is your user templates directory, but 
you can choose a different location if you prefer.

4) Finally, you have the option of creating a new document from your template 
immediately, or manually changing the template. For future documents, you 
can re-use the template created by the wizard, just as you would use any other 
template.
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Figure 10. Creating a template using a wizard

Adding Templates Using the Extension Manager

The Extension Manager provides an easy way to install collections of templates, 
graphics, macros, or other add-ins that have been “packaged” into files with a .OXT 
extension. See Chapter 11 (Setting up and Customizing Apache OpenOffice) for more 
about the Extension Manager.

This Web page lists many of the available extensions: https://extensions.openoffice.org/. 
Others may be available from third-party websites.

To install an extension, follow these steps:
1) Download an extension package and save it anywhere on your computer.
2) In Apache OpenOffice, select Tools > Extension Manager from the menu bar. 

In the Extension Manager dialog, click Add.
3) A file browser window opens. Find and select the package of templates you 

want to install and click Open. The package begins installing. You may be 
asked to accept a license agreement.

4) When the package installation is complete, the templates are available for use 
through File > New > Templates and Documents and the extension is listed 
in the Extension Manager.
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Editing a Template

You can edit a template’s styles and content, and then, if you wish, you can reapply 
the template’s styles to documents that were created from that template. You cannot 
reapply content.

To edit a template:
1) From the main menu, choose File > Templates > Edit. A file browser window 

opens.
2) Select the template that you want to edit and click Open.
3) Edit the template as you would edit any other document. To save your changes, 

choose File > Save from the main menu.

Updating a Document from a Changed Template
The next time you open a document that was created from the changed template, a 
confirmation message appears.

Click Update Styles to apply the template’s changed styles to the document, or click 
Keep Old Styles if you do not want to apply the changed styles to the document.

Caution If you choose Keep Old Styles, the document is no longer 
connected to the template, even though the template is still listed 
under File > Properties > General. To connect the document to the 
template again, use the procedure described in “Changing the 
Template Assigned to a Document” below.
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Changing the Template Assigned to a Document

You can change the template assigned to a document, or reconnect a document to a 
template, in two ways: manually or using the Template Changer extension to 
OpenOffice.

To change or reassign a template manually, first create a new, blank document from 
the required template, as described on page 13. Then copy the contents of the old 
document into the new document.

To use the Template Changer extension, first you need to download and install it, 
then restart OpenOffice to activate it. After that, you can open the document and use 
File > Templates > Change Template (current document) from the main menu.

The Template Changer extension works with Writer, Calc, Draw, and Impress.

Setting a Default Template

If you create a document by choosing File > New > Text Document (or 
Spreadsheet, Presentation, or Drawing) from the main menu, Apache OpenOffice 
creates the document from the Default template for that type of document. You can, 
however, set a custom template to be the default. You can reset the default later if 
you decide.

Setting a Template as the Default
You can set any template to be the default, as long as it is in one of the folders 
displayed in the Template Management dialog.

To set a custom template as the default:
1) From the main menu, choose File > Templates > Organize. The Template 

Management dialog opens.
2) In the box on the left, select the folder containing the template that you want 

to set as the default, then select the template.
3) Click the Commands button and choose Set As Default Template from the 

drop-down menu.

The next time that you create a document by choosing File > New, the document will 
be created from this template.

Although many important settings can be changed in the Options dialog (see Chapter 
11), for example default fonts and page size, more advanced settings (such as page 
margins) can only be changed by replacing the default template with a new one.

Resetting the Default Template
To re-enable Apache OpenOffice’s Default template for a document type as the 
default:

1) In the Template Management dialog, click any folder in the box on the left.
2) Click the Commands button and choose Reset Default Template from the 

drop-down menu.

The next time that you create a document by choosing File > New, the document will 
be created from Apache OpenOffice’s Default template for that document type.
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Organizing Templates

Apache OpenOffice can only use templates that are in Apache OpenOffice template 
folders. You can create new Apache OpenOffice template folders and use them to 
organize your templates. For example, you might have one template folder for report 
templates and another for letter templates. You can also import and export templates.

To begin, choose File > Templates > Organize from the main menu. The Template 
Management dialog opens.

Note
All the actions made by the Commands button in the Template 
Management dialogue can be made as well by right-clicking on the 
templates or the folders.

Creating a Template Folder
To create a template folder:

1) In the Template Management dialog, click any folder.
2) Click the Commands button and choose New from the drop-down menu. A 

new folder called Untitled appears.
3) Type a name for the new folder, and then press Enter. Apache OpenOffice saves 

the folder with the name that you entered.

Deleting a Template Folder
You cannot delete template folders supplied with Apache OpenOffice or installed 
using the Extension Manager; you can only delete template folders that you have 
created.

To delete a template folder that you have created:
1) In the Template Management dialog, select the folder that you want to delete.
2) Click the Commands button and choose Delete from the drop-down menu. A 

message box appears and asks you to confirm the deletion. Click Yes.

Moving a Template
To move a template from one template folder to another template folder:

1) In the Template Management dialog, double-click the folder that contains the 
template you want to move. A list of the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to move and drag it to the desired folder. If 
you do not have the authority to delete templates from the source folder, this 
action copies the template instead of moving it.

Deleting a Template
You cannot delete templates supplied with Apache OpenOffice or installed using the 
Extension Manager; you can only delete templates that you have created or imported.

To delete a template:
1) In the Template Management dialog, double-click the folder that contains the 

template you want to delete. A list of the templates contained in that folder 
appears underneath the folder name.
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2) Click the template that you want to delete.
3) Click the Commands button and choose Delete from the drop-down menu. A 

message box appears and asks you to confirm the deletion. Click Yes.

Importing a Template
If the template that you want to use is in a different location, you must import it into 
an Apache OpenOffice template folder.

To import a template into a template folder:
1) In the Template Management dialog, select the folder into which you want to 

import the template.
2) Click the Commands button and choose Import Template from the drop-

down menu. A standard file browser window opens.
3) Find and select the template that you want to import and click Open. The file 

browser window closes and the template appears in the selected folder.
4) If you want, type a new name for the template, and then press Enter.

Exporting a Template
To export a template from a template folder to another location:

1) In the Template Management dialog, double-click the folder that contains the 
template you want to export. A list of the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to export.
3) Click the Commands button and choose Export Template from the drop-

down menu. The Save As window opens.
4) Find the folder into which you want to export the template and click Save.

Examples of Style Use

The following examples of common use of page and paragraph styles are taken from 
Writer. There are many other ways to use styles; see the guides for the various 
components for details.

Defining a Different First Page for a Document
Many documents, such as letters and reports, have a first page that is different from 
the other pages in the document. For example, the first page of a letter typically has 
a different header, or the first page of a report might have no header or footer, while 
the other pages do. With Apache OpenOffice, you can define the page style for the 
first page and specify the style for the following pages to be applied automatically.

As an example, we can use the First Page and Default page styles that come with 
Apache OpenOffice. Figure 12 shows what we want to happen: the first page is to be 
followed by the default page, and all the following pages are to be in the Default page 
style. Details are in Chapter 4 (Formatting Pages) in the Writer Guide.
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Dividing a Document into Chapters
Similarly, you can divide a document into chapters. Each chapter might start with the 
First Page style, with the following pages using the Default page style, as above. At 
the end of the chapter, insert a manual page break and specify the next page to have 
the First Page style to start the next chapter, as shown in Figure 13.

Figure 13: Dividing a document into chapters using page 
styles

Changing Page Orientation Within a Document
A Writer document can contain pages in more than one orientation. A common 
scenario is to have a landscape page in the middle of a document, where the other 
pages are in a portrait orientation. This can be done with page breaks and page 
styles. Position the cursor at the point where you want to start the new (landscape) 
page. Click Insert > Manual Break on the main menu. In the Insert Break dialog, 
select Page Break under Type, and select a page style with landscape orientation in 
the Page Style list. Click OK to insert the page. To go back to the portrait page style, 
insert another page break and select the portrait page style you are using (which may 
be Default Page Style, if you haven’t selected or created a different one).

Different Headers on Right and Left Pages
Page styles can be set up to have the facing left and right pages mirrored or only 
right (first pages of chapters are often defined to be right-page only) or only left. 
When you insert a header on a page style set up for mirrored pages or right-and-left 
pages, you can have the contents of the header be the same on all pages or be 
different on the right and left pages. For example, you can put the page number on 
the left-hand edge of the left pages and on the right-hand edge of the right pages, put 
the document title on the right-hand page only, or make other changes.
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Controlling Page Breaks Automatically
Writer automatically flows text from one page to the next. If you do not like the 
default settings, you can change them. For example, you can require a paragraph to 
start on a new page or column and specify the style of the new page. A typical use is 
for chapter titles to always start on a new right-hand (odd-numbered) page.

Compiling an Automatic Table of Contents
To compile an automatic table of contents, first apply styles to the headings you want 
to appear in the contents list, then use Tools > Outline Numbering to tell Writer 
which styles go with which level in the table of contents. See Chapter 3 for more 
information.

Defining a Sequence of Styles
You can set up one paragraph style so that when you press Enter at the end of that 
paragraph, the following paragraph automatically has the style you wish applied to it. 
For example, you could define a Heading 1 paragraph to be followed by a Text Body 
paragraph. A more complex example would be: Title followed by Author followed by 
Abstract followed by Heading 1 followed by Text Body. By setting up these sequences, 
you can often avoid manually applying styles.
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