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Getting Started with Impress

What is Impress?
Impress is OpenOffice.org’s slide show (presentations) program. You
can create slides that contain many different elements, including text,
bulleted and numbered lists, tables, charts, clip art, and a wide range
of graphic objects. Impress also includes a spelling checker, a
thesaurus, prepackaged text styles, and attractive background styles.
This chapter includes instructions, screenshots, and hints to guide you
through the Impress environment while designing the easier
presentations. Although more difficult designs are mentioned
throughout this chapter, explanations for creating them are in the
Impress Guide. If you have a working knowledge of how to create slide
shows, we recommend you use the Impress Guide for your source of
information.
To use Impress for more than very simple slide shows requires some
knowledge of the elements which the slides contain. Slides containing
text use styles to determine the appearance of that text. Slides
containing objects are created the same way that drawings are created
in Draw. For this reason, we recommend that you also study Chapter 3
(Working with Templates and Styles) and Chapter 7 (Getting Started
with Draw).

Parts of the main Impress window
The main Impress window (Figure 1) has three parts: the Slides pane,
Workspace, and Tasks pane. Additionally, several toolbars can be
displayed or hidden during the creation of a presentation.

Tip

You can remove the Slides pane or Tasks pane from view by
clicking the X in the upper right corner. You can also show or
hide these panes using View > Slide Pane or View > Tasks
Pane.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your
presentation, in the order they will be shown (unless you change the
order). Clicking a slide selects it and places it in the Workspace. While
it is there, you can apply any changes desired to that particular slide.

Parts of the main Impress window
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Figure 1: Main window of Impress
Several additional operations can be performed on one or more slides
in the Slides pane:
• Add new slides at any place within the presentation after the first
slide.
• Mark a slide as hidden so that it will not be shown as part of the
slide show.
• Delete a slide from the presentation if it is no longer needed.
• Rename a slide.
• Copy or move the contents of one slide to another (copy and
paste, or cut and paste, respectively).
It is also possible to perform the following operations, although there
are more efficient methods than using the Slides pane:
• Change the slide transition following the selected slide or after
each slide in a group of slides.
• Change the sequence of slides in the presentation.
• Change the slide design. (A window opens allowing you to load
your own design.)
• Change slide layout for a group of slides simultaneously. (This
requires using the Layouts section of the Tasks pane.)
6
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Tasks pane
The Tasks pane has five sections.
Master Pages
Here you define the page style for your presentation. Impress
contains 28 prepackaged Master Pages (slide masters). One of them
—Default—is blank, and the rest have a background.
Tip

Press F11 to open the Styles and Formating window, where
you can modify the styles used in any slide master to suit your
purpose. This can be done at any time.

Layout
Twenty prepackaged layouts are shown. You can choose the one you
want, use it as it is or modify it to your own requirements. At
present it is not possible to create custom layouts.
Table Design
Eleven standard table styles are provided in this pane. You can
further modify the appearance of a table with the selections to show
or hide specific rows and columns, or to apply a banded appearance
to the rows and columns.
Custom Animation
A variety of animations for selected elements of a slide are listed.
Animation can be added to a slide, and it can also be changed or
removed later.
Slide Transition
Fifty-six transitions are available, including No Transition. You can
select the transition speed (slow, medium, fast). You can also choose
between an automatic or manual transition, and how long you want
the selected slide to be shown (automatic transition only).

Workspace
The Workspace has five tabs: Normal, Outline, Notes, Handout, and
Slide Sorter. These five tabs are called View buttons. There are also
many toolbars that can be used during slide creation; they are revealed
by selecting them with View > Toolbars. The Workspace is below the
View buttons. This is where you assemble the various parts of your
selected slide.

Parts of the main Impress window
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Each view is designed to make completing certain tasks easier. In
summary:
• Normal view is the main view for creating individual slides. Use
this view to format and design slides and to add text, graphics,
and animation effects.
• Outline view shows topic titles, bulleted lists, and numbered lists
for each slide in outline format. Use this view to rearrange the
order of slides, edit titles and headings, rearrange the order of
items in a list, and add new slides.
• Notes view lets you add notes to each slide that are not seen
when the presentation is shown.
• Slide Sorter view shows a thumbnail of each slide in order. Use
this view to rearrange the order of slides, produce a timed slide
show, or add transitions between selected slides.
• Handout view lets you print your slides for a handout. You can
choose one, two, three, four, or six slides per page from Tasks
pane > Layouts. Thumbnails can be re-arranged in this view by
dragging and dropping them.

Toolbars
The various Impress toolbars can be displayed or hidden by clicking
View > Toolbars and selecting from the menu. You can also select the
icons that you wish to appear on each toolbar. For more information,
refer to Chapter 1 (Introducing OpenOffice.org).
Many of the toolbars in Impress are similar to the toolbars in OOo
Draw. Refer to the Draw Guide for details on the functions available
and how to use them.

Status bar
The Status bar (Figures 2 and 3) is located at the bottom of the
workspace. In addition to fields common to several OOo components, it
includes several Impress-specific fields. For details on the contents and
use of these fields, see Chapter 1 (Introducing OpenOffice.org) in this
book and Chapter 1 (Introducing Impress) in the Impress Guide.

Note
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The sizes are given in the current measurement unit (not to be
confused with the ruler units). This unit is defined in Tools >
Options > OpenOffice.org Draw > General, where you can
also change the scale of the page. Another way to change the
scale is to double-click on the number shown in the status bar.
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Figure 2: Left end of the Impress status bar

Figure 3: Right end of Impress status bar

Navigator
The Navigator (Figure 4) displays all objects contained in a document.
It provides another convenient way to move around a document and
find items in it. The Navigator icon
is located on the Standard
toolbar. You can also display the Navigator by choosing Edit >
Navigator on the menu bar or pressing Ctrl+Shift+F5.
The Navigator is more useful if you give your slides and objects
(pictures, spreadsheets, and so on) meaningful names, instead of
leaving them as the default “Slide n” and “Shape n” shown in Figure 4.

Figure 4: Navigator

Parts of the main Impress window
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Working with views
This section describes the use of the five views.

Normal view
Normal view is the main view for working with individual slides. Use
this view to format and design and to add text, graphics, and animation
effects.
To place a slide in the Slide Design area of the Normal view, click the
slide thumbnail in the Slides pane or use the Navigator.
To select a slide in the Navigator, scroll down the list until you find it
and then double-click it.

Outline view
Outline view (Figure 5) contains all the slides of the presentation in
their numbered sequence. It shows topic titles, bulleted lists, and
numbered lists for each slide in outline format. Only the text contained
in the default text boxes in each slide is shown, so if your slide includes
other text boxes or drawing objects, the text in these objects is not
displayed. Slide names are also not included.

Figure 5: Outline view
10
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Outline view serves at least two purposes.
1) Making changes in the text of a slide:
•
You can add and delete the text in a slide just as you would in
the Normal view.
•
You can move the paragraphs of text in the selected slide up
or down by using the up and down arrow buttons (Move Up or
Move Down) on the Text Formatting toolbar.
•
You can change the Outline Level for any of the paragraphs in
a slide using the left and right arrow buttons (Promote or
Demote).
•
You can both move a paragraph and change its outline level
using a combination of these four arrow buttons.
2) Comparing the slides with your outline (if you have prepared one
in advance). If you notice from your outline that another slide is
needed, you can create it directly in the Outline view (pressing
Enter when the cursor is on the first line of the slide) or you can
change to the Normal view to create it, then return to Outline
view to continue reviewing the slides against your outline.
If a slide is not in the correct sequence, you can move it to its
proper place.
a) In the slide pane, click the slide icon of the slide you are
moving.
b) Drag and drop it where you want it.

Notes view
Use the Notes view to add notes to a slide.
1) Click the Notes tab in the Workspace (Figure 6).
2) Select the slide to which you want to add notes.
•
Click the slide in the Slide pane, or
•
Use the Previous Slide and Next Slide buttons to move to
the desired slide in the Navigator.
3) In the text box below the slide, click on the words Click to add
notes and begin typing.
You can resize the Notes text box using the green resizing handles and
move it by placing the pointer on the border, then clicking and
dragging. To make changes in the text style, press the F11 key to open
the Styles and Formatting window.

Working with views
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Figure 6: Notes view

Slide Sorter view
Slide Sorter view contains all the slide thumbnails (Figure 7). Use this
view to work with a group of slides or with only one slide.

Figure 7: Slide Sorter view
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Change the number of slides per row if desired.
1) Check View > Toolbars > Slide View to make the Slide View
toolbar (Figure 8) visible.

Figure 8: Slide Sorter and Slide View toolbars
2) Adjust the number of slides (up to a maximum of 15).
3) When you have adjusted the number of slide per row, click View
> Toolbars > Slide View to remove this toolbar from view.
To move a slide in a presentation in the Slide Sorter:
1) Click the slide. A thick black border is drawn around it.
2) Drag and drop it to the location you want.
•
As you move the slide, a black vertical line appears to one side
of the slide.
•
Drag the slide until this black vertical line is located where
you want the slide to be moved.
To select a group of slides, use one of these methods:
• Use the Control (Ctrl) key: Click on the first slide and, while
pressing Control, select the other desired slides.
• Use the Shift key: Click on the first slide, and while pressing the
Shift key, click on the final slide in the group. This selects all of
the other slides in between the first and the last.
• Use the mouse cursor: Click on the first slide to be selected. Hold
down the left mouse button. Drag the cursor to the last slide
thumbnail. A dashed outline of a rectangle forms as you drag the
cursor through the slide thumbnails and a thick black border is
drawn around the selected slides. Make sure the rectangle
includes all the slides you want to select.
To move a group of slides:
1) Select the group.
2) Drag and drop the group to their new location. The same vertical
black line appears to show you where the group of slides will go.
Note

Selection of a group of slides works in a rectangular fashion.
Slides that do not fall within a rectangular area cannot be
grouped.

Working with views
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You can work with slides in the Slide Sorter view just as you can in the
Slide pane. To make changes, right-click a slide and do any of the
following using the pop-up menu:
• Add a new slide after the selected slide.
• Delete the selected slide.
• Change the slide layout.
• Change the slide transition.
•
For one slide, click the slide to select it. Then add the desired
transition.
•
For more than one slide, select the group of slides and add the
desired transition.
• Mark a slide as hidden. Hidden slides are not shown in the slide

show.
• Copy or cut and paste a slide.

Handout view
Handout view is for setting up the layout of your slide for a printed
handout. Click the Handout tab in the workspace, then choose Layouts
in the Tasks pane. Layout contains five choices: 1, 2, 3, 4, 6, or 9 slides
per page (Figure 9).

Figure 9: Handout layouts
To print a handout:
1) Select the slides using the Slide Sorter. (Use the steps listed in
selecting a group of slides on page 13.)
2) Select File > Print or press Control+P to open the Print dialog.
3) Select Options in the bottom left corner. of the Print dialog.
4) Check Handouts in the Contents section, and then click OK.
5) Click OK to close the Print dialog.
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Creating a new presentation
This section describes how to set up a new presentation. The settings
selected here are general: they apply to all the slides.

Planning a presentation
The first thing to do is to decide what you are going to do with the
presentation. For example, putting a group of digital photos together in
a presentation requires very little planning. However, using a
presentation to increase the knowledge of others about your topic
requires much more planning.
You need to ask and answer many questions before you begin creating
a presentation. If you are not acquainted with creating presentations,
the answers will be more general. Those who have created a variety of
presentations in the past will want to have more specific answers.
Who is to see the presentation? How will it be used? What is the
subject matter? What should be in its outline? How detailed should the
outline be? Will an audio file be played? Is animation desirable? How
should the transition between slides be handled? These are some of the
many questions that should be asked, answered, and written down
before creating the presentation. Sound and animation are more
advanced topics and are explained in the Impress Guide.
Again, it is not always necessary at this point to have specific answers
to every question. Making an outline is extremely important. You may
already know exactly what some of the slides will contain. You may
only have a general idea of what you want on some of the slides. That
is alright. You can make some changes as you go. Change your outline
to match the changes you make in your slides.
The important part is that you have a general idea of what you want
and how to get it. Put that information on paper. That makes it much
easier to create the presentation.

Using the Presentation Wizard
You can start Impress in several ways:
• From the OOo Welcome screen, if no component is open.
• From the system menu or the OOo Quickstarter. Details vary with
your operating system; see Chapter 1 for more information.
• From any open component of OOo. Click the triangle to the right
of the New icon on the main toolbar and select Presentation from
Creating a new presentation
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the drop-down menu or choose File > New > Presentation from
the menu bar.
When you start Impress, the Presentation Wizard appears (Figure 10).

Tip

If you do not want the wizard to start every time you launch
Impress, select the Do not show this wizard again checkbox.
You can enable it again later if you need under Tools >
Options > OpenOffice.org Impress > General > Wizard,
and select the Start with wizard checkbox.
Leave the Preview checkbox selected, so templates, slide
designs, and slide transitions appear in the preview box as you
choose them.

Figure 10. Choosing the type of presentation
1) Select Empty Presentation under Type. It creates a presentation
from scratch.

Note
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From Template uses a template design already created as the
basis for a new presentation. The wizard changes to show a list
of available templates. Choose the template you want.
Open Existing Presentation continues work on a previously
created presentation. The wizard changes to show a list of
existing presentations. Choose the presentation you want.
Both of these options are covered in the Impress Guide.
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2) Click Next. Figure 11 shows the Presentation Wizard step 2 as it
appears if you selected Empty Presentation at step 1. If you
selected From Template, an example slide is shown in the Preview
box.

Figure 11. Selecting a slide design
3) Choose a design under Select a slide design. The slide design
section gives you two main choices: Presentation Backgrounds
and Presentations. Each one has a list of choices for slide designs.
If you want to use one of these other than <Original>, click it to
select it.
•
The types of Presentation Backgrounds are shown in Figure
11. By clicking an item, you will see a preview of the slide
design in the Preview window. Impress contains three choices
under Presentations: <Original>, Introducing a New Product,
and Recommendation of a Strategy.
•
<Original> is for a blank presentation slide design.
•
Both Introducing a New Product and Recommendation of a
Strategy have their own prepackaged slide designs. Each
design appears in the Preview window when its name is
clicked.

Note

Introducing a New Product and Recommendation of a Strategy
are prepackaged presentation templates. They can be used to
create a presentation by choosing From template in the first
step (Figure 10).

Creating a new presentation
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4) Select how the presentation will be used under Select an output
medium. Most often, presentations are created for computer
screen display. Select Screen.
5) Click Next. The Presentation Wizard step 3 appears.

Figure 12. Selecting a slide design
6) Choose the desired slide transition from the Effect drop-down
menu.
7) Select the desired speed for the transition between the different
slides in the presentation from the Speed drop-down menu.
Medium is a good choice for now.
8) Click Create. A new presentation is created.
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Tip

You might want to accept the default values for both Effect and
Speed unless you are skilled at doing this. Both of these values
can be changed later while working with Slide transitions
and animations. These two are explained in more detail in
Chapter 9 of the Impress Guide.

Note

If you selected From template on step 1 of the Wizard, the Next
button will be active on step 3 and other pages will be
available. These pages are not described here.
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Formatting a presentation
Now put your presentation together based on your outline.

Caution

Remember to save frequently while working on the
presentation, to prevent any loss of information should
something unexpected occur. You might also want to activate
the AutoRecovery function (Tools > Options > Load/Save >
General). Make sure Save AutoRecovery information every
is selected and that you have entered a recovery frequency.

Creating the first slide
The first slide is normally a title slide. Decide which of the layouts will
best suit your purposes for this first slide: simplicity would be
appropriate in this instance. You can use the prepackaged layouts
available in the Layout section of the Tasks pane. Suitable layouts are
Title Slide (which also contains a section for a subtitle) or Title Only,
however all but one layout (the blank one) contains a title section, so
you are not restricted to the two layouts described here.

Tip

If you do not know the names for the prepackaged layouts, you
can use the tooltip feature. Position the cursor on an icon in
the Layout section (or on any toolbar icon) and its name will be
displayed in a small rectangle.
If the tooltips are not enabled, you can enable them. From the
main menu, select Tools > Options > OpenOffice.org >
General > Help and mark the Tips checkbox. If the
Extended tips checkbox is also marked, you will get more
detailed tooltip information, but the tooltip names themselves
will not be provided.

Select a layout in the Layout section of the Tasks pane by clicking on it:
it appears in the Workspace. To create the title, click on “Click to add
title” (assuming the Blank Slide layout was not used) and then type the
title text. Adjustments to the formatting of the title can be done by
pressing the F11 key, right-clicking the Title presentation style entry,
and selecting Modify from the pop-up menu.
If you are using the Title Slide layout, click on Click to add text to add
a subtitle. Proceed as above to make adjustments to the formatting if
required.

Formatting a presentation
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Inserting additional slides
The steps for inserting additional slides are basically the same as for
selecting the title page. It is a process that has to be repeated for each
slide. Unless you are using more than one slide master, your only
concern is the Layouts section of the Tasks pane (Figure 13).

Figure 13: Choosing a slide layout
First insert all the slides your outline indicates you will need. Only
after this should you begin adding special effects such as custom
animation and slide transitions.
Step 1: Insert a new slide. This can be done in a variety of ways—take
your pick.
• Insert > Slide.
• Right-click on the present slide, and select Slide > New Slide
from the pop-up menu.
• Click the Slide icon in the Presentation toolbar (Figure 14).

Figure 14: Presentation toolbar
Step 2: Select the layout slide that bests fits your needs.
Step 3: Modify the elements of the slide. At this stage, the slide
consists of everything contained in the slide master, as well as the
chosen layout slide, so this includes removing unneeded elements,
adding needed elements (such as pictures), and inserting text.
20
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Caution

Changes to any of the pre-packaged layouts can only be made
using View > Normal, which is the default. Attempting to do
this by modifying a slide master may result in unpredictable
results and requires extra care as well as some trials and
errors.

1) Remove any element on the slide that is not required.
•
Click the element to highlight it. (The green squares show it is
highlighted.)
•
Press the Delete key to remove it.
Tip

Sometimes you will accidentally select the wrong layout slide
or decide to change it. This is safe and does not cause loss of
the contents already on the slide.

2) Add any elements to the slide that you do need.
a) Adding pictures to the clipart frame, if your chosen layout
includes one:
•
Double-click the picture within the frame. The Insert
picture dialog opens.
•
Browse to the location of the picture you want to include.
To see a preview of the picture, check Preview at the
bottom of the Insert picture dialog.
•
Select the picture and click Open.
•
Resize the picture as necessary. Follow the directions in
the Caution note below.
b) Adding pictures from graphic files to places other than the
clipart frame:
•
Insert > Picture > From File. The Insert picture dialog
opens.
•
Browse to the graphic file. To see a preview of the picture,
check Preview at the bottom of the Insert picture dialog.
Select a picture and click Open.
•
Move the picture to its location.
•
Resize the picture, if necessary.
c) Adding OLE Objects is an advanced technique covered in
Chapter 7 of the Impress Guide.

Formatting a presentation
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Caution

When resizing a graphic, right-click the picture. Select
Position and Size from the context menu and make sure that
Keep ratio is selected. Then adjust the height or width to the
size you need. (As you adjust one dimension both dimensions
will change.) Failure to do so will cause the picture to become
distorted. Remember also that resizing a bitmap image will
reduce its quality; better by far to create an image of the
desired size outside of Impress.

3) Adding text to a slide: If the slide contains text, click on Click to
add an outline in the text frame and then type your text. The
Outline styles from 1 to 10 are automatically applied to the text as
you insert it. You can change the outline level of each paragraph
as well as its position within the text using the arrow buttons on
the Text Formatting toolbar.
Step 4: To create additional slides, repeat steps 1–3.

Modifying the appearance of slides
To change the background and other characteristics of all slides in the
presentation, you need to modify the slide master or choose a different
slide master.
A Slide Master is a slide with a specified set of characteristics which is
used as the beginning point for creating other slides. These
characteristics include the background, objects in the background,
formatting of any text used, and any background graphics.

Note

OOo uses three interchangeable terms for this one concept.
Master slide, slide master, and master page all refer to a slide
that is used to create other slides. This book, however, will use
only the term slide master, except when describing the user
interface.

Impress has 28 prepackaged slide masters, found in the Master Pages
section of the Tasks pane. You can also create and save additional slide
masters.

Modifying the slide show
Now review the entire presentation and answer some questions. Run
the slide show at least once before answering them. You might want to
add some questions of your own.
1) Are the slides in the correct order? If not, some of them will need
to be moved.
22
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2) Would an additional slide make a particular point clearer? If so,
another slide needs to be created.
3) Would some custom animations help some of the slides?
(Advanced technique.)
4) Should some of the slides have a different slide transition than
others? The transition of those slides should be changed.
5) Do some of the slides seem unnecessary? Delete the affected slide
or slides after checking if they are indeed unnecessary.

Tip

If one or more slides seems to be unnecessary, hide the slide
or slides, and view the slide show a few more times to make
sure. To hide a slide, right-click the slide in the Slides pane
and select Hide Slide in the pop-up menu. Do not delete a
slide until you have done this, otherwise you may have to
create that slide again.

Once you have answered these and your own questions, you should
make the necessary changes. This is done most easily in the Slide
Sorter view. If you need one or more new slides, create them using the
steps listed in “Inserting additional slides” on page 20.

Slide masters and styles
A slide master is a slide that is used as the starting point for other
slides. It is similar to a page style in Writer: it controls the basic
formatting of all slides based on it. A slide show can have more than
one slide master.

Note

OOo uses three terms for this one concept. Master slide, slide
master, and master page all refer to a slide which is used to
create other slides. This book uses the term slide master,
except when describing the user interface.

A slide master has a defined set of characteristics, including the
background color, graphic, or gradient; objects (such as logos,
decorative lines, and other graphics) in the background; headers and
footers; placement and size of text frames; and the formatting of text.
All of the characteristics of slide masters are controlled by styles. The
styles of any new slide you create are inherited from the slide master
from which it was created. In other words, the styles of the slide
master are available and applied to all slides created from that slide
master. Changing a style in a slide master results in changes to all the
Slide masters and styles
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slides based on that slide master; it is, however, possible to modify
each individual slide without affecting the slide master.
Slide masters have two types of styles associated with them:
presentation styles and graphic styles. The pre-packaged presentation
styles can be modified, but new presentation styles cannot be created.
However, not only can the prepackaged graphic styles be modified, but
new graphic styles can also be created. What styles to use and when to
use them is described later in this chapter.
Presentation styles affect three elements of a slide master: the
background, background objects (such as icons, decorative lines, and
text frames), and the text placed on the slide. Text styles are further
divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The
outline styles are used for the different levels of the outline to which
they belong. For example, Outline 2 is used for the subpoints of Outline
1, and Outline 3 is used for the subpoints of Outline 2.
Graphic styles affect many of the elements of a slide. Notice that text
styles exist in both the presentation and graphic style selections.

Working with slide masters
Impress comes with 28 prepackaged slide
masters. They are shown in the Master Pages
section of the Tasks pane (Figure 15). This
section has three subsections: Used in This
Presentation, Recently Used, and Available for
Use. Click the + sign next to the name of a
subsection to expand it to show thumbnails of
the slides, or click the – sign to collapse the
subsection to hide the thumbnails.
Each of the slide masters shown in the
Available for Use list is from a template of the
same name. If you have created your own
templates, or added templates from other
sources, slide masters from those templates
will also appear in this list.

Figure 15: Available
master pages (slides)
24
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Creating slide masters
You can create a new slide master in a similar way to modifying the
default slide master.
To start, enable editing of slide masters by View > Master > Slide
Master.
On the Master View toolbar, click the New Master icon.
A second slide master appears in the Slides pane. Modify this slide
master to suit your requirements. It is also recommended that you
rename this new slide master: right-click on the slide in the Slides
pane and select Rename master from the popup menu.
When you are done, close the Master View toolbar to return to normal
slide editing mode.

Applying a slide master
In the Tasks Pane, be sure the Master Pages section is showing.
To apply one of the slide masters to all slides in your presentation,
click on it in the list.
To apply a different slide master to one or more selected slides:
1) In the Slide Pane, select the slides you want to change.
2) In the Tasks Pane, right-click on the slide master you want to
apply to the selected slides, and click Apply to Selected Slides
on the pop-up menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple
slide masters that may belong to different templates. For example, you
may need a completely different layout for the first slide of the
presentation, or you may want to add to your presentation a slide from
a different presentation (based on a template available on the hard
disk).
The Slide Design dialog makes this possible. Access this dialog either
from the menu bar (Format > Slide design) or by right-clicking on a
slide in the Slides pane.
The main window in the dialog shows the slide masters already
available for use. To add more:
1) Click the Load button.

Working with slide masters
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2) Select in the new dialog the template from which to load the slide
master. Click OK.
3) Click OK again to close the slide design dialog.
The slide masters in the template you selected are now shown also in
the Master Pages section of the Tasks pane in the Available for use
subsection.

Note

Tip

The slide masters you have loaded will also be available the
next time you load the presentation. If you want to delete the
unused slide masters, click the corresponding checkbox in the
Slide Design dialog. Due to a bug, if the slide master was not
used in the presentation, it is removed from the list of
available slide masters anyway.
To limit the size of the presentation file, you may want to
minimize the number of slide masters used.

Modifying a slide master
The following items can be changed on a slide master:
• Background (color, gradient, hatching, or bitmap)
• Background objects (for example, add a logo or decorative
graphics)
• Size, placement, and contents of header and footer elements to
appear on every slide
• Size and placement of default frames for slide titles and content
Before working on the slide master, make sure that the Styles and
Formatting window is open.
To select the slide master for modification:
1) Select View > Master > Slide Master from the menu bar. This
unlocks the properties of the slide master so you can edit it.
2) Click Master Pages in the Tasks pane. This gives you access to the
pre-packaged slide masters.
3) Click on the slide master you want to modify among the ones
available (Figure 15).
4) Make changes as required, then click the Close Master View
icon on the Master View toolbar. For details, see Chapter 2 of the
Impress Guide
5) Save the file before continuing.
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Caution

Any changes made to one slide when in Master View mode will
appear on all slides using this slide master. Always make sure
you close Master View and return to Normal view before
working on any of the presentation slides. Select View >
Normal from the menu bar, or click Close Master View in
the Master View toolbar to return to the normal slide view.

The changes made to one of the slides in Normal view (for example
changes to the bullet point style or the color of the title area and so
on...) will not be overridden by subsequent changes to the slide master.
There are cases, however, where it is desirable to revert a manually
modified element of the slide to the style defined in the slide master: to
do that, select that element and choose Format > Default
Formatting from the menu bar.
Sometimes you may want to try several of the available layouts to see
which one is more suitable for your contents. Applying a layout only
requires that you open the Layouts section of the Tasks pane and
double-click on the new layout. Alternatively you can right-click on the
desired layout thumbnail and select Apply to selected slide from the
pop-up menu.

Adding text to all slides
Some of the supplied slide masters have text objects in the footer. You
can add other text objects to the master page for your slides to act as a
header or a footer.
1) Choose View > Master > Slide Master from the menu bar.
2) On the Drawing toolbar (see Figure 11), select the Text icon.
3) Click once and drag in the master page to draw a text object, and
then type or paste your text into the object or add fields as
described below.
4) Choose View > Normal when you are finished.
To add a field, such as the date or page number, to a text object in the
header or footer, choose Insert > Fields. and select the required field
from the submenu. If you want to edit a field in your slide, select it and
choose Edit > Fields.
The fields you can use in Impress are:
• Date (fixed)
• Date (variable)—updates automatically when you reload the file
• Time (fixed)
• Time (variable)—updates automatically when you reload the file
Working with slide masters
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• Author—First and last names listed in the OpenOffice.org user

data
• Page number (slide number)
• File name

Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for
the page number field, choose Format > Page and then select
a format from the list in the Layout Settings area.
To change the author information, go to Tools > Options >
OpenOffice.org > User Data.

Adding and formatting text
Text in slides is contained in text boxes.
There are two ways to add text boxes to a slide:
• Choose a predefined layout from the Layouts section of the Tasks
pane. These text boxes are called AutoLayout text boxes.
• Create a text box using the text tool.

Using text boxes created from the Layout pane
In Normal view:
1) Click in the text box that reads Click to add text, Click to add
an outline, or a similar notation.
2) Type or paste your text in the text box.

Using text boxes created from the text box tool
In Normal View:
1) Click on the Text icon
on the Drawing toolbar. If the toolbar
with the text icon is not visible, choose View > Toolbars >
Drawing.
2) Click and drag to draw a box for the text on the slide. Do not
worry about the vertical size and position—the text box will
expand if needed as you type.
3) Release the mouse button when finished. The cursor appears in
the text box, which is now in edit mode (gray hashed border with
green resizing handles shown in Figure 16).
4) Type or paste your text in the text box.
5) Click outside the text box to deselect it.
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Figure 16: Selected text box showing the
green resizing handles and text toolbar
You can move, resize, and delete text boxes. For more information, see
Chapter 3 in the Impress Guide.

Note

In addition to the normal text boxes where text is horizontally
aligned, it is possible to insert text boxes where the text is
aligned vertically. This choice is available only when Asian
languages are enabled in Tools > Options > Language
Settings > Languages.
Click on the
button in the drawing toolbar to create a vertical
text box. Note that when editing the contents, the text is
displayed horizontally.

Quick font resizing
Starting with OOo3.1, Impress has convenient buttons on the
Formatting toolbar to increase or decrease font size of selected text.
The amount by which the font size changes depends on the standard
sizes available for the font in use.

Pasting text
You can insert text into a text box by copying it from another document
and pasting it into Impress. However, the pasted text will probably not
match the formatting of the surrounding text or that of the other slides
in the presentation. This may be what you want on some occasions,
however in most cases you want to make sure that the presentation
does not become a patchwork of different paragraph styles, font types,
Adding and formatting text
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bullet points and so on. There are several ways to ensure consistency;
these methods are explained below.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply
the formatting later. To paste without formatting, either press
Control+Shift+V and then select Unformatted text from the dialog
that appears, or click on the small black triangle next to the paste
symbol in the standard toolbar
and select Unformatted text.
The unformatted text will be formatted with the outline style at the
cursor position in an AutoLayout text box or with the default graphic
style in a normal text box.

Formatting pasted text
If pasting the text into an AutoLayout area, then to give the pasted
text the same look and feel of the rest of the presentation. you need to
apply the appropriate outline style to the text.
1) Paste the text in the desired position. Do not worry if it does not
look right: it will in a minute.
2) Select the text you have just pasted.
3) Select Format > Default formatting from the menu bar.
4) Use the four arrow buttons in the Text Formatting toolbar
to move the text to the appropriate position and
give it the appropriate outline level. The button with the arrow
pointing left promotes the list entry by one level (for example
from Outline 3 to Outline 2), the right arrow button demotes the
list entry by one level, the up and down arrow buttons move the
list entry.
5) Apply manual formatting as required to sections of the text (to
change font attributes, tabs, and so on).
If you are pasting text in a text box, you can still use styles to quickly
format the text. Note that one and only one graphic style can be
applied to the copied text. To do that:
1)
2)
3)
4)
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Paste the text in the desired position.
Select the text you have just pasted.
Select the desired graphic style.
Apply manual formatting as required to sections of the text.
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Tip

Presentation styles are very different from Writer styles and
are applied in quite a different way.

Creating bulleted and numbered lists
The procedure to create a bulleted or numbered list is quite different
depending on the type of text box used, although the tools to manage
the list and customize the appearance are the same.
In text boxes created automatically by Impress (called AutoLayout), the
outline styles available are by default bulleted lists, while for normal
text boxes an additional step is required to create a bulleted list.

Creating lists in AutoLayout text boxes
Every text box included in the available layouts is already formatted as
a bulleted list, therefore to create a bulleted list the only necessary
steps are:
1) From the Layout pane, choose a slide design that contains a text
box. Those are easily recognizable from the thumbnail.
2) Click in the text box that reads Click to add an outline.
3) Type the text, then press Enter to start a new bulleted line.
4) The default list type is a bulleted list. The mechanisms to change
the list from bulleted to numbered and vice versa are explained in
“Changing the appearance of the list” on page 32.

Tip

Press Shift + Enter to start a new line without creating a new
bullet or number. The new line will have the same indentation
of the previous line. Press instead the button bullets on/off on
the text formatting toolbar for a line without bullet. If the text
formatting toolbar is not showing, enable it selecting View >
Toolbar > Formatting in the menu bar.

Creating lists in other text boxes
To create a list in a text box, follow these steps:
1) Place the cursor in the text box.
2) Click the Bullets On/Off button
on the text formatting
toolbar. If the text formatting toolbar is not showing, enable it by
selecting View > Toolbar > Formatting from the menu bar.
3) Type the text and press Enter to start a new bulleted line.
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4) The default list type is a bulleted list. The mechanisms to change
the appearance of the list are explained on page 32.

Creating a new outline level
1) If necessary, press Enter to begin a new line.
2) Press Tab. Each time you press Tab the line indents to the next
outline level. Pressing Enter creates a new line at the same level
as the previous one. To return to the previous level, press
Shift+Tab.
In the AutoLayout text boxes, promoting or demoting an item in the list
corresponds to applying a different outline style, so the second outline
level corresponds to Outline 2 style, the third to Outline 3 style, and so
on.

Note

Unlike styles in Writer, do not try to change the outline level
by selecting the text and then clicking the desired outline
style. Due to the way the presentation styles work, it is not
possible to apply them in this way.

Changing the appearance of the list
You can fully customize the appearance of a list, changing the bullet
type or numbering for the entire list or for single entry. All of the
changes can be made using the Bullets and Numbering dialog, which is
accessed by selecting Format > Bullets and Numbering or by
clicking on the Bullets and Numbering icon on the text formatting
toolbar.
For the entire list:
1) Select the entire list or click on the gray border of the text box so
that just the green resizing handles are displayed.
2) Select Format > Bullets and Numbering or click on the
Bullets and Numbering icon
.
3) The Bullets and Numbering dialog contains five tabs: Bullets,
Numbering type, Graphics, Position, and Customize.
•
•
•
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If a bullet list is needed, select the desired bullet style from
the six default styles available on the Bullets page.
If a graphics style is needed, select one from those available
on the Graphics page.
If a numbered list is needed, select one of the 6 default
numbering styles on the Numbering type page.
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For a single line in the list:
1) Click anywhere in the line to place the cursor in it.
2) Follow steps 2–4 of the previous instruction set.
If the list was created in an AutoLayout text box, then an alternative
way to change the entire list is to modify the Outline styles. Changes
made to the outline style will apply to all the slides using them.
Sometimes this is what you want; sometimes it is not, so some care
must be taken.

Creating tables
For displaying tabular data, you can insert basic tables directly into
your slides in a number of ways:
• Use the Insert > Table menu option.
• With the Table button on the main toolbar.
• With the Table Design button on the table toolbar.
• By selecting a Style option from the Table Design section of the

Tasks pane.
Each method opens the Insert Table dialog, shown in Figure 17.
Alternatively, clicking on the black arrow next to the Table button
displays a graphic that you can drag and select the number of rows
and columns for your table.

Figure 17. Creating a table with the Insert
Table dialog.

Note

Selecting from any of the styles in the Table Design section of
the Tasks pane creates a table based on that style. If you
create a table by another method, you can still apply a style of
your choice later.

With the table selected, the Table toolbar should appear. If it does not,
you can access it by selecting View > Toolbars > Table. The Table
Creating tables
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toolbar offers many of the same buttons as the table toolbar in Writer,
with the exception of functions like Sort and Sum for performing
calculations. For those functions, you need to use a spreadsheet
inserted from Calc (discussed below).
After the table is created, you can modify it in much the same ways as
you would modify a table in Writer: adding and deleting rows and
columns, adjusting width and spacing, adding borders, background
colors and so on. Detailed information on working with tables and the
Table Properties dialog can be found in Chapter 9 of the Writer Guide.
By modifying the style of the table from the Table Design section of the
Tasks pane, you can quickly change the appearance of the table or any
newly created tables based on the Style options you select. You can
choose to add emphasis to a header and total row as well as the first
and last columns of the table, and apply a banded appearance to the
rows and columns.
Having completed the table design, entering data into the cells is
similar to working with text box objects. Click in the cell you wish to
add data to, and begin typing. To move around cells quickly, use the
following key options:
• The arrow keys move the cursor to the next table cell if the cell is

empty, otherwise they move the cursor to the next character in
the cell.
• The Tab key moves to the next cell, skipping over the contents of
the cell; Shift+Tab move backwards in this manner.

Adding graphics, spreadsheets, charts,
and other objects
Graphics in Impress are handled much the same as graphics in Draw.
For more information, see Chapter 7 (Getting Started with Draw), the
Draw Guide, or Chapters 4, 5, and 6 in the Impress Guide.
Spreadsheets embedded in Impress include most of the functionality of
spreadsheets in Calc and are therefore capable of performing
extremely complex calculations and data analysis. If you need to
analyze your data or apply formulas, these operations are best
performed in a Calc spreadsheet and the results displayed in an
embedded Impress spreadsheet.
To add a spreadsheet to a slide, select the corresponding layout in the
list of predefined layouts in the Tasks pane. This inserts a placeholder
for a spreadsheet in the center of a slide. To insert data and modify the
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formatting of the spreadsheet, it is necessary to activate it and enter
the edit mode. To do so, double-click inside the frame with the green
handles.
Alternatively, select Insert > Spreadsheet from the main menu bar.
This opens a small spreadsheet in the middle of the slide. When a
spreadsheet is inserted using this method, it is already in edit mode. It
is also possible to insert a spreadsheet as an OLE object.
To add a chart to a slide, select the corresponding layout in the list of
predefined layouts in the task pane or use the Insert Chart feature.
Impress offers the capability of inserting in a slide various other types
of objects such as music or video clips, Writer documents, Math
formulas, generic OLE objects and so on. A typical presentation may
contain movie clips, sound clips, OLE objects and formulas; other
objects are less frequently used since they do not appear during a slide
show.
For details on using spreadsheets, charts, and other objects in Impress,
refer to Chapter 7 of the Impress Guide.

Adding comments to a presentation
Starting with OOo 3.2, Impress supports comments (formerly called
sticky notes) similar to those in Writer and Calc.
In Normal View, choose Insert > Comment from the menu bar. A
small box containing your initials appears in the upper left-hand corner
of the slide, with a larger text box beside it. Impress has automatically
added your name and the date at the bottom of this text box.

Adding comments to a presentation
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Type or paste your comment into the text box. You can optionally apply
some basic formatting to parts of the text by selecting it, right-clicking,
and choosing from the pop-up menu. (From this menu, you can also
delete the current comment, all the comments from the same author,
or all the comments in the document.)
You can move the small comment markers to anywhere you wish on the
page. Typically you might place it on or near an object you refer to in
the comment.
To show or hide the comment markers, choose View > Comments.
Select Tools > Options > User Data to configure the name you want
to appear in the Author field of the comment, or to change it.
If more than one person edits the document, each author is
automatically allocated a different background color.

Setting up the slide show
Impress gives you the tools to organize and display a slide show,
including:
• Which slides to show and in what order
• Whether to run the show automatically or manually
• Transitions between slides
• Animations on individual slides
• Interactions: what happens when you click a button or link
Chapter 9 of the Impress Guide describes these tools.
Most tasks associated with putting together a show from your slides
are best done in Slide Sorter view. Choose View > Slide Sorter from
the menu bar or click the Slide Sorter tab at the top of the workspace.
All of your slides appear in the workspace; you may need to scroll to
see them all.
Custom animations are found on the Tasks pane. This is an advanced
technique and is explained in Chapter 9 (Slide Shows) in the Impress
Guide.
Your first slide show should probably have the same slide transition for
all slides. Setting Advance slide to On mouse click is the default and
a simple setting. If you want each slide to be shown for a specific
amount of time, click Automatically after and enter the number of
seconds. Click Apply to all slides.
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Slide transition choices are also found on the Tasks pane. For more
information about slide transitions, see Chapter 9 in the Impress
Guide.

Tip

The Slide transition section has a very useful choice:
Automatic preview. Select its checkbox. Then when you make
any changes in a slide transition, the new slide is previewed in
the Slide Design area, including its transition effect.

Running the slide show
To run the slide show, do one of the following:
• Click Slide Show > Slide Show.
• Click the Slide Show button on the Presentation toolbar.

Figure 18: Presentation Toolbar
• Press F5 or F9.

If the slide transition is Automatic after x seconds, let the slide show
run by itself.
If the slide transition is On mouse click, do one of the following to
move from one slide to the next:
• Use the arrow keys on the keyboard to go to the next slide or to
go back to the previous one.
• Click the mouse to move to the next slide.
• Press the spacebar on the keyboard to advance to the next slide.
Right-click anywhere on the screen to open a menu from which you can
navigate the slides and set other options.
To exit the slide show at any time including at the end, press the Esc
key.

Running the slide show
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