Chapter 11

Getting Started with Math

OpenOffice.org's Equation Editor
Copyright

This document is Copyright © 2005–2007 by its contributors as listed in the section titled Authors. You can distribute it and/or modify it under the terms of either the GNU General Public License, version 3 or later (http://www.gnu.org/licenses/gpl.html), or the Creative Commons Attribution License, version 3.0 (http://creativecommons.org/licenses/by/3.0/) or later.

All trademarks within this guide belong to their legitimate owners.

Authors

Agnes Belzunce
Daniel Carrera
Peter Kupfer
Ian Laurenson
Janet M. Swisher
Jean Hollis Weber

Feedback

Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Acknowledgments

This chapter is extracted from Chapter 16, “Math Objects: The OpenOffice.org Equation Editor” in the Writer Guide.

Publication date and software version

Published 20 April 2008. Based on OpenOffice.org 2.4.
# Contents

Copyright .................................................................................................................................................. i
Authors .................................................................................................................................................. i
Feedback ................................................................................................................................................ i
Acknowledgments ................................................................................................................................ i
Publication date and software version................................................................................................... i
What is Math? ............................................................................................................................................ 1
Getting started ........................................................................................................................................ 1
Entering a formula ..................................................................................................................................... 2
  The Selection window .......................................................................................................................... 2
  Example 1: ........................................................................................................................................... 2
  Right-click menu .................................................................................................................................. 4
  Markup .................................................................................................................................................. 4
  Greek characters ................................................................................................................................... 4
  Example 2: ........................................................................................................................................... 5
Customizations ......................................................................................................................................... 6
  Formula editor as a floating window ...................................................................................................... 6
  How can I make a formula bigger? .......................................................................................................... 7
Formula layout .......................................................................................................................................... 8
  Brackets are your friends ...................................................................................................................... 8
  Equations over more than one line ........................................................................................................ 8
Common problem areas .......................................................................................................................... 9
  How do I add limits to my sum/integral? .............................................................................................. 9
  Brackets with matrices look ugly! .......................................................................................................... 9
  How do I make a derivative? .................................................................................................................. 10
  Numbering equations ........................................................................................................................... 11
What is Math?

Math is OpenOffice.org (OOo)’s component for writing mathematical equations. It is most commonly used as an equation editor for text documents, but it can also be used with other types of documents or stand-alone. When used inside Writer, the equation is treated as an object inside the text document.

**Note** The equation editor is for writing equations in symbolic form (as in equation 1). If you want to evaluate a numeric value, see the *Calc Guide*.

\[
\frac{df(x)}{dx} = \ln(x) + \tan^{-1}(x^2)
\]  

(1)

**Getting started**

To insert an equation, go to **Insert > Object > Formula**.

The equation editor opens at the bottom of the screen, and the floating Selection window appears. You will also see a small box (with a gray border) in your document, where the formula will be displayed, as shown in Figure 1.

![Figure 1. Equation Editor, Selection window, and location of resulting equation.](image)

The equation editor uses a markup language to represent formulas. For example, `%beta` creates the Greek character beta (\( \beta \)). This markup is designed to read similar to English whenever possible. For example, `a over b` produces a fraction: \( \frac{a}{b} \).
Entering a formula

There are three ways to enter a formula:

• Select a symbol from the Selection window.
• Right-click on the equation editor and select the symbol from the context menu.
• Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a symbol. Incidentally, this provides a convenient way to learn the OoMath markup.

Note  
Click on the document body to exit the formula editor.
Double-click on a formula to enter the formula editor again.

The Selection window

The simplest method for entering a formula is the Selection window, shown in Figure 2.

The Selection window is divided into two main portions.

• **The top** shows the symbol categories. Click on these to change the list of symbols.
• **The bottom** shows the symbols available in the current category.

TIP  
You can hide (or unhide) the Selection window with View > Selection.

Example 1: $5 \times 4$

For this example we will enter a simple formula: $5 \times 4$  On the Selection window:

1) Select the top-left button of the categories (top) section (Figure 3).
2) Click on the multiplication symbol (shown in Figure 3).
When you select the multiplication symbol on the Selection window, two things happen:

• The equation editor shows the markup: `<?> times <?>`

• The body of the document shows a gray box with the figure: \( \Box \times \Box \)

The “ `<?>` ” symbols (Figure 4) are placeholders that you can replace by other text. The equation will update automatically, and the result should resemble Figure 5.

**Tip**

To keep the equation from updating automatically, select **View > AutoUpdate display**. To update a formula manually, press `F9` or select **View > Update**.
**Right-click menu**

Another way to access mathematical symbols is to right-click on the equation editor. This produces a menu as shown in Figure 6.

![Right-click menu](image)

*Figure 6. Right-click menu*

**Note**  
The entries in this menu correspond exactly to those in the Selection window.

**Markup**

You can type the markup directly on the equation editor. For example, you can type “5 times 4” to obtain $5 \times 4$. If you know the markup, this can be the fastest way to enter a formula.

**Tip**  
As a mnemonic, the formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

<table>
<thead>
<tr>
<th>Display</th>
<th>Command</th>
<th>Display</th>
<th>Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>$a = b$</td>
<td>$a = b$</td>
<td>$\sqrt{a}$</td>
<td>$\text{sqrt}{a}$</td>
</tr>
<tr>
<td>$a^2$</td>
<td>$a^2$</td>
<td>$a_n$</td>
<td>$a_n$</td>
</tr>
<tr>
<td>$\int f(x),dx$</td>
<td>$\text{int},f(x),dx$</td>
<td>$\sum a_n$</td>
<td>$\text{sum},a_n$</td>
</tr>
<tr>
<td>$a \leq b$</td>
<td>$a \leq b$</td>
<td>$\infty$</td>
<td>$\infty$</td>
</tr>
<tr>
<td>$a \times b$</td>
<td>$a \times b$</td>
<td>$x \cdot y$</td>
<td>$x \cdot y$</td>
</tr>
</tbody>
</table>

**Greek characters**

Greek characters ($\alpha$, $\beta$, $\gamma$, $\theta$, etc) are common in mathematical formulas. *These characters are not available in the selection box or the right-click menu*. Fortunately, the markup for Greek characters is simple: Type a `%` sign followed the name of the character, in English.
• To type a lowercase character, write the name of the character in lowercase.
• To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples.

<table>
<thead>
<tr>
<th>Lowercase</th>
<th>Uppercase</th>
</tr>
</thead>
<tbody>
<tr>
<td>%alpha → α</td>
<td>%ALPHA → A</td>
</tr>
<tr>
<td>%beta → β</td>
<td>%BETA → B</td>
</tr>
<tr>
<td>%gamma → γ</td>
<td>%GAMMA → Γ</td>
</tr>
<tr>
<td>%psi → ψ</td>
<td>%PSI → Ψ</td>
</tr>
<tr>
<td>%phi → ϕ</td>
<td>%PHI → Φ</td>
</tr>
<tr>
<td>%theta → θ</td>
<td>%THETA → Θ</td>
</tr>
</tbody>
</table>

**Note** A complete table of Greek characters is included in Chapter 16 (Math Objects) in the *Writer Guide*.

Another way to enter Greek characters is by using the catalog window. Go to *Tools > Catalog*. The catalog window is shown in Figure 7. Under “Symbol Set” select “Greek” and double-click on a Greek letter from the list.

![Figure 7. Catalog - used for entering Greek characters](image)

**Example 2:** \( \pi \approx 3.14159 \)

For this example we will suppose that:
• We want to enter the above formula (the value of pi rounded to 5 decimal places).
• We know the name of the Greek character (“pi”).
• But we do not know the markup associated with the \( \approx \) symbol.

**Step 1:** Type “%” followed by the text “pi”. This displays the Greek character \( \pi \).
**Step 2:** Open the Selection window (View > Selection).
Step 3: The $\simeq$ symbol is a relation, so we click on the relations button $\mathbin{\overset{\equiv}{\mathrel{\sim}}}$ and $\mathbin{\overset{\overline{\equiv}}{\mathrel{\sim}}}$ If you hover the mouse over this button you see the tooltip “Relations” (Figure 8).

![Relations button](image)

Figure 8. Tooltip indicates the “Relations” button.

Step 4: Delete the $<?>$ text and add “3.14159” at the end of the equation. Hence we end up with the markup “$\pi \simeq 3.14159$”. The result is shown in Figure 9.

![Final result](image)

Figure 9. Final result

**Customizations**

**Formula editor as a floating window**

As seen in Figure 1, the formula editor can cover a large part of the Writer window. To turn the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 10.
2) Hold down the Control key and double-click.
Figure 10. Hold down the Control key and double-click on the border of the math editor to turn it into a floating window.

Figure 11 shows the result. You can make the floating window back into an embedded frame, using the same steps. Hold down the Control key and double-click the window frame.

Figure 11. Equation editor as a floating window

How can I make a formula bigger?

This is one of the most common questions people ask about OOoMath. The answer is simple, but not intuitive:

1) Start the formula editor and go to Format > Font size.

Figure 12. Changing the font size for a formula
2) Select a larger font size under “Base Size” (top-most entry), as shown in Figure 13.

![Font Sizes dialog box](image)

*Figure 13. Edit "Base size" (top) to make a formula bigger.*

The result of this change is illustrated in Figure 14.

<table>
<thead>
<tr>
<th>Before:</th>
<th>After:</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\pi \approx 3.14159$</td>
<td>$\pi \approx 3.14159$</td>
</tr>
</tbody>
</table>

*Figure 14. Result of changing the base font size.*

---

**Formula layout**

The most difficult part of using OOoMath comes when writing complicated equations. This section provides some advice about writing complex formulas.

**Brackets are your friends**

OOoMath knows nothing about order of operation. You must use brackets to state the order of operations explicitly. Consider the following example:

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$\frac{2}{x+1}$</td>
<td>$\frac{2}{x+1}$</td>
</tr>
</tbody>
</table>

**Equations over more than one line**

Suppose you want to type an equation covering more than one line. For example:

\[
\begin{align*}
    x &= 3 \\
    y &= 1
\end{align*}
\]
Your first reaction would be to simply press the Enter key. However, if you press the Enter key, though the markup goes to a new line, the resulting equation does not. You must type the newline command explicitly. This is illustrated in the table below.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>$x = 3$</td>
<td>$x=3$</td>
</tr>
<tr>
<td>$y = 1$</td>
<td>$y=1$</td>
</tr>
<tr>
<td>$x = 3$ newline</td>
<td>$x=3$</td>
</tr>
<tr>
<td>$y = 1$</td>
<td>$y=1$</td>
</tr>
</tbody>
</table>

Common problem areas

How do I add limits to my sum/integral?

The “sum” and “int” commands can (optionally) take in the parameters “from” and “to”. These are used for lower and upper limits respectively. These parameters can be used singly or together. Limits for integrals are usually treated as subscripts and superscripts.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>sum from $k = 1$ to $n$ $a_k$</td>
<td>$\sum_{k=1}^{n} a_k$</td>
</tr>
<tr>
<td>int from 0 to $x$ $f(t)$ dt</td>
<td>$\int_{0}^{x} f(t) dt$ or $\int_{0}^{x} f(t) dt$</td>
</tr>
<tr>
<td>int $_0^x f(t)$ dt</td>
<td>$\int_{\mathbb{R}} f$</td>
</tr>
<tr>
<td>sum to infinity $2^{-n}$</td>
<td>$\sum_{-\infty}^{n} 2^{-n}$</td>
</tr>
</tbody>
</table>

Note For more details on integrals and sums, see Chapter 16 (Math Objects) in the Writer Guide.

Brackets with matrices look ugly!

For background, we start with an overview of the matrix command:
The first problem people have with matrices is that brackets do not “scale” with the matrix:

\[
\begin{pmatrix}
\begin{pmatrix} a & b \\ c & d \end{pmatrix}
\end{pmatrix}
\]

OOoMath provides “scalable” brackets. That is, the brackets grow in size to match the size of their contents. Use the commands `left(` and `right)` to make scalable brackets.

**TIP** Use `left[` and `right]` to obtain square brackets.

### How do I make a derivative?

Making derivatives essentially comes down to one trick: *Tell OOo it’s a fraction.*

In other words, you have to use the “over” command. Combine this with either the letter “d” (for a total derivative) or the “partial” command (for a partial derivative) to achieve the effect of a derivative.

<table>
<thead>
<tr>
<th>Markup</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>{df} over {dx}</code></td>
<td>( \frac{df}{dx} )</td>
</tr>
<tr>
<td><code>{\partial f} over {\partial y}</code></td>
<td>( \frac{\partial f}{\partial y} )</td>
</tr>
<tr>
<td><code>{\partial^2 f} over {\partial t^2}</code></td>
<td>( \frac{\partial^2 f}{\partial t^2} )</td>
</tr>
</tbody>
</table>

**Note** Notice that we had to use squiggly brackets to make the derivative.
Numbering equations

Equation numbering is one of OOOmath’s best hidden features. The steps are simple, but obscure:

1) Start a new line.
2) Type “fn” and then press F3.

The “fn” is replaced by a numbered formula:

\[ E = mc^2 \]  \hspace{1cm} (2)

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta function:

\[ \zeta(z) = \sum_{n=1}^{\infty} \frac{1}{n^z} \]  \hspace{1cm} (3)

You can reference an equation (“as shown in Equation (2)”) with these steps:

1) Insert > Cross-reference..
2) Click on the References tab (Figure 15).
3) Under Type, select Text.
4) Under Selection, pick the equation number.
5) Under Format, choose Reference.
6) Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the equations will automatically renumber and the cross-references will update.
Figure 15. Inserting a cross-reference to an equation number.

**TIP** To insert the equation number without parenthesis around it, choose *Numbering* instead of *Reference* under *Format*.