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What is Writer?

What is Writer?

Writer is the word processor component of OpenOffice.org (OOo). In addition to the usual features 
of a word processor (spell checking, thesaurus, hyphenation, autocorrect, find and replace, automatic 
generation of tables of contents and indexes, mail merge, and others), Writer provides these 
important features:

• Templates and styles

• Powerful page-layout methods (including frames, columns, and tables)

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents—to group a collection of documents into a single document

• Change tracking during revisions

• Database integration, including a bibliography database

• Export to PDF, including bookmarks

• And many more

Styles are central to using Writer. Styles enable you to easily format your document consistently and 
to change the format with minimal effort. Often, when you format your document in Writer, you are 
using styles whether you realize it or not. A style is a named set of formatting options. Writer defines 
several types of styles, for different types of elements: characters, paragraphs, pages, frames, and 
lists. The use of styles is described in more detail in other chapters in this guide, including Chapter 6 
(Introduction to Styles) and Chapter 7 (Working with Styles).

The other features of Writer listed above are also covered in detail in other chapters of this guide.

Starting Writer

If you are reading this document in OpenOffice.org, you already know how to start Writer. However, 
if this is a printed version or a PDF version, you may not know how to start Writer. So let’s look at 
three ways to do that:

• From the system menu

• From an existing document

• From the command line

Starting from the system menu
Using the system menu is the most common way to start Writer. The system menu is the standard 
menu from which most applications are started. On Windows, it is called the Start menu. On 
GNOME, it is called the Applications menu. On KDE, it is identified by the KDE logo. On Mac OS 
X, it is the Applications menu.
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Starting Writer

When OpenOffice.org was installed, a menu entry was added to your system menu. The exact name 
and location of this menu entry depends on your graphical environment. This chapter looks at 
Windows, GNOME and KDE on Linux, and Mac OS X. The concepts should easily be applicable to 
another operating system.

Windows
On Windows, the OpenOffice.org menu is located in Programs > OpenOffice.org 2.x,  where “2.x” 
corresponds to the version number of OpenOffice.org. Figure 1 shows a typical setup on Windows 
XP. Select OpenOffice.org Writer to start Writer with a blank document.

Figure 1. Starting Writer from the Windows XP Start menu
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Starting Writer

Linux/GNOME
GNOME installations differ from one distribution to the next. Most modern distributions come with 
OpenOffice.org already installed. You will find OpenOffice.org under Applications > Office, as 
shown in Figure 2.

Figure 2. Starting Writer from the GNOME Applications menu

Fedora/Red Hat Enterprise Linux comes with OpenOffice.org installed. On the GNOME desktop, 
OOo can be found under Main Menu > Office. If you have installed a newer version of OOo, you 
will find it under Main Menu > Office > More Office Applications.

If you installed by downloading OOo from the http://www.openoffice.org website, it is under 
Applications > Other.

Introducing Writer 3
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Starting Writer

Linux/KDE
On KDE, OpenOffice.org is installed in its own menu, called Office (see Figure 3).

Figure 3. Starting OOo from KDE start menu

Some Linux distributions install OpenOffice.org in the Office submenu. Mandrake is such a 
distribution. In this case, to launch Writer, choose Office > Word processors > OpenOffice.org 
Writer. Figure 4 illustrates the OOo menu with Math selected.
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Starting Writer

Figure 4: Starting OOo from Mandrake's KDE menu

Mac OS X
Go to the folder where you installed OpenOffice.org. You should see its icon in the Applications 
folder (Figure 5). To start Writer, double-click the OpenOffice.org icon.

Figure 5: Starting OpenOffice.org from the Mac Applications folder

To open the other components (Draw, Calc, Impress, Base), go to the File menu of the Writer 
window and select the component you want. See Figure 6.
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Starting Writer

Figure 6: Opening different OOo components on the Mac

Starting from an existing document
If you installed OpenOffice.org correctly, all Writer documents are associated with the Writer 
application. This means that you can start OpenOffice.org automatically, simply by double-clicking a 
Writer document in your favorite file manager (for example, Windows Explorer).

You can spot an OpenOffice.org Writer document by its icon: .

For Windows users
File associations are used to open certain types of files automatically with OpenOffice.org. When 
installing OOo, you could choose to associate Microsoft Office file types with OOo. If you chose to 
do this, then when you double-click on a *.doc file, it opens in OOo Writer.

If you did not associate the file types, then when you double-click on a Microsoft Word document, it 
opens in Microsoft Word (if Word is installed on your computer).

You can use another method to open *.doc files in OOo and save in the *.doc format from OOo. See 
“Opening an existing document” on page 17 for more information.

Using the Quickstarter under Windows
The Quickstarter is an icon that is placed in the Windows system tray during system startup. It 
indicates that OpenOffice.org has been loaded and is ready to use. (The Quickstarter loads  library 
*.DLL files required by OOo, thus shortening the startup time for OOo components by about half.) If 
the Quickstarter is disabled, see “Reactivating the Quickstarter” on page 7 if you want to enable it.
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Using the Quickstarter icon
Right-click the Quickstarter icon in the system tray to open a pop-up menu from which you can 
open a new document, open the Templates and Documents dialog box, or choose an existing 
document to open. (See Figure 7.) You can also double-click the Quickstarter icon to display the 
Templates and Documents dialog box.

Figure 7: Quickstarter pop-up menu

Disabling the Quickstarter
To close the Quickstarter, right-click on the icon in the system tray and then click Exit Quickstarter 
on the pop-up menu. The next time the computer is restarted, the Quickstarter will be loaded again.

To prevent OpenOffice.org from loading during system startup, deselect the Load OpenOffice.org 
During System Start-Up item on the pop-up menu. You might want to do this if your computer has 
insufficient memory, for example.

Reactivating the Quickstarter
If the Quickstarter has been disabled, you can reactivate it by selecting the Load OpenOffice.org 
during system start-up checkbox in Tools > Options > OpenOffice.org > Memory.

Using the Quickstarter under Linux
Some installations of OpenOffice.org under Linux have a Quickstarter that looks and acts like the 
one described above for Windows (the checkbox on the Memory page is labeled Enable systray 
quickstarter). 

Preloading OOo under Linux/KDE
In Linux/KDE, you can use KDocker to have OOo loaded and ready for use at startup. KDocker is 
not part of OOo; it is a generic “systray app docker” that is helpful if you open OOo often.

Starting from the command line
You may want to start Writer from the command line (using the keyboard instead of the mouse). 
Why? Well, by using the command line, you have more control over what happens when Writer is 
started. For example, using the command line, you can tell Writer to load a document and print it 
immediately, or to start without showing the splash screen.
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Note Most users will never need to do this.

There is more than one way to start Writer from the command line, depending on whether you have 
installed a customized version or the standard download from the OOo web site.

If you installed using the download on the OOo web site, you can start Writer by typing at the 
command line:

soffice -writer
or

swriter

Writer will start and create a new document.

To see a list of options you can use when starting Writer at the command line, type:

soffice -?

Below is a list of some of the more popular options.

Option Description

-help Get a complete list of options.

-nologo Do not show the startup screen.

-show <odp-file> Start presentation immediately.

-view <documents ...> Open documents in viewer (read-only) mode.

-minimized Start OOo minimized.

-norestore Suppress restart/restore after fatal errors.

-invisible No startup screen, no default document and no UI. 
This is useful for third-party applications that use 
functionality provided by OOo.

If you have a customized version of OOo (such as the one provided by Linux Mandrake or Gentoo), 
you can start Writer by typing at the command line:

oowriter

Note Although the command syntax differs, the effect is identical: it starts OOo with an 
empty Writer document.
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The Writer interface

The Writer interface

The main Writer workspace is shown in Figure 8.

Figure 8: The main Writer workspace in Print Layout view

Menus
Menus are located across the top of the Writer window. The main menu selections are File, Edit, 
View, Insert, Format, Table, Tools, Window, and Help. When you click one of the main menu 
names, a list of related options is displayed.

• File contains commands that apply to the entire document such as Open, Save, and Export as 
PDF.

• Edit contains commands for editing the document such as Undo and Find & Replace.

• View contains commands for controlling the display of the document such as Zoom and Web 
Layout.

• Insert contains commands for inserting elements into your document such as headers, footers, 
and pictures.

• Format contains commands for formatting the layout of your document, such as Styles and 
Formatting, Paragraph, and Bullets and Numbering.

• Table shows all commands to insert and edit a table in a text document.

• Tools contains functions such as Spellcheck, Customize, and Options.

• Window contains commands for the display window.

• Help contains links to the Help file, What’s This?, and information about the program. See 
“Getting help” on page 20.
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Toolbars
Writer has several types of toolbars: docked, floating, and tear-off. Docked toolbars can be moved to 
different locations or made to float, and floating toolbars can be docked.

The top docked toolbar (default position) is called the Standard toolbar. The Standard toolbar is 
consistent across the OpenOffice.org applications.

The second toolbar across the top (default location) is called the Formatting toolbar. It is a context-
sensitive bar which shows the relevant tools in response to the cursor’s current position or selection. 
For example, when the cursor is on a graphic, the Formatting bar provides tools for formatting 
graphics; when the cursor is in text, the tools are for formatting text.

Figure 9. Writer toolbars

Floating toolbars
Writer includes several additional context-sensitive toolbars, whose defaults appear as floating 
toolbars in response to the cursor’s current position or selection. For example, when the cursor is in a 
table, a floating Table toolbar appears, and when the cursor is in a numbered or bullet list, the Bullets  
and Numbering toolbar appears. You can dock these toolbars to the top, bottom, or side of the 
window, if you wish (see “Moving toolbars” on page 11).

Long-click buttons and tear-off toolbars
Buttons with a small triangle to the right will display submenus, tear-off toolbars, and other ways of 
selecting things with a long click, depending on the button. 

Figure 10 shows the Paste submenu.

Figure 11 shows a tear-off toolbar from the Drawing toolbar.

Figure 10. Example of a submenu

The tear-off toolbars can be floating or docked along an edge of the screen or in one of the existing 
toolbar areas. To move a floating tear-off toolbar, drag it by the title bar. See “Moving toolbars” 
below.

Introducing Writer 10
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The Writer interface

Figure 11: Example of a tear-off toolbar

Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in the list. 
An active toolbar shows a check mark beside its name. Tear-off toolbars are not listed in the View 
menu.

Moving toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle, hold down the left mouse 
button, drag the toolbar to the new location, and then release the mouse button (Figure 12.

To move a floating toolbar, click on its title bar and drag it to a new location. Figure 13 shows an 
example.

Figure 12: Moving a docked toolbar

Figure 13: Moving a floating toolbar

Docking/floating windows and toolbars
Some windows in OpenOffice.org, such as the Navigator and the Styles and Formatting window, are 
dockable. You can move, resize, or dock them to an edge.

Introducing Writer 11
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The Writer interface

To dock a window, do one of the following:

• Click on the title bar of the floating window and 
drag it to the side until you see the outline of a box 
appear in the main window (see Figure 14) and then 
release the window. This method depends on your 
system’s window manager settings, so it may not 
work for you.

• Hold down the Control key and double-click on a 
vacant part of the floating window to dock it in its 
last position. If that does not work, try double-
clicking without using the Control key.

To undock a window, hold down the Control key and 
double-click on a vacant part of the docked window.

Note The Styles and Formatting window can 
also be docked or undocked by using 
Control+ double-click on the gray area 
next to the icons at the top of the window.

Figure 14: Docking a window

Rulers
To show or hide rulers, choose View > Ruler. To show the vertical ruler, choose Tools > Options > 
OpenOffice.org Writer > View and select Vertical ruler.

Figure 15. Turn on the vertical ruler using Tools > Options > OpenOffice.org Writer > View

Changing document views
OpenOffice.org has several ways to view a document: Print Layout, Web Layout, Full Screen, and 
Zoom. You can select these choices on the View menu. The only document view option with a 
submenu is Zoom. When you choose View > Zoom, the following dialog box appears.
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Changing document views

Figure 16. Selecting a zoom factor

• Entire Page: Displays the entire page on the screen (text may be too small to read).

• Page Width: Displays the complete width of the document page. The top and bottom edges of the 
page may not be visible.

• Optimal: Resizes the display to fit the width of the text in the document.

• 200%: Displays the document at two times its actual size.

• 150%: Displays the document at one and a half times its actual size.

• 100%: Displays the document at its actual size.

• 75%: Displays the document at 75% of its actual size.

• 50%: Displays the document at half of its actual size.

• Variable: Enter the zoom factor (percentage) at which you want to display the document.

Using the Navigator

The Navigator displays all objects contained in a document. It provides a very convenient way to 
move around a document and find items in it. The Navigator button is located on the Standard 
toolbar. You can also display the Navigator by choosing Edit > Navigator, or open it quickly by 
pressing F5.

Figure 17. Navigator toolbar icon

The Navigator displays lists of Headings, Tables, Text frames, Graphics, Bookmarks, and other 
items. Click the + sign by any of the lists to display the contents of the list.

If you only want to see the content in a certain category, highlight the category and click the Content 
View icon.
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Using the Navigator

Figure 18. The Navigator

Note The Navigator looks somewhat different in a master document. For more 
information, see Chapter 13 (Working with Master Documents).

The Navigator helps you to reach objects quickly. Double-click the object in the Navigator to jump 
directly to that object’s position in the document, as shown in Figure 19.

Figure 19. Using the Navigator to jump quickly to a heading

Introducing Writer 14
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Using the Navigator

Arranging chapters using the Navigator
You can arrange chapters and move headings in the document by using the Navigator.

1) Click the Content View icon to expand the headings, if necessary.

2) Click on the heading in question.

3) Drag the heading to a new location on the Navigator or click the heading in the Navigator list, 
and then click Promote Level, Demote Level, Promote Chapter, or Demote Chapter.

Figure 20. Reorganizing with the Navigator

Creating a new document

Creating a blank document
You can create a new, blank document in Writer in a number of ways:

• Press the Control+N keys. A new empty document opens. If you already have a document 
open, the new document appears in a new window.

• Use File > New > Text Document. The result is the same as pressing the Control+N keys.

• Click the New button on the main toolbar .
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Creating a new document

Creating a document from a template
You can use templates to create new documents in Writer. Templates serve as the foundation of a set 
of documents, to make sure they all have a similar layout. For example, all the documents of the 
Writer Guide are based on the same template. As a result, all the documents look alike; they have the 
same headers and footers, use the same fonts, and so on.

A new OpenOffice.org installation does not contain many templates. It is possible for you to add new 
templates to your installation and use them for new documents. This is explained in Chapter 10 
(Working with Templates). Many more templates can be downloaded from 
http://extensions.services.openoffice.org/ and other websites.

Once you do have templates on your system, you can create new documents based on them by using 
File > New > Templates and Documents. This opens a window where you can choose the template 
you want to use for your document.

The example shown in Figure 21 uses a template called “Book” in the My Templates folder. Select it, 
then click the Open button. A new document is created based on the formats defined in the template.

Figure 21. Creating a document from a template
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Opening an existing document

Here is one way to open an existing document in Writer:

1) Click File > Open (or press Control+O).

2) In the file chooser, you can reduce the list of files by selecting the type of file you are looking 
for. If you choose Text documents as the file type, you will only see documents Writer 
understands.

3) Select the file you want, and then click Open.

Note This method opens Word (*.doc) files, as well as OOo files and other formats.

You can also open an existing OOo Writer document using the same methods you would use to open 
any document in your operating system.

Saving a document

There are three ways to save a document in Writer:

• Press Control+S.

• Select File > Save.

• Click the Save button on the main toolbar.

You also can tell Writer to save your document automatically at regular intervals. To enable this, you 
must configure OpenOffice.org to save all documents automatically.

1) Select Tools > Options. The Options window appears.

2) Select Load/Save > General.

3) Click on Save AutoRecovery information every. This enables the box to set the interval. 
The default value is 30 minutes. Enter the value you want by typing it or by pressing the up or 
down arrow keys.

Saving as a Microsoft Word document
You may need to share your documents with other people who do not use OpenOffice.org, but use 
Microsoft Word instead. Fortunately, OpenOffice.org can read and write Word files. To save a 
document as a Microsoft Word file:

1) First save your document in OpenOffice.org’s format (*.odt). If you do not, any changes you 
made since the last time you saved will only appear in the Microsoft Word version of the 
document.

2) Then click File > Save As. The Save As dialog box (Figure 22) appears.

3) In the Save as type drop-down menu, select the type of Word format you need.

4) Click Save.
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Saving a document

From this point on, all changes you make to the document will occur only in the Microsoft Word 
document. You have actually changed the name of your document. If you want to go back to working 
with the OpenOffice.org version of your document, you must open it again.

Tip To have OOo save documents by default in the Microsoft Word file format, go to 
Tools > Options > Load/Save > General. In the section named Default file format, 
under Document type, select Text document, then under Always save as, select your 
preferred file format.

Figure 22. Saving a file in Microsoft Word format

Printing a document

For more information about printing documents, see Chapter 5 (Printing, Faxing, Exporting, and E-
mailing).

Quick printing

Click the Print File Directly icon  to send the entire document to the default printer defined for 
your computer.
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Printing a document

Controlling printing using the Print dialog box
For more control over printing, use File > Print to display the Print dialog box (Figure 23).

Figure 23. The Print dialog box

On the Print dialog box, you can choose:

• Which printer to use (if more than one are installed on your system) and the properties of the 
printer—for example, orientation (portrait or landscape), which paper tray to use, and what 
paper size to print on. The properties available depend on the selected printer; consult the 
printer’s documentation for details.

• Which pages to print, how many copies to print, and in what order to print them.

• Use dashes to specify page ranges and commas or semicolons to separate ranges; for 
example, 1, 5, 11–14, 34–40.

• Selection is the highlighted part of a page or pages.

• Which items to print. Click the Options button to display the Printer Options dialog box. For 
details about print options and setting defaults for Writer, see Chapter 5 (Printing, Faxing, 
Exporting, and E-mailing).

Previewing pages before printing
The normal page view in Writer shows what each page will look like when printed, but it shows only 
one page at a time. If you are designing a document to be printed double-sided, you may want to see 
what facing pages look like. OOo provides a way to do this in Page Preview. For more information, 
see Chapter 5 (Printing, Faxing, Exporting, and E-mailing).

1) Click File > Page Preview, or click the Page Preview button . 

The Writer window changes to display the current page and the following page and shows the 
Page Preview toolbar (Figure 24) in place of the Formatting toolbar.
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Printing a document

Figure 24. Page Preview toolbar

2) Click the Book Preview icon  to display left and right pages in their correct orientation 
(facing pages).

3) To print the document in this page view, click the Print page view icon .

4) To choose margins and other options for the printout, click the Print options page view icon 

 to display the Print Options dialog box.

Exporting to PDF

OpenOffice.org can export documents to PDF (Portable Document Format). This industry-standard 
file format for file viewing is ideal for sending the file to someone else to view using Acrobat Reader 
or other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire document using the default PDF 
settings. You are asked to enter the file name and location for the PDF file, but you do not get a 
chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The 
PDF Options dialog box opens. This dialog box has four pages (General, Initial View, User Interface, 
and Security). Here you can choose which pages to include in the PDF, the type of compression to 
use for images (which affects the quality of images in the PDF), and other options. 

Make your selections, and then click Export. Then you are asked to enter the location and file name 
of the PDF to be created, and click Save to export the file.

For more information, see Chapter 5 (Printing, Faxing, Exporting, and E-mailing).

Getting help

Writer provides several forms of help. In addition to a full Help file, you can choose whether to 
activate tooltips, extended tips, and the Help Agent.

Placing the mouse pointer over any of the icons displays a small box, called a tooltip. It gives a brief 
explanation of the icon’s function. For a more detailed explanation, select Help > What’s This? and 
hold the mouse pointer over the icon you need more help with.

Note The extended tips option in OOo 2.x cannot be accessed from the Help menu as it 
was in OOo 1.x. Tips and extended tips can be turned on or off from Tools > Options 
> OpenOffice.org > General. What's This? help is a new feature in OOo 2.0.

Introducing Writer 20



Getting help

Figure 25. The Help menu

Closing a document

To close a document, click File > Close.

You can also close a document by clicking on the Close icon on the document window. In Windows 
XP, this button looks like the red X shown in Figure 26.

If more than one OOo window is open, each window looks like the sample shown on the left in 
Figure 26. Closing this window leaves the other OOo windows open.

If only one OOo window is open, it looks like the sample shown on the right in Figure 26. Notice the 
small black X below the large red X. Clicking the small X closes the document but leaves OOo open. 
Clicking the large red X closes OOo completely.

Figure 26. Close icons in Windows XP

If the document has not been saved since the last change, a message box is displayed. Choose 
whether to save or discard your changes.

• Save: The document is saved and then closed.

• Discard: The document is closed, and all modifications since the last save are lost.

• Cancel: Nothing happens, and you return to the document.

Caution Not saving your document could result in the loss of recently made changes, or 
worse still, your entire file.

Closing Writer

To close Writer completely, click File > Exit, or close the last open document as described in 
“Closing a document” on page 21.

If all the documents have been saved, Writer closes immediately. If any documents have been 
modified but not saved, a warning message appears. Follow the procedure in “Closing a document” 
to save or discard your changes.
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