
Getting Started Guide

Chapter 10
 Printing, Exporting, 

and E-mailing

This PDF is designed to be read onscreen, two pages at a 
time. If you want to print a copy, your PDF viewer should 
have an option for printing two pages on one sheet of 
paper, but you may need to start with page 2 to get it to 
print facing pages correctly. (Print this cover page 
separately.)



Copyright
This document is Copyright © 2005–2010 by its contributors as listed 
in the section titled Authors. You may distribute it and/or modify it 
under the terms of either the GNU General Public License, version 3 or 
later, or the Creative Commons Attribution License, version 3.0 or 
later.

All trademarks within this guide belong to their legitimate owners.

Authors
Jean Hollis Weber
Agnes Belzunce
Michael Kotsarinis
Peter Kupfer
Robert Scott
Janet M. Swisher

Feedback
Please direct any comments or suggestions about this document to: 
authors@user-faq.openoffice.org

Publication date and software version
Published 4 January 2010. Based on OpenOffice.org 3.2.

You can download
 an editable version of this document from

 http://oooauthors.org/english/userguide3/published/

http://oooauthors.org/english/userguide3/published/
mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html


Contents
Copyright...............................................................................................2

Introduction...........................................................................................4

Quick printing........................................................................................4

Controlling printing...............................................................................4

Exporting to PDF...................................................................................5

Quick export to PDF............................................................................5

Controlling PDF content and quality...................................................5

General page of PDF Options dialog................................................6

Initial View page of PDF Options dialog..........................................8

User Interface page of PDF Options dialog.....................................8

Links page of PDF Options dialog....................................................9

Security page of PDF Options dialog.............................................10

Exporting to other formats...................................................................12

E-mailing documents............................................................................12

E-mailing a document to several recipients......................................13

Digital signing of documents................................................................15

Printing, Exporting, and E-mailing 3



Introduction
This chapter provides general information about printing, exporting, 
and e-mailing documents from OOo.

Quick printing

Click the Print File Directly icon  to send the entire document to 
the default printer defined for your computer.

Note

You can change the action of the Print File Directly icon to 
send the document to the printer defined for the document 
instead of the default printer for the computer. Go to Tools > 
Options > Load/Save > General and select the Load 
printer settings with the document option.

Controlling printing
For more control over printing, use File > Print to display the Print 
dialog.

On the Print dialog, you can choose:

• Which printer to use (if more than one are installed on your 
system) and the properties of the printer—for example, 
orientation (portrait or landscape), which paper tray to use, and 
what paper size to print on. The properties available depend on 
the selected printer; consult the printer’s documentation for 
details.

• What pages to print, how many copies to print, and in what order 
to print them. Use dashes to specify page ranges and commas or 
semicolons to separate ranges; for example: 1, 5, 11–14, 34–40. 
Selection is the highlighted part of a page or pages.

• What items to print. Click the Options button to display the 
Printer Options dialog.

Selections on the Printer Options dialog are different in Writer, Calc, 
Impress, and Draw, but in all cases they apply to this printing of this 
document only. For details, see the chapters on the various OOo 
components.

To specify default printing options, see Chapter 2 (Setting up 
OpenOffice.org) and the chapters on the various OOo components.
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Figure 1. The Print dialog

Exporting to PDF
OpenOffice.org can export documents to PDF (Portable Document 
Format). This industry-standard file format is ideal for sending the file 
to someone else to view using Adobe Reader or other PDF viewers.

The process and dialogs are the same for Writer, Calc, Impress, and 
Draw, with a few minor differences mentioned in this section.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire 
document using your default PDF settings. You are asked to enter the 
file name and location for the PDF file, but you do not get a chance to 
choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use 
File > Export as PDF. The PDF Options dialog opens. This dialog has 
five pages (General, Initial View, User Interface, Links, and Security). 
Make your selections, and then click Export. Then you are asked to 
enter the location and file name of the PDF to be created, and click 
Save to export the file.
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General page of PDF Options dialog
On the General page, you can choose which pages to include in the 
PDF, the type of compression to use for images (which affects the 
quality of images in the PDF), and other options.

Figure 2: General page of PDF Options dialog

Range section
• All: Exports the entire document.
• Pages: To export a range of pages, use the format 3-6 (pages 3 to 

6). To export single pages, use the format 7;9;11 (pages 7, 9, and 
11). You can also export a combination of page ranges and single 
pages, by using a format like 3-6;8;10;12.

• Selection: Exports whatever material is selected.

Images section
• Lossless compression:  Images are stored without any loss of 

quality. Tends to make large files when used with photographs. 
Recommended for other kinds of images or graphics.
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• JPEG compression: Allows for varying degrees of quality. A 
setting of 90% works well with photographs (small file size, little 
perceptible loss of quality).

• Reduce image resolution: Lower-DPI (dots per inch) images 
have lower quality. For viewing on a computer screen generally a 
resolution of 72dpi (for Windows) or 96dpi (GNU/Linux) is 
sufficient, while for printing it is generally preferable to use at 
least 300 or 600 dpi, depending on the capability of the printer. 
Higher dpi settings greatly increase the size of the exported file.

Note
EPS images with embedded previews are exported only as 
previews. EPS images without embedded previews are 
exported as empty placeholders.

General section
• PDF/A-1: PDF/A is an ISO standard established in 2005 for long-

term preservation of documents, by embedding all the pieces 
necessary for faithful reproduction (such as fonts) while 
forbidding other elements (including forms, security, encryption, 
and tagged PDF). If you select PDF/A-1, the forbidden elements 
are greyed-out (not available).

• Tagged PDF: Exports special tags into the corresponding PDF 
tags. Some tags that are exported are table of contents, 
hyperlinks, and controls. This option can increase file sizes 
significantly.

• Create PDF form - Submit format: Choose the format of 
submitting forms from within the PDF file. This setting overrides 
the control’s URL property that you set in the document. There is 
only one common setting valid for the whole PDF document: PDF 
(sends the whole document), FDF (sends the control contents), 
HTML, and XML. Most often you will choose the PDF format.

• Export bookmarks: Exports headings in Writer documents, and 
page names in Impress and Draw documents, as “bookmarks” (a 
table of contents list displayed by some PDF readers, including 
Adobe Reader).

• Export comments: Exports comments in Writer and Calc 
documents as PDF notes. You may not want this! In Impress, 
exports a set of Comments pages following the set of slides.

• Export automatically inserted blank pages: If selected, 
automatically inserted blank pages are exported to the PDF. This 
is best if you are printing the PDF double-sided. For example, 
books usually have chapters set to always start on an odd-

Exporting to PDF 7



numbered (right-hand) page. When the previous chapter ends on 
an odd page, OOo inserts a blank page between the two odd 
pages. This option controls whether to export that blank page.

Initial View page of PDF Options dialog
On the Initial View page, you can choose how the PDF opens by default 
in a PDF viewer. The selections should be self-explanatory.

Figure 3: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog
On the User Interface page (Figure 4), you can choose more settings to 
control how a PDF viewer displays the file. Some of these choices are 
particularly useful when you are creating a PDF to be used as a 
presentation or a kiosk-type display.

Window options section
• Resize window to initial page. Causes the PDF viewer window 

to resize to fit the first page of the PDF.
• Center window on screen. Causes the PDF viewer window to be 

centered on the computer screen.
• Open in full screen mode. Causes the PDF viewer to open full-

screen instead of in a smaller window.
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• Display document title. Causes the PDF viewer to display the 
document’s title in the title bar.

Figure 4: User Interface page of PDF Options dialog

User interface options section
• Hide menubar. Causes the PDF viewer to hide the menu bar.
• Hide toolbar. Causes the PDF viewer to hide the toolbar.
• Hide window controls. Causes the PDF viewer to hide other 

window controls.

Transitions
In Impress, displays slide transition effects as their respective PDF 
effects.

Bookmarks
Select how many heading levels are displayed as bookmarks, if 
Export bookmarks is selected on the General page.

Links page of PDF Options dialog
On this page you can choose how links are exported to PDF.

Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, 
or Calc sheet names, this option exports them as “named 
destinations” to which Web pages and PDF documents can link.
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Convert document references to PDF targets
If you have defined links to other documents with OpenDocument 
extensions (such as .ODT, .ODS, and .ODP), this option converts the 
files names to .PDF in the exported PDF document.

Figure 5: Links page of PDF Options dialog

Export URLs relative to file system
If you have defined relative links in a document, this option exports 
those links to the PDF.

Cross-document links
Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be 
opened without a password) and apply some digital rights management 
(DRM) features.

• With an open password set, the PDF can only be opened with the 
password. Once opened, there are no restrictions on what the 
user can do with the document (for example, print, copy, or 
change it).

• With a permissions password set, the PDF can be opened by 
anyone, but its permissions can be restricted. See Figure 6. After 
you set a password for permissions, the other choices on the 
Security page become available.

• With both the open password and permission password set, the 
PDF can only be opened with the correct password, and its 
permissions can be restricted.

Figure 7 shows the pop-up dialog displayed when you click the Set 
open password button on the Security page of the PDF Options 
dialog.
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Figure 6: Security page of PDF Options dialog

Figure 7: Setting a password to encrypt a PDF
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Note
Permissions settings are effective only if the user’s PDF viewer 
respects the settings.

Exporting to other formats
OOo uses the term “export” for some file operations involving a change 
of file type. If you cannot find what you want under Save As, look 
under Export as well.

OpenOffice.org can export files to XHTML. In addition, OOo Draw and 
OOo Impress can export to Adobe Flash (.swf) and a range of image 
formats.

To export to one of these formats, choose File > Export. On the Export 
dialog, specify a file name for the exported document, then select the 
required format in the File format list and click the Export button.

E-mailing documents
OOo provides several ways to quickly and easily send documents as an 
e-mail attachment in one of three formats: OpenDocument (OOo’s 
default format), Microsoft Office formats, or PDF.

To send the current document in OpenDocument format:

1) Choose File > Send > Document as E-mail. OpenOffice.org 
opens the e-mail program specified in Tools > Options > 
Internet > E-mail. The document is attached.

2) In your e-mail program, enter the recipient, subject and any text 
you want to add, then send the e-mail.

File > Send > E-mail as OpenDocument Text (or Spreadsheet or 
Presentation) has the same effect.

If you choose E-mail as Microsoft [Word, Excel, or Powerpoint], 
OOo first creates a file in one of those formats and then opens your e-
mail program with the file attached.

Similarly, if you choose E-mail as PDF, OOo first creates a PDF using 
your default PDF settings (as when using the Export Directly as PDF 
toolbar button) and then opens your email program with the .PDF file 
attached.
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E-mailing a document to several recipients
To e-mail a document to several recipients, you can use the features in 
your e-mail program or you can use OOo’s mail merge facilities to 
extract email addresses from an address book.

You can use OOo’s mail merge to send e-mail in two ways:
• Use the Mail Merge Wizard to create the document and send it. 

See Chapter 11 (Using Mail Merge) of the Writer Guide for details.
• Create the document in Writer without using the Wizard, then use 

the Wizard to send it. This method is described here.

To use the Mail Merge Wizard to send a previously-created Writer 
document:

1) Click Tools > Mail Merge Wizard. On the first page of the 
wizard, select Use the current document and click Next.

Figure 8:  Select starting document

2) On the second page, select E-mail message and click Next.

Figure 9:  Select document type
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3) On the third page, click the Select Address List button. Select 
the required address list (even if only one is shown) and then click 
OK. (If the address list you need is not shown here, you can click 
Add to find it and add it to the list.)

Figure 10: Selecting an address list

4) Back on the Select address list page, click Next. On the Create 
salutation page, deselect This document should contain a 
salutation.

Figure 11: Deselecting a salutation
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5) In the left-hand list, click 8. Save, print or send. OOo displays a 
“Creating documents” message and then displays the Save, print 
or send page of the Wizard.

6) Select Send merged document as E-Mail. The lower part of the 
page changes to show e-mail settings choices.

Figure 12: Sending a document as an email message

7) Type a subject for your email and click Send documents. OOo 
sends the e-mails.

Digital signing of documents
To sign a document digitally, you need a personal key, the certificate. A 
personal key is stored on your computer as a combination of a private 
key, which must be kept secret, and a public key, which you add to your 
documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a 
governmental institution.

When you apply a digital signature to a document, a kind of checksum 
is computed from the document’s content plus your personal key. The 
checksum and your public key are stored together with the document. 
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When someone later opens the document on any computer with a 
recent version of OpenOffice.org, the program will compute the 
checksum again and compare it with the stored checksum. If both are 
the same, the program will signal that you see the original, unchanged 
document. In addition, the program can show you the public key 
information from the certificate. You can compare the public key with 
the public key that is published on the web site of the certificate 
authority.

Whenever someone changes something in the document, this change 
breaks the digital signature.

On Windows operating systems, the Windows features of validating a 
signature are used. On Solaris and Linux systems, files that are 
supplied by Thunderbird, Mozilla or Firefox are used. For a more 
detailed description of how to get and manage a certificate, and 
signature validation, see “Using Digital Signatures” in the OOo Help.

To sign a document:

1) Choose File > Digital Signatures.
2) If you have not saved the document since the last change, a 

message box appears. Click Yes to save the file.
3) After saving, you see the Digital Signatures dialog. Click Add to 

add a public key to the document.
4) In the Select Certificate dialog, select your certificate and click 

OK. 
5) You see again the Digital Signatures dialog, where you can add 

more certificates if you want. Click OK to add the public key to 
the saved file.

A signed document shows an icon  in the status bar. You can double-
click the icon to view the certificate.
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