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Introduction

Introduction

OpenOffice.org (OOo) has a component for mathematical equations.  It is most commonly 
used as an equation editor for text documents, but it can also be used with other types of 
documents or stand-alone. When used inside Writer, the equation is treated as an object inside 
the text document.

Note The equation editor is for writing equations in symbolic form (as in equation 1). If 
you want to evaluate a numeric value, see the Calc Guide.

df x
dx

=ln x tan−1
x2
  

(1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Selection window 
appears. You will also see a small box (with a gray border) in your document, where the 
formula will be displayed.

Figure 1. Equation Editor, Selection window, and location of resulting equation.

The equation editor uses a markup language to represent formulas. For example, %beta 
creates the Greek character beta (  ). This markup is designed to read similar to English 

whenever possible. For example, a over b produces a fraction: 
a
b

.
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Entering a formula

Entering a formula

There are three ways to enter a formula:

• Select a symbol from the Selection window.

• Right-click on the equation editor and select the symbol from the context menu.

• Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a symbol. 
Incidentally, this provides a convenient way to learn the OOoMath markup.

Note Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

The Selection window
The simplest method for entering a formula is the Selection window, shown in Figure 2.

Figure 2. Symbols are divided into categories

The Selection window is divided into two main portions.

• The top shows the symbol categories. Click on these to change the list of symbols.

• The bottom shows the symbols available in the current category.

Tip You can hide (or unhide) the Selection window with View > Selection.
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Entering a formula

Example 1: 5×4

For this example we will enter a simple formula: 5×4 On the Selection window:

1) Select the top-left button of the categories (top) section (Figure 3).

2) Click on  the multiplication symbol (shown in Figure 3).

Figure 3. Unary/binary operators

When you select the multiplication symbol on the Selection window, two things happen:

• The equation editor shows the markup: <?> times <?>

• The body of the document shows a gray box with the figure: ×

Figure 4. The multiplication symbol

The “ <?> ” symbols (Figure 4) are placeholders that you can replace by other text. The 
equation will update automatically, and the result should resemble Figure 5.

Figure 5. Result of entering “5” and “4” next to the “times” operator

Math Objects 3
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Entering a formula

Tip To keep the equation from updating automatically, select View > AutoUpdate 
display. 

To update a formula manually, press F9 or select View > Update.

Right-click menu
Another way to access mathematical symbols is to right-click on the equation editor. This 
produces a menu as shown in Figure 6.

Figure 6. Right-click menu

Note The entries in this menu correspond exactly to those in the Selection window.

Markup
You can type the markup directly in the equation editor. For example, you can type “5 times 
4” to obtain 5×4 . If you know the markup, this can be the fastest way to enter a formula.

Tip As a mnemonic, the formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command

a=b a = b  a sqrt {a}

a2 a^2 an a_n

∫ f xdx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y
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Entering a formula

Greek characters

Greek characters (  ,  , , , etc) are common in mathematical formulas. These characters 
are not available in the selection box or the right-click menu. Fortunately, the markup for 
Greek characters is simple: Type a % sign followed the name of the character, in English.

• To type a lowercase character, write the name of the character in lowercase.

• To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples:

Lowercase Uppercase

%alpha   %ALPHA  A

%beta   %BETA  B

%gamma   %GAMMA  

%psi    %PSI   

%phi    %PHI   

%theta   %THETA  

Note A complete table of Greek characters is included in page 23.

Another way to enter Greek characters is by using the catalog window. Go to Tools > 
Catalog. The catalog window is shown in Figure 7. Under “Symbol Set” select “Greek” and 
double-click on a Greek letter from the list.

Figure 7. Catalog - used for entering Greek characters
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Entering a formula

Example 2:  ≃ 3.14159

For this example we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal places).

• We know the name of the Greek character (“pi”).

• But we do not know the markup associated with the ≃  symbol.

Step 1: Type “%” followed by the text “pi”. This displays the Greek character  .

Step 2: Open the Selection window (View > Selection).

Step 3: The ≃  symbol is a relation, so we click on the relations button . If you hover the 
mouse over this button you see the tooltip “Relations” (Figure 8).

Figure 8. Tooltip indicates the “Relations” button.

Step 4: Delete the <?> text and add “3.14159” at the end of the equation. Hence we end up 
with the markup “ %pi simeq 3.14159 ”. The result is shown in Figure 9.

Figure 9. Final result
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Customizations

Customizations

Formula editor as a floating window
As seen in Figure 1, the formula editor can cover a large part of the Writer window. To turn 
the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 10.

2) Hold down the Control key and double-click.

Figure 10. Hold down the Control key and double-click on the border of  
the math editor to turn it into a floating window.

Figure 11 shows the result. You can make the floating window back into an embedded frame, 
using the same steps. Hold down the Control  key and double-click the window frame.

Figure 11. Equation editor as a floating window

How can I make a formula bigger?
This is one of the most common questions people ask about OOoMath. The answer is simple, 
but not intuitive:

1) Start the formula editor and go to Format > Font size.
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Customizations

Figure 12. Changing the font size for a formula

2) Select a larger font size under “Base Size” (top-most entry), as shown in Figure 13.

Figure 13. Edit “Base size” (top) to make a formula bigger.

The result of this change is illustrated in Figure 14.

Figure 14. Result of changing the base font size.

Formula layout

The most difficult part of using OOoMath comes when writing complicated equations. This 
section provides some advice about writing complex formulas.
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Formula layout

Brackets are your friends
OOoMath knows nothing about order of operation. You must use brackets to state order of 
operations explicitly. Consider the following example:

Markup Result

2 over  x + 1 2
x
1

2 over {x + 1} 2
x1

Equations over more than one line

Suppose you want to type an equation covering more than one line. For example:
x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter 
key, though the markup goes to a new line, the resulting equation does not. You must type the 
newline command explicitly. This is illustrated in the table below.

Markup Result

x = 3

y = 1

x=3 y=1

x = 3 newline

y = 1

x=3
y=1
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Common problem areas

Common problem areas

How do I add limits to my sum/integral?
The “sum” and “int” commands can (optionally) take in the parameters “from” and “to”. 
These are used for lower and upper limits respectively. These parameters can be used singly 
or together. Limits for integrals are usually treated as subscripts and superscripts.

Markup Result

sum from k = 1 to n a_k
∑
k=1

n

ak

int from 0 to x f(t) dt

or 

int_0^x f(t) dt

∫
0

x

f t dt  or  ∫0

x
f t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n}
∑
∞

2−n

Note For more details on integrals and sums, see the table on page 17.

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command:

Markup Result

matrix { a # b ## c # d } a b
c d

Note Rows are separated by two #’s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not “scale” with the matrix:

Markup Result

(  matrix { a # b ## c # d }  ) 
a b
c d



OOoMath provides “scalable” brackets. That is, the brackets grow in size to match the size of 
their contents. Use the commands left( and right) to make scalable brackets.
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Common problem areas

Markup Result

left(  matrix { a # b ## c # d }  right)

 a b
c d 

Tip Use left[ and right] to obtain square brackets.

How do I make a derivative?
Making derivatives essentially comes down to one trick: Tell OOo it’s a fraction.

In other words, you have to use the “over” command. Combine this with either the letter 
“d” (for a total derivative) or the “partial” command (for a partial derivative) to achieve the 
effect of a derivative.

Markup Result

{df} over {dx} df
dx

{partial f} over {partial y} ∂ f
∂ y

{partial^2 f} over {partial t^2} ∂2 f

∂ t 2

Note Notice that we had to use squiggly brackets to make the derivative.

Numbering equations
Equation numbering is one of OOoMath’s best hidden features. The steps are simple, but 
obscure:

1) Start a new line.

2) Type “fn” and then press F3.

The “fn” is replaced by a numbered formula:

E=mc2  (2)

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta 
function:

 z =∑
n=1

∞ 1

nz
 (3)
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Common problem areas

You can reference an equation (“as shown in Equation (2)”) with these steps:

1) Insert > Cross-reference.

2) Click on the References tab (Figure 15).

3) Under Type, select Text.

4) Under Selection, pick the equation number.

5) Under Format, choose Reference.

6) Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the 
equations will automatically renumber and the cross-references will update.

Figure 15. Inserting a cross-reference to an equation number.

Tip To insert the equation number without parenthesis around it, choose Numbering 
under Format instead of Reference.
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Math commands - Reference

Math commands - Reference

Unary / binary operators

Operation Command Display

+sign +1 1

–sign –1 −1

+/– sign +–1 ±1

–/+ sign –+1 ∓1

Boolean not neg a ¬a

Addition + a + b ab

Multiplication dot a cdot b a⋅b

Multiplication (X) a times b a×b

Multiplication (*) a * b a∗b

Boolean and a and b a∧b

Subtraction (–) a – b a−b

Division (fraction) a over b a
b

Division (operand) a div b a÷b

Division (slash) a / b a /b

Boolean or a or b a∨b

Concatenate a circ b a°b
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Math commands - Reference

Relational operators

Operation Command Display

Is equal a = b a=b

Is not equal a <> b a≠2

Approximately a approx 2 a≈2

Divides a divides b a∣b

Does not divide a ndivides b a∤b

Less than a < 2 a2

Greater than a > 2 a2

Similar to or equal a simeq b a≃b

Parallel a parallel b a∥b

Orthogonal to a ortho b a⊥b

Less than or equal to a leslant b ab

Greater than or equal to  a geslant b ab

Similar to a sim b a~b

Congruent a equiv b a≡b

Less than or equal to a <= b a≤b

Greater than or equal to a >= b a≥b

Proportional a prop b a∝b

Toward a toward b a b

Arrow left a dlarrow b a⇐b

Double arrow left and 
right

a dlrarrow b a⇔b

Arrow right a drarrow b a⇒b
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Math commands - Reference

Set operations

Operation Command Display

Is in a in B a∈B

Is not in a notin B a∉B

Owns A owns b A∋b

Empty set emptyset ∅

Intersection A intersection B A∩B

Union A union B A∪B

Difference A setminus B A∖B

Quotient A slash B A/B

Aleph aleph ℵ

Subset A subset B A⊂B

Subset or equal to A subseteq B A⊆B

Superset  A supset B A⊃B

Superset or equal to A supseteq B A⊇B

Not subset A nsubset B A⊄B

Not subset or equal A nsubseteq B A⊈B

Not superset A nsupset B A⊅B

Not superset or equal A nsupseteq B A⊉B

Set of natural numbers setN ℕ

Set of integers setZ ℤ

Set of rational numbers setQ ℚ

Set of real numbers setR ℝ

Set of complex numbers setC ℂ
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Math commands - Reference

Functions

Operation Command Display

Exponential func e^{a} ea

Natural logarithm ln(a) ln a

Exponential function exp(a) exp a

Logarithm log(a) log a 

Power a^{b} ab

Sine sin(a) sina

Cosine cos(a) cos a

Tangent tan(a) tana 

Cotangent cot(a) cot a

Square root sqrt{a}  a

Arcsine arcsin(a) arcsin a 

Arc cosine arccos(a) arccosa 

Arctangent arctan(a) arctan a

Arc cotangent arccot(a) arccot a

nth root nroot{a}{b} a b

Hyperbolic sine sinh(a) sinh a

Hyperbolic cosine cosh(a) cosh a 

Hyperbolic tangent tanh(a) tanha 

Hyperbolic cotangent coth(a) coth a

Absolute value abs{a} ∣a∣

Arc hyperbolic sine arsinh(a) arsinh a 

Arc hyperbolic cosine arccosh(a) arcosh a

Arc hyperbolic tangent arctanh(a) artanh a

Arc hyperbolic cotangent arccoth(a) arcoth a

Factorial fact{a} a!   
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Math commands - Reference

Operators
All operators can be used with the limit functions (“from” and “to”).

Operation Command Display

Limit lim{a} lim a

Sum sum{a} ∑ a

Product prod{a} ∏ a

Coproduct coprod{a} ∐ a

Upper and lower bounds 
shown with integral

int from {r_0} to {r_t} a
∫
r0

rt

a

Integral int{a} ∫ a

Double integral iint{a} ∬a

Triple integral iiint{a} ∭a

Lower bound shown with 
summation symbol 

sum from{3}b ∑
3

b

Contour integral lint a ∮a

Double curved integral llint a ∯a

Triple curved integral lllint a ∰a

Upper bound shown with 
product symbol

prod  to{3} r
∏

3

r
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Math commands - Reference

Attributes

Operation Command Display

Acute accent  acute a a

Grave accent grave a a

Reverse circumflex check a a

Breve breve a a

Circle circle a å

Vector arrow vec a a

Tilde tilde a a

Circumflex hat a a

Line above bar a a

Dot dot a ȧ

Wide vector arrow widevec abc abc

Wide tilde widetilde abc abc

Wide circumflex widehat abc abc

Double dot ddot a ä

Line over overline abc abc

Line under underline abc abc

Line through overstrike abc acb

Triple dot dddot a a

Transparent (useful to get a 
placeholder of a given size)

phantom a

Bold font bold a a

Italic font1 ital “a” a

Resize font size 16 qv qv
Following item in sans serif 
font2

font sans qv qv

Following item in serif font font serif qv qv

Following item in fixed font font fixed qv qv

Make color of following text 
cyan3

color cyan qv qv

1 Unquoted text that is not a command is considered to be a variable. Variables are, by default, italicized.

2 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed (non-proportional). To 
change the actual fonts used for custom fonts and the fonts used for variables (unquoted text), numbers and 
functions, use Format > Fonts.
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Math commands - Reference

Operation Command Display

Make color of following text 
yellow

color yellow qv qv

Make color of following text 
white

color white qv qv

Make color of following text 
green

color green qv qv

Make color of following text 
blue

color blue qv qv

Make color of following text 
red

color red qv qv

Make color green returns to 
default color black

color green X qv X qv

Brace items to change color 
of more than one item

color green {X qv} X qv

3 For all coloring, the color will apply only to the text immediately following the command until the next space is 
encountered. In order to have the color apply to more characters, place the text you want in color in curly 
brackets.
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Math commands - Reference

Miscellaneous

Operation Command Display

Infinity infinity ∞

Partial partial ∂

Nabla nabla ∇

There exists exists ∃

For all forall ∀

H bar hbar ℏ

Lambda bar lambdabar ƛ

Real part re ℜ

Imaginary part im ℑ

Weierstrass p wp ℘

Left arrow leftarrow 

Right arrow rightarrow 

Up arrow uparrow 

Down arrow downarrow 

Dots at bottom dotslow 

Dots at middle dotsaxis ⋯

Dots vertical dotsvert ⋮

Dots diagonal upward dotsup ⋰

Dots diagonal downward dotsdown ⋱
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Math commands - Reference

Brackets

Operation Command Display

Round Brackets (a) a

Square Brackets [b] [b]

Double Square Brackets ldbracket c rdbracket 〚c〛

Single line lline a rline ∣a∣

Double line ldline a rdline ∥a∥

Braces lbrace w rbrace {w}

Angle Brackets langle d rangle 〈d 〉

Operator Brackets langle a mline b rangle 〈a∣b〉

Group brackets (used for 
program control)

{a} a

Scalable round brackets
(add the word “left 
before a left bracket and 
“right” before a right 
bracket)

left ( stack{a # b # z} right )


a
b
z 

Square brackets scalable

(as above)

left [ stack{ x # y} right ] [ x
y ]

Double square brackets 
scalable

left ldbracket c right 
rdbracket 

〚c〛

Line scalable left lline a right rline ∣a∣

Double line scalable left ldline d right rdline ∥d∥

Brace scalable left lbrace e right rbrace {e}

Angle bracket scalable left langle f right rangle 〈 f 〉

Operator brackets 
scalable

left langle g mline h right 
rangle 

〈 g∣h 〉

Over brace scalable {The brace is above} 
overbrace a Thebraceis above

a

Under brace scalable {the brace is 
below}underbrace {f}

the braceis below
f
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Math commands - Reference

Formats

Operation Command Display

Left superscript a lsup{b} ab

Center superscript a csup{b}
a
b

Right superscript a^{b} ab

Left subscript a lsub{b} ab

Center subscript a csub{b} a
b

Right subscript a_{b} ab

Align character to left (text 
is aligned center by default) 

stack { Hello world # alignl (a) } Hello world
a

Align character to center stack{Hello world # alignc(a)} Hello world
a

Align character to right stack { Hello world # alignr(a)} Hello world
a

Vertical stack of 2 binom{a}{b} a
b

Vertical stack, more than 2 stack{a # b # z} a
b
z

Matrix stack matrix{a # b ## c # d} a b
c d

Common mathematical 
arrangement

matrix{a # "="b ## {} # "="c} a = b
= c

New line asldkfjo newline sadkfj asldkfjo
sadkfj

Small gap (grave) stuff `stuff stuff stuff

Large gap (tilde) stuff~stuff stuff stuff
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Math commands - Reference

Characters – Greek

%ALPHA A %BETA B %CHI X %DELTA  %EPSILON E

%ETA H %GAMMA  %IOTA I %KAPPA K %LAMBDA 

%MU M %NU N %OMEGA  %OMICRO
N

O %PHI 

%PI  %PSI  %RHO P %SIGMA  %THETA 

%UPSILO
N 

%XI  %ZETA Z

%alpha  %beta  %chi  %delta  %epsilon 

%eta  %gamma  %iota  %kappa  %lambda 

%mu  %nu  %omega  %omicron  %phi 

%pi  %rho  %sigma  %tau  %theta 

%upsilon


%varepsilo
n 

 %varphi  %varpi  %varrho ϱ

%varsigma  %vartheta  %xi  %zeta 

Characters – Special

%and ∧ %angle ∢ %element ∈ %identical ≡

%infinite ∞ %noelement ∉ %notequal ≠ %or ∨

%perthousand  %strictlygreaterthan ≫ %strictlylessthan ≪ %tendto 
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