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Chapter 4 
Getting Started with Calc

What Is Calc?

Calc is the spreadsheet component of Apache OpenOffice. You can enter data (usually 
numerical) in a spreadsheet and then manipulate this data to produce certain results.

Alternatively you can enter data and then use Calc in a ‘What if…’ manner by 
changing some data and observing the results without having to retype the entire 
spreadsheet

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex 
calculations on data

• Database functions, to arrange, store, and filter data

• Dynamic charts; a wide range of 2D and 3D charts

• Macros, for recording and executing repetitive tasks

• Ability to open, edit, and save Microsoft Excel spreadsheets

• Import and export of spreadsheets in multiple formats, including HTML, CSV, 
PDF, and PostScript

Spreadsheets, Sheets, and Cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of 
individual sheets, each sheet containing cells arranged in rows and columns. A 
particular cell is identified by its row number and column letter.

Cells hold the individual elements—text, numbers, formulas—that make up the data 
to display and manipulate.

Each spreadsheet can have many sheets, up to 256, and each sheet can have many 
individual cells. Each sheet can have a maximum of 1,048,576 rows and 1024 
columns.
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Parts of the Main Calc Window

When Calc is started, the main window looks similar to Figure 1.

Title Bar
The Title bar, located at the top, shows the name of the current spreadsheet. When 
the spreadsheet is newly created, its name is Untitled X, where X is a number. When 
you save a spreadsheet for the first time, you are prompted to enter a name of your 
choice.

Menu Bar
Under the Title bar is the Menu bar. (On a Mac, the Menu bar is at the top of the 
screen, above the Title bar, the same location as for other Mac applications.) When 
you choose one of the menus, a sub menu appears with other options. You can modify 
the Menu bar, as discussed in Chapter 11 (Setting up and Customizing Apache 
OpenOffice).

Figure 1: Parts of the Calc window

Toolbars
Three toolbars are located under the Menu bar by default: the Standard toolbar, the 
Formatting toolbar, and the Formula Bar.

The icons (buttons) on these toolbars provide a wide range of common commands 
and functions. You can also modify these toolbars, as discussed in Chapter 11 
(Setting Up and Customizing Apache OpenOffice).

In the Formatting toolbar, the three boxes on the left are the Apply Style, Font 
Name, and Font Size lists. They show the current setting for the selected cell or 
area. (The Apply Style list may not be visible by default.) Click the down-arrow to the 
right of each box to open the list.
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Figure 2. Apply Style, Font Name and Font Size lists 

Formula Bar
On the left-hand side of the Formula bar is a small text box, called the Name Box, 
with a letter and number combination in it, such as D7. This combination, called the 
cell reference, is the column letter and row number of the selected cell.

To the right of the Name box are the Function Wizard, Sum, and Function buttons.

Clicking the Function Wizard button opens a dialog from which you can search 
through a list of available functions This can be very useful because it also shows how 
the functions are formatted.

Figure 3. Formula Bar

In a spreadsheet the term function covers much more than just mathematical 
functions. See Chapter 7 in the Calc Guide for more details.

Clicking the Sum button inserts a formula into the current cell that totals the 
numbers in the cells above the current cell. If there are no numbers above the 
current cell, then the cells to the left are placed in the Sum formula.

Clicking the Function button inserts equals (=) sign into the selected cell and the 
Input line, thereby enabling the cell to accept a formula.

When you enter new data into a cell, the Sum and Equals buttons change to Cancel 
and Accept buttons .

The contents of the current cell (data, formula, or function) are displayed in the 
Input line, which forms the remainder of the Formula Bar. You can edit the contents 
of the current cell on the Input line or in the cell itself. To edit on the Input line, click 
in the line, then type your changes. To edit within the current cell, just double-click 
the cell.

Individual Cells
The main section of the screen displays the cells in the form of a grid, with each cell 
being at the intersection of a column and a row.

At the top of the columns and at the left end of the rows are a series of gray boxes 
containing letters and numbers. These are the column and row headers. The columns 
start at A and go on to the right, and the rows start at 1 and go down.
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These column and row headers form the cell references that appear in the Name Box 
on the Formula Bar (Figure 3). You can turn these headers off by selecting View > 
Column & Row Headers.

Sheet Tabs
At the bottom of the grid of cells is the sheet tabs. These tabs enable access to each 
individual sheet, with the visible (active) sheet having a white tab. You can choose 
colors for the different sheet tabs by right-clicking the space, choosing Tab Color, and 
choosing a color from the palette.

Clicking on another sheet tab displays that sheet, and its tab turns white. You can 
also select multiple sheet tabs at once by holding down the Ctrl key while you click 
the names.

Figure 4: Choosing a tab color

Status Bar
At the very bottom of the Calc window is the status bar, which provides information 
about the spreadsheet and convenient ways to quickly change some of its features. 
Most of the fields are similar to those in other components of Apache OpenOffice; see 
Chapter 1 (Introducing Apache OpenOffice). Right-clicking on the Cell or object 
information field brings up a menu of functions that summarize the cells selected in 
the sheet. Among the options are Sum, Average, Minimum and Maximum. See 
Selecting Cells for information about selecting multiple cells.
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Opening and Saving CSV files

Chapter 1 (Introducing Apache OpenOffice) includes instructions on starting new 
Calc documents, opening existing documents, and saving documents.
A special case for Calc is opening and saving comma-separated-values (CSV), which 
are text files that contain the cell contents of a single sheet. Each line in a CSV file 
represents a row in a spreadsheet. Commas, semicolons, or other characters are used 
to separate the cells. Text may be entered in quotation marks, numbers are entered 
without quotation marks.

Opening a CSV File
To open a CSV file in Calc:

1) Choose File > Open.
2) Locate the CSV file that you want to open.
3) If the file has a *.csv extension, select the file and click Open.
4) If the file has another extension (for example, *.txt), select the file, select Text 

CSV (*.csv;*.txt) in the File type box (scroll down into the spreadsheet 
section to find it) and then click Open.

5) On the Text Import dialog (Figure 7), select the Separator options to divide the 
text in the file into columns.
You can preview the layout of the imported data at the bottom of the dialog. 
Right-click a column in the preview to set the format or to hide the column. 
Selecting Detect special numbers allows values with formatting such as 
currency symbols and some date formats to be read correctly. They will 
otherwise be read as text, which is a common source of difficulty with 
subsequent calculations.
If the CSV file uses a text delimiting character that is not in the Text delimiter 
list, click in the Other box and type the character.

6) Click OK to open the file.
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Figure 7: Text Import dialog, with Comma (,) selected as the separator and double 
quotation mark (“) as the text delimiter.

Saving as a CSV File
To save a spreadsheet as a comma separated value (CSV) file:

1) Choose File > Save As.
2) In the File name box, type a name for the file.
3) In the File type list, select Text CSV (.csv) and click Save.

You may see the message box shown below. Click Keep Current Format.
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4) In the Export of text files dialog, select the options you want and then click 
OK. You will get a warning that only the current sheet was saved. CSV files do 
not support multiple sheets.

Figure 8: Choosing options when exporting to Text CSV

Navigating Within Spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet 
to sheet. You can generally use whatever method you prefer.

Going to a Particular Cell

Using the mouse
Place the mouse pointer over the cell and click.

Using a cell reference
Click on the little inverted black triangle just to the right of the Name Box (Figure 
3). The existing cell reference will be highlighted. Type the cell reference of the 
cell you want to go to and press Enter. Or just click into the Name box, backspace 
over the existing cell reference and type in the cell reference you want and press 
Enter.

Using the Navigator

To open the Navigator, click its icon  on the Standard toolbar, or go to the 
Navigator deck of the Sidebar, or press F5, or choose View > Navigator on the 
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Menu bar, or double-click on the Sheet Sequence Number  in the Status 
Bar. Type the cell reference into the top two fields, labeled Column and Row, and 
press Enter. In Figure 9 the Navigator would select cell A7.

You can dock the Navigator to either side of the main Calc window or leave it 
floating. (To dock or float the Navigator, hold down the Ctrl key and double-click in 
an empty area near the icons in the Navigator dialog.) If you want a docked 
Navigator, using the Sidebar is typically the easiest approach. The Sidebar is 
described in Chapter 1. Introducing Apache OpenOffice.

Figure 9: The Navigator in Calc

The Navigator displays lists of all the objects in a document, grouped into 
categories. If an indicator (plus sign or arrow) appears next to a category, at least 
one object of this kind exists. To open a category and see the list of items, click on 
the indicator.

To hide the list of categories and show only the icons at the top, click the 

Contents icon . Click this icon again to show the list.

Moving from Cell to Cell
In the spreadsheet, one cell normally has a darker black border. This black border 
indicates where the focus is (see Figure 10). If a group of cells is selected, they have 
a highlight color, with the focus cell having a dark border.

Using the mouse
To move the focus using the mouse, simply move the mouse pointer to the cell 
where you want the focus to be and click the left mouse button. This changes the 
focus to the new cell. This method is most useful when the two cells are a large 
distance apart.

Using the Tab and Enter keys
• Pressing Enter or Shift+Enter moves the focus down or up, respectively.

• Pressing Tab or Shift+Tab moves the focus to the right or to the left, 
respectively.
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Figure 10. (Left) One selected cell and (right) a group of selected 
cells

Using the arrow keys
Pressing the arrow keys on the keyboard moves the focus in the direction of the 
arrows.

Using Home, End, Page Up and Page Down
• Home moves the focus to the start of a row.

• End moves the focus to the column furthest to the right that contains data.

• Page Down moves the display down one complete screen and Page Up moves 
the display up one complete screen.

• Combinations of Ctrl and Alt with Home, End, Page Down, Page Up, and the 
cursor keys move the focus of the current cell in other ways. See the Help or 
Appendix A (Keyboard Shortcuts) in the Calc Guide for details.

Tip Use one of the four Alt+Arrow key combinations to resize a cell.

Customizing the Enter Key
You can customize the direction in which the Enter key moves the focus, by selecting 
Tools > Options > OpenOffice Calc > General.

The four choices for the direction of the Enter key are shown on the right-hand side of 
Figure 11. It can move the focus down, right, up, or left. Depending on the file being 
used or on the type of data being entered, setting a different direction can be useful.

The Enter key can also be used to switch into and out of editing mode. Use the first 
two options under Input settings in Figure 11 to change the Enter key settings.

Figure 11: Customizing the effect of the Enter key
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Moving from Sheet to Sheet
Each sheet in a spreadsheet is independent of the others, though they can be linked 
with references from one sheet to another. There are three ways to navigate between 
different sheets in a spreadsheet.

Using the Navigator
When the Navigator is open (Figure 9), double-clicking on any of the listed sheets 
selects the sheet.

Using the keyboard
Pressing Ctrl+Page Down moves one sheet to the right and pressing Ctrl+Page Up 
moves one sheet to the left.

Using the mouse
Clicking on one of the sheet tabs at the bottom of the spreadsheet selects that 
sheet.

If you have a lot of sheets, then some sheet tabs may be hidden behind the 
horizontal scroll bar at the bottom of the screen. If this is the case, then the four 
buttons at the left of the sheet tabs can move the tabs into view. Figure 12 shows 
how to do this.

Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary; 
you can name a sheet as you wish.

Note
The sheet tab arrows that appear in Figure 12 only appear if you 
have some sheet tabs that are hidden by the horizontal scrollbar. 
Otherwise, they will appear faded as in Figure 1.

Selecting Items in a Sheet or Spreadsheet

Selecting Cells
Cells can be selected in a variety of combinations and quantities.

Single cell
Left-click in the cell. The result will look like the left side of Figure 10. You can verify 
your selection by looking in the Name box.
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Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of 

the range.

The result of these methods looks like the right side of Figure 10.

To select all the occupied cells in one direction:
1) Click the first cell in the desired range.
2) Hold the Ctrl + Shift keys and press the arrow to move in the desired direction. 

The cursor will jump to the last occupied cell.

Tip

You can also directly select a range of cells using the Name box. 
Click into the Name Box as described in “Using a cell reference” on 
page 11. To select a range of cells, enter the cell reference for the 
upper left-hand cell, followed by a colon (:), and then the lower right-
hand cell reference. For example, to select the range that would go 
from A3 to C6, you would enter A3:C6.

Range of noncontiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Ctrl key and click or click-and-drag to select a range. 
4) Repeat as necessary.

Selecting Columns and Rows
Entire columns and rows can be selected very quickly in Apache OpenOffice.

Single column or row
To select a single column, click on the column identifier letter (see Figure 1).

To select a single row, click on the row identifier number.

Multiple columns or rows
To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.

Chapter 4 Getting Started with Calc | 15



To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Ctrl key.
3) Click on all the subsequent columns or rows while holding down the Ctrl key.

Entire sheet
To select the entire sheet, click on the small box between the A column header and 
the 1 row header. You can also press Ctrl+A to select the entire sheet.

Figure 13. Select All box

Selecting Sheets
You can select either one or multiple sheets. It can be advantageous to select multiple 
sheets at times when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The active sheet becomes 
white (see Figure 14).

Multiple contiguous sheets
To select multiple contiguous sheets:

1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the last desired sheet.
3) Hold down the Shift key and click on the sheet tab.

All the tabs between these two sheets will turn white. Any actions that you perform 
will now affect all highlighted sheets.

Multiple noncontiguous sheets
To select multiple noncontiguous sheets:

1) Click on the sheet tab for the first sheet.
2) Move the mouse pointer over the second sheet tab.
3) Hold down the Ctrl key and click on the sheet tab.
4) Repeat as necessary.

The selected tabs will turn white. Any actions that you perform will now affect all 
highlighted sheets.

All sheets
Right-click any one of the sheet tabs and choose Select All Sheets from the pop-up 
menu.

Working with Columns and Rows

Inserting Columns and Rows
Columns and rows can be inserted individually or in groups.
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Note

When you insert a single new column, it is inserted to the left of the 
highlighted column. When you insert a single new row, it is inserted 
above the highlighted row.

Cells in the new columns or rows are formatted like the 
corresponding cells in the column or row before (or to the left of) 
which the new column or row is inserted.

Single column or row
Using the Insert menu:

1) Select the cell, column, or row where you want the new column or row 
inserted.

2) Choose either Insert > Columns or Insert > Rows.

Using the mouse:
1) Select the cell, column, or row where you want the new column or row 

inserted.
2) Right-click the header of the column or row.
3) Choose Insert Rows or Insert Columns.

Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a 
time.

1) Highlight the required number of columns or rows by holding down the left 
mouse button on the first one and then dragging across the required number 
of identifiers.

2) Proceed as for inserting a single column or row above.

Deleting Columns and Rows
Columns and rows can be deleted individually or in groups.

Single column or row
A single column or row can only be deleted by using the mouse:

1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Columns or Delete Rows from the pop-up menu.

Multiple columns or rows
Multiple columns or rows can be deleted at once rather than deleting them one at a 
time.

1) Highlight the required number of columns or rows by holding down the left 
mouse button on the first one and then dragging across the required number 
of identifiers.

2) Proceed as for deleting a single column or row above.
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Working with Sheets

Like any other Calc element, sheets can be inserted, deleted, and renamed.

Inserting New Sheets
There are several ways to insert a new sheet. The first step for all the methods is to 
select the sheets that the new sheet will be inserted next to. Then any of the 
following options can be used.

• Choose Insert > Sheet from the menu bar.

• Right-click on the sheet tab and choose Insert Sheet.

• Click in an empty space at the end of the line of sheet tabs.

Each method will open the Insert Sheet dialog (Figure 15). Here you can select 
whether the new sheet is to go before or after the selected sheet and how many 
sheets you want to insert. If you are inserting only one sheet, there is the opportunity 
to give the sheet a name.

Figure 15. Insert Sheet dialog
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Moving and Copying Sheets
You can move or copy sheets within the same spreadsheet by using either the mouse 
(drag and drop) or a dialog. Drag and drop does not work if you wish to move or copy 
a sheet to a different spreadsheet; instead, you need to use the dialog.

Using the Mouse
To move a sheet to a different position within the same spreadsheet, click on the 
sheet tab and drag it left or right. Two little triangles indicate where the sheet will be 
dropped (see Figure 16). The mouse pointer (not shown in the illustration) may 
change to include an indicator; the indicator symbol varies with your operating 
system.

Figure 16: Dragging a sheet to move it

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on 
Mac) while you click on the sheet tab and drag it. The mouse pointer may change to 
include a plus sign or other indicator; the symbol varies with your operating system.

Using a dialog
The Move/Copy dialog provides the opportunity to specify exactly where you want the 
sheet to go (in the same or a different document), at the same time as moving or 
copying occurs.

Note When moving or copying sheets between different spreadsheets, be 
sure that both documents are open.

Follow these steps:
1) In the current document, right-click on the sheet tab you wish to move or copy.
2) Select Move/Copy Sheet from the context menu.
3) On the Move/Copy Sheet dialog (Figure 17):

• Select or deselect the Copy option at the bottom.

• To document: select the document in which you want to place the sheet. 
By default, the field will show the current document. If you have another 
spreadsheet open, its name will appear in the drop-down list along with—
new document.
Insert before: select the position within the target document.

4) When you are done, click OK.
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Figure 17: Move/Copy Sheet dialog

Caution

If you choose—new document—as the location, a new spreadsheet 
will be created. This may cause conflicts with formulas linked to 
other sheets in the previous location. If you accidentally move a 
sheet, you can fix it by moving or copying the sheet back to the 
original location.

This caution also applies to moving sheets to other existing 
documents.

Deleting SheetsSheets can be Deleted Individually or in 
Groups.

Single sheet
Right-click on the tab of the sheet you want to delete and choose Delete Sheet 
from the pop-up menu, or choose Edit > Sheet > Delete from the menu bar.

Multiple sheets
To delete multiple sheets, select them as described earlier, then either right-click 
over one of the tabs and select Delete Sheet from the pop-up menu, or choose 
Edit > Sheet > Delete from the menu bar.

Renaming Sheets

The default name for a new sheet is SheetX, where X is a number. While this works 
for a small spreadsheet with only a few sheets, it becomes awkward when there are 
many sheets.

To give a sheet a more meaningful name, you can:

• Enter the name in the Name box when you create the sheet, or

• Right-click on a sheet tab and choose Rename Sheet from the pop-up menu; 
replace the existing name with a better one.

• Double-click on a sheet tab to pop up the Rename Sheet dialog.
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Note
Sheet names must start with either a letter or a number. Apart from 
the first character of the sheet name, allowed characters are letters, 
numbers, spaces, and the underline character. Attempting to rename 
a sheet with an invalid name will produce an error message.

Viewing Calc

Using Zoom
Use the zoom function to change the view to show more or fewer cells in the window. 
For more about zoom, see Chapter 1 (Introducing Apache OpenOffice) in this book.

Freezing Rows and Columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns 
on the left of a spreadsheet or both. Then when scrolling around within the sheet, any 
frozen columns and rows remain in view.

Figure 18 shows some frozen rows and columns. The heavier horizontal line between 
rows 3 and 14 and the heavier vertical line between columns C and H denote the 
frozen areas. Rows 4 through 13 and columns D through G have been scrolled off the 
page. The first three rows and columns remained because they are frozen into place.

You can set the freeze point at a row, a column, or both a row and a column as in 
Figure 18.

Freezing single rows or columns
1) Click on the header for the row below where you want the freeze or for the 

column to the right of where you want the freeze.
2) Choose Window > Freeze.
3) A dark line appears, indicating where the freeze is put.

Freezing a row and a column
1) Click into the cell that is immediately below the row you want frozen and 

immediately to the right of the column you want frozen.
2) Choose Window > Freeze.
3) Two lines appear on the screen, a horizontal line above this cell and a vertical 

line to the left of this cell. Now as you scroll around the screen, everything 
above and to the left of these lines will remain in view.

Unfreezing
To unfreeze rows or columns, choose Window > Freeze. The check mark by 
Freeze will vanish.
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Figure 18. Frozen rows and columns

Splitting the Screen
Another way to change the view is by splitting the window, also known as splitting 
the screen. The screen can be split either horizontally or vertically or both. You can 
therefore have up to four portions of the spreadsheet in view at any one time.

Why would you want to do this? Imagine you have a large spreadsheet and one of the 
cells has a number in it which is used by three formulas in other cells. Using the split 
screen technique, you can position the cell containing the number in one section and 
each of the cells with formulas in the other sections. Then you can change the 
number in the cell and watch how it affects each of the formulas.

Figure 19. Split screen example

Splitting the Screen Horizontally
To split the screen horizontally:

1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of 
the screen, and place it over the small button at the top with the black 
triangle. Immediately above this button you will see a thick black line.
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2) Move the mouse pointer over this line, and it turns into a line with two arrows, 
as in Figure 21.

Figure 21. Split screen bar 
on vertical scroll bar with 
cursor

3) Hold down the left mouse button. A gray line appears, running across the 
page. Drag the mouse downwards and this line follows.

4) Release the mouse button and the screen splits into two views, each with its 
own vertical scroll bar. You can scroll the upper and lower parts independently.

Notice in Figure 19, the Beta and the A0 values are in the upper part of the window 
and other calculations are in the lower part. Thus, you can make changes to the Beta 
and A0 values and watch their effects on the calculations in the lower half of the 
window.

Tip
You can also split the screen using a menu command. Click in a cell 
immediately below and to the right of where you wish the screen to 
be split, and choose Window > Split.

Splitting the Screen Vertically
To split the screen vertically:

1) Move the mouse pointer into the horizontal scroll bar at the bottom of the 
screen and place it over the small button on the right with the black triangle. 
Immediately to the right of this button is a thick black line.

2) Move the mouse pointer over this line, and it turns into a line with two arrows.
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3) Hold down the left mouse button, and a gray line appears, running up the 
page. Drag the mouse to the left and this line follows.

4) Release the mouse button and the screen is split into two views, each with its 
own horizontal scroll bar. You can scroll the left and right parts of the window 
independently.

Removing Split Views
To remove a split view, do any of the following:

• Double-click on each split line.

• Click on and drag the split lines back to their places at the ends of the scroll 
bars.

• Choose Window > Split to remove all split lines at the same time.

Entering Data Using the Keyboard

Most data entry in Calc can be accomplished using the keyboard.

Entering Numbers
Click in the cell and type in the number using the number keys on either the main 
keyboard or the numeric keypad.

To enter a negative number, either type a minus (–) sign in front of it or enclose it in 
parentheses (brackets), like this: (1234).

By default, numbers are right-aligned and negative numbers have a leading minus 
symbol.

Note If a number beginning with 0 is entered in to a cell, Calc will drop the 
0 (for example 01234 becomes 1234).
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To enter a number and retain the leading 0, right-click on the cell and choose Format 
> Cells > Numbers. In the Format Cells dialog (Figure 23), under Options select the 
required number of Leading zeros.

The number selected for leading zeros needs to be one higher than the digits in a 
number. For example, if the number is 1234, the number entered for the leading zero 
will be 5.

Entering Text
Click in the cell and type the text. Text is left-aligned by default.

Entering Numbers as Text

A number can be entered as text to preserve a leading zero by entering an 
apostrophe before the number, like this: '01481.

The data is now regarded as text by Calc and displayed exactly as entered. Typically, 
formulas will treat the entry as a zero and functions will ignore it. Take care that the 
cell containing the number is not used in a formula.

Note

If “smart quotes” are used for apostrophes, the apostrophe remains 
visible in the cell.

To choose the type of apostrophe, use Tools > AutoCorrect 
Options > Localized Options. The selection of the apostrophe 
type affects both Calc and Writer.
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Entering Dates and Times
Select the cell and type the date or time. You can separate the date elements with a 
slant (/) or a hyphen (–) or use text such as 10 Oct 20. Calc recognizes a variety of 
date formats. You can separate time elements with colons such as 10:43:45. Calc may 
change the appearance of the entered value to match the current cell format. You can 
adjust the cell appearance through the menu Format > Cells. See the section 
Formatting Numbers for more details.

Deactivating Automatic Changes
Calc automatically applies many changes during data input, unless you deactivate 
those changes. You can also immediately undo any automatic changes with Ctrl+Z.

AutoCorrect changes
Automatic correction of typing errors, replacement of straight quotation marks by 
curly (custom) quotes, and starting cell content with an uppercase (capital letter) 
are controlled by Tools > AutoCorrect Options. Go to the Localized Options, 
Options, or Replace tabs to deactivate any of the features that you do not want. 
On the Replace tab, you can also delete unwanted word pairs and add new ones as 
required.

AutoInput
When you are typing in a cell, Calc automatically suggests matching input found 
in the same column. To turn the AutoInput on and off, set or remove the check 
mark in front of Tools > Cell Contents > AutoInput.

Automatic date conversion
Calc automatically converts certain entries to dates. To ensure that an entry that 
looks like a date is interpreted as text, type an apostrophe at the beginning of the 
entry. The apostrophe is not displayed in the cell. You can also set the cell format 
to Text through the menu Format > Cells, using the Numbers tab.

Speeding Up Data Entry

Entering data into a spreadsheet can be very labor-intensive, but Calc provides 
several tools for removing some drudgery from input.

The most basic ability is to drop and drag the contents of one cell to another with a 
mouse. Calc also includes several other tools for automating input, especially of 
repetitive material. They include the Fill tool, selection lists, and the ability to input 
information into multiple sheets of the same document.

Using the Fill Tool on Cells
At its simplest, the Fill tool is a way to duplicate existing content. Start by selecting 
the cell to copy, then drag the mouse in any direction (or hold down the Shift key and 
click in the last cell you want to fill), and then choose Edit > Fill and the direction in 
which you want to copy: Up, Down, Left or Right.

Caution Choices that are not available are grayed out, but you can still 
choose the opposite direction from what you intend, which could 
cause you to overwrite cells accidentally.
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Tip
A shortcut way to fill cells is to grab the “handle” in the lower right-
hand corner of the cell and drag it in the direction you want to fill. If 
the cell contains a number, the number will fill in series. If the cell 
contains text, the same text will fill in the direction you choose.

 

Using a Fill Series
A more complex use of the Fill tool is to use a fill series. The default lists are for the 
full and abbreviated days of the week and the months of the year, but you can create 
your own lists as well.

To add a fill series to a spreadsheet, select the cells to fill, choose Edit > Fill > 
Series. In the Fill Series dialog (Figure 25), select AutoFill as the Series type, and 
enter as the Start value an item from any defined series. The selected cells then fill in 
the other items on the list sequentially, repeating from the top of the list when they 
reach the end of the list. The available lists can be seen at Tools > Options > 
OpenOffice Calc > Sort Lists.

You can also use Edit > Fill > Series to create a one-time fill series for numbers by 
entering the start and end values and the increment. For example, if you entered 
start and end values of 1 and 7 with an increment of 2, you would get the sequence of 
1, 3, 5, 7. If you set a Start value but no End value, the series will fill all the selected 
cells. If you set both a Start and an End value the behavior depends on the number of 
selected cells, If there are at least enough cells selected to contain the series, the 
series will stop at the End value, possibly leaving some selected cells empty. If there 
are not enough cells selected, the series will stop at the last selected cell and not 
reach the End value.

In all these cases, the Fill tool creates only a momentary connection between the 
cells. Once they are filled, the cells have no further connection with one another.
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Figure 25: Specifying the start of a fill series (result is in Figure 26)

Defining a Fill Series
To define your own fill series:

1) Go to Tools > Options > OpenOffice Calc > Sort Lists. This dialog shows 
the previously-defined series in the Lists box on the left, and the contents of 
the highlighted list in the Entries box.

Figure 27: Predefined fill series  

2) Click New. The Entries box is cleared.
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3) Type the series for the new list in the Entries box (one entry per line). Click 
Add. The new list will now appear in the Lists box.

4) Click OK at the bottom of the dialog to save the new list.

Figure 28: Defining a new fill series

Using Selection Lists
Selection lists are available only for text, and are limited to using 
only text that has already been entered in the same column.

To use a selection list, select a blank cell and press Ctrl+D. A 
drop-down list appears of any cell in the same column that either 
has at least one text character or whose format is defined as Text. 
Click on the entry you require.

Validating Cell Contents

When creating spreadsheets for other people to use, you may want to make sure they 
enter data that is valid or appropriate for the cell. You can also use validation in your 
own work as a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but they are limited to 
predefined information. To validate new data entered by a user, select a cell and use 
Data > Validity to define the type of contents that can be entered in that cell. For 
example, a cell might require a date or a whole number, with no alphabetic 
characters or decimal points; or a cell may not be left empty. Valid values may also be 
defined by the contents of a cell range.

Depending on how validation is set up, the tool can also define the range of contents 
that can be entered and provide help messages that explain the content rules you 
have set up for the cell and what users should do when they enter invalid content. 
You can also set the cell to refuse invalid content, accept it with a warning, or start a 
macro when an error is entered.
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See Chapter 2 (Entering, Editing, and Formatting Data) in the Calc Guide for more 
information.

Editing Data

Editing data is done in much the same way as entering data. The first step is to select 
the cell containing the data to be edited.

Removing Data from a Cell
Data can be removed (deleted) from a cell in several ways.

Removing data only
The data alone can be removed from a cell without removing any of the formatting 
of the cell. Click in the cell to select it, and then press the Backspace key.

Removing data and formatting
The data and the formatting can be removed from a cell at the same time. Press 
the Delete key (or right-click and choose Delete Contents, or use Edit > Delete 
Contents) to open the Delete Contents dialog. From this dialog, the different 
aspects of the cell can be deleted. To delete everything in a cell (contents and 
format), check Delete all.

Replacing All the Data in a Cell
To remove data and insert new data, simply type over the old data. The new data will 
retain the original formatting.

Changing Part of the Data in a Cell
Sometimes it is necessary to change the contents of cell without removing all the 
contents, for example if the phrase “See Dick run” is in a cell, and it needs to be 
changed to “See Dick run fast.” It is often useful to do this without deleting the old 
cell contents first.

The process is the similar to the one described above, but you need to place the 
cursor inside the cell. You can do this in two ways.
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Using the keyboard
After selecting the appropriate cell, press the F2 key and the cursor is placed at 
the end of the cell. Then use the keyboard arrow keys to move the cursor through 
the text in the cell.

Using the mouse
Using the mouse, either double-click on the appropriate cell (to select it and place 
the cursor in it for editing), or single-click to select the cell and then move the 
mouse pointer up to the input line and click into it to place the cursor for editing.

Formatting Data

The data in Calc can be formatted in several ways. It can either be edited as part of a 
cell style so that it is automatically applied, or it can be applied manually to the cell. 
Some manual formatting can be applied using toolbar icons. The Properties tab of 
the Sidebar also contains panels for Text properties, Alignment, Cell Appearance, 
and Number Format. For more control and extra options, click the More Options 
icon at the right edge of the Sidebar panel titles or select the appropriate cell or 
cells, right-click on it, and select Format Cells. All the format options are discussed 
below.

Note

All the settings discussed in this section can also be set as a part of 
the cell style. If several cells will be formatted identically, defining a 
cell style makes it easy to keep the format consistent. See Chapter 4 
(Using Styles and Templates in Calc) in the Calc Guide for more 
information.

Formatting Multiple Lines of Text
Multiple lines of text can be entered into a single cell using automatic wrapping or 
manual line breaks. Each method is useful for different situations.

Using Automatic Wrapping
To set text to wrap at the end of the cell, right-click on the cell and select Format 
Cells (or choose Format > Cells from the menu bar, or press Ctrl+1). On the 
Alignment tab (Figure 30), under Properties, select Wrap text automatically and 
click OK. This setting is also available on the Alignment panel of the Properties 
deck of the Sidebar. The results are shown in Figure 31 alongside examples of text 
that overflows into neighboring empty cells or whose display is truncated because the 
cell does not have text wrapping turned on.
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Figure 31: Automatic text wrap

Using Manual Line Breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. This method 
does not work with the cursor in the input line. When editing text, first double-click 
the cell, then single-click at the position where you want the line break or move to 
the location using the arrow keys.

When a manual line break is entered, the cell width does not change. Figure 32 
shows the results of using two manual line breaks after the first line of text.

 Figure 32: Cell with manual line breaks

Shrinking Text to Fit the Cell
The font size of the data in a cell can automatically adjust to fit in a cell. To do this, 
select the Shrink to fit cell size option in the Format Cells dialog (Figure 30). 
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Figure 33 shows the results in the top left cell along with other cells in the default 
font size demonstrating text overflow or truncation.

Figure 33: Shrinking font size to fit cells

Formatting Numbers

Several number formats can be applied to cells by using icons on the Formatting 
toolbar. Select the cell, then click the relevant icon. Not all the icons in Figure 34 are 
visible by default. Icons can be added or removed from the toolbar as explained in the 
Customizing toolbars section of Chapter 1 (Introducing Apache OpenOffice).

For more control or to select other number formats, use the Numbers tab (Figure 35) 
of the Format Cells dialog:

• Apply any of the data types in the Category list to the data.

• Control the number of decimal places and leading zeros.

• Enter a custom format code.

The Language setting controls the local settings for the different formats such as the 
date order and the currency marker.

Note

Changing the format of a cell never changes its value. This can 
cause confusion when a value that is intended to be a number, such 
as a date, is interpreted by Calc as text. This may happen, for 
example, when data is read in from a CSV file. Text has a value of 
zero and changing the format after Calc has set the value will not 
change that value. The cell format must be changed and then the 
data reentered.
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Figure 35: Format Cells > Numbers

Formatting the Font
To quickly choose the font used in a cell, select the cell, then click the arrow next to 
the Font Name box on the Sidebar or on the Formatting toolbar and choose a font 
from the list.

Tip

To choose whether to show the font names in their font or in plain 
text, go to Tools > Options > OpenOffice > View and select or 
deselect the Show preview of fonts option in the Font Lists 
section. For more information, see Chapter 11 (Setting Up and 
Customizing Apache OpenOffice).

To choose the size of the font, click the arrow next to the 
Font Size box on the Formatting toolbar. For other 
formatting, you can use the Bold, Italic, or Underline icons.

To choose a font color, click the arrow next to the Font Color 
icon to display a color palette. Click on the required color.

(To define custom colors, use Tools > Options > 
OpenOffice > Colors. See Chapter 11.)

All the formatting options just discussed are also available in 
the Text panel of the Properties deck of the Sidebar.

To specify the language of the cell (useful because it allows 
different languages to exist in the same document and be 
spell-checked correctly), use the Font tab of the Format 
Cells dialog. Use the Font Effects tab to set other font 
characteristics. See Chapter 4 (Using Styles and Templates in Calc) of the Calc Guide 
for more information.
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Formatting the Cell Borders
To add a border to a cell (or group of selected cells) click on the Borders icon on the 
formatting toolbar, and select one of the border options displayed in the palette.

To quickly choose a line style and color for the borders of a cell, click the small 
arrows next to the Line Style and Line Color icons on the Formatting toolbar. In each 
case, a palette of choices is displayed.

Icons for the border pattern options, line style and color are also available on the Cell 
Appearance panel of the Properties deck of the Sidebar.

For more controls, including the spacing between the cell borders and the text, use 
the Borders tab of the Format Cells dialog. The same dialog can be reached through 
the More Options button in the line style list in the Sidebar. There you can also define 
a shadow. See Chapter 4 (Using Styles and Templates in Calc) of the Calc Guide for 
details.

Note

The cell border properties apply to a cell, and can only be changed if 
you are editing that cell. For example, if cell C3 has a top border 
(which would be equivalent visually to a bottom border on C2), that 
border can only be removed by selecting C3. It cannot be removed 
in C2.

Formatting the Cell Background
To quickly choose a background color for a cell, click the small arrow next to the 
Background Color icon on the Formatting toolbar or on the Cell Appearance panel 
of the Properties deck of the Sidebar. A palette of color choices, similar to the Font 
Color palette, is displayed.

(To define custom colors, use Tools > Options > OpenOffice > Colors. See Chapter 
11 for more information.)

You can also use the Background tab of the Format Cells dialog. See Chapter 4 (Using 
Styles and Templates in Calc) of the Calc Guide for details.

Auto-formatting Cells and Sheets

You can use the AutoFormat feature to quickly apply a set of cell formats to a sheet or 
a selected cell range.

1) Select the cells, including the column and row headers, that you want to 
format.

2) Choose Format > AutoFormat.
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Figure 36: Choosing an AutoFormat

Note
The AutoFormat feature can only be applied if the selected set of 
cells consists of at least 3 columns and 3 rows and includes the 
column and row headers.

3) To select which properties (number format, font, alignment, borders, pattern, 
autofit width and height) to include in an AutoFormat, click More. Select or 
deselect the required options.

4) Click OK.

If you do not see any change in color of the cell contents, choose View > Value 
Highlighting from the menu bar.

Defining a New AutoFormat
You can define a new AutoFormat that is available to all spreadsheets.

1) Format a sheet (in the style for the new AutoFormat).
2) Choose Edit > Select All.
3) Choose Format > AutoFormat. The Add button is now active.
4) Click Add.
5) In the Name box of the Add AutoFormat dialog, type a meaningful name for the 

new format.
6) Click OK to save. The new format is now available in the Format list in the 

AutoFormat dialog.

Formatting Spreadsheets Using Themes

Calc comes with a predefined set of formatting themes that you can apply to your 
spreadsheets.

It is not possible to add themes to Calc, and they cannot be modified. However, you 
can modify their styles after you apply them to a spreadsheet.
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To apply a theme to a spreadsheet:
1) Click the Choose Themes icon in the Tools toolbar. If this toolbar is not 

visible, you can show it using View > Toolbars > Tools.
2) The Theme Selection dialog appears. This dialog lists the available themes for 

the whole spreadsheet.

3) In the Theme Selection dialog, select the theme that you want to apply to the 
spreadsheet. As soon as you select a theme, some properties of the custom 
styles are applied to the open spreadsheet and are immediately visible.

4) Click OK. If you wish, you can now go to the Styles and Formatting window to 
modify specific styles. These modifications do not change the theme; they only 
change the appearance of this specific spreadsheet document.

Using Conditional Formatting

You can set up cell formats to change depending on conditions that you specify. For 
example, in a table of numbers, you can show all the values above the average in 
green and all those below the average in red. The feature is reached through Format 
> Conditional Formatting.

Conditional formatting depends upon the use of styles, and the AutoCalculate feature 
(Tools > Cell Contents > AutoCalculate) must be enabled. See Chapter 2 
(Entering, Editing, and Formatting Data) in the Calc Guide for details.

Hiding and Showing Data

When elements are hidden, they are not visible and may be hidden when printed, but 
can still be selected for copying if you select the surrounding elements. For example, 
if column B is hidden, it is copied when you select columns A and C. When you need a 
hidden element again, you can reverse the process, and show the element.

To hide or show sheets, rows, and columns, use the options on the Format menu or 
the right-click (context) menu. For example, to hide a row, first select the row, and 
then choose Format > Row > Hide (or right-click on the row header and choose 
Hide).

To hide or show selected cells, choose Format > Cells from the menu bar (or right-
click and choose Format Cells). On the Format Cells dialog, go to the Cell Protection 
tab and select either Hide all or Hide a formula.
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Figure 38: Hiding or showing cells

Outline Group Controls
If you are continually hiding and showing the same cells, you can simplify the process 
by creating outline groups, which add a set of controls for hiding and showing the 
cells in the group that are quick to use and always available.

If the contents of cells falls into a regular pattern, such as four cells followed by a 
total, then you can use Data > Group and Outline > AutoOutline to have Calc add 
outline controls based on the pattern. Otherwise, you can set outline groups manually 
by selecting the cells for grouping, then choosing Data > Group and Outline > 
Group. On the Group dialog, you can decide whether to group the selected cells by 
rows or columns.

When you close the dialog, the outline group controls are visible between either the 
row or column headers and the edges of the editing window. The controls resemble 
the tree-structure of a file-manager in appearance, and can be hidden by selecting 
Data > Outline > Hide Details. They are strictly for on screen use, and do not 
print.

The basic outline controls have plus or minus signs at the start of the group to show 
or hide the hidden cells. However, if outline groups are nested, the controls have 
numbered buttons for hiding different levels.

If you no longer need a group, place the mouse cursor in any cell in it and select 
Data > Group and Outline > Ungroup. To remove all groups on a sheet, select 
Data > Group and Outline > Remove.
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Filtering Which Cells Are Visible
A filter is a list of conditions that each entry has to meet in order to be displayed. You 
can set three types of filters from the Data > Filter sub-menu.

Automatic filters add a drop-down list to the top row of a column that contains 
commonly used filters. They are quick and convenient and are useful with text and 
with numbers, because the list includes every unique entry in the selected cells.

In addition to these unique entries, automatic filters include the option to display all 
entries, the ten highest numerical values, and all cells that are empty or not-empty, as 
well as a standard filter. The automatic filters are somewhat limited. In particular, 
they do not allow regular expressions, so you cannot use them to display cell contents 
that are similar, but not identical.

Standard filters are more complex than automatic filters. You can set as many as 
eight conditions as a filter, combining them with the operators AND, and OR. 
Standard filters are mostly useful for numbers, although a few of the conditional 
operators, such as = and < > can also be useful for text.

Other conditional operators for standard filters include options to display the largest 
or smallest values, or a percentage of them. Useful in themselves, standard filters 
take on added value when used to further refine automatic filters.

Advanced filters are structured similarly to standard filters. The differences are 
that advanced filters are not limited to eight conditions, and their criteria are not 
entered in a dialog. Instead, advanced filters are entered in a blank area of a sheet, 
then referenced by the advanced filter tool to apply them.

Sorting Records

Sorting arranges the visible cells on the sheet. In Calc, you can sort by up to three 
criteria, which are applied one after another. Sorts are handy when you are searching 
for a particular item, and become even more powerful after you have filtered data.

In addition, sorting is often useful when you add new information. When a list is long, 
it is usually easier to add new information at the bottom of the sheet, rather than 
adding rows in the proper places. After you have added information, you can then 
sort it to update the sheet.

Highlight the cells to be sorted, then select Data > Sort to open the Sort dialog (or 
click the Sort Ascending or Sort Descending toolbar buttons). Using the dialog, 
you can sort the selected cells using up to three columns, in either ascending (A-Z, 1-
9) or descending (Z-A, 9-1) order.

On the Options tab of the Sort dialog, you can choose the following options:

Case-sensitive
If two entries are otherwise identical, one with an upper case letter is placed 
before one with a lower case letter in the same position.

Range contains column labels
Does not include the column heading in the sort.

Include formats
A cell's formatting is moved with its contents. If formatting is used to distinguish 
different types of cells, then use this option.
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Copy sort results to
Sets a spreadsheet address to which to copy the sort results. If a range is 
specified that does not have the necessary number of cells, then cells are added. If 
a range contains cells that already have content, then the sort fails.

Custom sort order
Select the box, then choose one of the sort orders defined in Tools > Options > 
OpenOffice Calc > Sort Lists from the drop-down list.

Direction
Sets whether rows or columns are sorted. The default is to sort by rows.

Using Formulas and Functions

You may need more than numbers and text on your spreadsheet. Often the contents 
of one cell depend on the contents of other cells. Formulas are equations using 
numbers and variables to get a result. The variables are cell locations that hold the 
data you require for the equation.

A function is a predefined calculation entered in a cell to help you analyze or 
manipulate data. All you have to do is add the arguments, and the calculation is 
automatically made for you. Functions help you create the formulas needed to get the 
results that you are looking for.

Refer to Chapter 7 in the Calc Guide for more information.

Analyzing Data

Calc includes several tools to help you analyze the information in your spreadsheets, 
ranging from features for copying and reusing data, to creating subtotals 
automatically, to varying information to help you find the answers you need. These 
tools are divided between the Tools and Data menus.

One of the most useful of these tools is the Pivot Table. This is a tool for combining, 
comparing, and analyzing large amounts of data easily. Using the Pivot Table, you can 
view different summaries of the source data, display the details of areas of interest, 
and create reports, whether you are a beginner, an intermediate or advanced user. 
Refer to Chapter 8 in the Calc Guide for more information.

Other analysis options include:

Consolidation
Data > Consolidate provides a way to combine data from two or more ranges of 
cells into a new range while running one of several functions (such as Sum or 
Average) on the data.

Subtotals
Use Data > Subtotals to calculate subtotals for up to three columns.

Scenarios
Tools > Scenarios opens a dialog for testing “what-if” questions, such as 
different interest rates on a loan.

Goal seek
Use Tools > Goal Seek if you know the result you want, but need to discover 
what values will produce this result.
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Solver
Tools > Solver is similar to Goal Seek, but you can use more than one variable. 
The Solver is designed to minimize or maximize the result according to a set of 
rules that you define.

All of these options are further discussed in Chapter 9 in the Calc Guide.

Printing

Printing from Calc is much the same as printing from other Apache OpenOffice 
components (see Chapter 9), but some details are different, especially regarding 
preparation for printing.

Using Print Ranges
Print ranges have several uses, including printing only a specific part of the data or 
printing selected rows or columns on every page. For more about using print ranges, 
see Chapter 6 (Printing, Exporting, and E-mailing) in the Calc Guide.

Defining a Print Range
To define a new print range or modify an existing print range:

1) Highlight the range of cells that comprise the print range.
2) Choose Format > Print Ranges > Define.

The page break lines display on the screen.

Tip You can check the print range by using File > Page Preview. Calc 
will only display the cells in the print range.

Adding to the Print Range
After defining a print range, you can add more cells to it. This allows multiple, 
separate areas of the same sheet to be printed, while not printing the whole sheet. 
After you have defined a print range:

1) Highlight the range of cells to be added to the print range.
2) Choose Format > Print Ranges > Add. This adds the extra cells to the print 

range.

The page break lines no longer display on the screen.

Note The additional print range will print as a separate page, even if both 
ranges are on the same sheet.

Removing a Print Range
It may become necessary to remove a defined print range, for example if the whole 
sheet needs to be printed later.

Choose Format > Print Ranges > Remove. This removes all defined print ranges 
on the sheet. After the print range is removed, the default page break lines will 
appear on the screen.
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Editing a Print Range
At any time, you can directly edit the print range, for example to remove or resize 
part of the print range. Choose Format > Print Ranges > Edit.

Selecting the Page Order, Details, and Scale
To select the page order, details, and scale to be printed:

1) Choose Format > Page from the main menu.
2) Select the Sheet tab.
3) Make your selections, and then click OK.

Figure 40. The Sheet tab of the Page Style dialog

Page Order
When a sheet will print on more than one page (of paper) you can set the order in 
which pages print. This is especially useful in a large document; for example, 
controlling the print order can save time if you have to collate the document a certain 
way. The two available options are shown below.

Top to bottom, then 
right

Left to right, then 
down

Details
You can specify which details to print. These details include:

• Row and column headers

• Sheet grid—prints the borders of the cells as a grid
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• Comments—prints the comments defined in your spreadsheet on a separate 
page, along with the corresponding cell reference

• Objects and graphics

• Charts

• Drawing objects

• Formulas—prints the formulas contained in the cells, instead of the results

• Zero Values—prints cells with a zero value

Note
Remember that since the print detail options are a part of the page’s 
properties, they are also a part of the page style’s properties. 
Therefore, different page styles can be set up to quickly change the 
print properties of the sheets in the spreadsheet.

Scale
Use the scale features to control the number of pages the data will print on. This can 
be useful if a large amount of data needs to be printed compactly or if you want the 
text enlarged to make it easier to read.

• Reduce/Enlarge printout—scales the data in the printout either larger or 
smaller. For example if a sheet would normally print out as four pages (two 
high and two wide), a scaling of 50% would print as one page (both width and 
height are halved).

• Fit print range(s) on number of pages—defines exactly how many pages the 
printout will take up. This option will only reduce a printout, it will not enlarge 
it. To enlarge a printout, the reduce/enlarge option must be used.

• Fit print range(s) to width/height—defines how high and wide the printout will 
be, in pages.

Printing Rows or Columns on Every Page
If a sheet is printed on multiple pages, you can set up certain rows or columns to 
repeat on each printed page.

For example, if the top two rows of the sheet as well as column A need to be printed 
on all pages, do the following:

1) Choose Format > Print Ranges > Edit. On the Edit Print Ranges dialog, type 
the rows in the text entry box under Rows to repeat. For example, to repeat 
rows 1 and 2, type $1:$2. This automatically changes Rows to repeat from, –
none – to – user defined -.

2) To repeat columns, type the columns in the text entry box under Columns to 
repeat. For example, to repeat column A, type $A. In the Columns to repeat 
list, – none – changes to – user defined -.

3) Click OK.

Note You do not need to select the entire range of the rows to be 
repeated; selecting one cell in each row works.
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Figure 41: Specifying repeating rows

Page Breaks
While defining a print range can be a powerful tool, it may sometimes be necessary to 
manually adjust Calc’s printout. To do this, you can use a manual break. A manual 
break helps to ensure that your data prints properly. You can insert a horizontal page 
break above, or a vertical page break to the left of, the active cell.

Inserting a Page Break
To insert a page break:

1) Navigate to the cell where the page break will begin.
2) Select Insert > Manual Break.
3) Select Row Break or Column Break depending on your need.

The break is now set.

Row break
Selecting Row Break creates a page break above the selected cell. For example, if 
the active cell is H15, then the break is created between rows 14 and 15.

Column break
Selecting Column Break creates a page break to the left of the selected cell. For 
example, if the active cell is H15, then the break is created between columns G 
and H.

Tip
To see page break lines more easily on screen, you can change their 
color. Choose Tools > Options > OpenOffice > Appearance and 
scroll down to the Spreadsheet section.

Deleting a Page Break
To remove a page break:

1) Navigate to a cell that is next to the break you want to remove.
2) Select Edit > Delete Manual Break.
3) Select Row Break or Column Break depending on your need.

The break is now removed.
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Note

Multiple manual row and column breaks can exist on the same page. 
When you want to remove them, you have to remove each one 
individually. This may be confusing at times, because although there 
may be a column break set on the page, when you go to Edit > 
Manual Break, Column break may be grayed out.

In order to remove the break, you have to be in the cell next to the 
break. For example, if you set the column break while you are in 
H15, you can not remove it if you are in cell D15. However, you can 
remove it from any cell in column H.

Headers and Footers
Headers and footers are predefined pieces of text that are printed at the top or 
bottom of a sheet, outside the sheet area. Headers are set in the same way as footers.

Headers and footers are assigned to a page style. You can define more than one-page 
style for a spreadsheet and assign different page styles to different sheets. For more 
about page styles, see Chapter 4 (Using Styles and Templates) in the Calc Guide.

Setting a Header or Footer
To set a header or footer:

1) Navigate to the sheet that you want to set the header or footer for. Choose 
Format > Page.

2) On the Page Style dialog, select the Header (or Footer) tab. See Figure 42.
3) Select the Header on option.

Figure 42: Header dialog

From here you can also set the margins, the spacing, and height for the header or 
footer. You can check the AutoFit height box to automatically adjust the height of 
the header or footer.
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Margin
Changing the size of the left or right margin adjusts how far the header or footer 
is from the side of the page.

Spacing
Spacing affects how far above or below the sheet the header or footer will print. 
So, if spacing is set to 1.00", then there will be 1 inch between the header or 
footer and the sheet.

Height
Height affects how big the header or footer will be.

Header or Footer Appearance
To change the appearance of the header or footer, click the More button in the 
header dialog. This opens the Border/Background dialog (Figure 43).

From this dialog you can set the background and border of the header or footer. For 
more information see Chapter 4 (Using Styles and Templates) in the Calc Guide.

Figure 43: Header/Footer Border/Background

Setting the Contents of the Header or Footer
The header or footer of a Calc spreadsheet has three columns for text. Each column 
can have different contents.

To set the contents of the header or footer, click the Edit button in the header or 
footer dialog shown in Figure 42 to display the dialog shown in Figure 44.

Areas
Each area in the header or footer is independent and can have different 
information in it.
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Header
You can select from several preset choices in the Header drop-down list, or specify 
a custom header using the buttons below the area boxes. (To format a footer, the 
choices are the same.)

Figure 44: Edit contents of header or footer

Custom header
Click in the area (Left, Center, Right) that you want to customize, then use the 
buttons to add elements or change text attributes.

 Opens the Text Attributes dialog.

 Inserts the File Name field.

 Inserts the Sheet Name field.

 Inserts the current page number.

 Inserts the total number of pages.

 Inserts the Date field.

 Inserts the Time field.
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