Copyright

This document is Copyright © 2006–2008 by its contributors as listed in the section titled Authors. You can distribute it and/or modify it under the terms of the Creative Commons Attribution License, version 3 or later (http://creativecommons.org/licenses/by/3.0/).

All trademarks within this guide belong to their legitimate owners.

Authors

Agnes Belzunce  
Daniel Carrera  
Martin Fox  
Thomas Hackert  
Lin M. Hall  
Regina Henschel  
Peter Hillier-Brook  
Peter Kupfer  
Ian Laurenson  
Alexandre Martins  

Paul Miller  
Daniel Rentz  
Carol Roberts  
Iain Roberts  
Gary Schnabl  
Bernd Schukat  
Wolfgang Uhlig  
Jean Hollis Weber  
Linda Worthington

Feedback

Please direct any comments or suggestions about this document to: authors@user-faq.openoffice.org

Acknowledgments

This book has a convoluted history. It is based on an original French document written for OpenOffice.org 1.x by Michel Pinquier (translated to English by Alex Thurgood), and previous content revised by Jim Taylor. It has been heavily rewritten. It was revised for OpenOffice 2.0 and later translated into German by Wolfgang Uhlig, Thomas Hackert and Regina Henschel; the German revisions were then translated into English by Martin Fox.

This book was created entirely using OpenOffice.org, including writing, page layout, and PDF creation. Most graphics were produced using OOo Draw.

Publication date and software version

Published 10 April 2008. Based on OpenOffice.org 2.4.
Contents

Chapter 1
Introduction to Draw........................................................................................................... 1
  Introduction................................................................................................................... 2
  The Draw workplace..................................................................................................... 2
  Rulers.......................................................................................................................... 3
  Status bar.................................................................................................................... 4
  Toolbars....................................................................................................................... 6
    Floating toolbars...................................................................................................... 6
    Standard toolbar....................................................................................................... 8
    Line and Filling toolbar............................................................................................ 8
    Drawing toolbar........................................................................................................ 8
    Color bar.................................................................................................................. 8
    Options toolbar........................................................................................................ 10
  Drawing grid and guides.............................................................................................. 11
  Customizing toolbars................................................................................................... 12

Chapter 2
Drawing Basic Shapes..................................................................................................... 13
  Creating simple drawings.......................................................................................... 14
  Custom shapes........................................................................................................... 14
  Drawing basic shapes................................................................................................. 14
    Drawing a straight line............................................................................................. 15
    Drawing an arrow..................................................................................................... 16
    Drawing lines and arrows....................................................................................... 16
    Drawing a rectangle or square............................................................................... 17
    Drawing ellipses (ovals) and circles....................................................................... 17
    Adding ellipse and arc tools to the Drawing toolbar............................................. 18
  Drawing elliptical and circular arcs.......................................................................... 19
  Curves......................................................................................................................... 19
  Gluepoints and connectors (basics)........................................................................... 20
    Gluepoints............................................................................................................... 20
    Connectors................................................................................................................ 20
  Drawing geometric shapes......................................................................................... 21
    Basic shapes............................................................................................................. 22
    Symbol shapes......................................................................................................... 22
    Block arrows............................................................................................................ 23
    Flowcharts................................................................................................................ 23
    Callouts..................................................................................................................... 23
    Stars and banners................................................................................................. 24
  Adding text to objects................................................................................................. 24
  Using dynamic text frames......................................................................................... 24
Contents

Using text elements in Draw objects ..................................................................................................26

Chapter 3
Working with Objects and Object Points .........................................................................................27
Introduction ........................................................................................................................................28
Selection modes ...............................................................................................................................28
Changing the selection mode ..........................................................................................................29
Selecting objects ................................................................................................................................29
Direct selection ...............................................................................................................................29
Selection by framing .........................................................................................................................29
Selecting hidden objects ..................................................................................................................30
Arranging objects ............................................................................................................................30
Selecting several objects ..................................................................................................................30
Moving and dynamically adjusting an object’s size .........................................................................31
Dynamic movement of objects .........................................................................................................31
Dynamic size modification of objects ...............................................................................................31
Dynamic size modification of objects with the help of the Status Bar ................................................32
Modifying an arc ..................................................................................................................................33
Rotating and shearing an object ........................................................................................................33
Changing with the mouse ................................................................................................................33
Changing inclination or perspective .................................................................................................34
Setting size and position exactly ......................................................................................................35
Position and Size .............................................................................................................................35
Rotating objects ..............................................................................................................................36
Slant and corner radius ....................................................................................................................36
Editing object points ........................................................................................................................37
An alternative way to change the form of basic shapes .....................................................................38
How curves work .............................................................................................................................38
The Edit Points toolbar ....................................................................................................................39
The three kinds of tangent .................................................................................................................39
Examples ...........................................................................................................................................40

Chapter 4
Changing Object Attributes ..............................................................................................................45
Toolbars and menus ..........................................................................................................................46
Line and Filling toolbar ....................................................................................................................46
The context menu .............................................................................................................................46
Editing lines and borders ..................................................................................................................47
Common line properties ..................................................................................................................47
Drawing arrows ..................................................................................................................................48
Customizing line and arrow styles .................................................................................................49
Customizing line styles ...................................................................................................................49
Customizing arrow styles .................................................................................................................50
Editing the inside (fill) of an object .................................................................................................51
Common fill properties..................................................................................................................51
Fill with a uniform color................................................................................................................52
Fill with a gradient........................................................................................................................52
Fill with a line pattern....................................................................................................................52
Fill with an image..........................................................................................................................53
Adding a shadow...........................................................................................................................53
Advanced area fill options............................................................................................................54
Creating your own fill color...........................................................................................................54
Creating your own gradient............................................................................................................54
Creating your own hatching (line pattern).....................................................................................56
Creating your own bitmap fill..........................................................................................................57
Customizing shadows....................................................................................................................58
Adding transparency.......................................................................................................................59
Using styles....................................................................................................................................60
Creating a new style.......................................................................................................................60
Applying a style.............................................................................................................................60
Modifying a style...........................................................................................................................61
Special effects................................................................................................................................61
Rotating an object...........................................................................................................................61
Flip an object...................................................................................................................................62
Mirror copies....................................................................................................................................62
Distorting an image..........................................................................................................................63
Distort an object..............................................................................................................................63
Set in circle (perspective)..............................................................................................................63
Set to circle (slant).........................................................................................................................64
Dynamic gradients..........................................................................................................................65

Chapter 5
Combining Multiple Objects............................................................................................................67
Introduction: grouping and combining objects..............................................................................68
Grouping objects..............................................................................................................................68
Grouping by common selection.......................................................................................................68
Maintaining groups and undoing groups.........................................................................................68
Editing individual objects in a group..............................................................................................69
Nesting groups................................................................................................................................69
Combining objects..........................................................................................................................69
Merging, subtracting, or intersecting shapes...................................................................................70
Merge...............................................................................................................................................70
Subtract............................................................................................................................................71
Intersect...........................................................................................................................................71
Practical example.............................................................................................................................71
Aids for positioning objects...........................................................................................................72
Moving an object to the front or to the back....................................................................................72
Contents

Aligning objects.........................................................................................................................74
Distributing the distance and space between objects.............................................................75

Chapter 6
Editing Pictures (Raster Graphics)..........................................................................................77
Introduction.................................................................................................................................78
Importing raster and vector graphics.......................................................................................78
To link or to embed?.....................................................................................................................78
Scanning......................................................................................................................................79
Pasting from the clipboard........................................................................................................80
Dragging and dropping.............................................................................................................81
Inserting from a file....................................................................................................................81
Exporting graphics....................................................................................................................82
Exporting the entire file.............................................................................................................82
Exporting single objects...........................................................................................................82
Exporting as a vector graphic....................................................................................................83
Exporting as a raster graphic.....................................................................................................83
Modifying raster object properties..........................................................................................84
View options...............................................................................................................................84
The picture (editing) toolbar......................................................................................................85
Cropping.....................................................................................................................................87
The graphic filter toolbar...........................................................................................................88
Eyedropper.................................................................................................................................91
Practical example: Changing wrong colors to transparency......................................................92
Effect of the tolerance parameter..............................................................................................93
Color depth.................................................................................................................................93
Modifying the menu..................................................................................................................93
Reducing color depth................................................................................................................94
Conversion..................................................................................................................................95
Convert to a contoured image....................................................................................................95
Convert to a polygon................................................................................................................96
Number of colors......................................................................................................................96
Point reduction..........................................................................................................................96
Fill holes.....................................................................................................................................97
Convert to bitmap......................................................................................................................99
Print options with raster graphics..........................................................................................100

Chapter 7
Working with 3D Objects.........................................................................................................101
Creating 3D objects..................................................................................................................102
Creating 3D bodies...................................................................................................................102
Variation 1: Extrusion................................................................................................................102
Variation 2: Body rotation..........................................................................................................103
Variation 3: Using ready-made objects....................................................................................103
Tips and Tricks

Chapter 8

Splitting complex drawings on multiple layers........................................................................135
An example drawing – house plan and furniture.....................................................................136
Changing the layer of a drawing object...................................................................................138
Multi-page document................................................................................................................139
Pages area................................................................................................................................139
Contents

Chapter 9
Organization Charts, Flow Diagrams, and More.................................................................149
- Drawing an organization chart..................................................................................150
- Drawing a flow diagram.........................................................................................152
- Glue points and connectors....................................................................................153
  - The Connector toolbar.......................................................................................154
  - Drawing connectors—basics..............................................................................155
  - Editing glue points.............................................................................................156
  - Adding text to connectors..................................................................................157
  - Adjusting text to suit the connecting line..........................................................158

Chapter 10
Advanced Draw Techniques..............................................................................................161
- Drawing to scale.......................................................................................................162
  - Working with the Position and Size dialog.......................................................162
  - Setting glue points.............................................................................................164
  - Copying individual pictures to the Gallery.........................................................165
  - Drawing a logic circuit diagram using the Gallery.............................................166
- Dimensioning a drawing.........................................................................................170
  - Configuring the dimensioning style.....................................................................170
  - Dimensioning objects.........................................................................................171
  - Editing dimension lines......................................................................................172
- Working with text in Draw.......................................................................................173
  - Configuring text elements with styles..............................................................173
    - Text animation.................................................................................................173
    - Text................................................................................................................174
    - Anchoring text.................................................................................................174
    - Fitting text in frames.....................................................................................176
    - Distance from frame.....................................................................................177
  - Text frames and callouts....................................................................................178
  - Pictures and text.................................................................................................180
Contents

Fontwork Gallery........................................................................................................................................180
Writer OLE object......................................................................................................................................182
   Insert..................................................................................................................................................183
   Editing mode......................................................................................................................................183
   Object mode......................................................................................................................................184
Guide to Bézier curves.............................................................................................................................185
   Bézier curves—what are they?............................................................................................................185
   Point mode of the Bézier curve..........................................................................................................185
   Direct drawing of a Bézier curve..........................................................................................................185
   Drawing a succession of Bézier curves..............................................................................................186
   Transition points...............................................................................................................................187
   Corner points....................................................................................................................................187
   Smooth transition points...................................................................................................................187
   Symmetric transition points................................................................................................................188
   Changing point types........................................................................................................................188
   Closing the curve...............................................................................................................................188
Transformation between straight line and Bézier curve.........................................................................189
   Transform a straight segment into a Bézier curve............................................................................189
   Transform a Bézier curve into a straight segment..........................................................................189
Transform complete curves, polylines and polygons.............................................................................189
   Transform a polygon or a polyline into a curve...............................................................................189
   Transform a curve into a polygon or a polyline............................................................................189
Freehand lines.......................................................................................................................................190
Combining closed curves.......................................................................................................................190
Connecting curves...............................................................................................................................190

Index............................................................................................................................................................191
Chapter 1

Introduction to Draw

OpenOffice.org’s Vector Drawing Component
**Introduction**

Draw is a vector graphics drawing tool, although it can also perform some operations on raster graphics (pixels). It offers a series of powerful tools that enable you to quickly create a wide variety of graphical images.

Vector graphics store and display a picture as simple geometric elements (lines, circles, polygons, among others) rather than as a collection of pixels (points on the screen). This permits simpler storage and supports precise scaling of the picture elements.

Draw is fully integrated into the OpenOffice.org (OOo) suite, and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as doing a copy-and-paste. You can also work with drawings directly from within Writer or Impress, using a subset of the functions and tools from Draw.

Draw’s functionality is extensive, and even though it was not designed to rival high-end graphics applications, it possesses significantly more functionality than the drawing tools that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

The *Draw Guide* is not a course book that must be worked through from beginning to end. Rather, it is a reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some notions, such as file management or the way the OOo environment works, are mentioned only briefly, as they are covered in the *Getting Started* guide.

**The Draw workplace**

The main components of the Draw interface are shown in Figure 1.

The large area in the center of the window is where you make the drawings. You can surround the drawing area with toolbars and information areas. The number and position of the visible tools vary as a function of the task at hand or user preferences. Therefore, your setup may appear a little different. For example, many users put the main Drawing toolbar on the left-hand side of the workspace—not at the bottom, as shown here. The setup procedure is described in detail in Chapter 4 (Menus and Toolbars) in the *Getting Started* guide.

You can split drawings in Draw over several pages. Multipage drawings are used mainly for presentations. The Pages pane, on the left side of the Draw window in Figure 1 gives an overview of the pages that you create. If the Pages pane is not visible on your setup, you can enable it from the View menu (*View > Page Pane*). To easily make changes to the page order, drag and drop one or more pages.
Rulers

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they are not visible, you can enable them by selecting them from the View menu (View > Ruler).

The rulers show the size of a selected object on the page (see the gray double lines, highlighted in Figure 2). When no object is selected, they show the location of the mouse pointer, which helps to accurately position drawing objects.

You can also use the rulers to manage object handles and guide lines, making it easier to position objects.

The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse.
**Rulers**

To modify the units of measurement of the rulers (which you can define independently), right-click on the desired ruler, as illustrated for the horizontal ruler in Figure 3.

**Status bar**

The Status bar is located at the bottom of the screen (in all OOO components) and includes several Draw-specific fields, as identified in Figure 4.

The Information field shows which action is being carried out, or which object type is selected. The Position field shows different information, depending on whether objects are currently selected or not:

- When no object is selected, the left number pair shows the current position (in X,Y Cartesian coordinates) of the mouse cursor.
- While an object is being resized with the mouse, the right number pair shows the size of the object (width and height).
Status bar

Figure 4: Items on the Draw status bar

Note

The sizes are given in the current measurement unit (not to be confused with the ruler units). This unit is defined in Tools > Options > OpenOffice.org Draw > General, where you can also change the scale of the page. Another way to change the scale is to double-click on the number shown in the status bar.

- If an object is selected, the left number pair shows the X,Y coordinates of the upper-left corner, and the right number pair displays the size of the object, as seen in Figure 4. These numbers do not relate to the solid object, but to the rectangle forming the selection outline. This outline is the smallest possible rectangle that can contain the visible part or parts of the object; see also Chapter 3 (Working with Objects and Object Points).

- When an object is selected, a double-click on this field opens the Position and Size dialog, which is described in detail in Chapter 4 (Changing Object Attributes).

The percentage shown in the Zoom field gives information about the current zoom factor. A double-click or right-click on this field opens the Zoom dialog, where you can quickly change the zoom factor.

In the Indicator field, an asterisk (*) is shown whenever any change is made to the document but not yet saved to disk.

If you wish to digitally sign the document, a double-click or right-click in the Signature field brings up the signature box. Note that a document must be saved at least once before it can be signed. After it is signed, an indicator is present in this field.

The Slide field shows the page-sequence number for the current drawing page, in addition to the total number of pages that you created so far. This is useful when your drawing has a number of pages. If you select an object, the field enclosed by parentheses shows the layer in which the object resides within the drawing. In the example of Figure 4, the object is on the Layout layer of Slide 1, and there is a total number of one slide, so far.

The Template field shows which page template is being used for the current page. If you saved several slide designs, you can select one for the current page by double-clicking in this field (see Figure 5) and selecting Load after choosing a slide design.
Status bar

Figure 5: Selecting a slide (page) design

Toolbars

You can display or hide the various Draw toolbars, according to your needs. To display or hide a toolbar, click View > Toolbars. On the menu that appears, choose which toolbars you want to display.

You can also select the icons that you wish to appear on the toolbars. Some toolbars have icons that are not displayed by default, but you can choose to display them. You can also hide any icons that do appear on the toolbars, by default. To change the visible icons on any toolbar, click the arrow at the right-hand end of the toolbar and select Visible Buttons. On the list of the available icons that appears, select or deselect the icons you want to be visible. A checkmark next to an icon indicates that it is visible.

Floating toolbars

Many toolbar icons are marked with a small arrow. The arrow indicates that this icon has additional functions. Click the arrow, and a submenu or floating toolbar appears, showing its additional functions (see Figure 6).

You may wish to keep this submenu displayed on your screen, but in a different position. You can make a submenu into a floating toolbar. To do so, click the area at the top of the submenu, drag it across the screen to a location you want, and then release the mouse button. Floating toolbars can be redocked on an edge of the screen or within one of the existing toolbar areas at the top of the screen, as described in Chapter 4 (Changing Object Attributes).

An icon marked with a small arrow can often become a floating toolbar. The floating-toolbar capability is common to all components of OOo.
Toolbars

Figure 6: An arrow next to an icon indicates additional functions.

**Tip**  
If you double-click on an icon on a floating toolbar, the command corresponding to that icon will run. You can then repeat this action as often as you like. To exit from this mode, press the *Esc* key or click on another icon (for example).

**Note**  
The icon of a floating toolbar always shows the last command you used. This means that the icon you see on your screen may differ from any icon shown in this Guide.

Similarly, click on the arrow on the title bar of a floating toolbar to display additional functions (see Figure 7).

Figure 7: An arrow on a floating toolbar indicates that there are additional functions available.

In Draw, as in all OOo components, a toolbar can move to a new position by using the mouse. Hover the mouse over the end of the toolbar (look for two vertical columns of dots) until the cursor becomes two crossed arrows and then drag-and-drop, as desired.

The tools available in the various toolbars are explained in the following sections.
Toolbars

**Standard toolbar**

The Standard toolbar is the same for all OOO components and is not described in detail here.

![Standard toolbar](image)

*Figure 8: Standard toolbar*

**Line and Filling toolbar**

The Line and Filling toolbar (Figure 9) lets you modify the main properties of a drawing object: the icons and pulldown lists vary, according to the type of object selected. For example, to change the thickness of a line with the spinner, hover the mouse over the spinner and click the up or down arrow to achieve the desired thickness.

![Line and Filling toolbar](image)

*Figure 9: Line and Filling toolbar*

In the example above, the available functions enable you to change the color, style, and width of the line drawn or the fill color, style, and other properties of an object. The object must first be selected with a mouse click. If the selected object is a text frame, the buttons for line style and fill color are changed to **Invisible**.

When text is selected, the Line and Filling toolbar changes to the Text Formatting toolbar (Figure 10), which is very similar to the Formatting toolbar in Writer. A more detailed explanation of the buttons on this toolbar can be found in Chapter 4 (Changing Object Attributes).

![Text Formatting toolbar](image)

*Figure 10: Text Formatting toolbar*

**Drawing toolbar**

The Drawing toolbar (Figure 11) is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes and for organizing them on the page. It is described in detail in Chapter 2 (Drawing Basic Shapes).

![Drawing toolbar](image)

*Figure 11: Drawing toolbar*

**Color bar**

To display the Color bar (Figure 12), use **View > Toolbars > Color Bar**. The toolbar then appears at the bottom of the workspace and displays the current color palette.

![Color bar](image)

*Figure 12: Color bar*

This toolbar lets you rapidly choose the color of the various objects (lines, areas, and 3D effects) in your drawing. The first box in the panel corresponds to transparency (no color).
You can access several specialized color palettes in Draw, as well as change individual colors to your own taste. This is done using the Area dialog, reached by choosing **Format > Area**, as shown in Figure 13, or the *pouring can* icon on the Line and Filling toolbar (Figure 9).

![Figure 13: Two ways to display the Area dialog](image)

On the Area dialog, choose the tab marked **Colors** (Figure 14).

To load another palette, click on the **Load Color List** button (circled). The file selector dialog asks you to choose one of the standard OOo palettes (files bearing the file extension *.*.soc). For example, `web.soc` is a color palette that is particularly adapted to creating drawings that are going to appear in Web pages. The colors will correctly display on workstations with screens displaying at least 256 colors.

A more detailed description of color palettes and their options can be found in Chapter 8 (Tips and Tricks).
Toolbars

Figure 14. Changing the color palette

Options toolbar

The Options toolbar lets you activate or deactivate various drawing aids. The Options Bar is not one of the toolbars displayed by default. To display it, select View > Toolbars > Options.

Figure 15: Options toolbar

The most important options to learn when starting to work in Draw are enclosed in red above. Their functions are described in the table below. The other buttons are described in greater detail in other chapters of the Draw Guide.
### Table 1: Functions on the Options toolbar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rotation Mode after Clicking Object</td>
<td>Display (or hide the) Grid</td>
</tr>
<tr>
<td>Display (or hide the) Guides</td>
<td>Display (or hide Guides) When Moving</td>
</tr>
<tr>
<td>Snap to Grid</td>
<td>Snap to Guides</td>
</tr>
<tr>
<td>Snap to Page Margins</td>
<td>Snap to Object Borders</td>
</tr>
<tr>
<td>Snap to Object Points</td>
<td>Allow Quick Editing</td>
</tr>
<tr>
<td>Select Text Area Only</td>
<td>Double-click to edit Text</td>
</tr>
<tr>
<td>Simple Handles</td>
<td>Large Handles</td>
</tr>
<tr>
<td>Create Object with Attributes</td>
<td>Contour Mode</td>
</tr>
<tr>
<td>Picture Placeholders</td>
<td>Text Placeholders</td>
</tr>
<tr>
<td>Contour Mode</td>
<td>Line Contour Only</td>
</tr>
<tr>
<td>Exit All Groups</td>
<td></td>
</tr>
</tbody>
</table>

### Drawing grid and guides

Draw offers a grid as a drawing aid. The grid can be turned on or off by clicking on the **Grid** icon on the Options toolbar. The points of the grid displayed on the screen are not shown on the printed drawing. The color, spacing, and resolution of the grid points can be individually chosen for each axis. This is described in more detail in Chapter 8 (in the section titled “Configuring the grid”).
Guides are special “helper lines” that can be turned on or off by clicking on the Guides icon on the Options toolbar. Draw offers a “Snap” function\(^1\), with which you can place drawings exactly on these guides. All snap functions are described in detail in Chapter 8.

Showing the position of the object while moving it makes positioning the object much easier. If this function is activated, pairs of vertical and horizontal lines enclosing the object are shown while moving the object. These lines extend to the edges of the drawing area. This function is also described in detail in Chapter 8.

**Customizing toolbars**

For greater control, you can add other functions to a toolbar and move tools between toolbars. To do this, in the View > Toolbars menu select Customize, select the Toolbars tab (see Figure 16), select the toolbar you want to change, and then select the desired buttons for that toolbar. Each toolbar has a different list of buttons.

---

\(^1\) Drawing objects can be snapped—that is, they can be attached to a grid point, a guide, a page margin, or a border or point of another object.
Chapter 2

Drawing Basic Shapes
Creating simple drawings

You can create 2D and 3D objects in Draw. In this chapter, we restrict ourselves to producing 2D drawing objects. The following chapters describe how to work with and edit such objects.

This chapter describes how to draw simple shapes. All shapes, whether they are simple lines, rectangles, or more complicated shapes, are called objects. This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar. Figure 22 shows the standard form of the toolbar, as installed with Draw. You can configure any and all the toolbars to your own needs and add, move, hide, or delete toolbar icons as you wish.

The Drawing toolbar is normally located at the bottom of the window. If you do not see it, activate it from the View > Toolbars menu. As in all OpenOffice.org (OOo) components, you can place the toolbar on the Draw window wherever you wish.

Custom shapes

Draw version 2 offers the ability to create custom shapes. These correspond to autoshapes in Microsoft Office. The shape elements used in version 1 of Draw are still available, but you are encouraged to use custom shapes instead because current and future development of Draw is focused on these, rather than shape elements.

The two types of shapes differ in their properties and are dealt with separately in the relevant chapter of this guide. The main differences relate to the behavior of 3D objects and text handling. Beginners can safely ignore both for the present.

Text frames in Draw version 2 have their own geometric format.

Drawing basic shapes

Basic shapes include:

- Lines
- Arrows
- Rectangles and squares
- Ellipses and circles
- Curves and polygons
- Connectors
- Lines and arrows
When you draw a basic shape or select one for editing, the Info field in the status bar changes to reflect the action taken: Line created, Text frame xxyy selected, and so on.

Figure 18 shows part of the Drawing toolbar with the icons needed in the following sections. The Text icon is also included.

**Drawing a straight line**

We begin with the drawing of the simplest element—a straight line.

Click on the Line icon on the Drawing toolbar and place the mouse pointer at the point where you want to start the line (see Figure 19). Drag the mouse while keeping the mouse button pressed. Release the mouse button at the point where you want to end the line.

A blue or green selection handle appears at each end of the line, showing that this is the currently selected object. The colors depend on the standard selection mode—green with a normal selection or blue if you are in the point edit mode (this effect is easily apparent if on the Options toolbar both Simple Handles and Large Handles are switched on).

Holding down the Shift key while you draw a line restricts the angle of the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

Keeping the Ctrl key pressed while drawing a line enables the end of the line to snap to the nearest grid point.

The effect of the Ctrl key depends on the settings of the Snap to Grid option on the View->Grid menu:

- **Snap to Grid on**: Ctrl deactivates the snap option for this activity.
- **Snap to Grid off**: Ctrl activates the snap option for this activity.

The spacing (resolution) of the grid points can be adjusted under Tools > Options > OpenOffice.org-Draw > Grid. See also Chapter 8 (Tips and Tricks).
Drawing basic shapes

Holding down the *Alt* key while drawing a line results in the line extending outwards symmetrically from the start point. (The line will extend out equally each side of the starting point). This lets you draw lines by starting from the middle of the line.

The line just drawn has all the standard attributes, such as color and line style. To change any of these line properties, select the line by clicking on it, then right-click and select **Line**.

While you are working with a line (or other elements), you can look at the information field on the status bar to monitor the activity or status. A description of the current activity or status of the selection is shown when you are working with an element or elements. See Figure 20 for two examples.

![Figure 20: The information area in the status bar](image)

**Drawing an arrow**

Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines: Lines with arrowheads. They are shown in the information field on the status bar only as lines. Click on the **Line Ends with Arrow** icon to draw an arrow.

**Drawing lines and arrows**

Click on the small black triangle on the **Lines and Arrows** icon to open a floating toolbar with ten tools for drawing lines and arrows (Figure 21). Alternatively, you can click directly on the symbol to repeat the last-used command chosen from this toolbar. In both cases, the last-used command will be stored on the toolbar to make it quicker to call it up again.

![Figure 21: Lines and Arrows toolbar](image)
### Drawing a rectangle or square

Drawing a rectangle is similar to drawing a straight line, except that you click on the **Rectangle** icon on the **Drawing** toolbar, and the (imaginary) line drawn by the mouse corresponds to a diagonal of the rectangle. In addition, you will see the outline of the future rectangle change in shape as you drag the mouse around. The outline is shown as a dashed line until you release the mouse button, when the rectangle is drawn.

![Figure 22: Drawing a rectangle](image)

Draw considers squares to be rectangles with equal length sides. Hold down the **Shift** key to draw a square. Hold down the **Alt** key while dragging with the mouse to create a rectangle with its center (rather than a corner) at the start point.

### Drawing ellipses (ovals) and circles

To draw an ellipse (also called an oval) or a circle, click on the **Ellipse** icon on the main **Drawing** toolbar. (A circle is simply an ellipse with both axes the same length.) The ellipse drawn is the largest ellipse that fits within the (imaginary) rectangle drawn by the mouse (Figure 23).

![Figure 23: Drawing an ellipse](image)

There are three ways to draw an ellipse or a circle:

- Holding down the **Shift** key while dragging with the mouse draws a circle.
- Holding down the **Alt** key (together with the **Shift** key) draws a symmetrical ellipse (a circle) with the center point as the starting point.
- Holding down the **Ctrl** key while dragging with the mouse draws an ellipse or circle that snaps to the nearest grid points.
Note If you first press and hold the Ctrl key down and then click on one of the icons for Line, Rectangle, Ellipse or Text, a “standard” sized object is drawn automatically in the work area—the size, shape, and color are all standard values. These attributes can be changed later, if desired.

Adding ellipse and arc tools to the Drawing toolbar

In previous versions of Draw, a long-click on the ellipse button opened a new toolbar that contained tools for drawing elliptical and circular arcs. This function is not directly available in Version 2.

If you really need this tool, you can add an Ellipse toolbar to the Drawing toolbar:

1) Click on the arrow on the right-hand end of the Drawing toolbar and select Customize Toolbar.

2) On the Toolbars page of the Customize dialog, select Drawing in the Toolbar field and click Add.

3) In the Add Commands dialog (Figure 24), select Drawing in the Category drop-down menu, select the second Ellipse command in the Commands drop-down menu, and then drag that Ellipse icon from that Commands drop-down menu to the Commands drop-down menu in the Customize dialog. Click Close.

4) On the Customize dialog, select the checkbox to enable the new Ellipse command and use the arrow buttons to move it to the desired position on the toolbar.

5) If you wish, you can now remove the simple Ellipse icon from the Drawing toolbar by deselecting it.

6) Click OK to complete the process.

You should now see another Ellipse icon on the Drawing toolbar. If you use this icon instead of the standard Ellipse icon on the Drawing toolbar, all the extended ellipse functions (from Version 1) are available. Clicking on the black arrow by the icon opens the floating Circles and Ovals toolbar (Figure 25).

Figure 24: Adding the extended Ellipse toolbar

Figure 25: Circles and Ovals toolbar
**Drawing elliptical and circular arcs**

To draw an arc, choose the appropriate **Arc** symbol. Drag with the mouse to create the circle or ellipse.

Release the mouse button and move the cursor to the position where you want the arc to start. In the status bar, you can measure the actual angle in degrees. Single-click this point; the circle (or ellipse) disappears and moving the mouse creates the arc. Again, the status bar shows the current angle.

When you have drawn the arc to the length you want, click once more. The drawing of the arc is complete.

**Curves**

The tools for drawing curves or polygons are on the toolbar that appears when you click the **Curve** icon on the Drawing toolbar. This toolbar contains eight tools (Figure 26).

---

**Note**

Up to version 2.3 of Draw, hovering the mouse over this icon gives a tooltip of **Curve**. If you convert the icon to a floating toolbar, however, the title is **Lines**, as shown in Figure 26. This is rather confusing but is expected to be corrected in a future version.

---

![Floating Curves toolbar](image)

*Figure 26: Floating Curves toolbar (incorrectly titled “Lines”)*

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the function. For a more detailed description of the handling of Bézier curves (curves and filled curves), see Chapter 10 (Advanced Draw Techniques).

- **Polygons**: Draw the first line from the start point with the left mouse button held down. As soon as you release the mouse button, a first corner point is drawn, and you can move the mouse to see how the second line will look. Every mouse click sets another corner point. A double-click ends the drawing. A filled polygon automatically joins the last point to the first point to close off the figure and fills it with the current standard fill color. A polygon without filling will not be closed at the end of the drawing.
Drawing basic shapes

- **Polygon 45°**: Just as with ordinary polygons, these will be formed from lines but with angles of 45 or 90 degrees between them.

- **Freeform Line**: With this tool you can draw just like with a pencil. Press and hold the left mouse button and move the mouse. It is not necessary to end the drawing with a double-click. Just release the mouse button and the drawing is completed. If you have selected *Freeform Line, Filled*, the end point is joined automatically to the start point and the object is filled with the appropriate color.

## Gluepoints and connectors (basics)

### Gluepoints

All Draw objects have associated invisible gluepoints. Most objects have four gluepoints, as shown in Figure 27.

![Figure 27: Four gluepoints](image)

**Note**  
Gluepoints are not the same as the little blue or green “handles” of an object. The handles are for moving or changing the shape of an object, as described in Chapter 3 (Working with Objects and Object Points), but the gluepoints are used to “glue” a connector to an object.

You can add more gluepoints, and customize gluepoints, using the toolbar of the same name (Figure 28). Gluepoints become visible when you click the Gluepoints icon on the Drawing toolbar and then move the end of a connector over the object. For a more detailed description of the use of gluepoints, see Chapter 9 (Organization Charts, Flow Diagrams, and More).

![Figure 28: Gluepoints toolbar](image)

### Connectors

Connectors are lines or arrows whose ends automatically dock to a gluepoint of an object. Connectors are especially useful in drawing organization charts, flow diagrams, and mindmaps. Even when objects are moved or reordered, the connectors remain attached.

Figure 29 shows two Draw objects and a connector.
Gluepoints and connectors (basics)

Draw offers a range of different connectors and connector functions. Open the floating Connectors toolbar by clicking on the Connector icon "Connector" (Figure 30).

For a more detailed description of the use of connectors, see Chapter 9 (Organization Charts, Flow Diagrams, and More).

**Figure 29: A connector between two objects**

**Figure 30: The Connector toolbar**

For a more detailed description of the use of connectors, see Chapter 9 (Organization Charts, Flow Diagrams, and More).

**Drawing geometric shapes**

Geometric shapes include:

- Basic shapes
- Symbol shapes
- Block arrows
- Flowcharts
- Callouts
- Stars

**Note** Independent of which type of geometric shape you draw or select for editing, the information field in the toolbar shows always only *Create Shape* or *Shape selected.*
Figure 31 shows part of the Drawing toolbar with the icons necessary for the following sections. They open floating toolbars with the relevant work tools.

![Figure 31: Part of the main Drawing toolbar](image)

**Tip** The use of all these tools is similar to that of the Rectangle tool, even though they produce different geometric shapes.

### Basic shapes

The **Basic Shapes** icon makes available the range of tools for drawing basic shapes (Figure 32).

If you choose the rectangle tool from this toolbar, it looks the same as a rectangle drawn using the Rectangle tool on the Drawing toolbar. The only differences you will see are in the information field in the status bar.

![Figure 32: Basic shapes toolbar](image)

### Symbol shapes

The **Symbol Shapes** icon brings you to an array of tools for drawing the various symbol shapes (Figure 33).

![Figure 33: Symbol Shapes toolbar](image)
Block arrows

The Block Arrows icon opens the Block Arrows toolbar (Figure 34).

![Block Arrows](image)

Figure 34: Block Arrows

Flowcharts

The tools for drawing flowcharts are accessed by clicking on the Flowcharts icon (Figure 35).

The creation of flowcharts, organization charts, and similar planning tools are described in Chapter 9 (Organization Charts, Flow Diagrams, and More).

![Flowchart](image)

Figure 35: Flowchart

Callouts

With the Callouts icon, you can open the Callouts toolbar (Figure 36).

![Callouts](image)

Figure 36: Callouts

**Note** These new callouts replace the older ones in Version 1. If you still need the older ones, you can add them manually to this or another toolbar.
**Drawing geometric shapes**

**Stars and banners**

These tools are associated with the **Stars** icon 🌟.

You can add text to all these shapes. See “Using text elements in Draw objects” on page 26.

![Figure 37: Stars and Banners](image)

**Adding text to objects**

Draw offers two ways to add text to a drawing: in a dynamic text frame as an independent Draw object or as text in a previously drawn object. In the latter case, the text is integrated with the object.

**Using dynamic text frames**

The text tool is activated by clicking on the **Text** icon T for horizontal text or the **Vertical Text** icon for vertical script (to be able use this latter option, you must activate support for Asian languages under **Tools > Options > Language Settings > Languages**).

Text frames can be moved and rotated like all draw objects. For more details on text input, see Chapter 10 (Advanced Draw Techniques).

- After activating Text command mode, click at the location where you want to position the text. A small text frame appears. It contains only the cursor. You can move the frame, if desired. The Text Formatting toolbar appears (Figure 38), and you can choose the font type, font size, and other text properties and begin to type in your text.

![Figure 38: Text Formatting toolbar](image)
The text frame grows with the text. You can insert a line break with the \textit{Shift+Enter} key combination. The \textit{Enter} key begins a new paragraph. Neither line breaks nor new paragraphs terminate the text frame.

\begin{figure}
\centering
\includegraphics[width=\textwidth]{figures/dynamic_text_frame.png}
\caption{Text input in a dynamic text frame}
\end{figure}

Observe the information field in the status bar: it shows that you are editing text and also provides details about the current cursor location—paragraph, line, and column numbers.

Text properties can also be changed during text input. Any changes will be reflected from the cursor position onwards (Figure 40).

\begin{figure}
\centering
\includegraphics[width=\textwidth]{figures/text_properties_change.png}
\caption{Changing text properties}
\end{figure}

After choosing the \textbf{Text} icon, you can also draw a frame with the mouse to contain future text. Line breaks are inserted automatically at the right edge of the frame when the text fills the frame width (Figure 41). You can, however—just like when editing other text—insert your own line breaks, begin new paragraphs, or change any of the text properties.

\begin{figure}
\centering
\includegraphics[width=\textwidth]{figures/fixed_text_frame.png}
\caption{Text input in a fixed frame – the text wraps automatically}
\end{figure}
Using text elements in Draw objects

A text element is associated with most Draw objects. By means of these elements, text can be added to an object (see Figure 39).

The exceptions to this are control elements like buttons or list boxes, as well as 3D scenes and their associated elements and groups.

If the Double-click to edit Text icon on the Options toolbar is active, you can start editing an object by double-clicking on it (or by pressing F2). In the middle of the Draw object, a black bar indicates the text cursor; start typing to input text. The status bar shows at the lower left “Text Edit” and the position of the cursor within the text.

Text can contain paragraphs, and these can be in the form of bulleted or numbered lists. For a new line without beginning a new paragraph, use (as in text documents) the key combination Shift+Enter. To end the text input, click next to the object or press the Esc key.

![Figure 42: Adding text to objects](image)
Chapter 3
Working with Objects and Object Points
Introduction

This chapter looks at the tools and functions that let you modify existing drawings. All of the functions apply to the selected object or group of objects. The selected object or group can be distinguished from others by small colored squares or circles located around the object (this is also true when several objects are selected simultaneously). These points are called handles.

The handles form a rectangular frame that is just big enough to contain the object. Where several objects are selected, the frame around them corresponds to the smallest rectangle that can contain all of the objects. This frame is called the selection rectangle.

If the Options bar is displayed (select View > Toolbars > Options to turn it on, if it is not displayed), you can change the size of the handles using two buttons: Simple Handles shows the handles as flat squares, and Large Handles shows the handles in a larger size. You can combine the effects obtained by pressing on both buttons and thus have large handles having a 3D shape or small handles having no 3D shape, whichever suits your needs or preferences. The figure below shows the location of the handles and other buttons.

![Figure 43: Location of handles on the Options toolbar](image)

Selection modes

There are three selection modes:

1) Moving and changing size
2) Editing
3) Rotating points

To set the default mode (1 or 2) for selecting objects, click on the Points button on the Drawing toolbar.

In standard mode (when you begin a new drawing), the Points button is not active, and the default mode is for selections to be moved or changed in size; these selections are indicated by small green squares.

![Selection in standard mode](image)

When the Points button is active, the default mode is for selections to be edited; these selections are indicated by blue squares. Some objects will have one or more extra handles, which are larger or colored differently. This is explained in more detail in “Editing object points” on page 37.
Selections for rotating objects are indicated by small red circles and a symbol representing the center of rotation. To choose these selections, click on the **Effects** drop-down button from the **Drawing** toolbar and after that on the object.

### Changing the selection mode

To go from one mode to another, you can do one of the following:

1. Choose the **Points** button from the **Drawing** toolbar to switch from simple selection mode to Points mode. You can also use the keyboard shortcut F8 (Points).

2. Choose the **Effects** drop-down button from the **Drawing** Toolbar to activate the Rotation mode for a selected object. To exit Rotation mode, click on the **Selection** icon.

If you often work in Rotation mode, you can choose the **Rotation Mode after Clicking Object** button from the **Options** bar and cycle through normal and rotation modes just by clicking on the object. This can be more convenient than repeatedly clicking the selected object, then clicking the **Rotate** button from the **Drawing** toolbar.

### Selecting objects

**Direct selection**

To select an object, the easiest way is to click directly on it. For objects that are not filled, you have to click directly on the object’s outline to select it.

**Selection by framing**

You can select several objects at once by using the mouse to drag a large rectangle around the objects with the **Select** button, as shown. For this to work, the icon on the Drawing toolbar must be active.

Only objects that lie entirely within the rectangle will be selected.
**Selecting hidden objects**

Even if objects are located behind others and not visible, they can still be selected. To select an object that is covered by another object, hold down the *Alt* key and click the object. To select an object that is covered by several objects, hold down the *Alt* key and click through the objects until you reach the required underlying object. To cycle through the objects in reverse order, hold down the *Alt+Shift* keys when you click. To help in making accurate selections, you can check the number and type of the selected objects, shown at the left of the status bar.

**Note**

There may be some variation in the use of the *Alt* key on different operating systems. In general the *Alt* key on a Windows computer functions as described above, but on a Linux system it usually does not. If the *Alt* key on your system does not operate as described above, use the *Tab* key method described below.

To select an object that is covered by another object using the keyboard, use the *Tab* key to cycle through the objects, stopping at the object you wish to select. To cycle through the objects in reverse order, press *Shift+Tab*. This is a very quick way to reach the object you want, but it may not be practical if you have a large number of objects in your drawing.

When you click on the selected object, its outline will appear briefly through the objects on top of the selected object.

In the illustration below, the square located beneath the circle was selected in this way (the circle was made semi-transparent in order to see the square).

![Figure 44: Selecting a covered object](image)

**Arranging objects**

In a complex drawing, you may have objects stacked up, one on top of the other, with the result that a particular object is hidden by one or more other objects above it. You can rearrange the stacking order of objects (move an object to the front or to the back of the stack) by selecting the object, clicking *Modify > Arrange* and selecting the appropriate *Bring Forward* or *Send Backward* option, or by right-clicking the object and selecting *Arrange* from the context menu, then selecting from the list of *Bring Forward* or *Send Backward* options.

On the Drawing toolbar, the Arrange tear-off menu on the button contains the above options. A keyboard shortcut is *Shift+Ctrl++* to bring an object to the top, and *Shift+Ctrl+-* to send an object to the bottom.

An exception to the above is an object which is located on the Controls layer. Such objects always lie above all other objects and are located within a separate stack on the Controls layer.

**Selecting several objects**

To select or deselect several objects one by one, hold down the *Shift* key and click on the various objects to be selected or deselected. One click on an object selects it; a second click deselects it.
Moving and dynamically adjusting an object’s size

There are several ways of moving or changing the size of an object. The method described here is called dynamic—in the sense that it is carried out using the mouse.

When you dynamically change an object, remember to check the right-hand area of the Status Bar at the bottom of your screen. This shows detailed information about the ongoing manipulation. For example, during a resizing manipulation, the following information is displayed.

The Information field (not shown in Figure 45) shows which object is selected; the (current) position—X/Y coordinates, and object dimensions—width x height, of the object being moved are shown. The information displayed changes as the mouse is moved. The units of measurement displayed are those selected under Tools > Options > OpenOffice.org Draw > General.

![Status Bar during dynamic adjustment](image)

**Figure 45: Status Bar during dynamic adjustment**

### Dynamic movement of objects

To move an object, select it and then click within the object’s border and hold down the left mouse button while moving the mouse. During movement, the shape of the object appears as dotted lines to help with repositioning.

![Moving an object](image)

**Figure 46: Moving an object**

To drop the object at its new location, release the mouse button. The new position appears immediately in the Status Bar.

### Dynamic size modification of objects

To change the size of a selected object (or a group of selected objects) with the mouse, you need to move one of the handles located around the selection. As shown in the following illustration, the outline of the resulting new object appears as a dotted line while the mouse button is pressed.

![Changing the size of a selected object](image)

**Figure 47: Changing the size of a selected object**
Moving and dynamically adjusting an object’s size

The results will differ depending on which handle you use. If you choose a corner handle (as shown in the figure above), you will resize the object along two axes at the same time. If you use a side handle, the objects will only be resized along one axis. The new size will appear immediately in the Status Bar.

**Note** If you press the *Shift* key at the same time as you carry out the resizing operation, the increase or decrease in size will be carried out symmetrically with respect to the two axes, which enables you to keep the same height/length aspect ratio of the object.

**Dynamic size modification of objects with the help of the Status Bar**

If you select an object and modify it using the mouse, the changes are immediately reflected in the Information field of the Status Bar. With geometric *shapes* (such as Basic Shapes, Symbol Shapes, Block Arrows), the only information shown in the Status Bar is that the shape is being resized, as shown in the top-left image in Figure 48. With geometric *elements* (rectangles, circles, and so on), the changes to the attributes of the element (either relative or absolute) are also shown, as in the top-right image in Figure 48.

In the case of a rectangle, the relative percentage of the x and y dimensions of the original shape are shown. For a line, much more information is given: the absolute change in x,y coordinates of the end point being moved, together with the current length and bearing of the modified line. These are all given in the Status Bar and updated dynamically as the end point is moved (see Figure 48).

This information can be very useful. It is the only place in which one can see the exact start and end angle locations of an arc, or where the length and bearing of a sloping line are shown. With this information you can size the object with considerable accuracy.

*Figure 48: The Information field during dynamic size modification of objects*
Modifying an arc

The beginning and end points of an arc can be modified. Select the arc and click on the Points icon on the Drawing toolbar to enter the Edit points mode. In this mode, the handles on the selection frame change—two larger blue handles appear at the beginning and end points of the arc. When the mouse hovers over one of these points the cursor will change to a hand.

If you click and hold the mouse button when the hand cursor appears, moving the mouse will change the location of the start or end point of the arc. The actual coordinates are shown in the Status Bar.

Rotating and shearing an object

Changing with the mouse

Rotating an object lets you slant the object along an axis. To do this dynamically, use the red handles, as you do when changing the size of the object.

Note

Rotation works in a slightly different way for 3D objects because the rotation occurs in 3D space and not in one plane. See Chapter 7 (Working with 3D Objects) regarding rotation when the Edit Points mode is active.

To rotate an object (or a group of objects), drag a red corner handle point of the selection with the mouse. The mouse cursor takes the shape of an arc of a circle with an arrow at each end. A dotted outline of the object being rotated appears and the current angle of rotation is dynamically shown in the Status Bar.

Rotations are made about an axis which is displayed as a small symbol. This is normally located at the midpoint of the object, but you can move the axis of rotation with the mouse to any location you like.
Rotating and shearing an object

If you hold down the Shift key during the rotation, the operation will be carried out in increments of 15°.

Changing inclination or perspective

To slant or shear objects, use the red handles located at the midpoint of an edge of the selected objects. The mouse pointer changes to a \( \Rightarrow \) when the pointer hovers over one of these midpoint handles. Not every object can be slanted—basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be used for shearing the object. This point stays fixed in location; the other sides and edges move in relation to it as the mouse is dragged (make sure that the \( \Rightarrow \) handle icon is showing before dragging).

Figure 51 shows how the vertices move in relation to each other during the shearing process. The circles represent the path of the vertices. The inclination axis is the bottom vertex of the triangle (the slanting handle used is the midpoint of the upper enclosing frame). All points on the figure will move through the same angle irrespective of the final shape. The actual angle is shown in the Status Bar.

Note Should you wonder where the triangle in the next figure comes from—it was produced with the (unfilled) polygon tool and then Close Object selected from the context menu.

Figure 51: Shearing an object
This tool can be used to produce perspective drawings. The series of pictures in Figure 52 shows the method of constructing a cuboid or rectangular prism. To shorten the edges leading from front to back, reduce the length before you distort the height or width of the surface.

Figure 52: Perspective production of a cuboid

As with rotation, you can set the slanting to occur as steps of 15° by pressing the *Shift* key while moving the handle.

### Setting size and position exactly

You can position and resize objects with the mouse, but this method is not very exact. If you need accurate positioning of objects, use *Format > Position and Size* from the menu bar, or right-click the object and select *Position and Size* from the context menu, or press *F4*.

#### Position and Size

Open the *Position and Size* dialog (see Figure 53) and click on the first tab to set the appropriate values.

Figure 53: Position and size of an object
Setting size and position exactly

Position is defined as an X,Y coordinate relative to a fixed point (the base point), typically located at the upper left of the drawing area. If desired, you can temporarily change this base point to make positioning or dimensioning simpler (click on the radio button corresponding to the location of the base point in either of the two selection windows on the right side of the dialog—upper for positioning or lower for dimensioning). The possible base point positions correspond to the handles on the selection frame plus a central point. The change in position lasts only as long as you have the dialog open; when you close this dialog, Draw resets the base point to the standard position.

Tip The Keep ratio checkbox is very useful. Click it to keep the ratio of width to height fixed while you change the size of an object.

Either or both the size and position can be protected so that they cannot be inadvertently changed. Check the appropriate boxes to achieve this.

Tip You cannot move an object? Check to see if the position is protected!

Rotating objects

Click on the Rotation tab of the Position and Size dialog (see Figure 54). Here you can define the rotation angle, as well as the location of the pivot point.

Figure 54: Rotating an object


**Slant and corner radius**

With some Draw objects the slant angle (inclination or shearing) and corner radius can be set in this dialog (Figure 55).

![Setting rounded corners and slant angle](image)

**Corner radius**

You can use this dialog to round the corners of the usual Draw objects—text boxes, legends, rectangles, and squares, as shown in Figure 56. The same effect can be achieved when you are in the points mode (by clicking the Points icon on the Drawing toolbar), by dragging the large handle with the mouse. The larger the value for the corner radius, the more round will be the object.

**Slant**

You can shear the older, classic Draw objects, but not the newer Shape objects. Enter the slant angle in the box marked Slant Angle.

![Example of setting the slant angle in a classic Draw object](image)

**Editing object points**

For polygons and Bézier curves, Draw offers a complete set of tools that let you accurately edit the contour of an object. To edit other objects in the same way, you must first convert them into curves. To do this, select the object, then right-click and choose Convert > To Curve or choose Modify > Convert > To Curve from the menu bar.

You can also convert the shapes to a polygon (Convert > To Polygon). With polygons, the edge points are always connected with straight lines and not with curves. Some of the techniques described work equally with polygons as with curves.
Editing object points

An alternative way to change the form of basic shapes

In current versions of Draw, many of the new shapes can be directly edited without having to first convert them to curves. You can recognize these objects by the presence of one (or more) yellow handles. Figure 58 shows a selection of shapes with such handles.

If you hover the mouse pointer over one of these handles and then drag it, you can change the form of the shape; the exact type of change is dependent on the shape itself. The mouse pointer changes to a hand with index finger outstretched when hovered over one of these handles.

Examples of what you can do with this tool are rounding the corners of a rectangle or square, changing the angles of an arc or ellipse, or altering the control points of a circular or elliptical segment.

Figure 58: Some basic shapes with yellow “handles”

How curves work

Editing curves works on the basis of a method called Bézier curves⁴. The complete study of such curves goes beyond this scope of this guide, and only the basics of this powerful method of editing the contour of an object are covered here. Chapter 10 (Advanced Draw Techniques) provides more information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through these points. Each tangent has two control points—one at each end—and a junction point where it meets the curve. The relative angle and distance between the control points determine the shape of the curve. Figure 59 shows several variations starting from a basic circle and changing only one point on the circle.

You can create many different shapes by moving either the junction point itself, or one or both of the round handle points at either end of the tangent.

⁴ Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles easier.
Experimenting with moving the control points of a tangent will yield countless variations of the basic starting shape. Draw offers even more possibilities when you use the functions on the Bézier curve toolbar.

**The Edit Points toolbar**

When you work in Edit Points mode, use the Edit Points toolbar, shown in Figure 60. This toolbar can be activated by View > Toolbars > Edit Points. Once activated, it will appear whenever you select a curve and the Edit Points icon on the Drawing toolbar is active.

![Edit Points toolbar](image)

On this toolbar, some buttons are active or inactive depending on the selected object and object point. With the Convert to Curve icon, you can determine for individual points whether their connection will be made with straight lines or with curves.

Only with curves are the icons for tangents activated. An object which contains no curves is treated as a polygon.

The role of the three buttons enabling you to choose the type of tangent is described in the following chapter. The other buttons are described here in relation to working examples.

**The three kinds of tangent**

Three buttons in the Edit Points Toolbar let you select the type of tangent and convert from one type to another. Only one of these buttons can be active at any given time.

![Symmetric Transition](image)

The **Symmetric Transition** button lets you work with a symmetrical tangent (Figure 61). Any movement of one or the other of the handles will be carried over symmetrically to the other handle.
How curves work

The Smooth Transition button lets you separately adjust the lengths of the two parts of a tangent and so make the curve flatter or steeper. In Figure, you can clearly see that the curve is flatter on the longest side of the tangent. The tangent remains as a single straight line. This kind of tangent is known as a smooth junction. This button should not to be confused with the preceding one because their representations are fairly similar.

It is also possible to completely detach both sides of the tangent. In this case, the central point is known as the inflexion point. Using this technique, you can draw spikes and troughs in objects. Use the Corner Point button to create an inflexion point around the selected point.

Examples

The following examples start from a filled circle. As mentioned earlier, in order to use Edit Points mode, you first need to convert the object to a curve.

You will notice that after the conversion, the handles located in the corners of the rectangle have disappeared. This behavior is normal in that the handles which are used in the Edit Points mode are located along the outline or trace of the drawn object.

The Move Points button is the default mode when editing points. If it has not been activated, click on its button. When this mode is active, the mouse cursor has the following shape when it is hovered over an edit point:

Movement of a point is one of the easiest manipulations to do. Figure illustrates how an egg can be drawn very easily by starting from a circle and dragging the the top point upwards.
To change the direction or location of the tangents, move the circular handles at each end. The mouse cursor then looks like this:

Use the **Add Points** button to add an extra edit point to an existing curve. Click on the curve at the spot where you want to insert a point and then move the mouse slightly, in any direction, while holding down the button. Watch out! If you just click, the new point will not be added.

The tangent attributes associated with the new point depend on the buttons that are selected on the toolbar.

The **Delete Points** button has the opposite effect: it subtracts one or more points from the curve. The resulting curve stretches itself automatically around the remaining points after subtraction.

Select one or more points to delete. You can select several points by holding down the **Shift** key (1).

When you have selected the points you want to delete, click the **Delete Points** button. The selected points disappear from the curve, which then reforms around the remaining points (2).

You can also delete the selected points by pressing the **Del** key on the keyboard.
How curves work

Use the **Split Curve** button to split or cut a curve at the location of the selected handle. If the object is filled, it will be emptied because the curve that represented the edge is no longer closed.

Check that you have selected the correct handle (➊), click the **Split Curve button** (➋) and notice that the object is no longer filled. You can then check, by moving the point, that the curve has indeed been separated (➌).

If you have an open curve, the start point of the curve is larger than the others.

You can also separate a curve at several points simultaneously. Just keep the **Shift** key pressed down and select all of the points at which the cut should occur.

Drag and drop segments with the mouse to move them from the original curve.

To close an existing curve, select an open curve and click on the **Close Bézier** button.

The opening point is identified by a slightly larger handle (Figure 70).
How curves work

The Select button on the Drawing toolbar functions as a switch. It works as follows.

If you have two points linked together by a straight line (you do not need to have a curve between the points) and you insert a new point between them that is set at an angle to the initial straight line (and hence the two endpoints), then:

- If the Select button is active, you will have a drawing similar to that illustrated in ➊.
- If the Select button is not active, and you move the point you have just inserted to bring it back close to its initial position in the straight line, you will have a drawing similar to that illustrated in ➋.

The Eliminate Points button button only functions with lines with multiple points.

If the button is active, clicking on a point, holding the mouse key down and moving the mouse will draw virtual straight lines between the neighboring left and right points.

When the two lines are more or less straight and you release the mouse button, the point is deleted and a line between the above mentioned two neighboring points replaces the previous two lines, thus eliminating one point.

Note that this only works when the angle between the two lines shown dashed in the figure at left is less than a certain amount.

In the Tools > Options > OpenOffice.org Draw > Grid window there are options for snap settings relating to editing points when rotating and in point reduction mode.
How curves work

The **Rotate** function from the **Effects** drop-down button on the Drawing toolbar and the **Rotation Mode after Clicking Object** button on the Options toolbar can be used in Edit Point mode. In this case, it can be used to move single points around the contour of an object.

Switch into rotation mode by clicking on either of the rotation buttons. Notice that in rotation mode, all of the tangent points become red dots.

Select the point to be moved and then drag it around the contour while keeping the left mouse button pressed down (➊). When you let go of the mouse button, the point will be moved to the new position (➋).

If you move one of the handles located at the end of the tangents during rotation, you will make the object rotate in exactly the same way as with the usual rotation operations.

**Important:** To exit the effects mode, do not just single click on the **Effects** button but single click the **Select** button on the Drawing toolbar.

*Figure 76: Moving a point on a curve*
Chapter 4
Changing Object Attributes
Toolbars and menus

To change an object’s attributes (such as color, border width, among others) you can use the Line and Filling toolbar or the context menu.

Line and Filling toolbar

If the Line and Filling toolbar (Figure 77) is not visible, you can display it using View > Toolbars > Line and Filling. From here you can edit the most common object attributes. You can also open the Line dialog by clicking on the Line icon and the Area dialog by clicking on the Area icon to see more options.

Figure 77: Line and Filling toolbar

When you select text, this toolbar changes to show text formatting options (Figure 78).

Figure 78: Line and Filling toolbar (when text is selected)

The context menu

When an object is selected, you can right-click on the object to bring up a context menu (Figure 79). The context menu provides additional access to the options shown above and another way to change an object’s attributes. The entries with a small arrow on the right-hand side contain a submenu.

Figure 79: Right-click on an object to see the context menu.
Editing lines and borders

Lines (like arrows) and the borders of an object are managed through the same dialog. An object’s border is just another type of line (Figure 80).

![Figure 80: Lines and borders](image)

You can change some properties from the Line and Filling toolbar. To see more options, select the object and click on the Line icon or right-click on the object and choose Line from the context menu. This opens the Line dialog.

![Figure 81: Line dialog (right-click on an object and choose Line).](image)

Common line properties

In most cases the property you want to change is the line’s style (solid, dashed, invisible, and so on), its color, or its width. These options are all available from the Line and Filling toolbar.
Editing lines and borders

You can also edit these properties from the Line dialog. They are on the first tab, left column (see Figure 82). From the Line dialog you can also change the line’s transparency. Figure 83 illustrates different degrees of transparency.

![Figure 83: The vertical lines have different levels of transparency (0%, 25%, and 50%).](image)

**Drawing arrows**

Arrowheads (and other line endings—usually referred to in this guide collectively as arrows) are a line property. Select a line and click on the **Arrow Style** icon. This opens the Arrowheads menu.

![Figure 84: Arrowheads menu](image)

There are several types of arrowheads available. Each end of the line can have a different arrowhead (or no arrowhead).

**Note** Arrowheads are only applicable to lines. They have no effect on an object’s border.
In the Line dialog (see Figure 81), *Arrow styles* on the right-hand side contains a number of options to fine tune the arrow properties. If *Synchronize ends* is selected, both line endings will have the same appearance. The option *Center* brings the middle of the arrow over the end point of the line. If this checkbox is not selected, the line ends on the outermost edge of the arrow. It is much easier to understand if you look at the following sketch.

![Figure 85: Default arrowheads (left) vs centered arrowheads (right)](image)

**Customizing line and arrow styles**

You are not constrained to using only the line and arrow styles provided by default in Draw. You can modify the styles and create your own.

**Customizing line styles**

In the Line dialog, click on the *Line Styles* tab (see Figure 86). From here you can customize the line styles or create your own (click on the *Add* button to create your own). You can change the length of the dashes, the space between them, and other attributes.

![Figure 86: Editing line styles](image)
Editing lines and borders

Use the **Load Line Style** and **Save Line Style** icons to save a new definition or read one from disk (file extension `.sod`).

**Customizing arrow styles**

You can also create your own arrowheads to create some interesting effects, such as:

![Arrow Head Example]

The first step is to draw a curve with the shape you want for the arrowhead.

**Note**
The arrowhead must be a curve. A curve is something you could draw without lifting a pencil. For example, 🌟 is a curve but 😊 is not a curve. You can however draw forms which are not curves and then at the end convert them to a curve.

Select the curve, open the Line dialog, and go to the **Arrow Styles** page. Click on **Add**, enter a name for the arrow style and click **OK**.

**Tip**
The part of the shape which should point in the direction of the line must be drawn facing upwards. In Figure 87 the top of the shape will point towards the “outside” of the line.

![Arrow Style Dialog]

**Figure 87: To create your own arrowhead, you must first draw a curve.**

**Figure 88: Adding an arrow style**
Now you can access the new style from the *Arrow style* list (Figure 89) or the Arrowheads dialog (Figure 84).

![Arrow style list](image)

**Figure 89: Arrow style list**

### Editing the inside (fill) of an object

The OpenOffice.org term for the inside of an object is **Area fill**. The area fill of an object can be a uniform color, a gradient, a hatching, or a pattern from an image. It can be made partly or wholly transparent and can throw a shadow.

![Different types of area fill](image)

**Figure 90: Different types of area fill**

### Common fill properties

In most cases, you will choose one of the standard fill options, whether it is a color, a gradient or an image. These options are all available from the Line and Filling toolbar.
Editing the inside (fill) of an object

![Common fill options](image)

Figure 91: Common fill options

**Fill with a uniform color**
Select the object you wish to edit. On the **Line and Filling** toolbar, select **Color** on the pull down list at the right of the paint can, and then choose a color from the right-hand menu (Figure 92).

![Filling with a color](image)

Figure 92: Filling with a color

**Fill with a gradient**
Select the object you wish to edit. On the **Line and Filling** toolbar, select **Gradient** and then choose a gradient from the right-hand menu (Figure 93).

![Filling with a gradient](image)

Figure 93: Filling with a gradient

**Fill with a line pattern**
The OOo term for line patterns is Hatching. Select the object you wish to edit. On the **Line and Filling** toolbar, select **Hatching** and then choose an option from the menu (Figure 94).
Fill with an image

You can fill an object with a bitmap image (as opposed to a vector graphic image). Select the object you wish to edit. On the Line and Filling toolbar, select Bitmap and then choose an option from the menu (Figure 95).

Adding a shadow

In Draw, shadows are considered an area property. Click on the Filling icon on the Line and Filling toolbar—next to the area fill functions (Figure 96).
Advanced area fill options

Click on the Area icon to bring up the Area dialog. From this dialog, you can fine tune the area fill of an object in greater detail.

Creating your own fill color

Click on the Colors tab of the Area dialog (Figure 97). From here you can modify existing colors or create your own.

![Figure 97: Customizing the color palette](image)

Depending on the color model (RGB or CMYK can be selected from the pull down menu) in use you can change the individual values of the constituent colors—Red, Green, and Blue or Cyan, Magenta, Yellow, and Black. Click on Add to add this color to the color table. Clicking on the Modify button will change the values to those on the screen. The Edit button allows you to fine tune the color using a palette with visual feedback.

Further explanation about color palettes can be found in Chapter 8 (Tips and Tricks).

Creating your own gradient

On the Area dialog, click on the Gradients tab. From here you can modify existing gradients or create your own.
Chapter 4  Changing Object Attributes

A gradient works by creating a smooth transition from one color to another. First, you need to choose two colors.

Then choose a type of gradient. There are several available (Linear, Axial, Radial, and so on) and each has up to four different options to specify it in detail. For example, a radial gradient has a center you can specify (Figure 100).

Figure 98: Customizing gradients

Figure 99: Choosing colors for a gradient

Figure 100: Center option in a radial gradient
Editing the inside (fill) of an object

Figure 101 shows how an ellipsoid gradient is rotated, moved vertically and horizontally, and the color of the border area varied.

![Figure 101: Center, Angle, and Border options for a gradient](image)

Creating your own hatching (line pattern)

On the Area dialog, click on the Hatching tab. From here you can modify existing hatchings (line patterns) or create your own.

![Figure 102: Modifying hatchings](image)

You can customize options like the spacing between lines, the angle and the color of the lines. There is no way to edit the line thickness.
Creating your own bitmap fill

You can add your own bitmap images to fill an area. First, you need to create the bitmap image. This could be a photo or another sketch you have created in another program. For example, you can draw something with Draw and export it as a PNG format image file.

To export a PNG image file: Create the image, select it, then File > Export, choose PNG from the pulldown list of file formats, give it a name, and save it (Figure 103).

To use an image as a bitmap fill, open the Area dialog and click on the Bitmaps tab. From there you can add new bitmap images to serve as area fills (Figure 104).
Editing the inside (fill) of an object

Click on **Import** and choose a file you previously saved. Give it a distinguishing name that will make it easy to remember. The last imported image will appear at the bottom of the pulldown list of bitmap fills. Now you can use that image as an area fill.

![Figure 105: Adding your own bitmap images](image)

**Tip** If the imported image seems to be very small in the preview in Figure 104 probably you forgot to **select** the image before you exported it. The exported image was then the whole page with a (small) drawing on it.

**Customizing shadows**

First, select the object you want to apply a custom shadow to. Open the Area dialog and go to the **Shadow** tab. There you can customize the shadow’s position, distance and color (Figure 106).

![Figure 106: Customizing shadows.](image)
Shadows can also have transparency, so the shadow does not hide objects behind it.

![Figure 107: Shadow with 50% transparency](image)

**Adding transparency**

You can make objects partly or fully transparent, or even a with a varying degree of transparency (as a gradient). On the **Transparency** page (Figure 108), choose **Transparency** (for a uniform transparency) or **Gradient** for a gradient transparency.

![Figure 108: Transparency page of Area dialog](image)

An example of gradient transparency is shown in Figure 109. See also “Dynamic gradients” on page 65.

![Figure 109: Example of gradient transparency](image)
Using styles

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a formatting template (a style) and then to apply that style to multiple objects. For more about styles, see Chapter 6 (Introduction to Styles) in the *Writer Guide*.

Click on the **Styles and Formatting** icon on the **Line and Filling** toolbar or press the *F11* key to open the Styles and Formatting window (Figure 110). This window can be docked to the left or right side of the main Draw window, if you wish.

![Figure 110: Styles and Formatting window](image)

**Creating a new style**

Select an object and customize the area fill and border. When you are satisfied, click on the **New Style from Selection** icon on the Styles and Formatting window. This defines a new style based on the selected object. Type a name for the new style and click **OK**.

**Applying a style**

Once the new style is defined, you can apply it to other objects. Select another object and double-click on the style name you defined. The new object will acquire the area fill and line properties of that style.

**Tip**

**Question:** What happens if I modify a style after it has been applied?

**Answer:** Then every object with that style is updated automatically!
**Modifying a style**

Modifying a style is similar to creating a new style. Select an object with that style and change the area and line properties. When satisfied, click on the **Update Style** icon.

**Special effects**

First make sure that the **Drawing toolbar** is selected (View > Toolbars > Drawing). On the Drawing toolbar, locate the **Effects** icon. Click on the arrow next to that icon. This opens a submenu with all the special effect tools (see Figure 111).

![Mode tear-off submenu](image)

1. Rotate  
2. Flip  
3. In 3D Rotation Object  
4. Set in Circle (perspective)  
5. Set to Circle (slant)  
6. Distort  
7. Transparency  
8. Gradient

*Figure 111: Mode tear-off submenu*

The tools are described in the following sections with the exception of the 3D rotation tool, which is described in Chapter 7 (Working with 3D Objects).

**Rotating an object**

Click on the **Effects** icon to select the **Rotate** tool. Then select an object. The selected object will have red handles instead of the usual green handles.

Grab one of the handles and move it to rotate the object. The black circle in the middle of the object is the pivot (center of rotation). You can move the pivot with the mouse.
**Flip an object**

Select an object and click on the Flip icon. You will see a dashed line through the middle of the object.

This dashed line is the **axis of symmetry**. The object will be reflected about this line. Move one or both ends of the line with your mouse to set the axis.

Then, grab any one of the eight green handles and move it across to the other side of the dashed line. The new position of the figure is shown dashed until the mouse is released.

**Note**  
If you press the *Shift* key while moving the line, the line will rotate in 45-degree increments.

**Mirror copies**

Officially, this useful command does not (yet) exist in Draw. It can, however, be easily emulated.

Move the axis of symmetry to the desired location of the mirror axis. Copy the object to the clipboard. Flip the object, then click on an empty area of the Draw screen in order to deselect the object. Paste from the clipboard to put a copy of the object in its original location and now you have a mirror copy.

*Figure 112: Making a mirror copy of an object*
**Distorting an image**

There are three tools on the Effects menu that let you drag the corners and edges of an object to distort the image.

The **Distort** tool distorts an object in perspective, the **Set to Circle (slant)** and **Set in Circle (perspective)** tools both create a pseudo three-dimensional effect.

The results of using these tools are shown in the following figures.

**Distort an object**

Select an object and click on the **Distort** icon. Draw will ask if you want to transform the object to a curve. This is a necessary step before distortion, so click **Yes**. Then you can move the object handles to stretch it.

The corner handles distort, as shown in Figure 113. The midpoint handles distort the figure either horizontally (handle on vertical side of figure) or vertically (handle on horizontal side of figure).

![Figure 113: Distort an image](image)

**Set in circle (perspective)**

Select an object and click on the **Set in Circle (perspective)** icon. Draw will ask if you want to transform the object to a curve. This is a necessary step before distortion, so click **Yes**. Then you can move the object handles to give a pseudo three-dimensional perspective (Figure 114).
Special effects

Figure 114: Set an image in a circle with perspective.

Set to circle (slant)

Select an object and click on the Set to Circle (slant) icon. Draw will ask if you want to transform the object to a curve. This is a necessary step before distortion, so click Yes. Then you can move the object handles to give a pseudo three-dimensional slant perspective (Figure 115).

Figure 115: Set an image to a circle with slant perspective

Note  Transforming an object into a curve is a safe operation, but it cannot be reversed other than by clicking the Undo button.
**Dynamic gradients**

You can control transparency gradients in the same manner as color gradients. Both types of gradient can be used together. With a transparency gradient, the direction and degree of an object’s fill color changes from opaque to transparent (in a regular gradient, the fill changes from one color to another, but the degree of transparency remains the same).

If you have assigned transparency to an object with a color fill, you can control the transparency by clicking on the **Transparency** icon 🌈. To define a transparent gradient, select an object, choose a transparency fill from the **Line and Filling** toolbar, The transparency icon is now active. When you click on this icon, a dashed line connecting two squares appears on the object. Move the two squares to modify the gradient. You can define the direction of the gradient (vertical, horizontal, or at any angle) and the spot at which the transparency begins.

In the same manner, to define a regular gradient, select an object, choose a gradient fill from the **Line and Filling** toolbar, The **Gradient** icon 🌈 is now active. When you click on the gradient icon, a dashed line connecting two squares appears on the object, just as it does for a transparency gradient.

In both cases a dashed line connecting two small squares appears on top of the object. Click outside the object to set the gradient.

**Note**

If the transparency and gradient icons are not visible, you can display them using **View > Toolbars > Mode**.

Moving the squares will have different effects, depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.

The three examples in Figure 85 demonstrate how the type and degree of transparency can be controlled.
Special effects

A single color object and a transparency gradient, covering part of the underlying object.

The gradient can be dynamically adjusted, made more transparent by moving the white square or more opaque by moving the black square.

An object with a color gradient, completely covering another object.

The gradient is adjusted dynamically by moving the squares – the color of the square relating to the increase or decrease in that color.

An object with both color and transparency gradients, partly covering the underlying object.

Figure 116: Dynamic gradients
Chapter 5

Combining Multiple Objects
Introduction: grouping and combining objects

Using Draw, you can combine drawing objects together in two distinct ways: grouping and combining. These two methods allow you to treat multiple objects as one unit, or to merge objects to form a new shape.

Grouping is like putting objects in a container. You can move them as a group and apply global changes to them. A group can always be undone and the objects that make up the group can always be manipulated separately.

A combination is a permanent fusion of objects leading to a new object. The original objects are no longer available as individual entities and the operation is not reversible.

Tip

To select multiple objects, click on each object while holding down the Shift key or click the Select icon (on the Drawing toolbar) and draw a rectangle around the objects.

Grouping objects

Grouping by common selection

When several objects are selected, any operations you carry out are applied to all of the objects. For example, you can rotate a group of objects in its entirety. Groups obtained through common selection of several objects are undone as soon as you click outside the group. However, you can group objects and keep those selected objects grouped together.

Maintaining groups and undoing groups

To group selected objects, right-click and choose Group from the pop-up menu. You can also use the keyboard shortcut Control+Shift+G or choose Modify > Group from the menu bar.

Figure 117: Grouping objects using the right-click menu.

When objects are grouped, any editing operations carried out on that group are applied to all members of the group. If you click on one member of the group, the whole group is selected.

The objects of a group retain their own individual properties. To undo a group, right-click and choose Ungroup from the pop-up menu, use the keyboard shortcut Control+Alt+Shift+G or choose Modify > Ungroup from the menu bar.
**Editing individual objects in a group**

You can edit a member of a group individually without breaking the group. To do this, right-click and choose **Enter group** or double-click on the group.

![Figure 118: When you enter a group, objects outside the group can not be selected and are grayed out.](image)

Once inside the group, click on any object to edit it.

![Figure 119: Editing an object inside a group.](image)

To leave this mode, right-click and choose **Exit group** or double-click outside the group.

**Nesting groups**

You can create “nested” groups, or groups of groups. In this case, Draw keeps the initial group hierarchy. If you ungroup a group made of other groups, you are left with individual groups that you can then ungroup further, and so on until only single objects remain.

**Combining objects**

In contrast to grouping functions, **combinations** create a new object; subsequent “un-combining” in the same manner as ungrouping is not possible. Select a collection of objects, then right-click and choose **Combine** from the pop-up menu. The result of this operation is shown in Figure 120.

![Figure 120: Combining objects](image)

At first glance, this can seem rather surprising. Once you understand the rules governing combination in Draw, however, it will become clearer.
Combining objects

- The attributes (for example, area fill) of the resulting object are those of the object furthest back. In this example, it is the circle.

- Where the objects overlap, the overlapping zone is either filled or empty depending on the number of overlaps. When the number of overlaps is even, you get an empty space; when the number is odd, you get a filled area.

![Figure 121: Odd numbered overlaps are filled, even numbered overlaps are empty.](image)

Tip
You can reorder objects so they are further back in the background or further forward in the foreground: right-click on the object and select Arrangement from the pop-up menu. See also “Aids for positioning objects” on page 72.

An object which is a combination can be broken up into its constituent parts by selecting **Modify > Break**. This is not the equivalent of ungrouping as the objects were converted to Bézier curves when they were combined. The resulting object is a set of base level objects (for example, a rectangle will be broken into 4 separate lines). The original formatting—line thickness, colors, and area properties—is not retained.

Merging, subtracting, or intersecting shapes

After you have selected more than one object, the Merge, Subtract, and Intersect functions can be reached in the **Modify > Shapes** menu or though the group’s right-click menu under the heading **Shapes**.

**Merge**

When you merge objects, the new object covers the entire surface of the original objects (it is the union of the objects). In the same way as combining, the fill of the merged object is determined by the fill of the object furthest in the background. Other properties are not taken over into the new object.
**Subtract**

When you subtract, the upper object is subtracted from the lower object.

**Intersect**

When you intersect two objects, you get the area covered by both objects.

---

**Tip** How do I move an object so it is further back or closer to the front? See page 72.

---

**Practical example**

The following example shows how you can use the merge functions to create a complex shape, namely a knife with a wooden handle.

1) Draw an ellipse and then a rectangle overlapping half of its width.

2) Select both shapes, right-click, and choose **Shapes > Subtract** from the pop-up menu. The result should resemble the shape at right:
Merging, subtracting, or intersecting shapes

3) Draw another rectangle and put it over the top half of the ellipse. Then subtract again.

4) Draw a small ellipse covering just the lower right corner and subtract again.

5) The knife blade is now complete. To make the handle, draw a rectangle and an ellipse as shown.

6) *Merge* the shapes together.

7) *Group* this image with the previous one.

Aids for positioning objects

Draw has various tools to help you arrange the objects with respect to each other. Here we explore some of the more important ones.

**Moving an object to the front or to the back**

When you combine or merge objects, the end result varies drastically depending on which object is “in front” and which one is “in the back”. In Figure 122 you can see the difference.

*Figure 122: Subtracting objects: the result varies depending on which object is in front.*

If you imagine several objects stacked one on top of the other, the one referred to as “Front” is the one on top of the stack. The one referred to as “Back” is the one on the very bottom of the stack.
First select an object, then click on \( \text{click} \) to open the \textbf{Position} toolbar from the main Drawing toolbar.

![Positioning toolbar](image)

1. Bring to Front
2. Bring Forward
3. Send Backward
4. Send to Back
5. In Front of Object
6. Behind Object
7. Reverse

*Figure 123: The floating Position toolbar*

- \( \text{Bring to Front} \) brings the selected object to the front of the group.

- \( \text{Send Forward} \) brings the selected object one step upwards.

- \( \text{Send Backward} \) sends the selected object one step backwards.

- \( \text{Send to Back} \) sends the selected object to the back of the group.
Aids for positioning objects

moves the selected object in front of another chosen object.

moves the selected object behind another chosen object.

Click first on the object you want to change in position. Click next on the icon and then move the mouse over the other object. The mouse cursor changes into a hand and the outline of the second object becomes a dashed line (see below). Clicking on this object completes the rearrangement of position.

reverses the order of the selected objects.

Aligning objects

Click on to open the floating *Align* toolbar. This toolbar helps you position objects with respect to each other.

*Figure 124: The floating Align toolbar*
Aids for positioning objects

- Center horizontally.
- Align right.
- Align top.
- Center vertically.
- Align bottom.

Distributing the distance and space between objects

Select at least three objects. Now you are able to select the option **Distribution** on the **Modify** menu or from the right-click menu. A dialog containing a number of selections appears (see Figure 125). The use of each option is indicated by the tooltip (under Windows) or by clicking the Help button in the Distribution dialog.
Aids for positioning objects

Figure 125: Distribution of spacing between objects

**Horizontal distribution**

None. Does not distribute the objects horizontally.

Left. The left edges of the objects are evenly spaced from one another.

Center. The horizontal centers of the objects are evenly spaced from one another.

Spacing. The horizontal spacing between the objects is evenly distributed.

Right. The right edges of the objects are evenly spaced from one another.

**Vertical distribution**

None. Does not distribute the objects vertically.

Top. The top edges of the objects are evenly spaced from one another.

Center. The vertical centers of the objects are evenly spaced from one another.

Spacing. The vertical spacing between the objects is evenly distributed.

Bottom. The bottom edges of the objects are evenly spaced from one another.

Figure 126 shows four objects before distribution of spacing.

![Figure 126: Before distribution](image)

The result of the selections made in Figure 125 (change to equal horizontal spacing, no vertical change) is shown in Figure 127.

![Figure 127: After distribution – change to equal horizontal spacing, no vertical change](image)
Chapter 6
Editing Pictures
(Raster Graphics)
**Introduction**

Earlier chapters of the Draw Guide have dealt only with vector graphics. However, Draw also contains a number of functions for editing raster graphics (bitmaps)—for example, photos, scanned pictures, and so on—including import and and export as well as conversion from one format to another.

Draw can read in all the usual range of graphic file formats. It does not have the same capabilities as the specialized raster graphics programs like Adobe Photoshop or The Gimp.

**Importing raster and vector graphics**

You can import stored graphics files choosing **Insert > Picture > From File** on the main menu bar or by clicking on the 📁 icon on the Draw toolbar. In the list of supported data types are many different formats; Draw possesses a suitable import filter for each one. The list includes both vector and raster graphic file types. If your data file has a nonstandard file extension, you need to select the file and then explicitly choose the data type.

If you select the **Preview** checkbox in the Insert picture dialog (Figure 128), Draw shows a preview of the picture in the box on the right-hand side. This makes it much easier to choose the picture you want and to see whether Draw can import a file of this format.

**To link or to embed?**

Take careful note of the **Link** checkbox. When a graphic is linked, the graphic itself is not inserted into the document but rather a link to the graphic is created. This link is relative to the storage location of the document, even when it shows as an absolute link. If you store the document and the graphic in the same folder, and transport the folder as a whole to another computer, the graphic will show up in the document as before.

---

5 An import filter for svg graphics is planned - more information can be found at [http://wiki.services.openoffice.org/wiki/SVG_Import_Filter](http://wiki.services.openoffice.org/wiki/SVG_Import_Filter)
Linked graphics are not changed as a result of any actions carried out with OpenOffice.org. Any changes affect only the view of the graphic in the document and not the graphic itself. In particular, the format of a linked graphic remains unchanged. In contrast, when a raster graphic is embedded in an OOo document, it is embedded in PNG format.

Linking offers the advantage that the file size of the Draw document remains small. If the picture is edited or even replaced by another, the link will still function. As long as the new picture is given the same name as the old one, links will be reestablished and updated when the document containing the link is next opened. However, some actions do not last beyond the current session (for example, Filter) or are simply not possible on a linked graphic (for example using the Eyedropper to exchange colors).

Links can easily be removed. The linked picture will then be embedded in the document. To break a link, choose Edit > Links from the main menu bar. In the Edit Links dialog (see Figure 129), choose the link to be broken and then click on the Break Link button.

![Edit Links](image)

*Figure 129: Editing links to documents*

### Scanning

With most scanners you can directly insert a picture in a document from the scanner. Click Insert > Picture > Scan and then either Select Source or Request.

The Select Source option opens a window which acts as an interface to a scanner device. Some scanner options can be directly set from within this window. See Figure 130.
Importing raster and vector graphics

Click on Create Preview to carry out a preview scan. The results are shown in the preview box on the left. Modify the scan area as desired and review the result as before. When you are satisfied with the scan preview output, click OK and then insert the scan into the document with Insert > Picture > Scan > Request.

Scanned images are embedded in the document as a PNG format picture.

Pasting from the clipboard

The clipboard offers another way to insert graphics. Depending on the source and the operating system, figures may be in different formats. You can obtain an overview by choosing Edit > Paste contents from the menu bar or by clicking on the small black triangle next to the Paste icon on the main toolbar.
Drag and drop also functions in many situations. The exact way in which it works is not determined by whether the graphic is to be embedded or linked but rather the operating system in use and the source of the graphic. The behavior can often be controlled by the use of the Control or Control+Shift keys together.

Draw objects and images which are used frequently can be stored in the Gallery. Objects can be dragged from the Gallery to the Draw surface quite simply. Working with the Gallery is dealt with in Chapter 10 (Advanced Draw Techniques).

Inserting from a file

With this option, you can insert complete pages or single objects from Draw or Impress documents into your Draw document. In addition you can insert text in Rich Text Format (RTF), HTML format or plain text. The text will be contained in the Draw document within a text frame. The usual paragraph and character formatting options are available for this text.

Selecting Insert > File brings up the File selection dialog. If the file is a Draw or Impress document, a special import dialog opens (see Figure 131).

To access single pages or slides of the document, click on the + sign before the file name in the selection area. You can select whether to embed or link the selected page. If the name of the page or object already exists in the current document, you are requested to give it a new name before it is inserted.

Raster graphics (for example, photos) and Metafiles are marked with a symbol, drawing objects with a symbol. Choose the object or objects (multiple selection using the Control or Shift key is possible). The inserted object keeps its original name, if it was named in the source document. To rename an inserted object, right-click and choose Name from the pop-up menu. Renaming has the advantage that the object is then listed in the Navigator.
Exporting graphics

Exporting graphics

Saving drawings in the native OpenOffice.org Draw format (*.odg) means that (currently) in general only OOo (or StarOffice) users can open the files. To make it easier for other users and to use the drawings in other applications, you can export the graphics in other formats. Choose the command File > Export and then in the File format pull-down list select the desired format (see Figure 132).

<table>
<thead>
<tr>
<th>File format options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PDF</td>
<td>Portable Document Format (.pdf)</td>
</tr>
<tr>
<td>Macromedia Flash</td>
<td>(SWF) (.swf)</td>
</tr>
<tr>
<td>XHTML (.xhtml)</td>
<td>BMP - Windows Bitmap (.bmp)</td>
</tr>
<tr>
<td>EMF - Enhanced Metafile (.emf)</td>
<td>EPS - Encapsulated PostScript (.eps)</td>
</tr>
<tr>
<td>GIF - Graphics Interchange Format (.gif)</td>
<td>JPEG - Joint Photographic Experts Group (.jpg, jpeg, jif, jif, jpe)</td>
</tr>
<tr>
<td>BMP - Windows Bitmap (.bmp)</td>
<td></td>
</tr>
</tbody>
</table>

**Figure 132: Section of the file selection list**

### Exporting the entire file

The file format options in the upper area of the File format box—PDF, Flash, and HTML—result in the complete file being exported. Export in Flash or HTML format results in each page of the Draw document being exported as a raster graphic. You will then not be able to access individual objects on the page. The Export Assistant can generate—if you choose—a Navigation aid to help in moving from page to page.

If you want to use the objects in other applications, you would be better advised to select one of the Metafile formats (JPEG, PNG, TIFF, BMP etc) in the lower part of the File format list (see Figure 133). With this type of export only the currently active page is exported.

<table>
<thead>
<tr>
<th>File format options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PCT - Mac Pict (.pct)</td>
<td>PGM - Portable Graymap (.pgm)</td>
</tr>
<tr>
<td>PNG - Portable Network Graphic (.png)</td>
<td>PPM - Portable Pixelmap (.ppm)</td>
</tr>
<tr>
<td>RAS - Sun Raster Image (.ras)</td>
<td>SVG - Scalable Vector Graphics (.svg)</td>
</tr>
<tr>
<td>SVM - StarView Metafile (.svm)</td>
<td>TIFF - Tagged Image File Format (.tiff)</td>
</tr>
<tr>
<td>WMF - Windows Metafile (.wmf)</td>
<td>XPM - X PixMap (.xpm)</td>
</tr>
</tbody>
</table>

**Figure 133: Lower part of the Export dialog**

### Exporting single objects

In order to export individual drawing objects, you need to first select them. A selection can include more than one object. Take care to choose the Selection option on the Export dialog.
**Exporting as a vector graphic**

The choice of vector formats is still limited. An export to a DXF format file (Autocad) is not possible. Even the export of a graphic to a SVG format file is not yet fully implemented: the graphic objects are exported as paths and 3D objects only as preview images. Best supported are the Metafile formats and exporting to one of these is usually successful.

**Exporting as a raster graphic**

The choice of formats for export as a raster graphic is large enough that you can always find one that is supported by the application you wish to use. In case of any doubt, test a number of the different formats to see which gives the best results; some programs behave differently depending on the format of the image imported into them.

After typing in a name for the exported file and selecting the file format, you may be able to set options for the exported image—compression, color format, version of Metafile—depending on the format chosen. Some examples of the various option dialogs are shown in Figure 134.

![Figure 134: Adjusting format specific properties prior to export](image)

In cases where the export dialog permits the input of the image resolution, note that this does not affect the number of raster points in the image. Rather it inserts into the picture information that tells other programs the dimensions to be used in displaying the image. This means that, among other things, missing raster points can be interpolated when the graphic is opened in the other program.

The number of pixels used is determined by the screen resolution set up within the operating system and through the Drawing scale factor set in **Tools > Options > OpenOffice.org Draw > General**. This is a limitation of the current user interface; it is possible to set other resolutions using macros.
Exporting graphics

Embedded raster graphics, or objects that have been converted to a bitmap or Metafile (from the context menu Convert > To Bitmap / To Metafile) may subsequently be saved as a picture; from the context menu choose Save as Picture. In this way the picture is saved, but without Draw-specific additions such as text elements, borders, or shadows, and without the possibility of setting any of the options referred to above.

Draw objects can be imported into Writer, Calc, or Impress documents without any problems. For objects used often this is most simply done by storing them in the Gallery or by using the clipboard. As Writer and Calc do not possess the same range of tools available within Draw, it makes sense to use Draw to produce a complex drawing and then to copy it into the other OOo application. A link to single drawing objects is not possible, but you can incorporate Draw documents in the other modules as linked OLE objects.

Modifying raster object properties

Like other objects, the properties of a raster graphic can be modified. You can format the graphic using the Format menu or the context menu. Use the Picture toolbar to adjust the Lines, Areas and Shadows properties. The Transparency property in the Format menu does not relate to the transparency of the raster graphic itself but to the background area. To set the transparency of the graphic, you must use the Picture toolbar.

Graphics can also have a text element. For more on text, see Chapter 10 (Advanced Draw Techniques).

In a manner similar to that described for drawing objects in Chapter 3 (Working with Objects and Object Points), you can change the position and size of graphics as well as rotate them. Raster graphics can be flipped (Modify > Flip), but note that some Metafile formats might have problems with the flipping of text.

Graphics included as a member of a group behave like other drawing objects when the properties of the group are modified.

You should take the opportunity to (re-)name the graphic using Name from the Modify menu or the right-click menu. Only named objects are visible in the Navigator and only named objects can be directly imported directly from another file.

View options

Graphics in the commonly used PNG and JPG file formats are stored in a compressed form and the file sizes are relatively small. If you wish to show one of these in a document it must be stored in an uncompressed form in the computer memory. This can lead to slow viewing times on systems with slower processors or less memory when your document includes many (compressed) graphics. OOo therefore offers the possibility to turn on and off the display of graphics.

The general settings are found under Tools > Options > OpenOffice.org Draw > View, in the section Alternative Display. While editing a document you can switch the display of graphics on and off using the Picture Placeholders icon on the Options toolbar. When the display of graphics is turned off, a thin frame, together with the name of the object (if it exists), is shown in place of the normal view (see Figure 135). In the preview of the page in the Pages pane, the graphic is shown as normal.
The picture (editing) toolbar

If you have enabled the Picture toolbar (in View > Toolbars), the toolbar will automatically appear on the screen whenever you select a (bitmap) picture (see Figure 136). It appears either directly under the menu bar in place of the formatting toolbar or as a floating toolbar on the screen.

![Figure 136: The Picture toolbar](image)

Note

The object bar of Draw 1.x was replaced by the Picture toolbar in version 2.x. The Filter icon was also placed on this toolbar.

The following table explains the individual functions on the Picture toolbar and illustrates their use with examples.

<table>
<thead>
<tr>
<th>Filter</th>
<th>This is a sub-toolbar and its function is described in “The graphic filter toolbar” on page 88.</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Graphics Mode</th>
<th>Use the Graphics mode menu to change the display of the graphic from normal color to grayscale, black and white, or a watermark. This setting affects only the display and printing of the picture; the picture itself remains unchanged.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default:</td>
<td>The graphic is displayed unaltered in color.</td>
</tr>
<tr>
<td>Grayscale:</td>
<td>The graphic is displayed in a grayscale: 256 shades of gray.</td>
</tr>
<tr>
<td>Black/White:</td>
<td>The graphic is displayed in black and white.</td>
</tr>
<tr>
<td>Watermark:</td>
<td>The brightness and contrast of the graphic are reduced to the extent that the graphic can be used as a watermark (background).</td>
</tr>
</tbody>
</table>
The picture (editing) toolbar

**Color**

Use the Color tool to adjust the values of the three RGB colors, the brightness, contrast and the Gamma value. These adjustments do not affect the original picture but the values are stored in Draw as a separate formatting set.

You can select values from between −100% (no color) to +100% (full intensity); 0% indicates the original value of the property.

The brightness can be adjusted between −100% (totally black) and +100% (totally white).

The contrast can be adjusted between −100% (minimum) and +100% (maximum).

The Gamma value affects the brightness of the middle color tones. Values can range from 0.10 (minimum) to 10 (maximum)

Hint: Try adjusting this value if changing brightness/contrast does not quite give you the result you want.

**Transparency**

The degree of transparency of the picture can be adjusted between 0% (opaque) and 100% (fully transparent).

**Crop**

Use this function to crop (trim) a graphic. When you click on this icon, a Crop dialog is opened (see “Cropping” on page 87).

**Line**

Opens the Line dialog. In this context, line refers to the outline of the border. See also Chapter 4 (Changing Object Attributes).

**Area**

Opens the Area dialog. Here you can edit color, gradient, hatching and fills of the background area that contains the graphic—not the graphic itself. To see the background, you must set the transparency of the graphic to a suitably high value.

**Shadow**

Use this tool to set a shadow effect around the graphic.
Cropping

The fields *Left*, *Right*, *Top*, and *Bottom* establish the amount to be trimmed off the appropriate edge. The new dimensions of the graphic are shown in the *Image Size* field. The dimensions are related to the original size of the graphic. In Figure 137 you can see that 3 cm from the sides and 2 cm from the top and bottom will be trimmed from the original object size. The preview pane shows the location of the new edges of the graphic.

- If you choose *Keep Scale*, the graphic will be cropped to the scales shown in the width and height boxes (in the above example both 32%) and the picture reduced in size accordingly.
- If you choose *Keep image size*, the graphic will be cropped and then enlarged to the original image size.

In addition to cropping, you can also enlarge or reduce the size of the graphic by changing the percentage scaling values, or directly determine the size in the *Image Size* width and height boxes. Take care with these operations: in the Crop dialog the width and height are treated as totally independent values. Changing one without the other can result in significant distortion of the image; this might not be what you want. (The Position and Size dialog on the context menu has an option for keeping the width:height ratio fixed while changing one of the two dimensions.) Changing values in one area (Scale or Image Size) will show up correspondingly in the other area.

**Caution** Any changes made in the Crop dialog change only the *view* of the picture. The original picture is not changed. If you want to export a cropped graphic, you must do it through *File > Export*. If you use the option *Save as Picture* from the context menu, the changes are *not* exported.
Click the **Filter** icon (icon) to open the Filter toolbar. Draw offers eleven filter effects. Filters work on the current view of an object and they can be combined. Filters always apply to the entire graphic; it is not possible to use filters to edit only a part of the object.

- **Invert**. The colors of an image will be inverted (reversed) so that it appears as a color negative of the image.

- **Smooth** reduces the contrast between neighboring pixels and produces a slight lack of sharpness. If you use the filter several times in a row, the effect will be strengthened.

- **Sharpen** increases the contrast between neighboring pixels, emphasizing the brightness difference. This will accentuate the outlines. The effect will be strengthened if you apply the filter several times in a row.
**Remove noise.** The filter reduces noise, in which every pixel is compared with its neighbors, and the extreme values (those that deviate in color by a large amount from a mean value) are replaced by a pixel with a mean color value. The amount of picture information does not increase, but because there are not so many contrast changes our brains can better recognize the resulting graphic. This filter tends to make the picture also a little more smooth.

**Solarization** was originally a photochemical effect. If the location of the photograph is extremely highly lit, you can experience a reversal of color and brightness. Similarly, entry of light during the developing process reverses the brightness values. These phenomena were used for artistic production of pictures.

With this effect filter you input a threshold value, above which brightness the color values are reversed (middle picture, threshold value 70%). With the Invert option the whole of the resulting picture will be inverted in color (right picture).

**Aging** lends pictures a certain “look” resembling that of old photos. The process first produces a grayscale picture from the original and then reduces the intensity of the blue and green color values, so that the final picture appears darker and redder. In the middle example, the aging degree was set to 0%, at right it was 15%.
The **Posterize** filter reduces the number of colors in the picture. The fewer colors, the more flat the picture appears. In the right picture below the number of colors was reduced to 8. The results of this filter are not always good.

The **Pop-Art** filter is supposed to change the colors of the picture to a pop-art format, but unfortunately it does not seem to function correctly at present.

The **Charcoal sketch** filter makes the picture appear as if it had been drawn with charcoal. The outlines are in black and the original colors are suppressed.

The **Relief** filter calculates the edges in relief of the picture and produces a picture as if illuminated by a light source, the position of the illuminating light being variable and producing shadows in different directions and magnitude.
The **Mosaic** filter takes a number of pixels and converts them into a single color rectangular ‘tile’. The whole picture is tiled and appears to be a mosaic. Both pictures below had an element resolution of 5 pixels. The picture on the right had in addition the **Enhance edges** option selected, and with the greater contrast at the edges appears to be a little sharper.

If your picture is linked, filters are applied only to the current view. The stored picture is not changed. When you close the document, all filtering is lost. You should ensure that you export the picture to create a copy with all the filters applied (**File > Export**).

If you have embedded the graphic in the document, all filters are applied directly on the embedded graphic. You cannot remove filtering applied to a picture. If you do not want to retain a filter, you must use **Edit > Undo** to return to an earlier state of editing. After you save and close the document, the filter effects are permanent.

**Eyedropper**

Use the eyedropper to change one color in a picture for another or set the the color as transparent. The tool works always on the entire picture; you cannot select only a region for editing.

The changes are carried out on the graphic itself. For this reason you cannot use the eyedropper tool on a linked graphic. If you try, you will receive the following message.

The tool can be used on all raster graphic formats and with many Metafile formats.

**Note** Contrary to the statement in the Help, the eyedropper does not currently work on some Metafile formats.
Practical example: Changing wrong colors to transparency

Some applications, which cannot correctly handle transparency, show transparent areas with the color Magenta and then store the graphic without the correct transparency information with this color.

Bitmap graphic with area in magenta, which actually should be shown transparent. On the left is the original picture, right is the picture after saving it with MS Paint.

If you receive such a picture, you can recreate the transparency with the eyedropper tool.

Open the Eyedropper dialog with Tools > Eyedropper and click on the picture to be edited.

Now click on the icon , to change to the color selection mode. Outside the dialog the cursor changes to a hand. The field next to the icon shows the color immediately under the hand cursor.

Click on the color to be changed. The first Source Color box is now marked and the color selected appears in the left box. In the Replace with selection list, the option Transparent is already selected. You can then click on the Replace button at the top right of the box to carry out the changes to the picture. There is no preview of the effect. If the result is not what you wanted, choose Edit > Undo.

The dialog does not close automatically, so you can carry out further color replacements. Mark first the field for the Source color and choose again the color with the eyedropper. Close the dialog with Ctrl+F4 or the Close icon on the window border. Draw uses an Alpha channel for transparency so that pixels of different colors can be made transparent.
It is also possible to carry out the operation in reverse, to change a transparent area to a color. For this process, select nothing in the graphic but mark the Transparency checkbox at the lower left of the dialog and at lower right select the color to replace areas that are currently transparent.

The selection list for replacement colors shows all the available colors in the current color palette of the document. You cannot define any new colors here but you can add colors to the available palette before using the eyedropper tool. For more on this topic, see Chapter 8 (Tips and Tricks).

**Effect of the tolerance parameter**

The tolerance parameter describes how exactly a color value in the picture must agree with the source color, in order to be replaced. In the figure the red color tone at the left edge of the color palette was input and a pure blue chosen as the replacement color. The original is a rectangle with color palette from red to green. Because the eyedropper is not usable on drawings, the rectangle on the left side was converted into a raster graphic (Convert > Bitmap). The picture was then exported in an Enhanced Metafile format and again inserted.

![Color depth example](image)

**Note** The application of transparency effects on raster graphics and Metafiles leads to quite different results. This is a known problem, which will be corrected in a future version.

**Color depth**

**Modifying the menu**

In OOo 1.1 the context menu contained a submenu *Color resolution*. This is no longer available in version 2 although the individual commands still exist. If you want to have all these commands available, you should create a separate menu (refer to OOo help if you are not sure how to do this). For most of these commands there is no icon available and creating a separate toolbar is probably not worthwhile.

To find the tools, click on **Tools > Customize, Toolbars**, and **Add** (Command). The commands are in the category *Modify*, at the top of the list.
Reducing color depth

Original with a 24 bit pixel depth (=8 bits per channel)

1 bit dithered

The impression of grayscale is produced by a raster. Actually there are only two colors.

1 bit threshold

You cannot directly set the threshold value. With the help of the color tool on the Picture toolbar you can influence which part of the image is set to black (vary color settings—red, green, blue level, brightness, contrast and/or gamma value—to see what works best for your image). To do this you must first export and save the modified image with File > Export and then reopen it, before you finally change the color depth.

4 bit color palette

With 4 bits a total of 16 colors can be produced. The color steps are quite fine, because the process uses not the 16 RGB basic colors, but selects those from the palette which best match the colors in the image.
4 bit grayscale palette

8 bit color palette

With 8 bits a total of 256 colors can be produced. The image at left is at first glance very difficult to distinguish from the original. A big difference is that the picture is only one third of the size of the 24 bit version.

8 bit grayscale palette

Conversion

Convert to a contoured image

Select the picture so you see the green handles. From the context menu or from the Modify menu choose Convert > to Contour. This command creates from the original image a polygon or group of polygons, with four corner points and the image set as a background graphic. In this state you are not able to further edit the graphic. All your modifications must be completed before this point.

The polygon is in fact a vector graphic but the picture remains as a bitmap image. The polygon offers you in any case a number of possibilities for further change: modify shape or define transparency gradient.
Convert to a polygon

Select the picture so you see the green handles. From the context menu or from the Modify menu, choose Convert > to Polygon. This command creates, from areas of the same color, a number of small polygons filled with color. The total image effectively becomes a vector graphic and can be resized with no loss of image quality. The resulting format will be a Metafile.

The conversion begins with the Convert to Polygon dialog, where a number of settings can be defined. The Preview button generates a preview of the conversion with the current settings. Because graphics conversion can take some time, depending on the picture and the computer, a progress bar is included at the bottom of the dialog (see Figure 138).

![Figure 138: Conversion of a picture to polygons](image)

**Number of colors**

Draw considers between 8 and 32 colors in the conversion. The picture can, however, contain fewer colors. For every color occurring in the picture, Draw creates a polygon; the polygon may in fact consist of several disconnected parts. These polygons are then filled with the relevant color.

The algorithm used in the reduction of the number of colors is not yet optimal. It is worthwhile to try reducing the number of colors by changing the color depth or with the Poster filter.

**Point reduction**

Polygons will only be created if they have a size greater than the value given in this setting. The section of the picture below, highly magnified, shows that with a larger point count small flecks of color—typical of irregular color patterns—simply disappear.
**Fill holes**

Point reduction can result in small areas or “holes” which are not covered by a polygon. If the Fill holes option is marked, additional square, tiled areas are created with a background color the same as the hole. The Tile size option allows the width in pixels of the width of these square areas to be preset.

Original picture

Original picture with 16 colors and 0 Pixel point reduction vectorized

Original picture transformed with the Poster filter and 64 colors …

… and then with 16 colors and 0 pixel point reduction vectorized.
Here again the picture is transformed with the Poster filter, but this time with a point reduction of 4 pixels and a tile size of 16 pixels.

The effect below was generated from the picture at left (posterized and vectorized), the polygons were split with Modify > Break, and a number (in this case 6) of the (foreground) polygons were deleted until the resulting background was achieved.

Note: To select such polygons for deletion, click on a curved colored area (the text in the status bar shows “Polygon nnn corners selected”, where nnn is the number of corners of the polygon) and a frame with green handles encloses the area of the polygons selected. Press Delete to delete the polygons. Repeat until you have achieved the desired effect, here to have only the background showing.

If you next split the existing Metafile (Modify > Split), access is gained to individual polygons. To be able to operate on these together you should immediately group them after splitting.

With such a vectorized form of the image you can now carry out operations which you would know from classic drawing programs. It is possible for example to carry out a curved warping operation. For transformations like this it is much less effort to use a conversion with background tiles, because then the edges of the picture are straight.
Conversion

To use this tool to vectorize the first letter of a chapter in a special font, set the color depth to 1 bit and do not use any background tiling. An example is shown below.

Original polygon.

After the conversion there are two polygons, one with the visible letter and another polygon, not visible because the lines and area filling are all in white. You can select this “invisible” polygon by pressing the Tab button (click on the visible letter first, then press Tab; this moves the current selection to the next object). In the example at left, the invisible polygon has been moved to the side.

This invisible polygon encloses the letter. After changing lines and area to a different color, the polygon becomes visible.

Convert to bitmap

With the command Convert > To Bitmap from the context menu, you can convert a vector graphic (all drawing objects are vector graphics) to a raster graphic. Draw creates a raster graphic in PNG format with a color depth of 24 bits. Any transparency effects which were created in the vector graphic are unfortunately lost in this conversion, although the PNG format used in Draw does support transparency. Only if you use the eyedropper tool to set transparency will an Alpha channel also be produced.

To determine the number of pixels required, Draw considers the dpi setting of the operating system for the screen and the percentage scaling factor set under Tools > Options > OpenOffice.org > View in the section User Interface.

Example:

Width of vector graphic: 1.5 inch
Monitor setting of operating system: 96 dpi (= 96 dots per inch)
Scaling 130 %

Calculation: 1.5 inch x 96 dpi *130% = 187 pixels

The actual number of pixels will vary somewhat from this value due to rounding. When the format permits, Draw uses a dpi value (in this case 125 dpi) which permits the calculation to be reversed and the picture with this pixel value reproduced with the correct width of 1.5 inch.
**Print options with raster graphics**

If you have a black and white printer or are experiencing problems with printing, you should have a look at the following settings.

You can set up printing so that all text and all graphics are printed in grayscale or black and white. The general settings are in **Tools > Options > OpenOffice.org Draw > Print** in the section *Quality*. The same settings may be set for the current document only under *Options* in the Print dialog (**File > Print**). With both Black & white printing and Grayscale printing, no background is printed.

---

*Figure 139: Options - OpenOffice.org Draw - Print*

Other options are in **Tools > Options > OpenOffice.org > Print**. They relate to page options (scaling) and other printing variables. They affect the size of the print file and the time taken to print the document. With most modern systems you can simply accept the defaults. As different operating systems and printers have their own requirements, you need to tailor the settings to your particular site conditions. Refer to the individual sections of the Help file for more information.

---

*Figure 140: Options - OpenOffice.org - Print dialog*
Chapter 7

Working with 3D Objects
Creating 3D objects

Although Draw does not match the functionality of the leading drawing or picture editing programs, it does offer a wide array of tools and methods to produce and edit very good 3D drawings and pictures.

Draw can render drawings using internal routines or it can use the OpenGL libraries if they are installed. The use of OpenGL can be switched on or off under Tools > Options > OpenOffice.org > View (see Figure 141).

![Figure 141: OpenGL option](image)

Draw offers two different types of 3D objects: the ones carried forward from OOo version 1, 3D bodies, and the ones newly introduced in version 2, 3D shapes. Depending on which type you choose, there are different possibilities for further editing of the object (rotation, illumination, perspective). Setting up and editing 3D objects is simpler with 3D shapes than with 3D bodies, but 3D bodies currently allow for more customizing than 3D shapes.

Creating 3D bodies

You can produce 3D bodies in several different ways: extrusion, body rotation, and using ready made objects.

**Variation 1: Extrusion**

First draw one of the common Draw objects, for example a square/rectangle, circle/ellipse or a text box using the or icons on the Drawing toolbar. Next choose Modify > Convert > To 3D (alternatively right-click on the object and choose Convert > To 3D, or click the icon to produce a 3D object from the 2D surface.

The icon is not usually visible on the Drawing toolbar. To make it visible, select Visible Buttons from the toolbar menu at the right hand end of the toolbar and click on the icon to make it visible.

![Figure 142: Extruding 3D objects from 2D surfaces](image)

The procedure by which parallel surfaces are moved to create a 3D object is known as *extrusion*. In this case the 2D surface is moved forwards “out of” the drawing level. At the same time the object is slightly tilted and central projection turned on so that one can better recognize the object. Draw uses a default value for the extrusion (the body depth) based on the size of the 2D object. The value can be changed after the extrusion; see “Editing 3D objects” on page 106).
**Variation 2: Body rotation**

Choose a common drawing object, for example a (non-black) line. Then change this into a rotation body. Draw provides two methods to do this.

**Method 1.** Click the icon 🔄 in the Drawing toolbar (this icon is also usually not visible) or choose **Modify > Convert > To 3D Rotation object.** With this rotation method, the axis of rotation lies always on the left edge of the enclosing rectangle, through the green rectangle handles.

![Figure 143: Rotation body created using variation 2.1](image)

**Method 2.** Click the icon 📢 on the pulldown menu **Effects** on the Drawing toolbar. Watch out – this icon has no large red arrow. The same icon can be accessed from the tearoff menu Mode, opened with **View > Toolbars > Mode.**

With this method, you can change the location of the rotation axis.

![Figure 144: Rotation body created using variation 2.2](image)

Click one of the white endpoints and drag it so that the axis moves to the desired position. You may need to move both ends to achieve this. The outline shows how the figure will be rotated. When you click on the figure again, the rotation is carried out and the new 3D body is produced.

**Variation 3: Using ready-made objects**

Use the 3D Objects toolbar/pulldown menu (Figure 145). To activate this toolbar, click **View > Toolbars > 3D Objects.**

![Figure 145: The 3D Objects toolbar](image)
Creating 3D objects

If you add the icon to the Drawing toolbar, the 3D Object bar will be available as a pulldown menu or as a floating toolbar.

After choosing the type of object, left-click on the starting point and drag the mouse diagonally until the outline of the object is the size you want.

After releasing the mouse button, the 3D object appears. If you keep the Shift key pressed while dragging the mouse, you can change the height:width ratio of the object. These objects are constructed as rotation objects. Cubes and spheres are special types of 3D objects that are directly defined in the OoO program code.

3D scenes

Variations 1–3 all produce a result known as a 3D scene. If you click on a 3D scene, the status bar text shows 3D scene selected. Such a scene is actually a group of objects.

As mentioned in Chapter 6 (Editing Pictures), you can access individual elements of the group using Modify > Enter group or the context menu. The status bar text then changes and shows the type of each individual element selected, for example Sphere selected or Extrusion object selected.

If you constructed the object using one of the above methods, the 3D scene consists of the 3D body as a single element. 3D scenes can, however, be extended to include other 3D objects, as described in “Combining objects in 3D scenes” on page 123.

Producing 3D shapes

With the release of Version 2.0 of OpenOffice.org, Draw contains a new type of drawing object: Shapes. A special method of extrusion exists for these shapes.

Variation 4: Extrusion of shapes

You use the Basic Shapes toolbar (or another shape toolbar) to produce 2D surfaces. Shapes such as cylinders or cubes are technically possible but not very useful, because they produce curiously curved images. If you have drawn a shape, the last icon of the Drawing toolbar is active. A click on this icon can transform a 2D surface into a 3D object (see Figure 147).

If this icon is active, it changes the object view to 3D. Actually it does not create a new object type but changes only the appearance. With the same button you can also go back to a 2D view. It is a switch allowing both types of views to be shown. The actual object properties and settings are not lost in the switching operation from one view to another.

Figure 146: The Basic Shapes toolbar

You use the Basic Shapes toolbar (or another shape toolbar) to produce 2D surfaces. Shapes such as cylinders or cubes are technically possible but not very useful, because they produce curiously curved images. If you have drawn a shape, the last icon of the Drawing toolbar is active. A click on this icon can transform a 2D surface into a 3D object (see Figure 147).

If this icon is active, it changes the object view to 3D. Actually it does not create a new object type but changes only the appearance. With the same button you can also go back to a 2D view. It is a switch allowing both types of views to be shown. The actual object properties and settings are not lost in the switching operation from one view to another.

Figure 147: 3D objects from basic shapes
Creating 3D objects

If you click on such an object, the 3D-Settings toolbar is available. If this is not automatically opened switch it on with View > Toolbars > 3D-Settings.

![3D-Settings toolbar](image)

**Figure 148: 3D-Settings toolbar**

The first icon corresponds to the icon on the Drawing toolbar. This icon also works as a switch. After changing to 2D, the 3D-Settings toolbar is again hidden. To change the object again to 3D, you must use the icon on the Drawing toolbar.

**Variation 5: Fontwork**

For text you can also use the shapes from the Fontwork Gallery. These produce a similar type of extrusion objects to those from Variation 4. The Fontwork Gallery is opened with the icon on the Drawing toolbar (see Figure 149).

![Fontwork Gallery](image)

**Figure 149: Extrusion Shapes from the Fontwork Gallery**

Draw objects of the type “Shape” cannot be viewed with OpenOffice.org Version 1.x. They are simply missing from the drawing. If you save a document with extruded shapes in the older *.sxw format, the shapes will be converted to 3D scenes.
Editing 3D objects

Rotating 3D objects

Procedure for 3D bodies

With the Rotation command used for 2D objects, you can also edit 3D objects. Due to the additional axis, there are a few differences with the editing of 3D objects (see Figure 150). The selection of the object is identical to that used for a 2D object.

You can rotate the object about each axis (X,Y,Z). The X and Y axes are parallel to the edges of the drawing layer, while the Z axis comes out of the page. It is not possible to change the axis orientation. The three axes themselves are not shown directly, but the symbol indicates the intersection point of all three axes.

You want to … \hspace{1cm} You must …
... rotate the object about the X or Y axis. \hspace{1cm} ... put the mouse cursor over the object. With the left mouse key pressed you can now rotate the object as you wish. Moving one of the red points at the middle of an edge allows you to rotate the object about only one axis. Note that the cursor initially shows the cursor for a (2D) shearing movement but pressing the mouse button changes it to a rotation cursor.

... rotate the object about the Z axis. \hspace{1cm} ... move the handle on one of the corner points with the left mouse button pressed. Rotation about the Z axis is independent of the setting of the rotation angle in the dialog Position and Size.

... move the axis intersection point. \hspace{1cm} ... simply drag the Symbol to the desired location. The point is located by default in the middle of the object.

These rotations can be carried out either on the 3D scene as a whole or on individual objects within a 3D scene.
Procedure for 3D shapes

Objects produced using variations 4 and 5 (see above) can only be rotated about the Z axis using the three methods described in the previous section. This rotation is carried out on the underlying 2D object. It is also possible to rotate the 3D (as with 2D) object using Format > Position and Size > Rotation (shortcut key for Position and Size is F4) and giving in the pivot point location and the number of degrees of rotation desired.

Shape objects have their own procedure for rotation about the X and Y axes. If you have activated the 3D-Settings toolbar (under View > Toolbars) this becomes active when you select the 3D object, and icons 2 to 5 on this toolbar (see Figure 151) rotate the object in 5 degree increments about the X and Y axes.

3D settings for 3D bodies

3D Effects dialog – general buttons

The 3D Effects dialog offers a wide range of possible settings for 3D objects produced with variations 1 to 3 (see previous sections). To open the dialog, right-click on such a 3D object and choose 3D Effects from the pop-up menu. You can also activate a 3D Effects icon on the Standard toolbar or add it to another toolbar using Customize Toolbar > Add > Category Options > 3D Effects.

The dialog can be docked in a similar manner to the Navigator or Template windows.

The possible settings are arranged in various thematic categories. The buttons at the top of the window serve to bring up the appropriate dialog pages. To apply the settings you have altered on a dialog page, click the Assign button. This applies all the changes you have made—on the other pages of the dialog as well as the current one—to the object.

Note

Only the selected effects are assigned to the object. There is no object conversion; thus a cylinder cannot be transformed into a ring through the application of a 3D effect. However, it is possible to change the appearance to a wooden or metal body. By the assignment of a 3D effect, 2D objects are transformed into 3D objects.

So that the Effects dialog can take over all the current properties of the object, you must click the button. If you deactivate this button before you leave an object and click on it again when you open the Effects dialog for another object, the settings are carried over from the first object to the second object. You can use this as a sort of a transfer of “favorite” settings from one object to another as all the settings are brought over to the other object. In normal use, however, the icon should be left activated.

Chapter 7 Working with 3D Objects
Editing 3D objects

In the lower area of the dialog is another row of buttons (see Figure 153), which are available on each page of the dialog.

Figure 153: Buttons for geometric transformations

The first two buttons correspond to the menu commands Modify > Convert > To 3D / To 3D Rotation Object. When the dialog for a 3D object is called up, these buttons are inactive. The third icon switches on or off a perspective view of the object.

- Converts the selected 2D object to an extrusion body.
- Converts the selected 2D object to a rotation body.
- Switches between a central projection and a perspective projection.

With a central projection parallel edges are shown as meeting at some common point in the distance, as shown on the button symbol. Parallel projection retains all parallel edges as parallel, as is often used to produce oblique figures in school. The switching process is carried out on the entire 3D scene.

With central projection (see Figure 154) Draw produces the object with three vanishing points. The parameters for central projection are set indirectly through the camera settings on the dialog page Shading.

Figure 154: Figure shown using central projection. For clarity the projection lines have been added.

Dialog page - Geometry

On the Geometry page (see Figure 155), you can make changes to the geometry of a 3D object. This page is opened with the Geometry button in the upper part of the 3D Effects dialog.
In the first example, the depth (length) of a body is to be changed. This only makes sense if you created it through extrusion. Draw a circle and convert it according to variation 1 above into a 3D object (a flat cylinder); see Figure 156a and b.

If necessary, select the cylinder, change the parameter Depth to 3.5cm and click on the Assign icon. The cylinder should now resemble the figure in Figure 156c.

This parameter cannot be applied to a rotation body or one of the ready-made 3D objects.

With the parameter Rounding you can specify how strongly the edges of the 3D object are rounded. Select (if necessary) the lengthened cylinder again and change the rounding to 30%. The cylinder should now resemble that in Figure 157.
Editing 3D objects

This parameter is also interesting if you convert text into a 3D object. The rounding process works also on objects which have been extruded.

The parameter Scaled Depth sets the ratio of the size of the front to that of the back of a 3D object produced using extrusion. The front side of a 3D object produced by extrusion always protrudes out from the original surface – the rear side is the original surface of the 2D object, that is the 2D exit surface, even if the object has in the meantime been rotated.

By default the scaling is set to 100%, which results in both surfaces being scaled by the same amount. If you set this scaling to 50% the cylinder becomes the frustum of a cone (see Figure 158).

![Figure 158: Cylinder with 50% scaling](image)

The diameter of the front side is 50% that of the corresponding rear side. It is of course also possible to create the reverse effect, with the rear side smaller than the front side, by using a value of scaling depth greater than 100%.

With rotation bodies this parameter influences the width of the surface parallel to the axis of rotation. At the end of the rotation the surface width is the figure given by the scaling depth. The distance to the rotation axis remains unchanged. In Figure 159 a line is rotated to create a 3D object with a scaling depth figure of 0%.

![Figure 159: Scaling depth of a rotation body](image)

The parameter Rotation Angle is only available for rotation bodies. With this parameter you can create a segment of a complete rotation body by choosing an angle less than 360 degrees. Figure 160 shows a hemisphere with a rotation angle of 270°.

![Figure 160: Hemisphere with a rotation angle of 270°](image)
The parameters *Horizontal* and *Vertical* Segments define the number of segments out of which Draw builds spheres and rotation objects\(^6\). With rotation objects the horizontal segments are of more importance. The vertical segments have an influence on the degree of edge rounding.

In Figure 161 the left sphere is made up from 10 horizontal and vertical segments while the right sphere has 25 segments. The more segments you choose the smoother the surface will be, but it will take longer to generate the figure on the screen. By default spheres and hemispheres are constructed with 24 segments. For a square pyramid you need four horizontal segments.

![Figure 161: Sphere from 10 segments (left) and 25 segments (right)](image)

These are properties belonging to individual objects. If you use the setting for segments on a 3D scene, all the objects contained in the scene are modified accordingly.

If you extrude an unfilled circle or intersecting lines with a filling the result is probably not what you expect. In this case the Double-Sided \(\text{Double-Sided}\) tool, on the lower part of the dialog page, may be able to help. The effect becomes clear when one changes the line properties of an object from invisible to continuous and so enables all edges to be seen. Otherwise it may happen that some surfaces receive no filling (see Figure 162). For lines without filling the effect is switched on by default and cannot be switched off. This is also a property of single objects.

![Figure 162: Left: without "Double-Sided"
Middle: with continuous lines but without "Double-Sided"
Right: with "Double-Sided"](image)

Use the buttons in the section *Normals* to modify the normals of a 3D object.

A *Normal* is a straight line which is perpendicular to the surface of an object (in the same way that a vector, starting from inner and extending outwards, is at right angles to the surface of the object at the point where it exits. Figure 163 shows some normals extending outwards from a sphere made up of 10 segments.

---

\(^6\) To reduce both calculation time and data storage, circles are often constructed as regular polygons. If you cut a sphere or cylinder of 10 segments through the middle you end up with a 20 cornered cut section (10 cornered for a hemisphere).
Using normals the display of the object surface and the variation in colors, textures and lighting can be controlled. You can thus influence directly how the surface of the object is rendered.

The three icons in the first row work as “Either-Or” switches. Only one of the effects can be active at a given time – an effect can be switched off by clicking on one of the other icons.

The setting is associated with an individual object – every object can have its own setting. The rest of the icons are “normal” On-Off switches. The following effects are available:

- **Object specific**: The object is so rendered, that independent of its shape the best result is generated. Single segments are changed but their “edges” will hardly be visible.
- **Flat**: The surface of the 3D object will be divided into single polygons, whose edges are clearly recognizable. Every polygon is generated with a uniform color.
- **Spherical**: The enclosing sphere is calculated for the object and then projected onto the object. This form of calculation produces an object with a smoother surface; the edges of individual segments are more smoothly rounded than with the Object-specific effect (see Figure 164). Surfaces that meet at a point do not have a realistic lighting effect.
- **Invert Normals**: This results in a reversal of the lighting direction. The inside of the body then becomes the outside. This property is particular to each individual object.
- **Double sided illumination**: The lighting is also computed for the inside of the object. In other cases the lighting value for the outside is simply transferred to the inner side. This property is of interest for open objects.

It is a property of the 3D scene and affects all objects in the scene.

The following table shows the linkage between Double sided illumination and Invert Normals.
The light source is on the right.

<table>
<thead>
<tr>
<th>Normals not inverted</th>
<th>Normals inverted</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Image" /></td>
<td><img src="image2.png" alt="Image" /></td>
</tr>
<tr>
<td><img src="image3.png" alt="Image" /></td>
<td><img src="image4.png" alt="Image" /></td>
</tr>
</tbody>
</table>

No double sided illumination

With double sided illumination

**Dialog page - Shading**

The Shading page (see Figure 165) offers functions for shading of the object surface, addition of shadows and “camera settings”.

![Image](image5.png)

**Figure 165: Shading page**

**Shading** is the rendering method, involving a consideration of the lighting ratios, which is used to produce curved 3D surfaces. The surfaces are broken down into small triangular segments. Draw offers three methods to produce this effect: *Flat, Phong and Gouraud*. The setting selected applies to all objects in the 3D scene.
Editing 3D objects

- **Flat** is the fastest and simplest method. For every individual segment a special color tone is determined, based on the lighting ratio and the direction of the segment area. This tone is used for the whole area of the segment. The segmentation is clearly visible.

- **Phong** is the most time-consuming method. With this method, for each pixel the associated normal is determined by interpolation, based on the normals of the segment edges. This causes the segment area to appear curved and the segment intersections are no longer visible.

- **Gouraud** is a relatively quick method. It determines the color value for the segment corners and calculates the color value for every pixel through linear interpolation. The segment edges are still recognizable, but importantly are less so than with the flat method. The Gouraud method considers only light reflection on diffuse, reflecting surfaces (dispersal).

![Figure 166: Flat, Phong and Gouraud shading](image)

In Figure 166 the left sphere was rendered with flat shading, the middle with Phong and the right with Gouraud. The quality of the flat method is clearly different to the other two. The difference between Phong and Gouraud is small. With the Gouraud method the segments can be very faintly seen and rendered objects have a slightly less “shine” than with the Phong method.

All three methods function at the pixel level and as such, shadowing and mirroring inside the 3D scene is not possible in the way that ray tracing methods permit.

With the the Shadow button you can provide a 3D object with a shadow. By changing the Surface angle you can influence the form of the shadow (see Figure 167). The left sphere has a surface angle of 0° (the paper lies at right angles behind the object) while the right sphere has a surface angle of 45°. With 90° the paper would be directly under the object.

![Figure 167: Shadows using different surface angles](image)

The shape and size of the the shadow are influenced also by the lighting properties. These can be adjusted on the dialog page *Illumination*. Multiple light sources are at this time not supported. The shadow properties can be set for individual objects in a drawing but the shadow produced is that of the entire scene where objects form part of a 3D scene.

It is possible to set the shadow property for single objects using the Area property. The shadow is then shown with the color selected in the shadow dialog, however again the representation of the lighting of the scene determines the end result of the entire scene. In this way, colored shadows, with different distance to the object, color and transparency effects are possible.
In the field *Camera* of the shading dialog the settings of the virtual camera can be changed. These settings relate only to the view in central projection and apply to the entire 3D scene. With the *Distance* parameter the spacing between the camera and scene is adjusted. The default value for an extruded body is equal to the predetermined depth. With equal length edges front and rear the effect at large distances is quite small. The standard value of *Focal length* is 10cm. It has the same significance as with an ordinary camera. Larger focal lengths work like a telephoto lens, smaller like a wide angle lens. The effect that changes in the camera settings have on an object are shown in Figure 168.

![Figure 168: Effect of camera settings](image)

Picture *a* shows the 3D object with the standard settings. The individual changes are listed in the following table.

<table>
<thead>
<tr>
<th></th>
<th>a</th>
<th>b</th>
<th>c</th>
<th>d</th>
</tr>
</thead>
<tbody>
<tr>
<td>Distance:</td>
<td>0.81 cm</td>
<td>3.81 cm</td>
<td>0.81 cm</td>
<td>0.81 cm</td>
</tr>
<tr>
<td>Focal length:</td>
<td>10 cm</td>
<td>10 cm</td>
<td>5 cm</td>
<td>15 cm</td>
</tr>
</tbody>
</table>

**Dialog page - Illumination**

On the Illumination page (see Figure 169) you define how a 3D object is lit. The settings apply to all objects in a scene.

![Figure 169: Illumination (lighting) page](image)
You can light a scene with a maximum of eight individual Light sources at the same time. For each of these sources the light color and position relative to the scene can be set. The light sources are shown in the form of eight small light bulbs. When you select this dialog page the first bulb “lights up” 7. This symbol functions like a press switch. With the first mouse click the bulb is selected and with the second click the settings mode for this light source is activated (see Figure 170).

In the selection list next to the symbols you can choose the color of the active light source. If desired, the button gives access to a color palette dialog, with which you can define your own color. This dialog also allows the brightness to be adjusted (in the underlying colors dialog). For the first light source it is best to retain the neutral color value (default is white), with several light sources it is advisable to reduce the brightness.

In the lower right corner of the menu the light source location and orientation is depicted. With the vertical slider bar you can adjust the lighting angle; with the horizontal bar the light is rotated about the object. Alternatively you can click on the light point with the mouse and drag the point as you please (see Figure 171). With a click on the small square in the bottom right the preview image can be changed from a sphere to a cube.

7 There must always be at least one light source active, otherwise the rendering and shading functions cannot function correctly.
To apply the changed settings to the selected object, click on the the **Assign** button.

The use of additional light sources can result in some interesting effects.

![Lighting Settings](image)

*Figure 172: Lighting with three independent light sources*

In Figure 172 the ring has the lighting settings from Figure 171 with the standard color white. In addition it was lit with the color magenta and from the left underside also with yellow. The number and position of the light sources is shown in the window at the lower right. The light sources in use can be recognized by the “lit” symbol.

To see the effect of a particular lighting effect you can also temporarily turn it off. With an object selected, clicking on a “lit” symbol turns it “off”. This new setting must then be applied (assigned) to the scene. With a further mouse click on the light source the effect can be switched back on and then re-assigned to the scene.

You can also change the settings for the **Ambient lighting**. The selection of properties (lighting color, brightness etc.) is carried out in same way as for light sources.

**Dialog page - Textures**

Textures are raster graphics (bitmaps) which can be used as an object property for the surface of an object. Every object of a 3D scene can have its own texture.

You can set a raster graphic as a texture for a 3D object in the same way as for a 2D object (**Format > Area > Bitmaps** or right-click on the object > Area > Bitmaps) – as is the case for Gradient and Hatching. More details are found in Chapter 4 (Changing Object Attributes).

If the Fill setting on the Area dialog is **Color**, then the Texture page is inactive. Change it to Bitmap to activate the Texture page for 3D objects. If the texture is not tiled or stretched and is smaller than the object, then the remainder of the area will have the color of the Object color property on the Material page.

In the first row of the page (Figure 173) are two switches (Type) with which you can choose between black and white or color for the texture (see Figure 174).
With the two switches in the row **Mode** you can control whether the texture of the selected objects is rendered with light and shadows (Switch 2) or not (Switch 1); see Figure 175. By means of appropriate lighting and shading adjustments, the graphic object is more realistically rendered.
**Projection X / Y**

With one of the three buttons you can determine how the texture for this coordinate axis should be projected onto the object. The default setting, *Object specific*, in general gives the best result. Examples of the use of each button are shown below.

<table>
<thead>
<tr>
<th>Button</th>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Object specific" /></td>
<td>Object specific</td>
<td>The texture is automatically adjusted to best fit with the form and size of the object.</td>
</tr>
<tr>
<td><img src="image" alt="Parallel" /></td>
<td>Parallel</td>
<td>The texture is projected parallel to the axis of the object. It is mirrored on the rear side of the object.</td>
</tr>
<tr>
<td><img src="image" alt="Circular" /></td>
<td>Circular</td>
<td>The axis of the texture pattern is wrapped around the object.</td>
</tr>
</tbody>
</table>

With a rotation body, the turning axis is the Z axis and the wrapping in the X direction; with an extrusion body, the extrusion direction is the Z axis and the extruded surface is the X direction. In this way different positions of the texture result, depending on how the object was produced.

With a rotation body, the turning axis is the Z axis and the wrapping in the X direction; with an extrusion body, the extrusion direction is the Z axis and the extruded surface is the X direction. In this way different positions of the texture result, depending on how the object was produced.

![Figure 176: Cylinder as a rotation body](image)
**Editing 3D objects**

<table>
<thead>
<tr>
<th></th>
<th>OpenOffice.org</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Area fill without tiling, with adjustments</td>
<td>Projection X</td>
<td>Projection X</td>
<td>Projection X</td>
</tr>
<tr>
<td>Projection Y</td>
<td><img src="image1" alt="Image" /></td>
<td><img src="image2" alt="Image" /></td>
<td><img src="image3" alt="Image" /></td>
<td></td>
</tr>
</tbody>
</table>

(Difference is small)

**Figure 177: Cylinder as an extrusion object**

**Dialog page - Material**

On this page (see Figure 178) you can assign certain material properties to the 3D object.

**Figure 178: Material page**
In the selection list under Favorites are the most commonly used materials (see Figure 179).

![Image](image.png)

**Figure 179: The favorites (from left to right): Metal, Gold, Chrome, Plastic and Wood**

With the individual *color parameters* additional effects can be produced. The meaning of these parameters corresponds to those on the Illumination dialog page.

Materials and textures can be combined with one another. With all settings the material of an object is only simulated and it is sometimes a matter of trial and error to achieve the desired result.

| **Tip** | Do not use too high a brightness value for individual colors – these are all additive and it is easy to end up with a totally white “colored” area. |

The *Illumination color* brightens those parts of the object which lie in shadow. The body is thus a little more illuminated.

With textures the Illumination color is combined with the white color part of the texture. On the left the object has a black Illumination color, on the right bright green.

With the *Specular color* the reflecting capability of the surface is simulated. The position of the illuminated point is determined by the setting of the first light source.

Left: Set the Specular color the same as the object color and the illumination point intensity to a low value, in order to give the impression of a matt body.

Right: Set the Illumination point color the same as the light source color, in order to give a shiny appearance to the object surface.

Metallic surfaces and glass are not so well simulated, because the impression of material is produced in this case through reflection. Such simulation is (at the moment) not possible to be calculated by OpenOffice.org.
**3D settings for 3D shapes**

The appearance of the shape object is changed using the 3D-Settings toolbar (see Figure 180). The concept is totally different from that presented above for objects in 3D scenes. The dialog 3D Effects described above should not be used for shape objects and will in fact not give the correct formatting results when used on a shape object.

![Figure 180: 3D-Settings toolbar, indicating icons for formatting 3D shapes](image)

In case you use it in error, you can remove the incorrect formatting with **Format > Default Formatting**.

With the appropriate button of the toolbar you can adjust the extrusion depth and perspective, lighting and material properties as well as the extrusion color. There are tear off bars, which you open by clicking on the small black triangle. The purpose of the individual functions are described by the tool tip. As opposed to the 3D Effects dialog used with 3D scenes, you do not need to “assign” the result of any of the functions to the object; every action is immediately applied and you can see its effect on the object in the main Draw window.

---

**Note**
The program sometimes seems to generate the wrong formatting with shape objects. The exact cause is not known, but you can undo the action with **Format > Default Formatting**. One reason can be that you have used a function from the 3D Effect dialog on a 3D shape.

---

Here are some examples of formatting of 3D shapes:

**Depth**

- left: 0.3cm (user defined)
- right: 1cm (selection)

**Direction**

The examples show “columns” at right angles to the drawing surface.

- left: 5 cm depth, Parallel projection
- Middle: 10 cm depth, Perspective
- right: Infinity, Perspective
Illumination

The light color cannot be changed, the brightness can be changed only in three levels, and some effects may not be totally correctly rendered.

left: from left under, dim
middle: from left under, bright
right: from right under, normal

Surface

Only four built-in variations are possible. At present only Wireframe and Matt are correctly rendered.

left: Wireframe
right: Matt

You can also choose a gradient, hatching, or bitmap for the surface; these are only applied to the extruded surface—the sides remain in the color of the object.

3D Color

Here you can choose the color of the sides of the extruded surface. The symbol shows the color of the most recently chosen shape object.

Combining objects in 3D scenes

3D objects produced by extrusion or rotation are shown in the status bar as a 3D scene. You can group together several of these objects. Other object types cannot be so grouped. Management of the group is carried out in the same way as described in other parts of this guide (Modify > Enter Group, or Modify > Exit Group), see also “Grouping Objects” in Chapter 5 (Combining Multiple Objects).

As an example, we will produce a game piece.

First produce both objects independently of each other. The subsequent joining together is made easier if you use parallel projection and rotate the objects into an upright, straight position.
Combining objects in 3D scenes

Click on the sphere and use **Edit > Copy** to take over the scene and put the sphere on the clipboard. If you are sure that you do not need the original anymore you can use **Edit > Cut**. In any case move the sphere a little to the side.

Click now on the cone. The status bar will show **3D Scene selected**. Right-click and enter the group. You will see that, as usual, elements that do not belong to the group are less bright.

Use **Edit > Paste**. Now the objects (not the whole scene) from the clipboard are pasted into this scene.

In the old position of the sphere is now a new sphere that belongs to the scene. This new sphere can be moved over to the cone. Exit the group after moving the sphere.

Notice that combining 3D objects results in them being more or less “fused” together – there is no stacking or layering as with 2D objects.

Adjust the position of the objects as you wish. You cannot arrange objects in front or behind others, as with 2D objects, but can only move them parallel to the drawing plane. Next the whole scene must be rotated 90 degrees.

Enter the group again and adjust the objects. The status bar indicates which object is marked. Use the **Tab** key to change from one object to the next in the group, should it not be possible with the mouse. Exit the group.
Now you can rotate the entire 3D scene and view your game piece from all sides.

Examples for your own experiments

All examples use objects in 3D scenes.

Extruding a 2D object with text generates letters as separate objects and they have a larger extrusion depth.

3D objects of the type Shape can be rendered as wireframe models. This effect can be produced in other 3D objects by setting the Area fill to None and the line style to Continuous.

If you select several 2D objects—without grouping them—and extrude the selection, they are transformed, according to their stacking order, with different extrusion depths. The object previously on top will be uppermost on the extruded object.

For 2D objects use Modify > Shapes > Merge/Subtract/Intersect to produce complex objects. The resulting figures can be also extruded, rotated and so on.
Combining objects in 3D scenes

Rotation of lines produces concave bodies. Use a bright line color. With a high number of vertical segments, the transition to the ground is relatively sharp-edged. Remember to switch on two-sided illumination.

The transparency of the platter is adjusted in the surface properties of the body. The best effect is obtained only when the transparent body is combined with other objects.

The color shadow of the fruit is produced by the use of multiple light sources – they are not “real” and do not rotate and change as the scene is rotated.
Chapter 8
Tips and Tricks
Positioning objects with zoom

With zoom you can place objects with higher precision (Figure 181).

![Figure 181: Using zoom to place objects with greater precision]

Zoom adjustments using the status bar

The current zoom value is displayed in the status bar.

![Figure 182: Zoom level on the status bar]

A double-click on the zoom value opens the Zoom dialog (see Figure 183), from which you can change the zoom factor (right-clicking opens a more limited selection list).

![Figure 183: Selecting a zoom factor]

You can enter a zoom factor in the Variable field, select from one of the preset zoom values, or use one of the three other choices:

- *Entire Page*: The entire page is displayed on the monitor, reduced in size if necessary to fit.
- *Page Width*: The right and left page edges are set to the vertical edges of the monitor.
- *Optimal*: The drawing (or selected object)—not the page—is enlarged to just fit in the Draw window.
The Zoom toolbar

The Zoom toolbar provides additional zoom options. On the Standard toolbar (View > Toolbars > Standard), click on the downwards arrow of the Zoom button. You can also permanently display the toolbar by clicking on View > Toolbars > Zoom.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Enlarges the monitor picture" /></td>
<td>Enlarges the monitor picture. First click on the button, then on the object. Alternatively drag to create a zoom “window”.</td>
</tr>
<tr>
<td><img src="image2" alt="Makes the monitor picture smaller" /></td>
<td>Makes the monitor picture smaller. Just click on the button.</td>
</tr>
<tr>
<td><img src="image3" alt="Zooms objects to their original size" /></td>
<td>Zooms objects to their original size.</td>
</tr>
<tr>
<td><img src="image4" alt="Changes between the last zoom factors" /></td>
<td>Changes between the last zoom factors.</td>
</tr>
<tr>
<td><img src="image5" alt="Shows the entire page" /></td>
<td>Shows the entire page.</td>
</tr>
<tr>
<td><img src="image6" alt="Zooms to page width" /></td>
<td>Zooms to page width.</td>
</tr>
<tr>
<td><img src="image7" alt="Zooms all objects of the drawing to Optimal" /></td>
<td>Zooms all objects of the drawing to Optimal.</td>
</tr>
<tr>
<td><img src="image8" alt="Zooms the selected object to Optimal" /></td>
<td>Zooms the selected object to Optimal.</td>
</tr>
<tr>
<td><img src="image9" alt="Enables moving the drawing inside the Draw window, using the mouse" /></td>
<td>Enables moving the drawing inside the Draw window, using the mouse.</td>
</tr>
</tbody>
</table>

Positioning objects with snap functions

In Draw, objects can be positioned to grid points, to special snap points and lines, to object frames, to single object points, or to page edges. This function is known as Snap. In this manner objects can be very accurately positioned in a drawing.

If you want to use the snap function, it is much easier to work with the highest practical zoom value. It is possible to use two different snap functions at the same time, for example snap to a guide line and to the page edge. It is best, however, to activate only those functions that you really need.

Examples for setting up the snap functions are found in Chapter 10 (Advanced Draw Techniques).
Positioning objects with snap functions

**Snap to grid**

Use this function to move an object exactly to a grid point (see Figure 186). This function can be switched on and off with View > Grid > Snap to Grid and on the Options toolbar with the icon.

![Figure 186: Exact positioning with the snap to grid function](image)

**Showing the grid**

Make the grid visible under View > Grid > Display Grid. Alternatively turn the grid on and off with the icon on the Options toolbar.

**Changing the color of the grid points**

By default the grid points are bright gray and not too easy to see. Go to Tools > Options > OpenOffice.org > Appearance. In the Drawing / Presentation section, you can change the color of the grid points (see Figure 187). On the Color Settings pulldown menu select a more suitable/visible color, for example black.

![Figure 187: Changing the color of the grid points](image)

**Configuring the grid**

Under Tools > Options > OpenOffice.org Draw > Grid you can change the settings of the grid (Figure 188).

No adjustment is necessary in the Grid field, for these settings can be changed directly from the icons on the Options toolbar.
Positioning objects with snap functions

Resolution: sets the horizontal and vertical distance between two grid points (see Figure 189).

Subdivisions: determines how many steps there are between adjacent grid points. Intermediate steps make it possible to have a larger separation between two grid points, so the drawing remains clearer (see Figure 190). Objects can snap to intermediate points in exactly the same way as grid points.

The other settings are largely self-explanatory. One important setting is the field Snap range. Grid points and guiding lines are both optical help elements that are managed separately by Draw. If you have activated a snap function and then move an object, Draw looks in the vicinity of the position of the object for those special help elements. This determines the final position of the object, and with the snap range setting you can determine the extent of this search area. Exactly how large the snap area is depends on the current environment: which particular snap functions are in use, how the grid is configured, and whether or not there may be collisions with other objects. It is usually necessary to do a little experimenting to find what best suits your needs.
Snap to Snap objects (snap lines and snap points)

Snap lines run horizontal or vertical and appear as dashed lines. Snap points appear as small crosses, again with dashed lines.

**Note** In Version 2 of OOO the name of the buttons in the Options toolbar are “Display Guides” and “Snap to Guides” when what is actually meant is “Display Snap line” and “Snap to Snap line”. These will be corrected in subsequent versions.

If you have activated this function, you can position objects exactly. Horizontal and vertical snap lines can be used together. Snap lines are not active immediately after inserting them but are turned on (or off) using the icon or with the View menu. If the snap line is no longer needed you can hide it (or subsequently display it again) with the Display Guides icon or using the View menu.

**Inserting a snap line with the mouse**

To insert a snap line in a drawing:

1) Hover the mouse cursor over either ruler.

2) Click and hold the right mouse button.

3) Drag the mouse into the drawing area to produce a snap line.

The snap line can at any time be moved with the mouse. Moving a snap line will not, however, move any objects that have been snapped to that line.

**Inserting snap points and snap lines using coordinates**

The command Insert > Snap point/line opens a dialog (Figure 192) where you can specify X and Y coordinates and choose the type of snap object: point, vertical line, or horizontal line.
Positioning objects with snap functions

Editing snap points and snap lines

All snap objects can be edited after setting them. If you right-click on a snap object, an appropriate menu opens. This menu contains a number of possible commands, including Delete.

Snap to page edge

With this function you can snap objects to the page edge (Figure 193). A combination with snap lines and snap to grid is also possible.

Snap to object frame

With this function you can position one drawing object on the frame of another. The connection point can lie anywhere on the object frame. If you want to use this function, you should deactivate Snap to grid. Figure 194 shows some examples of this function. Note that a typical object frame ‘touches’ the frame of a round object at only one of four points.
Positioning objects with snap functions

Figure 194: Objects positioned on the frame of another object

Snap to object points

This function operates in a similar manner to the one just described. The difference is that the connection point can lie only at one of the four corner points of both the object being moved and the target object. This leads to the situation where two round objects have a 'connection point' which does not lie on either object but at one of the red circled points in Figure 195.

Figure 195: Objects connected to the object point of another object

Positioning objects with helper lines

To simplify the positioning of objects it is possible to make visible guiding lines—extensions of the edges of the object—while it is being moved. These guiding lines have no snap function.

The guiding lines can be (de-)activated under Tools > Options > OpenOffice.org Draw > View > Guides when moving, or by clicking on the icon on the Options toolbar.
Positioning objects with snap functions

Figure 196: Working with guiding lines

Drawing to scale

In Draw a drawing is made on a predefined drawing area or canvas. This will usually be in the Letter or A4 format depending on your locale settings, and will be output to some “standard” printer that you have set up on your computer (usually referred to as the default printer). Depending on the actual size of the drawn objects it will often be necessary or convenient to reduce or enlarge the drawing by some scaling value. You can specify the scale that you wish to use under Tools > Options > OpenOffice.org Draw > General.

The scale and selected unit of measurement are automatically reflected in the rulers, the window position and the window size. If you work regularly with scaled drawings, it may be useful to store the details in a template that you can call up when you start a new drawing and not have to input the various settings every time.

Whether you draw in a 1:1 scale or in another has no effect on the basic drawing operations. Draw will automatically calculate the necessary values (for example, dimension lines). The grid spacing is independent of drawing scale as the grid is not a drawing element but only an optical drawing aid.

Note If you want to insert elements in a drawing from the Gallery or Clipboard, you should draw these to the same scale as you are using for the drawing to ensure the proper size ratio is maintained.

Splitting complex drawings on multiple layers

Layers are like transparencies that lie one on top of another on an overhead projector. You can insert and extract single layers as desired. For example in architecture the floor plan, heating, and electrical wiring can all be on separate layers. With complex drawings this layer technique offers many advantages. You can make layers visible or invisible as needed or you can protect a layer from further changes while you work.

In Draw three layers are always present by default: Layout, Controls, and Dimension Lines.
Splitting complex drawings on multiple layers

To change to a layer, click on its tab. Everything which is drawn will be placed on the currently selected layer (usually Layout—this is the default layer when you create a new drawing). The Controls layer is for control elements (for example icons, pulldowns etc) and is not usually used for ordinary drawing elements. The Dimension Lines layer is used whenever you insert a dimension line on a drawing (unless the layer is made invisible). Use Insert > Layer to insert a new layer in a drawing (Figure 197 left).

![Insert Layer](image)

**Figure 197: Insert and modify layers**

Right-click on a layer tab to bring up a menu where you can insert or delete a layer, rename an existing layer, or modify a layer. You can change the names of the user-defined layers; the default layer names cannot be changed.

If you choose Modify you will see the dialog in Figure 197 right. On the Modify Layer dialog you can specify the following properties:

- **Visible**: If this property is not activated, the layer will not be shown (the layer is removed from the stack).
- **Printable**: If this property is not activated, the layer will not be printed. This is useful if you use a ‘draft’ layer for guides or annotations that you use in making the drawing but should not appear in the final output.
- **Protected**: All objects on this layer are protected from deletion, editing, or moving. No additional objects can be added to a protected layer. This property is useful when a base plan is to be protected while adding a new layer with other details.

**Tip** Somewhat confusing is the fact that you can move objects on one layer although you are working on another layer. To prevent accidentally deleting or moving objects on another layer, you should protect that layer.

An example drawing – house plan and furniture

A popular application for programs like Draw is the “moving the furniture” scenario. The floor plan of a room or a house is easily drawn with Draw. The simplest way is to draw walls as thick lines. You can also draw single rectangles or polygons, place them together, select them and then from the right-click menu use Shapes > Merge to make a single figure, then add a hatching pattern. Before you do this, you should read the section “Drawing to scale” on page 135.
For this example a suitable measurement unit is centimeter. The drawing scale and grid settings will depend on the size of the floorplan.

With the field Position and Size you can very easily position and dimension the individual wall sections. Watch out that the rectangles completely overlap (see Figure 198) otherwise the merging will give uneven edges.

![Figure 198: Wall corner from two rectangles. From upper to lower: before merging, after merging and after hatching](image)

Figure 199 shows the finished floor plan. In addition, a chest of drawers has been added.

![Figure 199: Floorplan with chest of drawers](image)

The body of the chest is drawn on the Layout layer, the pulled-out drawers and the open doors drawn as a group and put on a separate user-defined layer (Layer4 in our example). Figure 200 shows how this is done. Making the layer with the drawers and doors visible or hidden will show them open and closed (see Figure 201). Hidden layers are shown with a colored tab.
Splitting complex drawings on multiple layers

Figure 200: Using layers for different parts of a drawing. (Left) Draw the body of the chest on the Layout layer. (Right) Create a new layer and draw the open drawers and doors, keeping the Layout layer visible to help you position the additional objects.

Figure 201: Making layers visible or hidden. (Left) Hide the Layout layer to see what is on Layer4. (Right) Show the Layout layer and hide Layer4 to show chest with drawers closed.

**Caution**

If you copy a drawing object to the Clipboard or in the Gallery all layers other than the three standard layers (Layout, Controls and Dimension Lines) are ‘lost’ and all objects will, by pasting into a new Draw document, be placed on the Layout layer. The reconstruction of layers is much easier if you assemble objects on a layer into a group before copying.

---

**Changing the layer of a drawing object**

Draw has no direct command to change layers. To move an object to another layer, change to the new layer, select the desired object or group, and then cut and paste it in position. Watch the status bar (here the information field) to follow and check the change in layer.

You can also click on the object, hold the mouse button pressed for about two seconds to copy the object to the Clipboard, and then paste it on the appropriate layer.
Multi-page document

Draw documents, like presentation (Impress) documents, can consist of multiple pages. As in Impress, tools to manage pages and backgrounds are available.

Pages are automatically named as Slide 1, Slide 2, on so on. This description is relative; if you move pages around, they are automatically renumbered. If you want to have fixed slide (page) names, you must name them yourself. Page names are useful for working with the Navigator and when you want to insert single slides using Insert > File into another document.

Pages area

By default the Pages area is docked on the left of the Draw window. It shows every page in the document as a small picture. Select a picture from the Pages area and the corresponding page is loaded in the main workspace. Click on the page to activate it for editing.

The Pages area behaves similar to the Styles and Formatting area. Drag on the gray separator line to change the width of the Pages pane. Click on the middle of this line to show or hide the pane. Double-click with the Control key pressed in the upper gray area to dock or undock the area, which can be turned into a floating window.

In the Pages area you can drag and drop a picture to change the order of pages in the document; a black horizontal line shows the position where the page will be inserted.
Using the context menu you can insert or delete pages or duplicate pages with copy and paste.

### Using page backgrounds

With background pages you set common page settings for multiple pages of the Draw document. These include setting the color or graphics of the background, background objects, and fields such as page numbering and author.

**Note** The terms used in this area may not be completely consistent, so that the terms Slide – Page and Master – Background – Page template are used more or less interchangeably in places. If you look for information in Help, it may serve to use alternative search terms.

### Creating a page background

Change with View > Master to the Master view and note that a related Master View toolbar opens. If this toolbar does not appear, activate it with View > Toolbars. In this toolbar are switches for a new background page and to rename the master page. The same functions are available by right-clicking on a page picture in the Pages area of the Master view. The button for deleting a master page is only available when you select a background page in the Pages area which has not yet been assigned to any page.

To return to normal mode, click the Close Master View button or View > Normal.

You can edit background pages just like normal pages. With Format > Page > Background you can set the color, pattern, or background picture. These settings are specific to each background page. You can set in the Master view the size and orientation of the page; such settings apply to all pages.

If you insert drawing objects on a background page, they are visible on all pages that use this background page. This a convenient way, for example, to place a logo on every page.
Master pages are organized in layers just like normal pages. The layers of normal pages are associated with the layer of the same name on the Master page. Accordingly the layers Layout/Control/Dimension Lines are considered to be a unit and the Master page layer Background objects is associated with them.

With Insert > Fields you can insert the date, time, page number, author and filename. No other fields are available. With page number you cannot insert a fixed page number but a variable – only on the page itself does the number appear and then determined by the position of the page. The number is automatically adjusted if the page is subsequently moved.

**Assigning and managing page backgrounds**

You can open the Slide Design dialog (Figure 204) in two ways:

- Right-click on the page and choose Page > Slide design (see Figure 203), or
- Look in the bottom right of the status bar to see which background page is considered as the current one. Double-click in this field.

![Figure 203: Commands on the Page pop-up menu](image)

The Slide Design dialog (Figure 204) shows the available background pages for that page.

![Figure 204: Slide design dialog](image)

If the Exchange background page checkbox is selected, the selected background page will be used on all pages of the document, not just on the currently active page.

The option Delete unused backgrounds (previous bug fixed in Version 2.3.1 and later) deletes any backgrounds (as shown in the Slide Design dialog) that have not been assigned to a page.
Click the **Load** button to open the Load Slide Design dialog (Figure 205). From here you can load previously prepared background pages. All Draw and Impress templates can be used for this purpose. Note, however, that using Impress templates will bring in only the background and not the other elements prepared in Impress.

![Load Slide Design dialog](image)

*Figure 205: Load Slide Design dialog*

There is no special option to store background pages as templates. Instead you can load a document with the desired background page and store this document as a document template with **File > Template > Store**.

### Color palette – adding or changing single colors

Draw (like all OOo components) uses color palettes for the representation of colors. In addition you can customize the color palette to suit your own needs and wishes. You can modify colors in a palette, add other colors, or create new color palettes.

Reach these options with **Tools > Options > OpenOffice.org > Colors** or with **Format > Area > Colors** (tab) (see Figure 206). The latter method allows color palettes to be loaded or to be stored for future use. Any modifications made to colors apply only to the currently active palette.

OpenOffice.org always uses internally the RGB color model. For the definition of a color value, other methods are also available. The conversion to RGB values is made automatically.

The color values can be input directly as numbers. Choose between the color model RGB (base colors Red, Green and Blue) and CMYK (base colors Cyan, Magenta, Yellow and Black, K= Key).

<table>
<thead>
<tr>
<th>Tip</th>
<th>Information about color models can be found under:</th>
</tr>
</thead>
</table>

The individual color tones are produced with different values of the base colors. The color value can be any integer value between 0 and 255. As an example, Red 3 has (in the RGB model) a red value of 184, a green value of 71 and a blue value of 0. The CMYK color model uses percentages (in this case 0%, 44%, 72%, and 28% respectively).

By changing these values, you manipulate the color tone. Either enter a number directly or use the spinners on the right side of each field. The change in color will be shown in the lower color field (see Figure 207). Click the **Modify** button to apply and store the new setting.

To add a new color to the current palette, enter a new name in the Name field and set the desired color values. Click **Add**. The new color will be added to the end of the palette and stored in the currently active palette.
You can also delete colors from a palette. Select the color from the **Color** pulldown menu and click on the **Delete** button, then on **OK** to confirm the change.

![Figure 206: The Colors tab in the Area dialog](image)

Clicking on the **Edit** button opens a special dialog to allow setting individual colors (see Figure 207). Many more input possibilities are available in this dialog.

In the lower area you can enter values in the RGB and CMYK models as well as the HSB (Hue, Saturation and Brightness) model.

The two color fields at lower right show the value of the color as selected (left) and the currently set value from the color value fields (right).

![Figure 207: Color dialog](image)
The color windows in the upper area permit a direct selection of color without any knowledge of color values. The right upper color window is linked directly with the various color model input fields; as you choose a color in this window the numbers change accordingly and a preview of the color appears in the right of the two color fields (lower right in Figure 207).

If you click **OK**, the color window is closed and the input field is again active. You can at this stage select your previously defined color, as described above, give it a new name and store it by clicking the **Add** button. The old color will then (without any further warning) be overwritten.

**Using the Color dialog**

**Method 1**

You can change the current color by modifying the individual color values. It is possible to jump from one color model to another during this process. The settings are always calculated and stored according to the RGB model, possibly with some slight adjustment to your input values in the other models.

With the HSB color model, the color tone of the three parameters Hue (possible values from 0 to 359), Saturation (possible values from 0 to 100) and Brightness (possible values from 0 to 100) is defined. The number for the color represents the angle in a color wheel, the other two are both percentage values.

**Method 2**

You can select a new color by clicking on a color in the color window at the upper right of the dialog. The chosen color is shown in a black frame. The frame can be dragged with the mouse. If this color is not quite right, you can fine tune it as described above in Method 1 by changing the color values.

As you drag the small square you will see the value change in the number fields. The CMYK and RGB are more or less self explanatory. To make the HSB model a little clearer, some additional comments are necessary.

To better understand the working of the HSB model, move the frame from left to right and top to bottom. You will see that the Hue and Saturation values change from their maximum to their minimum (hue by horizontal movement and saturation by vertical movement), the brightness remains the same (see figure at left). This latter can only be adjusted by inputing a value into the number field.

**Method 3**

The left color window is divided like a chess board into 8 x 8 individual fields, each with a different color. Most important are the colors in each of the corner fields. The color red changes stepwise to green in the first row, and stepwise to yellow in the first column. The color green in the last column changes stepwise to blue.
Color palette – adding or changing single colors

This window thus contains a stepwise change between each of the four main colors in the corner points. If you hover the mouse over a square the RGB value is shown as a tooltip. For example, the yellow corner field (lower left) has RGB values of 255, 255 and 0 (full red, full green and no blue).

Click on this yellow field. A frame appears. If you click the -> arrow under the color windows the selected color is assigned (see picture below).

You can also change the color fields by changing (one or more) of the corner fields. Click on the field you want to change, then set the color with the mouse in the right color window and/or with the number fields. When you click now on the <- arrow, the new color will be assigned to the corner square you selected (see Figure 208).

Cool effects

Duplication

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates.

To start duplication, click on an object or group and choose Edit > Duplicate. The Duplicate dialog (Figure 210) appears.
Cool effects

Choose the number of copies, their separation (placement), rotation, and so on. The choices above applied to a blue rectangle produce the result shown in Figure 209.

**Cross-fading**

Cross-fading transforms one shape into another. The result is a new group of objects including the two end points and the intermediate steps.

To do a cross-fade, first select two objects.

Then choose **Edit > Cross-fading**.
Cool effects

On the dialog choose the number of increments (transition steps). You probably want to have Cross-fade attributes and Same orientation both checked. The end result is shown in Figure 211.

**Which object goes in front?**

How do I tell OpenOffice.org I want 🍒 and not 🎨?

If you want 🍒 then select 🍒 (the object we want in front), right-click and choose **Arrange > Bring to Front** (or press Ctrl + Shift + +). Or select 🎨 (the object we want behind), right-click and choose **Arrange > Send to Back** or press Ctrl + Shift + -.
Chapter 9
Organization Charts, Flow Diagrams, and More
**Drawing an organization chart**

Draw offers no special toolbar for creating organization charts, where individual fields appear as rectangles. Drawing these charts presents no special problems, however. The use of different fill colors clearly represents organizational linkages and by drawing rectangles with different heights you can see the various hierarchies (see Figure 214). With a color progression from dark tones to bright, this effect can be reinforced. Watch that the color choices maintain a good contrast between text color and background so that you can easily read the printed diagram.

![Figure 214: Example of an Organization Chart](image)

At the beginning it is useful to prepare a setup page or draft, with snap lines, to assist in drawing the various hierarchies and responsibility paths and typical boxes that you will use in drawing the chart. Using styles can also be helpful; see the relevant section in Chapter 4 (Changing Object Attributes).

![Figure 215: Draft with snap lines](image)

Individual boxes are placed and dimensioned according to ‘feel’. The exact size (particularly width), position, and color will be fixed later. It is sometimes easier to draw only one box per level, copy and paste this box and then move it to the desired position.

You can also select one or more boxes and use **Edit > Duplicate** to make copies (see Figure 216). The spacing of the duplicated objects to the original can be input in the placement fields for X and Y axes. Note that positive values for X and Y are (relative to the original object) to the right and downwards respectively.
Which replication technique you use is up to you. The draft for the example in this chapter should look similar to that in Figure 217.

In the next step, add text to the boxes. As described in Chapter 2 (Drawing Basic Shapes), the text is best input as an element in the box. Activate the icon on the Options toolbar and then double-click the box to enter text into it. Alternatively, select the box and press F2. You should then see a blinking cursor in the box and the Text Formatting toolbar should be visible.

Set the text formatting and type the text. Depending on the length and formatting of the text, you may need to adjust the size of the box and the spacing to neighboring boxes. Adjustments can be made initially with the mouse and then fine-tuned with the Position and Size dialog.

Now you can set up the fill colors and save the drawing. The connections between the boxes are not drawn with ordinary lines but with Draw’s connectors. How to draw these connectors and add text to them is described in “Glue points and connectors” starting on page 153.

You can also use text frames for the boxes. These have the advantage of automatic line breaks. Figure 218 shows the individual editing steps of text input, adding lines, and setting the background color for a text frame.
Drawing an organization chart

Figure 218: Working with text frames

Drawing a flow diagram

For drawing flow diagrams (also known as flowcharts), Draw offers a separate toolbar, which is reached from an icon found on the main Draw toolbar (see Figure 219).

Figure 219: The Flowchart toolbar

The easiest way to draw a flowchart is to follow the same setup procedure as for organization charts. The necessary symbols are selected from the toolbar and dragged into position as described in Chapter 2 (Drawing Basic Shapes). See Figure 220 for an example of a typical flowchart.
The individual symbols must be exactly positioned if the connectors joining them are to form a vertical line. The midpoints of all the symbols that lie in a vertical straight line should have the same X coordinate and those on the same level should have the same Y coordinate.

Select the shapes that are to lie in a vertical straight line and center them with Modify > Alignment > Centered. For those on a horizontal line, select the shapes and center them with Modify > Alignment > Center.

After adding text and setting the fill color, you can join individual symbols together and add text to the connectors where necessary. This technique is described in the next section.

Figure 220: Example of a flow diagram

Glue points and connectors

These elements were briefly introduced in Chapter 2 (Drawing Basic Shapes). This section describes how to use them.

Connectors are lines or arrows whose ends automatically “dock” to a glue point of an object. Connectors are particularly useful when drawing organization charts, flow diagrams, and mindmaps. The connecting lines between the symbols remain intact even after moving and rearranging of the various drawing blocks.
The Connector toolbar

Click the button on the Draw toolbar to open the tearoff Connectors toolbar (Figure 221).

If the type of connector you want is not shown, click on the small black triangle in the right upper part of the Connectors toolbar. In the list that appears, click on Visible buttons (Figure 222). Here you can activate additional connector types.

Connector types fall into four groups:

- **Standard connectors** – the line segments run vertically and horizontally. All angles are right angles. The connector does not bend around the objects it binds.

- **Line connectors** – consist of a line segment and two smaller horizontal or vertical segments at the ends.

- **Straight connectors** – consist of a single line.

- **Curved connectors** – are based on Bézier curves, as described in Chapter 10 (Advanced Draw Techniques).
You can modify all the connector types. From the context menu, choose Connector to change from one connector type to another (as well as some other properties). With the Line dialog you can change the appearance of the line (color, arrow style, and line style) but not the connector type.

**Drawing connectors—basics**

When you choose a connector from the toolbar, the mouse pointer changes to $\Rightarrow$. As you move the cursor over an object, the available connection (glue) points become visible. To connect two shapes, move the mouse cursor over a glue point, click and hold the left mouse button to establish the first point, and then drag the mouse cursor (left button still pressed) to the other glue point and release the mouse button. The ends of the line are now docked and the connection is established (see Figure 223).

![Figure 223: Gluing a connector to a shape](image)

You can also attach the beginning or the end of a connector to the middle of an object. This is useful when the final position of the object is not yet fixed. When you move the object, Draw automatically selects the optimal location for the connector ends (see Figure 224).

![Figure 224: Connector attached to the middle of an object](image)

As with all other objects, connectors have one or more control points to simplify the construction of the drawing. You can use these points to change the shape, length, and proportions of the connector line (see Figure 225).

![Figure 225: Control points of a connector](image)

To remove a connector from an object, either move the end of the connector from the gluepoint of the object or simply delete the connector entirely.
Glue points and connectors

Editing glue points

Glue points can be edited using a separate toolbar (see Figure 226). This toolbar appears when you click on the Glue Points icon or select Edit > Glue Points from the main menu.

![Figure 226: The Gluepoints toolbar](image)

The following briefly describes the function of each button on this toolbar.

- Use this button to insert a new glue point. Draw a new object. If the object is filled, you can place a glue point anywhere inside the object or on its frame. With unfilled objects you can place a glue point only on the outside frame, but after inserting it you can then drag it inside the object. Activate the Glue Points icon on the Drawing toolbar.

  - The glue points that you add remain visible as long as the Glue Points icon is active. They appear as small blue crosses. A selected glue point has a gray square behind the cross. You can move a selected glue point with the mouse or delete it with the Del key.

- Use these four buttons to choose one or more directions permitted for a connector to join to a particular glue point.

  - Activate Glue Points and then choose the direction. If, for example, you activate only the button, every connector will be forced to come to that glue point from the left side of the point.

In the left drawing below is a glue point in the circle with a left entry and one in the square with a right entry. The effect of this is shown in the right drawing after adding a connector between the two glue points.

If you are in glue point editing mode and you add another direction to the glue point (for example by activating the button), Draw tries to optimize the length of the connector. For the example above, the connection inside the circle would change as shown below.
If the Glue Point Relative button is active (it is active by default) the glue point will move when you change the size of the object, as shown below.

If the Glue Point Relative button is deactivated, the remaining buttons on the toolbar, previously grayed out, become active. With these buttons you can decide how a glue point will be placed when the size of the object is changed.

These buttons determine how the horizontal position of a glue point changes when you resize the object containing the glue point. The distance of the glue point to the left edge, a vertical line through the middle, or the right edge of the object remains fixed when you change the size of the object. If the width of the object becomes less than the distance, the glue point is attached to the object frame.

The following example shows what happens when an object’s width is changed and the glue point is set to be a fixed distance to the left frame.

These buttons determine in a similar manner the vertical position of a glue point when the size of the object is changed.

### Adding text to connectors

To add text to a connector, double-click the connector. The end and control points become active and the familiar flashing text cursor appears (the cursor position is determined by the last used setting). The Text Formatting toolbar also appears (under the menu bar). Use this toolbar to set the desired text properties; you can directly input the text.

If you draw a connector and and then click on it, only the end and control points become active. In spite of this, a connector has its own object frame—in this case an invisible one. You can picture it easily by imagining a rectangle enclosing the start and end points of the connector (Figure 227).

When you add text to a connector, the location of the text is referenced to this rectangle. The exact position of the text can be set in the Text dialog (Figure 228). This dialog appears when you double-click on text and then choose Text from the pop-up menu or when you single-click on the connector and select Format > Text from the menu bar.
Adding text to connectors

Take particular note of the Spacing to borders and Text anchor sections in the Text dialog. In the Text anchor section you can see the possible locations for the text. In the above example the text is anchored at the top left. In the Spacing to borders section at the lower left you can input also negative values of spacing, to position the text outside the frame.

**Figure 228: The Text dialog**

Adjusting text to suit the connecting line

If you want the text to follow the slope or curve of a line, you need to activate and use the Fontwork tool. To add it to the Draw toolbar, choose Tools > Customize from the menu bar. On the Toolbars tab, in the upper pulldown list of toolbars choose Drawing. In the Toolbar content section, click Add. On the Add Commands dialog, select the Category Format and the Command Fontwork. Click Add, then Close. Back on the Customize dialog, in the list of commands under Toolbar Content, move the Fontwork icon to the location you want and then click OK.
To write slanting text, two steps are necessary. First, add the text to the connector as described earlier (Figure 229). The anchor location of the text is not important at this stage. Second, select the object with the text (in this case the connector) and click on the Fontwork icon to open the Fontwork dialog. To make the text lie along the inclined line, click the Rotate icon and set the distance to the line you wish (Figure 230).

![Figure 229: Adding text to an inclined line, Step 1](image)

![Figure 230: Adding text to an inclined line, Step 2](image)

The Fontwork dialog opens up many other possibilities to manipulate the text. You can, for example, turn the text around 180 degrees with the Orientation icon (ss was done in the example above) or place the text under the line by assigning a negative value to the spacing between text and line.

In addition, you can use the Fontwork dialog to generate curved text that follows the shape of a curved line. It pays to experiment a little to investigate some of the possibilities.
Chapter 10
Advanced Draw Techniques
Drawing to scale

Draw is not a CAD (computer-aided design) program but a graphics program with which you can produce drawings to a scale. The example used for this chapter is a drawing of a Logic Circuit Diagram. The exact meaning of the individual symbols is not described here as we are only interested in the drawing techniques used to produce the diagram.

The logic symbols in Figure 231 form the building block library for our scale drawing.

![Logic Symbol library](image)

**Figure 231: Logic Symbol library**

**Working with the Position and Size dialog**

So that the edges of the building block symbols do not coincide with the wiring, they should be 8 mm wide and 8 mm high. The connections to the symbols should have a length and separation of at least 5 mm. These values are all random values and you would normally substitute values that suit your own needs.

For the drawing we used a measurement unit of millimeters, a grid spacing of 5 mm, and a grid subdivision of 4 points. In addition you should probably activate Display grid and Guides when moving as well as Snap to grid (see Chapter 8). This drawing will serve later as a collection of available symbols and you should not only draw the symbols but fully detail them as well.

The first step is to draw a base element, an AND gate block. You can then dimension and detail this element (use the Position and Size dialog, as shown in Figure 232; double-click on the status bar or context menu to help with dimensioning). For this example, the left upper corner of the block is at x=10 mm and y=5 mm.

![Position and Size dialog](image)

**Figure 232: Positioning and dimensioning a Draw object**
Draw the first connection lead by eye and dimension and position it using the Position and Size dialog (Figure 233).

Use the same method to draw the remaining two leads. For positioning the input leads, fix the right end points; for the output lead, fix the left one. The first wire lies 1.5 mm below the upper edge of the block. The leads have a 5 mm spacing between them. The following table shows the relevant coordinates of the upper corner points and the leads.

<table>
<thead>
<tr>
<th>left (X/Y) [mm]</th>
<th>right (X/Y) [mm]</th>
<th>Input 1 (X/Y) [mm]</th>
<th>Output (X/Y) [mm]</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 / 5</td>
<td>18 / 5</td>
<td>10 / 6.5 (right EP.)</td>
<td>18 / 6.5 (left EP.)</td>
</tr>
</tbody>
</table>

For the lower input lead, increase the Y coordinate of Input 1 by 5 mm to 11.5.

The AND gate block is almost finished and we can use it as the basis for all the other gates. So that the drawing gives a good visual impression, use Edit > Duplicate to ensure uniformity of shape and size.

Because we want to copy the block vertically downwards, use a Placement on the X Axis of 0 mm and on the Y Axis 15 mm (see Figure 234).
With the same method, copy both blocks twice more to the right. Select both blocks, call up the Duplicate dialog, and use placement values of 30 mm (X) and 0 mm (Y). Your drawing should look similar to Figure 235.

![Figure 235: The blocks after duplication](image)

For the INVERTER or NOT gate the connection leads must be amended. Move one input and one output lead to the middle of the block and delete the superfluous input lead.

Draw the missing circle for negation with a diameter of 2 mm, place it by eye in the center and then position it and dimension the connections from the Position and Size dialog as described above.

You can copy the circle to the Clipboard and then paste it as many times as you need, positioning it and adjusting the lead lengths as above.

A wiring diagram also needs a symbol to show a connection point. Draw a filled circle for this.

Next add text to the symbols (&, =1 etc.). Activate the icon on the Options Toolbar. Double-clicking a symbol will now put you in a special text input mode. This integrates the text as an element in the object (see also Chapter 2 of this guide). You will find the OR symbol (≤) in the list of special characters (Insert > Special Characters).

It is probably a good idea to create a group for each type of gate. This will make it easier to use them in a diagram. Your diagram should now resemble Figure 235; save it to disk.

If you want you can add a name to each of the gate symbols (AND, OR ..), use a separate layer to add this text so that you can switch it off when necessary.

You can place glue points at the end of each connection lead. This will simplify the actual “wiring up” later when you add in the connectors.

### Setting glue points

This instruction assumes a basic knowledge of connectors and glue points. For additional information refer to Chapters 2, 8, and 9 of this guide.

| Note | If objects are included in a group it is **not** possible to add glue points to them. Glue points must be set before any grouping is done. |

Unfortunately you cannot set the position of glue points using numerical values. It is necessary that the glue points on the connection leads are placed exactly on the end of the line (otherwise the wires will not be properly aligned).
The best solution is to work with the Zoom toolbar. You can find this as a tearoff toolbar on the standard Drawing toolbar. It contains (among others) tools for zooming in and for zooming out (enlarging the view/making the view smaller) of the current view. If you click on the Zoom In tool and then click on the page, the scale is doubled and the view is centered on the place where you clicked.

As the ends of the connection leads in this example do not lie on grid points, you must switch off Snap to Grid and activate Snap to Object Points.

When you have done this, you can open the Glue Points toolbar with the Insert Glue Point icon on the Drawing toolbar or using View > Toolbars from the menu bar.

Select the block on which you want to insert a glue point. Click the Insert Glue Point icon. It is now activated and appears with a different background. The mouse cursor changes to a small cross and you can set the first glue point. Click the mouse at the desired location. If the point is not exactly where you want it, move it by dragging with the mouse.

When you are satisfied with the location, click on the Glue Points toolbar the icon with the exit direction you want (left, right, top or bottom). The selected icon now has a different (lighter or darker) background. Set the exit direction of the input connection leads to the left and the output leads to the right.

When you have set a glue point at the end of each gate’s connection lead, you can copy it into the Gallery.

**Copying individual pictures to the Gallery**

The Gallery is a very convenient way of controlling building blocks for drawings. It also functions as a symbol library.

First open the Gallery using Tools > Gallery or by clicking on the icon if it is present in one of the toolbars.

The Gallery appears above the drawing page. The left pane shows the folders available for use and the right pane shows the images contained in the current folder. Choose an image by clicking on it; additional information about the image appears in the header bar.

In the left pane, click the New Theme button to create a new folder. A new window opens. Click on the General tab and give the new theme a meaningful name (for example Logic) to replace the default of New Theme. You can rename a theme by right-clicking it in the folders pane on the left.

To import existing images into the Gallery, click on the Files tab and then on the Find Files... button. It is possible to bring in complete folders or individual files; the procedure is self-evident from the dialog windows that open, or see Chapter 14 (Working with the Gallery) in the Getting Started guide.
Drawing to scale

You can drag and drop Draw objects straight into the Gallery. (The Properties window can be closed after typing in the name.) First select the destination folder, then click on the first symbol that you wish to add to the Gallery. Position the mouse cursor inside the selection frame of the symbol. When the crossed arrows are visible, click on the symbol and keep the mouse button pressed. After about 1 or 2 seconds the cursor will briefly blink and change to the drag symbol. Drag the object into the Gallery and release the mouse button. When you move the mouse into the Gallery field, the cursor shape changes once more (see Figure 237).

![Figure 237: Crossed arrows > Drag symbol > Gallery symbol](image)

**Tip**  
Zoom in on very small graphics before you try to move them so that the crossed arrow symbol can be clearly seen.

When you have placed all the symbols in the Gallery they can be titled. Right-click on a symbol, choose **Title** from the menu and type the symbol name (AND, OR).

The symbol library is available to all OOo modules, at least for users who have the permission/rights to access it. Making available the drawing collection as a Draw file is the simplest way to distribute a symbol library to other users. After opening the drawing, other users can easily transfer the drawing objects into their own Gallery, as described above.

**Drawing a logic circuit diagram using the Gallery**

The use of the symbol library which you have created and placed in the Gallery can be illustrated by using the blocks to draw a **half adder** (see http://en.wikipedia.org/wiki/Half_adder#Half_adder). You can precisely place all the drawing objects with the help of Draw’s snap functions. The following instructions are only one way to achieve this objective.

![Figure 238: Half adder drawn using logic symbol building blocks](image)
Begin with a new drawing. Set the unit of measurement to centimeter, a grid point spacing of 0.5 cm and subdivision of 4 points. Activate the grid, guiding lines, and associated snap functions.

In the first part of the exercise you should draw only the two signal leads $a$ and $b$, the two INVERTER gates and the two AND gates.

Begin by drawing the two signal leads. To make it a bit easier, you can use the values in the following table.

<table>
<thead>
<tr>
<th>Signal wire</th>
<th>Start point</th>
<th>Length</th>
</tr>
</thead>
<tbody>
<tr>
<td>$a$</td>
<td>$X = 2 \text{ cm} / Y = 3.0 \text{ cm}$</td>
<td>5.5 cm</td>
</tr>
<tr>
<td>$b$</td>
<td>$X = 3 \text{ cm} / Y = 3.0 \text{ cm}$</td>
<td>5.5 cm</td>
</tr>
</tbody>
</table>

After drawing the two signal leads, you begin the hardest part. With grouped objects the snap function works only on points on the outside contours. The only way to work with these blocks as a unit, however, is as a grouped object. The input and output leads must lie right on grid points if the connecting lines are to be exactly horizontal or vertical.

Position two horizontal guiding lines (A, B) on the grid with $Y=4.0 \text{ cm}$ and $Y=6.0 \text{ cm}$. With Snap to grid active, this should be no problem. With an INVERTER gate the input and output leads lie in the middle of the block, 4 mm below the upper edge. In order that the input and output are docked to the guiding line, the upper edges of the INVERTER gate must be positioned (for a 5 mm grid spacing) at $Y=4.1 \text{ cm}$ and $Y=6.1 \text{ cm}$. Right-click on the guiding line, select **Edit guiding line** from the context menu and set the guiding lines to 4.1 cm and 6.1 cm.

In order that the blocks lie exactly underneath each other, insert vertical guiding lines at $X=5.0 \text{ cm}$ (INVERTER gate) and $X=8.0 \text{ cm}$ (AND gate).

Now open the Gallery and drag the Inverter gate into approximately the position desired. If the function **Snap to guiding line** is still active, you will be able to accurately position both blocks in the correct location. Your diagram should now look like Figure 239 and you can save it.

![Figure 239: Drawing a half adder - Step 1](image)

The input and output leads of the INVERTER lie at $Y=4.5 \text{ cm}$ and $Y=6.5 \text{ cm}$. Move the mouse over a guiding line. When the mouse cursor changes to a double arrow, drag the guiding line (with the left mouse button pressed) onto the input and output leads of the block. If the grid snap is still active, this should be exactly positioned without much effort.

The leads of the AND gate lie 1.5 mm below the upper edges of the two horizontal guiding lines. They must be moved up for the next step. The Y coordinates are reduced to 4.35 cm and 6.35 cm (the top edges of the AND gates). When you have moved the lines, you can drag both AND gates from the Gallery and position them. Your drawing should now resemble that in Figure 240.
Next drag the horizontal guiding lines again over the input and output of the gates (Y=4.5/6.5 cm), so that when you position the connection point of the leads (a small black circle) it will sit exactly on top of the leads from the gates.

To position the two last gates, you need to set the following additional guiding lines: a vertical line with X=11 cm and two horizontal lines (C,D) at Y=5.5 cm and Y=7.5 cm respectively. Shift the horizontal lines C and D each 1.5mm upwards (so that Y=5.35 cm and Y=7.35 cm).

Drag the OR and the last AND gate from the gallery and position them as in Figure 241.

Since the OR gate will be connected to the two previously positioned AND gates, you can delete the guiding line of the OR gate. Drag the horizontal guiding line C and D over the inputs of the AND gates (Y=7.0 and 7.5 cm) and put two other lines (E,F) on the remaining connections (Y=5.0 and 8.0 cm) as shown in Figure 242.

Deactivate all snap functions except snap to grid. It is a good idea to zoom in so that you can place the lead connections exactly over the intersection points. Drag the connections singly from the Gallery to where you want to position them. You will need to adjust their position with the mouse. The easiest way is to move the connection diagonally to the desired location (see Figure 243).
The guiding lines are no longer needed and can be hidden (it is better to wait until you have finished the drawing before you delete them). Your drawing should now start to look like Figure 242 and can be again saved.

**Figure 242: Drawing a half adder - Step 4**

The individual blocks must now be joined up so that the gates function as a half adder system. To do this, you use connectors. Open the Connector toolbar. Use the standard connector to join the OR to the two AND gates. All the other leads run horizontally and you can use the direct connector.

When all six lead connections have been positioned, both signal wires should have a small black circle added to their connection points. You can use the symbol for NOT from the Gallery as the basis for this.

**Figure 243: Setting the connections**

If you have correctly positioned the symbols in the drawing, all the connection leads will be straight lines. At this time you can delete all the guiding lines, add text to the drawing and your finished drawing should resemble Figure 242 above.
Dimensioning a drawing

Configuring the dimensioning style

As is usual with OOo, you configure dimensioning using its own style.

After opening a drawing, press F11 to access the Styles and Formatting window. In the Graphic Styles list, right-click on the style Dimension Line and select Modify. The dialog that opens contains the current settings. Click the Dimensioning tab (Figure 244).

You can configure all the properties you see in this window to suit your own needs. The left section includes the basic settings for dimension lines and dimension guide lines (these indicate where on the object the dimension is referenced):

- Line distance: the distance of the dimension arrow from the object edge
- Guide overhang: the distance the guide line extends past the arrow
- Guide distance: the distance of the guide line from the object edge

You can individually set the line lengths of the right and left guide lines and use positive or negative values to have the line above or below the reference point. The direction of the line with positive or negative distances depends on the setting of the Measure below object option (box checked or not), but this is easy to check by referring to the example dimension line in the bottom window of the dialog.

In the right section you can change the settings for the Legend, the text of the dimension line. You can use the Text position choices to change the location of the text – but only if one or both of the AutoVertical and AutoHorizontal checkboxes are unchecked. Use the various options on the Text and Alignment tabs to further change the text format.

Figure 244: Configuring dimension lines
Dimensioning a drawing

Calculation of dimensions always takes into account the scale and dimension units contained in Tools > Options > Draw > General. If you set a scale of 1:10 and a unit of centimeter, then a 6 cm long object in the drawing will be shown with a dimension of 60 cm when the option Show meas. unit is activated and the selection window is set to Automatic. Deselecting this option turns off the display of units. You can change the units displayed from Centimeters to (for example) Millimeters by choosing Millimeter instead of Automatic in the selection window.

Adjust the font type and size for the text of a dimension line by means of the Text tab.

The Standard button at the bottom of the dialog sets all the properties of the dimension line to the (inherited) standard properties of the style.

---

**Note**
The dimensioning style Dimension Line is always linked and stored with the current work page. All the changes that you make apply only to this page. New drawings are started with the standard properties of Draw. If you want to use the amended style for future drawings, save the page as an additional template.

---

**Dimensioning objects**

In this exercise you will dimension some logic blocks (see Figure 245). They are used here to demonstrate the technique; you can use your own drawing or fetch a picture from the Gallery.

So that Draw can clearly recognize the edges to be measured, you should set a number of guide lines delineating the edges. The previous sections explain how to do this. To place the guide lines exactly and easily, change the resolution of the Grid. Suitable values for this work are a resolution of 5 mm and a subdivision of 4 points. With this setting you should have a snap to grid function with 1 mm point separation.

We will begin by dimensioning the NOT gate. For this block we want the total width (18 mm) and the width of the block itself (8 mm) to have dimension lines. The first step is to add guide lines to delimit the dimension lines. With Snap to grid activated, you can position these quite accurately (see Figure 246a). Watch that the function Snap to guide lines is active and zoom in to the part of the block to be dimensioned. The block should not be selected.

Start the dimensioning command by clicking the Dimension Line icon on the Lines and Arrows dialog. The dimension line is placed automatically on the Dimension Lines layer so you can hide the dimension lines if you wish.
Dimensioning a drawing

Figure 246:
  a) Delimiting the edges with guide lines
  b) Dragging the dimension line (anticlockwise)
  c) Finished dimension line

After clicking the Dimension Line icon, the mouse cursor changes into a small cross. As we activated the option Dimension Line – Measure below Object, the dimensioning should be made in a counterclockwise direction. Place the mouse cursor at the left dimensioning point. Press the left mouse button and drag the mouse to the right dimensioning point. Release the mouse button. If you press the Shift key while dragging the mouse, you will restrain the dimensioning line in a horizontal (or vertical) direction (see Figure 246 b).

In the same way you can draw a vertical dimension line on the AND gate. The dimensioning of the NEGATION symbol should also be simple to accomplish, but it is important that for such small components you zoom in enough to accurately position the lines.

Editing dimension lines

Dimension lines can be subsequently edited. You can select single dimension lines which are displayed with four handles, located at the end of the dimension lines (Figure 247).

Figure 247: Editing dimension lines

With the upper handles you can (only) change the length of the guide lines. With the lower handles you can move the points that are being dimensioned. If you select the dimension text, you can edit the font type and size as well as changing the dimension units of the text.

If you only want to edit the text of the dimension, double-click on an unselected dimension line to enter text edit mode.

All the changes that you make relate only to the selected dimension line. They are stored and persistent, but do not affect the settings of the Dimension Line style. If you insert other dimension lines, they will have the settings contained in the style.

If you want to make general setting changes to the Dimension Lines style, change the appropriate style. As soon as you confirm the changes with OK, the new settings will be applied to all dimension lines.
Working with text in Draw

You can use text in Draw in various ways:

- as a text element
- as text associated with a picture
- as an element out of the Fontwork gallery
- as a Writer OLE object

Configuring text elements with styles

Text, like all drawing objects, can be associated with styles. The text settings in styles always affect the whole text element. You can format individual parts of a text element, but only by using manual formatting, which does not relate at all to styles and templates. Styles for characters and paragraphs do not exist in Draw.

Open the Styles and Formatting dialog by pressing F11. Access the formatting dialogs using the toolbar icons, the context menu, or the Format menu.

The Indents and Spacing, Text, Text effects, Tabs and Alignment tabs of the style dialog function the same as in text documents, although some options are not available in Draw. Specific to drawing objects are the tabs Text and Text Animation.

Text animation

On the Text Animation tab, you can set how the text moves within the object frame. Such effects are, however, only interesting for documents that are to be shown on the screen. They are more commonly used in the Impress module. For printed text they do not make any real sense and are not dealt with further in this guide.

Figure 248: Text tab of Style dialog
Text

On the Text tab, you can determine the behavior of the text block in relation to the border of the drawing object. The same settings can be altered—as manual formatting—under the Text... command in the Format menu or in the context menu.

The type of drawing object determines which settings are active and what effect they have on the text. Shapes behave differently to other drawing objects. If you want to experiment a little with the settings you will find it better to use objects with rounded edges—differences in spacing and alignment will be more clearly seen.

Anchoring text

To try out the different settings possible for text anchors, start by drawing an ellipse from the Basic Shapes toolbar, change into Text edit mode by double-clicking on the ellipse and write several, not too long lines of text.

In the Text tab of the Edit Style dialog set the values of the Spacing to Borders to 0 cm for all four directions.

Set Options as Left in the tab Alignment.

Now we can try out some of the different possibilities of text anchoring.

<table>
<thead>
<tr>
<th></th>
<th>Shapes</th>
<th>Classical drawing objects</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Text anchor" /></td>
<td><img src="image" alt="Anchor left middle" /></td>
</tr>
<tr>
<td></td>
<td>Text anchored to left middle – the text block is placed on the left side and centered vertically.</td>
<td>“Left edge” here means the left side of the object frame which is visible when you click on the object.</td>
</tr>
<tr>
<td></td>
<td>“Left edge” here means the edge of the text frame whose left side fits totally within the figure.</td>
<td>“Left edge” here means the left side of the object frame – the frame with the green handles which is visible when you click on the object.</td>
</tr>
</tbody>
</table>
Text anchor to lower right.

<table>
<thead>
<tr>
<th>Shapes</th>
<th>Classical drawing objects</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1.png" alt="Diagram" /></td>
<td><img src="image2.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>

The lower right corner of the text block sits against the edge of the figure. The lower right corner of the text block lies in the lower right corner of the (invisible) object frame.

The text anchoring always relates to the entire block, even when single lines are set differently to the other text through manual formatting.

<table>
<thead>
<tr>
<th>Shapes</th>
<th>Classical drawing objects</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image3.png" alt="Diagram" /></td>
<td><img src="image4.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>

If you checked the option **Full width**, the text block is always centered horizontally. The area of the text block is the greatest possible; here it extends either to the edge of the figure or object frame or (when not that wide) the width that is necessary to fit the length of the longest line. The difference becomes clear if you position the text on the **left**, but you set single lines through hard formatting to be aligned on the **right**. (Note: in the examples below, the first line of text was shortened to “First line with”, spacings were set to 0 and text anchor to middle left.)

<table>
<thead>
<tr>
<th>Without option “Full width”</th>
<th>Shapes</th>
<th>Classical drawing objects</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image5.png" alt="Diagram" /></td>
<td><img src="image6.png" alt="Diagram" /></td>
<td><img src="image7.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>With option “Full width”</th>
<th>Shapes</th>
<th>Classical drawing objects</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image8.png" alt="Diagram" /></td>
<td><img src="image9.png" alt="Diagram" /></td>
<td><img src="image10.png" alt="Diagram" /></td>
</tr>
</tbody>
</table>
**Fitting text in frames**

Here you find that shapes and classic Draw objects behave completely differently.

For *shapes* the options on the right are active.

*Figure 249: Options active for shapes*

These have the following effects.

<table>
<thead>
<tr>
<th>Word wrap text in shape:</th>
<th>No automatic hyphenation is available and you cannot insert a fixed hyphen. If the text does not fit in the shape it hangs over or under the outside of the shape.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>First line with exactly six words</strong> <strong>Second line</strong> <strong>Third line</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Resize shape to fit text:</th>
<th>Watch out! If you turn on this option it is not possible to undo the size changes – neither using the Undo function on the menu nor by switching off the option in the dialog.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>First line with exactly six words</strong> <strong>Second line</strong> <strong>Third line</strong></td>
</tr>
</tbody>
</table>

For the classic *drawing objects*, both lower left options in the dialog are active.

*Text*

- [ ] Fit width to text
- X Fit height to text
- [ ] Fit to frame
- [ ] Adjust to contour

These have the following effects.
**Distance from frame**

The spacing settings are added to the text. In this way the text block will be invisibly reduced or (with negative values) effectively made bigger.

In the examples below, the text is centered and the text block is anchored in the upper middle part of the frame.

<table>
<thead>
<tr>
<th>Value for spacing “Above”</th>
<th>-2 cm</th>
<th>-1 cm</th>
<th>0 cm</th>
<th>1 cm</th>
<th>2 cm</th>
<th>3 cm</th>
</tr>
</thead>
<tbody>
<tr>
<td>The behavior is the same for classic drawing objects and shapes.</td>
<td>M</td>
<td>M</td>
<td>M</td>
<td>M</td>
<td>M</td>
<td>M</td>
</tr>
</tbody>
</table>

If you anchor the text above, below, right or left, a positive spacing value positions the text in such a way that it sits close to the outside of the object frame at the anchoring point. Anchoring in the middle does not result in this movement.

To add text to a straight line, it is useful to produce the line as a very thin rectangle. To avoid the problem above, choose the anchor point in the middle of the rectangle. You can then determine the exact position of the text by setting the spacing accordingly.

Text added to the open line types *Bézier curve* (curves and freehand lines), *Polylines* (polygon and polygon 45°), and *Arcs* is also positioned in relation to the enclosing object frame. If you want to see the extent of this frame, just click on the object. To add text along one of these lines, you can use the Fontwork tool described on page 180.
Text added as described above is rotated when the object is rotated. The property settings, particularly those in relation to spacing to the frame, relate always to the situation where the object is not rotated.

**Text frames and callouts**

To test the range of setting possibilities, use a text frame or a callout with rounded corners. For text frames, as for rectangles, you can set the rounding in the Position and Size dialog (*Slant & Corner radius*) or in *Points* mode. This latter makes sense only if you have a visible outline. With callouts (as with text frames in Points mode), drag the larger marker in the left upper corner with the mouse to give the desired amount of rounding. An example of this is shown in Figure 250.

![Figure 250: Legend with rounded corners](image)

Unlike drawing objects, text frames and callouts support automatic line breaks and you can switch on automatic hyphenation under **Tools > Language > Hyphenation**.

Non-breaking dashes and protected separators are however not available. For a manual line break use, as elsewhere, the key combination *Shift+Enter*.

With the icons ![text frame icon] and ![callout icon] you can create text frames and callouts with vertical text. You need to activate **Enhanced language support > Enabled for Asian languages** in **Tools > Options > Language Settings > Languages**. Text frames can be rotated like drawing objects, but it is not possible to rotate callouts.

Text frames and callouts do not have an additional text element (that would be somewhat strange!), but you still use the **Text** dialog to set formatting properties. As soon as you have input text, the upper three settings on the left side become active (Figure 251). The settings for Spacing to Borders and Text anchors in the lower window area function in a similar manner to normal drawing objects and are not dealt with further here.

![Figure 251: Text options active for text frames and callouts](image)
All options off

The text is broken at the object frame. You do not see text which does not fit within the object frame. It is still available and if you enlarge the object it will be visible.

As with normal drawing objects the text positioning relates not to the figure itself but to the object frame. Observe that the text in the example at left extends outside the ellipse.

Fit width to text

This option forces the width of the text frame or callout to be enlarged so that the longest line fits, without a line break, inside the object frame.

A previously inserted manual line break (here after the word “longer”) remains in effect.

Fit height to text

This option forces the height of the text frame or callout to be enlarged so that all lines fit within the height of the object frame.

Fit to frame

This option results in the same effect as with normal drawing objects. The text is widened and/or compressed so it fits within the entire object frame.

With the symbols and you can produce a text frame that has this property already set.
Pictures and text

Pictures also possess a text element. To format this text, proceed in the same way as for a normal rectangle. You can use this text element to place lettering over the picture or to give the picture a caption. Usually you will produce text as a separate object and then group it with the picture, because you have more flexibility in what you can do with the text.

Here are two examples showing what is technically possible with text elements. The construction of each is carried out using a format style. Right-click on the picture and choose Edit Style to open the Graphics Styles dialog. You may first wish to choose a different style to edit for the picture, or create a new style for a special purpose. For more about styles, see Chapter 4 (Changing Object Attributes).

| Tab: Font, Comic Sans MS, Bold, 40pt | Tab: Alignment, Options Right |
| Font Effect, color white, with shadows | Text, Text anchor “upper right” and Spacing to borders right 0.5 cm, top 0.5 cm, others 0.0 cm |

Where the mountains meet the sea, empty beaches invite long walks

| Tab: Font, Bitstream Vera Serif, 14pt | Tab: Alignment, Options Left |
| Text anchor “lower left” and Spacing to borders bottom -1.3 cm |

Note: the line break after the word “sea,” was inserted manually.

If you store the picture using File > Export, the text is exported along with the graphic. If you use the context menu option Save as graphic, then the text is not exported.

Fontwork Gallery

Click the icon to open the Fontwork Gallery (Figure 252) which you can use to insert an eye-catching caption to an image. Fontwork drawing objects belong to the shape category. The Gallery contains a selection of popular text forms.
You are not limited to only these samples; you can subsequently edit and customize the chosen caption type. Proceed as follows.

Choose a caption type from the Gallery and click **OK**. The caption is then inserted into the middle of your document.

Use the green handles to drag and resize the caption.

Double-click to enter text editing mode and replace the placeholder text “Fontwork” with your own text.

Click outside the object or press the *Esc* key to leave the editing mode.
Working with text in Draw

With the Area dialog from the Format menu or the context menu, you can set the fill and shadow properties. Use the Line dialog to set a frame around the lettering.

For further adjustments you need to use the Fontwork toolbar. If this does not open automatically turn it on with View > Toolbars > Fontwork.

The left symbol is already familiar. It opens the Fontwork Gallery.

Use the small triangle on the symbol to open the tearoff Fontwork Shape toolbar and choose the shape of the frame of your caption.

Use the yellow handle to modify the form of the caption.

With the other icons you can further customize the text direction and spacings.

To change the font type of the caption, use (as for other text) the dialog from the Format > Character menu or the context menu.

If you want to give the text a 3D appearance, refer to the relevant section in Chapter 7 (Working with 3D Objects).

**Writer OLE object**

In some cases text frames are not flexible enough to meet your needs and offer too few possibilities for adjustment. For example, you may want to show a figure in Draw in exactly the form it was created in Writer. The best solution might be to insert an OLE object. This means that the object is linked or connected to the application that created it. Draw makes available to other applications (only) one viewing window. The object itself is not edited in Draw but in the other application.
Insert
Use Insert > Object > OLE Object to open the dialog as shown in Figure 253. Use the Create new option to embed the OLE object in the Draw document. With the Create from file option, you can choose whether the object should be embedded or linked. With a linked file any change in the stored file will be shown in Draw and vice versa: any change you make in Draw will be stored in the file on disk.

If you have decided to embed the object you can still create an independent text document from the OLE object. For this use the Save Copy as command from the context menu.

Figure 253: Inserting an OLE Object

Editing mode
As soon as you click on OK, the object is created and opens in editing mode. You can recognize this mode by the gray frame around the object and the small black handles.

Take special note of the toolbars. These are no longer those of the Draw module but of the Writer module. You input your text and format it almost the same as if you were in Writer itself. In particular you now have available all the format styles from Writer.

Figure 254: Writer OLE object in editing mode

With the handles of the gray frame you can determine which section of the entire text document is visible. You should switch off the ruler view.

Figure 255: Editing in Writer as an OLE object
Click outside the object to leave editing mode. Double-click on the object or use Edit > Object > Edit to change again into editing mode.

In an embedded Writer OLE object, you can connect to further “sub” OLE objects. You cannot edit a linked Writer “sub” OLE object directly in Draw; you must open it as a text document in Writer. This limitation can be illustrated by the use of formulas. Such formulas are technically OLE objects that belong to the Math module. If you want to use mathematical formulas inside flowing text, you must save the text in a separate text document and insert it as a linked OLE object in Draw.

**Object mode**

Click on an object to enter object mode, recognizable by the presence of the green handles. In object mode you remain in the Draw module.

Possibly you noticed that in edit mode there is no Zoom. Set the size of the OLE object on the Draw page in Object mode from the Position and Size dialog. In the left image of Figure 249 the object was inserted at the original size, at right the size was reduced. If you change the size, take care that the option **Keep ratio** is checked or else the object will become distorted. Line and Area properties are not available for OLE objects, nor is it possible to rotate objects as with text frames.

**Figure 256**: Zoom vs resizing of an OLE Writer object

OLE objects can be overlaid just like other drawing objects. In Figure 248 a drawing object from the basic shapes menu has been placed behind the OLE object.

**Figure 257**: Draw object behind an OLE object

The page with the text document has the background property set to “transparent”. If you change the background color of the OLE object in Edit mode, it will also show in the Draw document.

The **Format** menu has the entries Area and Line grayed out because they are not usable, but the menu entries Paragraph, Character, Text, and Bullets and Numbering are all available. These relate not to the text which you are currently editing in edit mode but rather to a text element (this is similar to the way that pictures are linked with an OLE object). To write something in this text element, press F2. A double-click, unlike with images, does not work here because it puts you in the edit mode of the OLE object. Note: Whether you can sensibly use a text element like this is an open question!
Guide to Bézier curves

Bézier curves—what are they?

OpenOffice.org uses cubic Bézier curves. A curve is defined by means of a start point \( P_0 \), an end point \( P_3 \), and two control points \( P_1 \) and \( P_2 \) (see the figure at left). For points on the curve the terms nodes or anchors are often used.

For the mathematical background of Bézier curves, see http://en.wikipedia.org/wiki/Bezier_curve.

Bézier curves are very suitable for experimenting with the shape and form of curves. In point mode you can change the curve alignment by dragging the points with the mouse. The curve leaves the start point \( P_0 \) in the direction of the control point \( P_1 \) and arrives at the end point \( P_3 \) from the direction of the control point \( P_2 \). These directions are shown in Draw by blue lines. The more distant a control is from its start or end point the smaller the curvature at that point. If a control point lies directly on one of these points, it has no influence on the curve.

Point mode of the Bézier curve

With the icon from the Draw toolbar or with the Edit points command from the context menu, you can bring the curve into a point mode from which you edit individual points on the curve. Points on the curve are shown with a square handle; the control points with a round handle. The starting point of a curve appears somewhat larger than the other points. When you hover the mouse over a curve point the mouse cursor changes to \( \text{over a control point it changes to } \)\( \text{. In point mode the toolbar Edit Points should appear. If not, turn it on from View > Toolbars > Edit Points.} \)

You can switch on the option All control points in Bézier editor under Tools > Options > OpenOffice.orgDraw > View. Without this switch on you see the control points and guide lines only when a point is marked – you do this by clicking the point. By holding the Shift key down as you mark, you can select and mark several points at the same time. A marked point is shown a little darker.

Direct drawing of a Bézier curve

Open the Curve toolbar by clicking on the small black triangle of the symbol on the Drawing toolbar. Click on the Curve icon. The mouse cursor changes to \( \text{.} \)
Click on the start point of the curve and keep the mouse button pressed (start and end points are shown here in the figures as snap points).

Drag the mouse to approximately the position of your first control point. It does not matter if this is not exactly right as you can move the control point location later. If you hold the Shift key down while dragging, the control point will lie on a 45 degree grid.

Release the mouse button and move the mouse to the position of the end point of the curve. You can see that the line of the curve follows the movement of the mouse. Double-click at the end position.

Turn on point mode with the icon from the Draw toolbar.

At the end of the curve you will see not only the end point but also an associated control point, the round handle. Hover the mouse cursor over this point; the cursor shape changes to show that you are in edit mode of a control point.

If necessary, now you can drag the control point to its correct position.

**Drawing a succession of Bézier curves**

Several lines or Bézier curves can be linked together. The single parts are referred to as segments. Technically such a succession of Bézier curves and lines is known as a *path*.

Begin the drawing as with a simple Bézier curve. At the end position of the first segment, end not with a double-click but rather with one of the following methods:
• Click on the end point of the first segment but do not keep the mouse button pressed. In this way you produce a curve point which is both a control point for the first segment and a control point for the second segment. This control point lies, however, on the actual curve point and so does not influence the direction of the following curve segment. Move the mouse to the end position of the second segment. This segment appears to be a straight line but is in fact a Bézier curve. Either double-click to finish the curve or repeat the above procedure to add successive segments.

or

• Go back and click once on the end point of the first segment and keep the mouse button pressed. Now you can, as at the start but now for the second segment, place the control point. Release the mouse button at the position of the control point and move the mouse to the end position of the second segment. The curve follows the line of movement of the mouse.

You can either end the drawing here with a double-click or continue and link in further segments.

To generate a closed curve, select the curve and click on the Close Bézier icon on the Edit Points toolbar, or right-click and select Close object from the context menu.

Transition points

For the transition from one segment to the next, there are three different types of points, each with its own properties.

Corner points
The point is only a common point between the two segments. The segments are otherwise independent of each other. It is likely that the curve has a kink at this point (depending on the angle of the tangents, the lines from the corner point to each control point; see Figure 258).

Smooth transition points
The tangent lines to the common point have the same angle and form a straight line. If you change the position of one of the control points the other also moves, so that the tangents remain in a straight line. This also applies to the case where a Bézier curve meets a straight line: the tangent line lies on the straight line and cannot be moved sideways.
**Guide to Bézier curves**

**Symmetric transition points**
In this case the tangents not only lie on a straight line but the distance of the control points from the curve point is the same. The segments have both the same direction and the same curvature at the transition point.

![Figure 260: Symmetric transition point](image)

**Changing point types**
When a point is selected, the *Edit Points* toolbar activates the three corner point icons.

The circled icons are, from left to right, *Corner point*, *Smooth transition*, and *Symmetric transition*. The latter two icons appear the same but you can identify them by looking at the tooltip. At any time only one of the three icons will be active. To change the type of point, click on one of the other two icons.

**Closing the curve**
To close an open curve, use *Close object* from the context menu or the *Close Bézier* icon from the Edit Points toolbar. A straight line is drawn between the start and end points if these points are *Corner points*.

![Figure 261: Close curve – start and end points are corner points (left), smooth or symmetric points (right)](image)

If the start and end points are *Smooth points* or *Symmetric points* and the control point does not lie directly on the curve point, it changes position so it is in a straight line with the line segment and the closing line will be a curve (see Figure 261 for a comparison).

To prevent this happening, change the curve point type before closing to a corner point.
Transformation between straight line and Bézier curve

Transform a straight segment into a Bézier curve
Select a point on the straight line, which will be the start point of the curve. This point is shown somewhat bigger. After a short time the Convert to curve icon on the Edit Points toolbar becomes active. It starts in the “out” position. Click the icon to turn on the function. The straight line is transformed into a Bézier curve. The type of the segment end point remains as it was. Using this function you can convert one side of a polygon or a part of a polyline into a Bézier curve.

Transform a Bézier curve into a straight segment
Select the point on the curve of the segment which will be the start point of the straight segment. This start point is shown somewhat bigger. After a short time the Convert to curve icon on the Edit Points toolbar becomes active. It starts in the “in” position. Click the icon to turn off the function. The Bézier curve segment is transformed into a straight line. The type of the segment end point remains as it was. If all segments are straight lines, Draw converts the object to a polygon or a polyline.

Transform complete curves, polylines and polygons

Transform a polygon or a polyline into a curve
Select the whole polygon or polyline. The object does not need to be in point mode. Choose Convert to curve from the context menu or the Modify menu. The points in the resulting curve are all of the type Corner point and the control points lie on the curve segments. All the segments thus appear as straight lines.

Transform a curve into a polygon or a polyline
Select the whole curve. Choose Convert to polygon from the context menu or the Modify menu. The curve does not need to be in point mode to do this. The individual segments are not replaced by straight lines. Additional points are generated on the curve so that the line of the polygon/polyline matches that of the curve as closely as possible. These points are placed closer together as the curvature increases.
Freehand lines

You can also produce a curved line from a Bézier curve using the freehand line tool \( 
\). This tool automatically inserts anchor points and control points to render the curve as close as possible to the original Bézier curve.

Place the mouse cursor at the beginning point and keep the mouse button pressed until you reach the end of the curve. As soon as you release the mouse button, the curve is complete.

Combining closed curves

If you draw a Bézier curve segment and, at the end point of the segment, click and hold the mouse button, followed by a single press of the Alt key, the curve is closed with a straight line and you are placed in Combining mode. You can now begin a second curve at an arbitrary point. Ending the drawing with a double-click also closes this curve. If you end it with an Alt-click as described above, you can draw further curves. The curves that you have just drawn form a common object, a so-called Combination. You can use this (for example) to place holes in filled curves.

If you want to bind two curves together into a Combination at some stage, select both curves and use Modify > Combine.

Even if you use a Combination, the individual curves are still available as objects. You can use Modify > Split to convert the Combination back to single objects.

You can create Combinations only from closed curves. Other objects, for example rectangles or polygons, will be automatically transformed into curves, and curves that are not closed will be closed with a straight line.

Connecting curves

To join curves together, select them and use Modify > Connect. A connection is only possible with open curves. If you use this tool on closed curves, they are first opened and an additional end point inserted at the starting point. A straight line is used to connect the curves.

The behavior of connected curves cannot (at present) be modified. It is not clear according to which method the transition properties of the connected curves are calculated, nor which end points will be connected. If you want to have a look at this tool, it is probably a good idea to work on a copy and try out the effect with different positions of the end points of the individual curves. To avoid changes to a shape, first set the property of the new connection point to the type Corner point.
Index

3
3D bodies 102
extrusion 102
ready-made objects 103
rotating 106
rotation 103
segments 110
settings 107
3D color 123
3D effects 107
Geometry 108
Illumination 115
Material 120
Shading 113
Textures 117
3D scenes 104
combining objects 123
3D settings 107
3D shapes 104
rotating 107

A
add points 41
Aging filter 89
aligning objects 74
Alpha channel 92
anchoring text 174
AND gate 162
Area dialog 54
area fill, editing 51
arranging objects 30
arrow styles, customizing 49, 50
arrows 48

B
background pages 140
Bézier curves
transition points 187
bitmap fill 57
bitmap image 53
bitmaps 78, 117
black and white printing 100
borders, editing 47
breaking links 79
brightness 86
bring forward 30
bring to front 72

C
CAD (computer-aided design) 162
callout 178
Charcoal sketch filter 90
close Bézier 42
closing a curve 188

CMYK color model 142
color adjustments 86
Color bar 8
color depth 93
color fill 52
color inversion 88
color negative 88
color palette 142
color picker dialog 143, 144
combining closed curves 190
combining objects 69
connecting curves 190
connectors 153
adding text 157
adjusting text 158
drawing 155
Connectors toolbar 154
context menu 46
contoured image 95
contrast 86
conversion 78, 95
convert polygon to curve 189
convert straight line to Bézier curve 189
convert to a contoured image 95
convert to a polygon 96
convert to bitmap 99
convert to curve 189
convert to polygon 189
corner points 187
cropping 87
cross-fading 146
curve 50
customizing toolbars 12

D
delete points 41
delete unused backgrounds 141
depth 122
Dimension Line style 170
dimensioning 170, 171
direction 122
distorting an image 63
distributing space between objects 75
dithered 94
dragging and dropping 81
drawing to scale 135
Drawing toolbar 8
duplicate 150
duplication 145
dynamic gradients 65

E
Edit Points toolbar 39
editing objects in a group 69
effects 44, 61

Index
embedding graphics 79
exchange background page 141
exporting as a raster graphic 83
exporting as a vector graphic 83
exporting graphics 82
exporting single objects 82
extrusion 102
extrusion of shapes 104
eyedropper 91

F
fields 141
file formats 82
fill color, creating 54
fill holes 97
fill properties 51
fill, editing 51
filter toolbar 88
flip an object 62
floating toolbar 6
flow diagram 152
flowchart 152
Fontwork 105
Fontwork Gallery 180
freehand line 190

G
Gallery 165
Gamma value 86
Geometry - 3D effects 108
glue points 153
ing 164
Glue Points toolbar 165
Gouraud shading 114
gradient fill 52, 54
gradients 65
graphic filter toolbar 88
graphics mode 85
grayscale 95
grayscale printing 100
grid points 129, 130
grid settings 130
grouping objects 68
guiding lines 134

H
half adder 166
handles 28
hatching 52
hidden objects 30
horizontal distribution of objects 76
HSB color model 144
hyphenation 176, 178

I
illumination 123
illumination color 121
illumination of 3D objects 115
image 53
import filter 78
inserting Draw or Impress objects 81
inserting graphics files 78
intersecting objects 71
invert colors 88

L
layers 135, 141
light source 116
Line and Filling toolbar 8, 46
line options 48
line pattern 56
line pattern, fill 52
line properties 47
line styles, customizing 49
line, customizing 49
lines, editing 47
linked graphics 78
Load Slide Design dialog 142
logic circuit diagram 162

M
Master view 140
Material 120
merging objects 70
metafile 81, 84, 98
mirror copies 62
modifying raster object properties 84
Mosaic filter 91
move points 40
move to front or back 72
multiple pages 139

N
Navigator 81
nesting groups 69
normals 111

O
objects
adjusting size 31
arranging 30
curves 38
dynamic movement 31
dynamic size modification 31, 32
editing points 37
framing 29
hidden 30
moving 31
rotating 33
selecting several 30
OLE object 182
OpenGL libraries 102
Options bar 28
Options toolbar 10
organization chart 150

P
page backgrounds 140
page margins 3
Pages area 139
pasting from the clipboard 80
Phong shading 114
Picture (editing) toolbar 85
pictures and text 180
placeholders 84
point reduction 96
polygon 95, 96
Pop-Art filter 90
Position and Size dialog 162
positioning objects 72
Posterize filter 90
Print options with raster graphics 100
projection 119

R
raster graphics 78, 117
reducing color depth 94
Relief filter 90
remove noise 89
removing links to files 79
renaming objects 84
RGB color model 142
RGB colors 86
rotating 3D objects 106
rotating an object 33, 61
rotation angle of 3D bodies 110
rotation mode 44
rounding of 3D object 109
rulers 3

S
s 154
scale drawings 162
scaled depth of 3D object 110
scanning 79
segments of 3D bodies 111
selecting objects 29
selection modes 28
send backward 30
send to back 73
set in circle (perspective) 63
set to circle (slant) 64
shading of 3D objects 113
shadows 53, 58
shadows of 3D objects 114
sharpen image 88
slanting an object 34
Slide Design dialog 141
smooth image 88
smooth transition 40
smooth transition points 187
snap functions 129
snap lines 132
snap points 132
Snap range 131
Snap to grid 130
snap to object frame 133
snap to object points 134
snap to page edge 133
Solarization filter 89
special effects 61
specular color 121
split curve 42
Standard toolbar 8
Status bar 4
styles 60
submenu display 6
subtracting objects 71
surface 123
symmetric transition 39
symmetric transition points 188

T
tangents 39
text anchors 174
text animation 173
text frames 176
text styles 173
textures of 3D objects 117
threshold 94
tolerance parameter 93
toolbar
  Edit Points 39
toolbars 6
transition points 187
transparency 59, 65, 84, 86, 92, 126

U
undoing groups 68
ungrouping 68

V
vector graphics 2
vectorize 96
vertical distribution of objects 76
vertical text 178
View options 84

W
wiring diagram 162
workplace 2
Writer OLE object 182

Z
zoom value 128