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Making changes

Making changes

The most efficient way to share a document among multiple reviewers is for all reviewers to 
record the changes they make to the document. If reviewers record changes, then the author 
can step through the changes one at a time and accept or reject them. During this process, 
reviewers can leave notes either in general in the document or attached to a specific change.

Recording changes
For this chapter we will work with a budget proposal for a baseball team.

You are the sponsor of a youth baseball team. The coach 
has submitted a budget to you for the season and you need 
to edit the costs and return it to her.

You are concerned that if you just make the changes then 
the coach won't see the changes you made. You decide to 
use Calc with the record changes feature so that the coach 
can easily see the change you have made.

Figure 1 shows the budget spreadsheet your coach submitted.

Figure 1: Baseball budget spreadsheet

Looking over the figures, you see a few places where money could be saved:

• Post-game snacks can be bought by parents.

• New uniforms can wait, only buy 10 to replace broken ones.

• Buy cheaper baseballs.
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• Only buy 2 spare gloves.

To make these changes, use the record changes feature in Calc. To start Calc recording 
changes:

1) Open the Budget Spreadsheet.

2) Select Edit > Changes > Record (Figure 2) from the menu bar.

Figure 2: Activating change recording

3) Begin editing the document.

Red borders appear around the cells where changes were made (Figure 3). Other reviewers 
then quickly know which cells were edited.

TIP To change the color that indicates changes, select Tools > Options > 
OpenOffice.org Calc > Changes.
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Figure 3: Edited document with red border on changed cells

Once you finish editing the document, you can send it to your coach. However, you may want 
to explain your rationale for the changes. You can add comments or notes to accomplish this.

Adding comments and notes
You can share your insight in two ways: by adding comments to the changes you made or by 
adding a general note to the spreadsheet. Functionally, these methods both accomplish the 
same purpose in Calc (there is a bigger difference between the two in Writer), but they have 
different uses.

In short, comments are only associated with a change you made and notes can be added at 
any time, with or without an accompanying change.

Adding comments

Reviewers and authors use comments to communicate with each other why they made the 
changes. This can be useful since often the author and the reviewers are not in the same 
physical location and other forms of communication may be inconvenient. To add a comment 
to a change:

1) Make the change to the spreadsheet.

2) Select the cell with the change that you want to add a comment to.

3) Select Edit > Changes > Comments. The dialog shown in Figure 4 appears.

4) Type your comment and click OK.
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Figure 4: Comment dialog box

TIP You can step through your changes one at a time using the left and right arrows on 
the right hand side of the comment dialog box, and add comments to each change. 
The menu bar for the comment dialog box tells you the cell and the change you are 
commenting on.

Once you have added a comment to a changed cell, you can see it by hovering the mouse 
pointer over the cell, as shown in Figure 5.

Figure 5: Comment added to cell B3

The comment you typed also appears in the dialog box when you are accepting and rejecting 
changes, as shown in the first line of Figure 10 on page 7.
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Adding a note

Notes are similar to comments, except that they do not need to be associated with a change. 
Authors and reviewers often use notes to exchange ideas, ask for suggestions, or brainstorm 
in the document. To add a note:

1) Select the cell that the note applies to.

2) Select Insert > Note. The box shown in Figure 6 appears.

Figure 6: Insert note box

3) Type the text of your note in the box.

4) Click outside the box to close it.

Now the cell you added the comment to has a colored dot in the corner, as shown in Figure 7.

Figure 7: Colored dot in noted cell

TIP You can change the colors Calc uses for notes by selecting Tools > Options > 
OpenOffice.org > Appearance.

To view the note you just added, follow the same procedure as for viewing a comment. Hover 
the mouse pointer over the cell that has a note; the note appears, as shown in Figure 8.

Figure 8: View note

Editing, Changing and Reviewing 5



Reviewing changes

Reviewing changes

At this point, we are going to change our perspective from the point of view of the team 
sponsor to that of the coach, so we can see how to review and accept or reject the changes to 
the document the coach originally wrote.

You are the coach of a youth baseball team and you 
submitted a potential budget created in Calc to your team 
sponsor.

Your sponsor has reviewed the document using the record 
changes feature of Calc. Now, you want to review those 
changes and accept or reject the counter proposal. 

Because the sponsor recorded changes in Calc, you can 
easily see what changes were made and decide how to act.

Viewing changes
Calc gives you tremendous control over what changes you see when reviewing a document. 
To change the available filters, select Edit > Changes > Show. The dialog shown in Figure 9 
opens.

Figure 9: Show changes dialog

Using the different settings, you can control which changes appear on screen. You can filter 
based on:

• Date – Only changes made in a certain time range are displayed.

• Author – Only changes made by a specific author are displayed. This is especially 
useful if you have multiple reviewers on the document.

• Range – Only changes made in a specific range of cells are displayed. This is 
especially useful if you have a large spreadsheet and only want to review a part of it.
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• Comment – Searches the content of the comments and only displays changes which 
have comments that match the search criteria.

• Show accepted changes – Only changes you accepted are displayed.

• Show rejected changes – Only changes you rejected are displayed.

Note You can also access the filter control in the Accept or Reject Changes dialog shown 
in Figure 10. Click the Filter tab to get a set of options similar to those shown in 
Figure 9.

Accepting or rejecting changes
When you receive a document back with changes, the beauty of the recording changes system 
becomes evident. Now, as the original author, you can step through each change and decide 
how to proceed. To begin this process:

1) Open the edited document.

2) Select Edit > Changes > Accept or Reject. The dialog shown in Figure 10 appears.

Figure 10: Accept or Reject Changes dialog

3) Calc steps through the changes one at a time. You can choose to accept or reject each 
change as you go through.

The Comment column by default always contains an explanation of the change that was 
made. If the reviewer added a comment to the change, it is displayed, followed by the 
description of the change, as in the first line of Figure 10.
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Merging documents

You submitted your budget proposal to your sponsor, 
but you sent it to one of your assistant coaches as well. 
Both of them returned their revised budget to you at the 
same time.

You could review each document and the changes 
separately, but to save time, you want to see both of 
their revisions simultaneously.

To do this, you can use Calc's merge document feature.

The processes discussed to this point are effective when you have one reviewer at a time. 
Sometimes, however, multiple reviewers all return edited versions of a document at the same 
time. In this case, it may be quicker to review all of these changes at once, rather than one 
review at a time. For this purpose, you can merge documents in Calc.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open the original document.

2) Select Edit > Changes > Merge Document (Figure 2).

3) A file selection dialog opens. Select a file you want to merge and click OK.

4) After the documents merge, the Accept or Reject Changes dialog opens, as in Figure
11, showing changes by more than one reviewer. If you want to merge more 
documents, close the dialog and then repeat steps 2 and 3.

Figure 11: Accept or reject for merged documents

Now all of the changes are combined into one document and you can accept or reject the 
changes. Changes from different authors appear in different colors in the document, as shown 
in Figure 12. In this example, all of the changes from Peter are blue and the changes from 
Gina are red.

Editing, Changing and Reviewing 8



Merging documents

Figure 12: Merged documents with different author colors

Comparing documents

Sometimes when sharing documents reviewers may forget to record the changes they make. 
This is not a problem with Calc. If a reviewer edits a spreadsheet but forgets to record the 
changes, Calc can find the changes if you compare documents.

In order to compare documents you need to have the original document and the one that is 
edited. To compare them:

1) Open the edited document that you want to compare with the original document.

2) Select Edit > Compare Document (Figure 2).

3) An open document dialog appears. Select the original document and click Insert.

Calc finds and marks the changes as follows:

• All data that occurs in the edited document but not in the original is identified as 
inserted.

• All data that is in your original document but is not in the edited document is 
identified as deleted.

• All data that is changed, is marked as changed.

From this point you can go through and accept or reject changes as you could normally. 
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Versions

Most documents go through many drafts. It is often useful to save all versions of a document. 
You do this by saving a copy of the document after each revision, or you could use Calc's 
version feature. To use the version management in Calc:

1) Select File > Versions. The Versions dialog opens as in Figure 13.

Figure 13: Version management dialog window

2) Click the Save New Version button to save a new version.

3) A dialog opens where you can enter comments about this version, as shown in Figure
14.

Figure 14: Version comment dialog

4) After you enter your comment and click OK, the version is included in the version list 
as shown in Figure 15.
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Versions

Figure 15: Updated version list

Now when you save the file, both versions are saved in the same file. From this point you 
can:

• Open an old version – Select the version and click the Open button and a read-only 
version of a previous version opens.

• Compare all versions – Clicking the Compare button performs an action similar to 
merging documents together. An Accept or Reject Changes dialog opens showing all 
of the changes through the different versions.

• Review the comments – Select a version and click the Show button to display the full 
comments made by yourself or other reviewers.

Note The new file is bigger in size, as if there were actually two spreadsheets saved 
together.

Caution

 

If you do a Save As... of a document with different versions stored in it, the old 
versions are not saved in the new file.

A note about file names and titles
When sharing documents it is important to keep track of the different copies of the document. 
This can be done either in the file name or in the file title. In Calc, the filename of the 
spreadsheet is displayed in the title bar. You can set the title of the spreadsheet in the 
Properties dialog. To set the title, select File > Properties > Description.
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