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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows
and Linux. The table below gives some common substitutions for the instructions in
this chapter. For a more detailed list, see the application Help.
Windows/Linux
Tools > Options
menu selection

Mac equivalent
OpenOffice.org >
Preferences

Effect
Access setup options

Right-click

Control+click

Open context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Open the Navigator

F11

z+T

Open Styles & Formatting window

You can download
an editable version of this document from
http://wiki.services.openoffice.org/wiki/Documentation/
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Drawing an organization chart
Even though Draw does not have an organization chart toolbar, you can draw these
charts by drawing rectangles and connector lines (see Figure 1). You can indicate
hierarchies by using a color progression from dark to light tones. Your color choices
should maintain a good contrast between text color and background so that you can
easily read the printed diagram.

Figure 1: Example of an Organization Chart
Before you begin, prepare a setup page or draft, with snap lines, to assist in drawing
the various hierarchies, responsibility paths, and typical boxes that you will use in
drawing the chart.

Figure 2: Draft with snap lines
Place and dimension the individual boxes according to the size of the overall chart.
The exact size (particularly width), position, and color will be fixed later. It is
sometimes easier to draw only one box per level; later you can copy and paste this
box and then move the copies to the desired positions. Using styles can also be
helpful; see the relevant section in Chapter 4 (Changing Object Attributes).
You can also select one or more boxes and use Edit > Duplicate to make copies (see
Figure 3). The spacing of the duplicated objects relative to the original can be
controlled using the placement fields for the X and Y axes. Note that positive values
for X and Y are to the right and downwards from the original object.

4

Organization Charts, Flow Diagrams, and More

Figure 3: Duplicating an object
Which replication technique you use is up to you. The draft for the example in this
chapter should look similar to that in Figure 4.

Figure 4: The finished draft
The next step is to add text to the boxes. It is easiest to insert it as a text element
within the box as described in Chapter 2 (Drawing Basic Shapes). Activate the
icon on the Options toolbar and then double-click the box to enter text into it.
Alternatively, select the box and press F2. You should then see a blinking cursor in
the box and the Text Formatting toolbar should be visible.
Set the text formatting and type the text. Depending on the length and format of the
text, you may need to adjust the size of the box and the spacing to neighboring boxes
or else change the formatting of the text to fit the box. Adjustments can be made
initially with the mouse and then fine-tuned with the Position and Size dialog.
Now set up the fill colors and save the drawing. The connections between the boxes
are not drawn with ordinary lines but with Draw’s connectors. How to draw these
connectors and add text to them is described in “Glue points and connectors” starting
on page 8.

Drawing an organization chart
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You can use dynamic text frames instead of boxes. These have the advantage of
automatic line breaks. Figure 5 shows the sequence of text input into a frame, adding
borders, and setting the background color. The Line and Filling toolbar may not be
visible until you have set a line type for the frame. Set the line type using Format >
Line or right-clicking the text frame and selecting Line.

Figure 5: Working with text frames

Drawing a flow diagram
For drawing flow diagrams (also known as flowcharts), Draw offers a separate
toolbar (Figure 6); click the flowchart icon

on the main Drawing toolbar.

The easiest way to draw a flowchart is to follow the same setup procedure as for
organization charts. Select the symbols from the toolbar and drag them into position
as described in Chapter 2 (Drawing Basic Shapes). See Figure 7 for an example of a
typical flowchart.
The individual symbols must be exactly positioned if the connectors joining them are
to form a vertical line. The midpoints of all the symbols that lie in a vertical straight
line should have the same X coordinate and those on the same level on a horizontal
line should have the same Y coordinate.
6
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Figure 6: The Flowchart toolbar

Figure 7: Example of a flow diagram

Drawing a flow diagram
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Select the shapes that are to lie in a vertical straight line and center them with
Modify > Alignment > Centered. For those on a horizontal line, select the shapes
and center them with Modify > Alignment > Center. You can also set snap lines if
you need several vertical lines.
After adding text and setting the fill color, you can join individual symbols together
and add text to the connectors. This technique is described in the next section.

Glue points and connectors
These elements were briefly introduced in Chapter 2 (Drawing Basic Shapes). This
section describes how to use them.
Connectors are lines or arrows whose ends automatically dock to a connection or
glue point on an object. Connectors are particularly useful when drawing
organization charts, flow diagrams, and mind-maps. The connecting lines between
the symbols remain intact even when the latter are moved or rearranged.

The Connector toolbar
Click on the
toolbar.

arrow of the

button on the Draw toolbar to open the Connectors

If the type of
connector you want
is not shown, drag
the toolbar to make
it float, then click on
the
arrow in the
toolbar’s title bar. In
the list that appears,
click on Visible
buttons to open a
menu from which
you can activate
additional types of
connector (Figure 8).

Figure 8: Activating additional connectors
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Connector types fall into four groups:

• Standard connectors – the line segments run vertically and horizontally. All
angles are right angles. The connector does not bend around the objects it
binds.

• Line connectors – consist of a line segment and two smaller horizontal or
vertical segments at the ends.

• Straight connectors – consist of a single line.
• Curved connectors – are based on Bézier curves, as described in Chapter 10
(Advanced Draw Techniques).
You can modify all the connector types from the context menu. Select Connector to
change from one connector type to another (as well as some other properties). With
the Line dialog you can change the appearance of the line (color, arrow style, and line
style) but not the connector type.

Drawing connectors—basics
When you choose a connector from the toolbar, the mouse pointer changes to
.
As you move the cursor over an object, the available connection points (also referred
to as glue points) become visible. To connect two shapes, move the mouse cursor
over a glue point, click and hold down the left mouse button to establish the first
point, and then drag the mouse cursor (left button still pressed) to the other glue
point and release the mouse button. The ends of the line are now docked and the
connection is established (see Figure 9).

Figure 9: Gluing a connector to a shape
You can also attach the beginning or the end of a connector to the middle of an
object. This is useful when the final position of the object is not yet determined. When
you move the object, Draw automatically selects the optimal location for the
connector ends (see Figure 10).

Figure 10: Connector attached to the middle of an object
Glue points and connectors
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As with all other objects, connectors have one or more control points to simplify the
construction of the drawing. You can use these points to change the shape, length,
and proportions of the connector line (see Figure 11).

Figure 11: Control points of
a connector
To remove a connector from an object, either move the end of the connector away
from the glue point of the object or simply delete the connector entirely.

Editing glue points
Glue points can be edited using a separate toolbar (see Figure 12). This toolbar
appears when you click on the Glue Points icon
from the main menu.

or select Edit > Glue Points

Figure 12: The Glue points toolbar
The following briefly describes the function of each button on this toolbar.
Use this button to insert a new glue point into an object you have drawn. If
the object is filled, you can place a glue point anywhere inside the object or
on its frame. With unfilled objects you can place a glue point only on the
outside frame but you can then drag it inside the object provided that the
Glue Points icon on the Drawing toolbar is still active .
The glue points that you add remain visible as long as
the Glue Points icon is active. They appear as small blue
crosses. A selected glue point has a gray square behind
the cross. You can move a selected glue point with the
mouse or delete it with the Del key.
Use these four buttons to choose one or more directions permitted for a
connector to join to a particular glue point.
Activate Glue Points and then choose the direction. If, for example, you
activate only the
button, every connector will be forced to come to that
glue point from the left side.
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In the left-hand drawing below is a glue point in the circle with a left entry
and one in the square with a right entry. The effect of this when adding a
connector between the two glue points is shown in the right-hand drawing..

If you are in glue point editing mode and you add another direction to a glue
point (for example by activating the
button), Draw tries to optimize the
length of the connector. For the example above, the connection inside the
circle would change as shown below.

If the Glue Point Relative button is active (as it is by default) the glue point
will move when you change the size of the object, as shown below.

If the Glue Point Relative button is deactivated, the remaining buttons on
the toolbar, previously grayed out, become active. With these buttons you
can decide how a glue point will be placed when the size of the object is
changed.
These buttons determine how the horizontal position of a glue point changes
when you resize the object containing the glue point. You can choose
whether the glue point remains at a fixed distance from the left edge of the
object, from a vertical line through the middle, or from the right edge of the
object when you change the size of the object. If the width of the object
becomes less than that distance, the glue point is attached to the object
frame.
The following example shows what happens when an object’s width is
changed and the glue point is set to be a fixed distance to the left frame.

Glue points and connectors
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These buttons determine in a similar manner the vertical position of a glue
point when the size of the object is changed.

Adding text to connectors
To add text to a connector, double-click the connector. The end and control points
become active and the familiar flashing text cursor appears (the cursor position is
determined by the most recent setting). The Text Formatting toolbar also appears
(under the menu bar). Use this toolbar to set the text properties; you can directly
insert the text.
If you draw a connector and then click on it, only the end points and control points
become visible. In spite of this, a connector has its own object frame—in this case an
invisible one. You can picture it easily by imagining a rectangle enclosing the start
and end points of the connector (Figure 13).

Figure 13: Object frame of a connector
When you add text to a connector, the location of the text is relative to this rectangle.
The exact position of the text can be set in the Text dialog (Figure 14). This dialog
appears when you double-click on text and then choose Text from the pop-up menu
or when you single-click on the connector and select Format > Text from the menu
bar.
Take particular note of the Spacing to borders and Text anchor sections in the Text
dialog. In the Text anchor section you can see the possible locations for the text. In
the example below the text is anchored at the top left. In the Spacing to borders
section at the lower left, negative values of spacing will position the text outside the
frame.
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Figure 14: The Text dialog

Adjusting text to suit the connecting line
If you want the text to follow the slope or curve of a line, you need to activate and use
the Fontwork tool. To add this tool to the Draw toolbar:
1) Choose Tools > Customize from the menu bar.
2) On the Toolbars tab, select Drawing from the Toolbars pull-down list. In the
Toolbar content section, click Add.
3) On the Add Commands dialog, select Format from the left-hand list and the
command Fontwork. Click Add, then Close to return to the Customize dialog.
4) In the list of commands under Toolbar Content, move the Fontwork icon
the location you want by using the up/down arrows, and then click OK.

to

To write slanting text, follow these steps:
1) Add the text to the connector as described earlier. The anchor location of the
text is not important at this stage.
2) Select the object with the text (in this case the connector) and click on the
Fontwork icon
to open the Fontwork dialog.
3) To make the text lie along the inclined line, click the Rotate icon and set the
distance to the line you wish.

Adding text to connectors
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Figure 15: Adding text to an inclined line, Step 1

Figure 16: Adding text to an inclined line, Step 2
The Fontwork dialog provides many other possibilities for manipulating text. You can,
for example, rotate the text 180 degrees with the Orientation
icon (which was
done in the example above) or place the text under the line by assigning a negative
value to the spacing between text and line.
In addition, you can use the Fontwork dialog to generate curved text that follows the
shape of a curved line. Experiment a little to investigate some of the possibilities.
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