Chapter 14
Working with Graphics and the Gallery
Copyright

This document is Copyright © 2005–2008 by its contributors as listed in the section titled Authors. You may distribute it and/or modify it under the terms of either the GNU General Public License, version 3 or later (http://www.gnu.org/licenses/gpl.html), or the Creative Commons Attribution License, version 3.0 (http://creativecommons.org/licenses/by/3.0/) or later.

All trademarks within this guide belong to their legitimate owners.

Authors

Agnes Belzunce
Jean Hollis Weber
Linda Worthington

Feedback

Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Publication date and software version

Published 21 April 2008. Based on OpenOffice.org 2.4.
# Contents

Copyright................................................................................................................................................. i
Authors.................................................................................................................................................... i
Feedback.................................................................................................................................................. i
Publication date and software version................................................................................................. i

Introduction................................................................................................................................................1
Inserting an image from a file.................................................................................................................1
  Linking an image file............................................................................................................................1
  Embedding linked images................................................................................................................... 2
Inserting images from a graphics program............................................................................................2
Inserting images using a scanner...........................................................................................................3
Modifying and positioning graphics........................................................................................................3
Using the OpenOffice.org Gallery...........................................................................................................3
  Inserting images into a document........................................................................................................ 4
  Inserting objects as links..................................................................................................................... 5
  Inserting an object as a background.................................................................................................... 5
Managing the Gallery.............................................................................................................................5
  Adding objects to the Gallery............................................................................................................ 6
  Deleting images from the Gallery....................................................................................................... 6
  Adding a new theme to the Gallery..................................................................................................... 7
  Deleting a theme from the Gallery....................................................................................................... 7
  Location of the Gallery and the objects in it...................................................................................... 7

Working with the Gallery i
Introduction

You can add graphic and image files, including photos, drawings, scanned images, and others, to OpenOffice.org documents. OOo can import various vector (line drawing) and raster (bitmap) file formats. The most common are GIF, JPEG or JPG, PNG, and BMP. See Chapter 3 (File Management) for a full list of supported graphic file types.

Inserting an image from a file

To insert an image from a file, the file must be already stored in a directory (folder) on the computer.

1) Determine the destination for the image. Place the cursor at or near the appropriate location in the document.

2) On the main menu, select Insert > Picture > From File. This displays the dialog shown in Figure 1.

3) Navigate to the file to be inserted, select it, and click Open.

![Figure 1. Insert picture dialog](image_url)

Note At the bottom of the Insert picture dialog are two checkboxes. If the Preview checkbox is checked, the selected graphic file is previewed in a pane, as shown in Figure 1, so you can verify that you have the correct file. The Link checkbox is discussed below.

Linking an image file

If the Link checkbox in the Insert picture dialog is checked, OOo creates a link to the file containing the image, instead of saving a copy of the image in the document. The result is that the image is displayed in the document, but when the document is saved, it contains only a reference to the image file—not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.
Linking an image has two advantages and one disadvantage:

- **Advantage** – Linking can reduce the size of the document when it is saved, because the image file itself is not included. File size is usually not a problem on a modern computer with a reasonable amount of memory, unless the document includes many large graphics files; OOo can handle quite large files.

- **Advantage** – You can modify the image file separately without changing the document because the link to the file remains valid, and the modified image will appear when you next open the document. This can be a big advantage if you (or someone else, perhaps a graphic artist) is updating images.

- **Disadvantage** – If you send the document to someone else, or move it to a different computer, you must also send the image files, or the receiver will not be able to see the linked images. You need to keep track of the location of the images and make sure the recipient knows where to put them on another machine, so the document can find them. For example, you might keep images in a subfolder named Images (under the folder containing the document); the recipient of the file needs to put the images in a subfolder with the same name (under the folder containing the document).

### Embedding linked images

If you originally linked the images, you can easily embed one or more of them later if you wish. To do so:

1. Open the document in OpenOffice.org and choose **Edit > Links**.
2. The Edit Links dialog shows all the linked files. In the **Source file** list, select the files you want to change from linked to embedded.
3. Click the **Break Link** button.
4. Save the document.

**Note** Going the other way, from embedded to linked, is not so easy—you must delete and reinser each image, one at a time, selecting the **Link** checkbox when you do so.

### Inserting images from a graphics program

You can use many different graphics programs to edit a graphic file. In these programs, you can select, copy, and paste an image or part of a graphic into an OpenOffice.org document. Figure 2 shows an example of this procedure.

1. In the graphics program window, select an area of the image to be copied.
2. Move the cursor over the selected area and press **Control+C** to copy.
3. Switch to the OpenOffice.org window.
4. Click to insert the cursor where the graphic is to be inserted.
5. Press **Control+V** to paste.
Inserting images from a graphics program

![Image of a graphics program](image.png)

**Figure 2. Inserting an image from a graphics program**

**Inserting images using a scanner**

If a scanner is connected to your computer, OOO can call the scanning application and inserted the scanned item into the OOO document page as an image. To start this procedure, select **Insert > Picture > Scan > Select Source**.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by cleaning up scanned material in a graphics program before inserting the resulting image into OOO.

**Modifying and positioning graphics**

OpenOffice.org provides many tools for resizing, modifying, filtering, and positioning graphics; wrapping text around graphics; and using graphics as backgrounds and watermarks. These tools are described in relevant chapters of the other guides. Some sophisticated adjustments of the graphics are best done in an image manipulation program and the results brought into OOO, rather than using OOO’s inbuilt tools.

**Using the OpenOffice.org Gallery**

The **Gallery** contains objects (graphics and sounds) that you can insert into your documents. The Gallery is available in all components of OpenOffice.org.

To open the Gallery, choose **Tools > Gallery**, or click the Gallery icon 🏡. If the Gallery is open, these choices close it.

Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and Backgrounds. You can create other groups or themes.
The box on the left of the gallery window lists the available themes. Click on a theme to see its graphics displayed in the Gallery window.

Figures 3 and 4 show two views of one of the themes supplied with OpenOffice.org.

You have the option of **Icon View** or **Detailed View** for the Gallery, and you can hide or show the Gallery by clicking on the **Hide** button.

**Inserting images into a document**

You can copy or link an object from the Gallery into a document.

To insert an object:

1) Choose **Tools > Gallery** and select a theme.

2) Select an object with a single click, then drag and drop the image into the document. (See Figure 5.)

   You also can right-click on the object to open the context menu and select **Insert > Copy**.
Using the OpenOffice.org Gallery

Figure 5. Copying a graphic object from the Gallery into a document

**Inserting objects as links**

To insert an object as a link:

1) Choose **Tools > Gallery** and select a theme.

2) Select an object with a single click, then while pressing the Shift and Ctrl keys, drag and drop the object into the document.

**Inserting an object as a background**

To insert an object as the background to a page or paragraph:

1) Choose **Tools > Gallery** and select a theme.

2) Select an object with a single click, right-click on the object and choose **Insert > Background > Page or Paragraph**.

**Managing the Gallery**

The default themes are locked; no items can be added or deleted from these themes. The locked themes are easily recognizable by right-clicking on them; the only available option in the pop-up menu is **Properties**.
In a default installation, only the *My themes* theme is customizable, although new themes can be added as explained in “Adding a new theme to the Gallery” on page 7.

**Adding objects to the Gallery**

You may wish to add to the Gallery any images that you use frequently, for example, a company logo. You can then very easily insert these graphics into a document later. You can add images only to “My Theme” or to any other theme that you have created; these are indicated by a green icon in the list of themes. You cannot add images to the built-in themes, indicated by an icon of another color.

**Method 1** (selecting a file):

1) In the theme’s Properties, on the *Files* page, click the **Find Files** button. The Select path dialog opens.

2) You can enter the path for the file’s directory in the *Path* text box, or you can navigate to locate the file's directory. Use the *File type* drop-down list to help limit the search.

3) Click the **Select** button to start the search.

A list of graphic files is then displayed in the window. You can use the *File type* filter again to further limit the search.

4) Select the files to add. To select more than one file, hold the *Control* key down while you click on each file.

5) Finally, click **Add**.

**Method 2** (drag and drop):

1) Open the document containing an image you want to add to the Gallery, and display the Gallery theme to which you want to add it.

2) Position the mouse pointer above the image, without clicking.

3) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this case, press the *Alt* key while you click the image, to select it without activating the link. If the mouse pointer does not change to a hand symbol, you can simply click the image to select it.

4) Once the image is selected, evident from the green selection handles around it, release the mouse button. Click again on the image, keeping the mouse button pressed for more than two seconds. Without releasing the mouse button, drag the image into the document.

5) Release the mouse button.

**Deleting images from the Gallery**

To delete an image from a theme:

1) Right-click on the name of the image file or its thumbnail in the Gallery.

2) Click **Delete** on the pop-up menu. A message appears, asking if you want to delete this object. Click **Yes**.

---

**Note**  Deleting the name of a file from the list in the Gallery does not delete the file from the hard disk or other location.
Adding a new theme to the Gallery

1) Click the New Theme button above the list of themes (see Figure 3).
2) In the Properties of New Theme dialog, click the General tab and type a name for the new theme.
3) Click the Files tab and add images to the theme, as described earlier.

Deleting a theme from the Gallery

You can delete only theme that you have added to the Gallery; you cannot delete any of the inbuilt themes. To delete a theme from the Gallery:

1) Go to Tools > Gallery.
2) In the left part of the Gallery, select in the list the theme you wish to delete.
3) Right-click on the theme, then click Delete on the pop-up menu.

Location of the Gallery and the objects in it

Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard disk, on a network drive, or on a CD-ROM. Listings in the Gallery refer to the location of each object. When you add graphics to the Gallery, the files are not moved or copied; only the location of each new object is added as a reference.

In a workgroup situation, you may have access to a shared Gallery (where you cannot change the contents unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.

The location of the user Gallery is specified in Tools > Options > OpenOffice.org > Paths. Typically it is something like \openoffice\user\gallery, although the exact location depends on your operating system. You can change this location, and you can copy your gallery files (*.sdv) to other computers.

Gallery contents provided with OOo are stored in a location like openoffice\share\gallery. You cannot change this location.