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Note for Mac Users
Some keystrokes and menu items differ on a Mac from those used in Windows and 
Linux. The table below gives some common substitutions for the instructions in this 
chapter. For a more detailed list, see the application Help.

Windows/Linux Mac equivalent Effect

Tools > Options 
menu selection

OpenOffice > 
Preferences

Access setup options

Right-click Control+click Open context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open Styles & Formatting window
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What is Math?

Math is OpenOffice's component for writing mathematical equations. It is most 
commonly used as an equation editor for text documents, but it can also be used with
other types of documents or stand-alone. When used inside Writer, the equation is 
treated as an object inside the text document.

Note
The equation editor is for writing equations in symbolic form, as in 
equation 1. If you want to evaluate a numeric value, see the Calc 
Guide.

df (x)
dx

=ln ( x)+tan−1( x2)  (1)

Getting Started
To insert an equation in Writer, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Elements 
window may appear. You will also see a small box with a gray border in your 
document where the formula will be displayed, as shown in Figure 1.

 

Figure 1: Equation Editor, Elements window, and location of resulting equation
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Entering a Formula

The equation editor uses a markup language to represent formulas. For example, 
%beta creates the Greek character beta (  ). This markup is designed to read 

similarly to English whenever possible. For example, a over b produces a fraction: 
a
b

.

You can enter a formula in three ways:

• Select a symbol from the Elements window.

• Right-click on the equation editor and select the symbol from the context 
menu.

• Type markup in the equation editor.

The context menu and the Elements window insert the markup corresponding to a 
symbol. This provides a convenient way to learn the AOO Math markup.

Note Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

The Elements Window
The simplest way to enter a formula is through the Elements window.

 

Figure 2: Symbols are divided into categories

The Elements window is divided into two main parts.

• The top shows the symbol categories. Click on these to change the list of 
symbols.

• The bottom shows the symbols available in the current category.

Tip You can hide or show the Elements window with View > Elements.
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Example 1: 5×4
For this example, we will enter a simple formula: 5×4 . On the Elements window:

1) Select the top-left button of the categories (top) section to reveal operators 
requiring one or two operands.

2) Click on the multiplication symbol.

 

Figure 3: Selecting the multiplication symbol

When you select the multiplication symbol on the Elements window, two things 
happen:

• The equation editor shows the markup: <?> times <?>
• The body of the document shows a gray box like this: ×

Figure 4: Result of selecting the multiplication symbol

The <?> symbols shown in Figure 4 are placeholders that you can replace with other 
text, for example, 5 and 4. The equation will update automatically, and the result 
should resemble Figure 5.

Tip
To keep the equation from updating automatically, select View > 
AutoUpdate display. To update a formula manually, press F9 or select
View > Update.
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Figure 5: Result of entering 5 and 4 next to the times operator

Right-click (Context) Menu
Another way to access mathematical symbols is to right-click on the equation editor. 
This pops up the menu shown in Figure 6. The items in this menu correspond exactly 
to those in the Elements window.

Figure 6: Right-click (context) menu

Markup
You can type the markup directly in the equation editor. For example, you can type 5 
times 4 to obtain 5×4 . If you know the markup, this can be the fastest way to enter
a formula.

Tip Formula markup will always resemble the way a formula reads in 
English.
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Below is a short list of common equations and their corresponding markup.

Display Command Display Command

a=b a = b a sqrt {a}

a2 a^2 an
a_n

∫ f x dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y

Greek Characters

Greek characters (  , , , , etc) are common in mathematical formulas. These 
characters are not available in the Elements window or the right-click menu. 
Fortunately, the markup for Greek characters is simple: Type a % sign followed by the
character's name in English.

• To write a lowercase character, type the name of the character in lowercase.

• To write an uppercase character, type the name of the character in uppercase.

A complete table of Greek characters is provided on page 27. See the table below for 
some examples.

Lowercase Uppercase

%alpha   %ALPHA  A

%beta   %BETA  B

%gamma → γ %GAMMA  

%psi    %PSI   

%phi    %PHI   

%theta   %THETA  

Another way to enter Greek characters is by using the Symbols catalog window. 
Choose Tools > Catalog. This window is shown in Figure 7. Under Symbol set, select
Greek and double-click on a Greek letter from the list. The character's markup name 
is shown below the list window.
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Figure 7: Symbols catalog, used for entering Greek characters and some 
special symbols

Example 2:  ≃ 3.14159
For this example, we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal 
places).

• We know the name of the Greek character (pi).

• But we do not know the markup associated with the ≃  symbol.

Step 1: Type % followed by the text pi. This displays the Greek character  .

Step 2: Open the Elements window (View > Elements).

Step 3: The ≃  symbol is a relation, so we click on the Relations button. If you hover
the mouse over this button, you see the tooltip Relations (Figure 8). 

Figure 9 shows the Selection window after clicking the Relations button. The symbol 
we want is circled.
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Figure 8: Tooltip indicates the 
Relations button

 

Figure 9: After selecting Relations

Step 4: Click on the a≃ b symbol. The equation editor now shows the markup 
%pi<?> simeq <?>.

Step 5: Delete the <?> text and add 3.14159 at the end of the equation. We end up 
with the markup %pi simeq 3.14159, as shown in Figure 10.

Figure 10. Final result
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Customizations

Formula Editor as a Floating Window
The formula editor can cover most of the Writer window. To turn the formula editor 
into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 11.
2) Press and hold the Control key, then double-click.

Figure 11: Turning the formula editor into a 
floating window

Figure 12 shows the result. You can dock the floating window again by using the 
same steps. Hold down the Control key and double-click the window frame.

 

Figure 12: Formula editor as a floating window

How Can I Make a Formula Bigger?
This is one of the most common questions people ask about Math. The answer is 
simple, but not intuitive:

1) Start the formula editor and choose Format > Font Size (Figure 13).
2) Select a larger font size under Base size (top-most entry) (Figure 14).
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Figure 13: Changing the font size for a formula

 
Figure 14. Edit Base size (top) to make a formula bigger

Figure 15 illustrates the result of this change.

Figure 15. Result of changing the base font size

Formula Layout

The hardest part of using AOO Math involves writing complicated formulas. This 
section provides some advice.

Brackets are Your Friends
AOO Math knows nothing about order of operations. You must use brackets to 
explicitly state the order. Consider the following example.
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Markup Result

2 over  x + 1
2
x
1

2 over {x + 1}
2

x1

Equations Over More Than One Line
Suppose you want to type an equation covering more than one line. For example:

x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the 
Enter key, though the markup goes to a new line, the resulting equation does not. You
must type the newline command explicitly. This is illustrated in the table below.

Markup Result

x = 3

y = 1 x=3 y=1

x = 3 newline

y = 1
x=3
y=1

How Do I Add Limits to My Sum/Integral?
The sum and int commands can (optionally) take the parameters from and to. These 
are used for lower and upper limits, respectively. These parameters can be used 
singly or together. Limits for integrals are usually treated as subscripts and 
superscripts.

Markup Result

sum from k = 1 to n a_k ∑
k=1

n

a k

int from 0 to x f(t) dt

or 
int_0^x f(t) dt

∫
0

x

f t dt  or  ∫0

x
f  t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n} ∑
∞

2−n

Note For more details on integrals and sums, see page 22.
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Brackets with Matrices Look Ugly!
For background, we start with an overview of the matrix command.

Markup Result

matrix { a # b ## c # d } a b
c d

Note Rows are separated by two #’s, and entries within each row are 
separated by one #.

The first problem people have with matrices is that brackets do not scale with the 
matrix:

Markup Result

(  matrix { a # b ## c # d }  ) 
a b
c d



AOO Math provides scalable brackets. That is, the brackets expand to match the size 
of their contents. Use the commands left( and right) to create scalable brackets.

Markup Result

left(  matrix { a # b ## c # d }  right) a b
c d 

Tip Use left[ and right] to obtain square brackets.

How Do I Make a Derivative?
Making derivatives essentially comes down to one trick: Tell AOO it’s a fraction.

In other words, you have to use the over command. Combine this with either the 
letter d (for a total derivative) or the partial command (for a partial derivative) to 
achieve the effect of a derivative.

Note Notice that we have to use braces (squiggly brackets) to make the 
derivative.
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Markup Result

{df} over {dx}
df
dx

{partial f} over {partial y}
∂ f
∂ y

{partial^2 f} over {partial t^2}
∂2 f

∂ t2

How Do I Align My Equations at the Equals Sign?
AOO Math does not have a command for aligning equations on a particular character,
but you can use a matrix to do this, as shown below.

Markup Result

matrix{

   alignr x+y # {}={} # alignl 2 ##

   alignr x   # {}={} # alignl 2-y

}

x y = 2
x = 2−y

The empty braces around = are necessary because = is a binary operator. That 
means it needs an expression on each side.

You can reduce the spacing around = if you change the inter-column spacing of the 

matrix: x+ y=2
x=2− y

1) With the equation editor open, choose Format > Spacing from the menu bar.
2) In the Spacing dialog (Figure 16), click the Category button and select 

Matrices in the drop-down menu.
3) Enter 0% for Column spacing and click OK.

Figure 16: Changing spacing in a matrix formula
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Numbering Equations

Equation numbering is one of AOO Math’s best hidden features. The steps are simple,
but not necessarily intuitive:

1) Start a new line.
2) Type fn and then press F3.

The fn is replaced by a numbered formula:

E=mc2  (2)

Now you can double-click on the formula to edit it. For example, here is the Riemann 
Zeta function:

 z =∑
n=1

∞ 1

nz

 
(3)

You can reference an equation (for example, “as shown in Equation (2)”) with these 
steps:

1) Choose Insert > Cross-reference from the menu bar.
2) On the Cross-references tab (Figure 17), under Type, select Text.
3) Under Selection, select the equation number.
4) Under Format, select Reference.

Click Insert.
Done! If you add more equations to the paper before the referenced equation, all the 
equations will automatically renumber and the cross-references will update.

Tip To insert the equation number without parentheses around it, choose 
Numbering instead of Reference under Format.
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Figure 17. Inserting a cross-reference to an equation number 
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Math Commands – Reference

Unary and Binary Operators

Operation Command Display

+sign +1 1

–sign –1 −1

+/– sign +–1 ±1

–/+ sign –+1 ∓1

Boolean not neg a ¬a

Addition + a + b ab

Dot product a cdot b a⋅b

Multiplication (X) a times b a×b

Multiplication (asterisk) a * b a∗b

Boolean ‘and’ a and b a∧b

Subtraction (–) a – b a−b

Division (as a fraction) a over b
a
b

Division (as an operator) a div b a÷b

Division (with a slash) a / b a /b

Boolean ‘or’ a or b a∨b

Concatenation a circ b a°b
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Relational Operators

Operation Command Display

Is equal a = b a=b

Is not equal a <> b a≠2

Approximately a approx 2 a≈2

Divides a divides b a∣b

Does not divide a ndivides b a∤b

Less than a < 2 a2

Greater than a > 2 a2

Similar to or equal a simeq b a≃b

Parallel a parallel b a∥b

Orthogonal to (i.e. Independent if) a ortho b a⊥b

Less than or equal to a leslant b ab

Greater than or equal to   a geslant b ab

Similar to a sim b a~b

Congruent a equiv b a≡b

Less than or equal to a <= b a≤b

Greater than or equal to a >= b a≥b

Proportional a prop b a∝b

Toward a toward b a b

Arrow left a dlarrow b a⇐b

Double arrow left and right a dlrarrow b a⇔b

Arrow right a drarrow b a⇒b
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Set Operations

Operation Command Display

Is in a in B a∈B

Is not in a notin B a∉B

Owns A owns b A∋b

Empty set emptyset ∅

Intersection A intersection B A∩B

Union A union B A∪B

Difference A setminus B A∖B

Quotient A slash B A/B

Aleph (the integer which is the 
smallest cardinal number in 
the set)

aleph ℵ

Subset A subset B A⊂B

Subset or equal to A subseteq B A⊆B

Superset  A supset B A⊃B

Superset or equal to A supseteq B A⊇B

Not subset A nsubset B A⊄B

Not subset or equal A nsubseteq B A⊈B

Not superset A nsupset B A⊅B

Not superset or equal A nsupseteq B A⊉B

Set of natural numbers setN ℕ

Set of integers setZ ℤ

Set of rational numbers setQ ℚ

Set of real numbers setR ℝ

Set of complex numbers setC ℂ
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Functions

Operation Command Display

Exponential func e^{a} ea

Natural logarithm ln(a) ln a

Exponential function exp(a) exp a

Logarithm log(a) log a 

Power a^{b} ab

Sine sin(a) sina

Cosine cos(a) cos a

Tangent tan(a) tana 

Cotangent cot(a) cot a

Square root sqrt{a} a

Arcsine arcsin(a) arcsin a 

Arc cosine arccos(a) arccosa 

Arctangent arctan(a) arctan a

Arc cotangent arccot(a) arccot a

nth root nroot{a}{b} ab

Hyperbolic sine sinh(a) sinh a

Hyperbolic cosine cosh(a) cosh a 

Hyperbolic tangent tanh(a) tanh a 

Hyperbolic cotangent coth(a) coth a

Absolute value abs{a} ∣a∣

Arc hyperbolic sine arsinh(a) arsinh a 

Arc hyperbolic cosine arcosh(a) arcosh(a)

Arc hyperbolic tangent artanh(a) artanh(a)

Arc hyperbolic cotangent arcoth(a) arcoth(a)

Factorial fact{a} a!
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Operators
All operators can be used with the limit functions from and to.

Operation Command Display

Limit lim{a} lim a

Sum sum{a} ∑ a

Product prod{a} ∏ a

Coproduct coprod{a} ∐ a

Upper and lower bounds shown
with integral

int from {r_0} to {r_t} a ∫
r0

rt

a

Integral int{a} ∫ a

Double integral iint{a} ∬a

Triple integral iiint{a} ∭a

Lower bound shown with 
summation symbol 

sum from{3}b ∑
3

b

Contour integral lint a ∮a

Double curved integral llint a ∯a

Triple curved integral lllint a ∰a

Upper bound shown with 
product symbol

prod  to{3} r ∏
3

r
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Attributes

Operation Command Display

Acute accent acute a a

Grave accent grave a a

Reverse circumflex check a a

Breve breve a a

Circle circle a å

Vector arrow vec a a

Tilde tilde a a

Circumflex hat a a

Line above bar a a

Dot dot a ȧ

Wide vector arrow widevec abc abc

Wide tilde widetilde abc abc

Wide circumflex widehat abc abc

Double dot ddot a ä

Line over overline abc abc

Line under underline abc abc

Line through overstrike abc abc

Triple dot dddot a a

Transparent (useful to get a placeholder of a 
given size)

phantom a

Bold font bold a a

Italic font1 ital “a” a

Resize font size 16 qv qv
Following item in sans serif font2 font sans qv qv

Following item in serif font font serif qv qv

Following item in fixed font font fixed qv qv

Make color of following text cyan3 color cyan qv qv

1 Unquoted text that is not a command is considered to be a variable. Variables are, by 
default, italicized.

2 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed (non-
proportional). To change the actual fonts used for custom fonts and the fonts used for 
variables (unquoted text), numbers and functions, use Format > Fonts.

3 Color applies only to the text immediately following the command until the next space. To 
have the color apply to more characters, place the text you want in color in curly brackets.
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Operation Command Display

Make color of following text yellow color yellow qv qv

Make color of following text white color white qv qv

Make color of following text green color green qv qv

Make color of following text blue color blue qv qv

Make color of following text red color red qv qv

Make color green returns to default color black color green X qv X qv

Brace items to change color of more than one 
item

color green {X qv} X qv

Miscellaneous

Operation Command Display

Infinity infinity ∞

Partial partial ∂

Nabla nabla ∇

There exists exists ∃

For all forall ∀

H bar hbar ℏ

Lambda bar lambdabar ƛ

Real part re ℜ

Imaginary part im ℑ

Weierstrass p wp ℘

Left arrow leftarrow 

Right arrow rightarrow 

Up arrow uparrow 

Down arrow downarrow 

Dots at bottom dotslow 

Dots at middle dotsaxis ⋯

Dots vertical dotsvert ⋮

Dots diagonal upward dotsup ⋰

Dots diagonal downward dotsdown ⋱
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Brackets

Operation Command Display

Round Brackets (a) a

Square Brackets [b] [b]

Double Square Brackets ldbracket c rdbracket 〚c〛

Single line lline a rline ∣a∣

Double line ldline a rdline ∥a∥

Braces lbrace w rbrace {w}

Angle Brackets langle d rangle 〈d 〉

Operator Brackets langle a mline b rangle 〈a∣b〉

Group brackets (used for 
program control; also called 
curly braces)

{a} a

Scalable round brackets
(add the word “left” before a 
left bracket and “right” before
a right bracket)

left ( stack{a # b # z} 
right ) 

a
b
z

Square brackets scalable

(as above)

left [ stack{ x # y} right ] [ xy]
Double square brackets 
scalable

left ldbracket c right 
rdbracket 

〚c〛

Line scalable left lline a right rline ∣a∣

Double line scalable left ldline d right rdline ∥d∥

Brace scalable left lbrace e right rbrace {e}

Angle bracket scalable left langle f right rangle 〈 f 〉

Operator brackets scalable
left langle g mline h right 
rangle 

〈g∣h〉

Over brace scalable
{The brace is above} 
overbrace a Thebraceis above

a

Under brace scalable
{the brace is 
below}underbrace {f}

the braceis below
f
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Formats

Operation Command Display

Left superscript a lsup{b} ab

Center superscript a csup{b} a
b

Right superscript a^{b} ab

Left subscript a lsub{b} ab

Center subscript a csub{b} a
b

Right subscript a_{b} ab

Align character to left (text is 
aligned center by default) 

stack { Hello world # alignl 
(a) }

Hello world
a

Align character to center
stack{Hello world # alignc(a)} Hello world

a

Align character to right
stack { Hello world # 
alignr(a)}

Hello world
a

Vertical stack of 2 binom{a}{b}
a
b

Vertical stack, more than 2 stack{a # b # z}
a
b
z

Matrix

matrix{
a # b ## 
c # d
}

a b
c d

Equations aligned at '=' 
(using 'matrix')

matrix{
a # "=" # alignl{b} ##
{} # "=" # alignl{c+1}
}

a = b
= c+1

Equations aligned at '=' 
(using 'phantom')

stack{
alignl{a} = b #
alignl{phantom{a} = c+1}
}

a=b
=c+1

New line asldkfjo newline sadkfj 
asldkfjo
sadkfj

No gap nospace { x + y } x+ y

Normal x+y x+ y

Small gap (grave) stuff `stuff stuff stuff

Large gap (tilde) stuff~stuff stuff stuff
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Caution
In localized versions of Writer, the markup names of Greek and special
characters are localized. If this document is not localized to the same 
language, then the names below may not work for input. You may still 
use the Symbol catalog (Figure 7) to select the desired character by 
its glyph. This will also display the character's localized markup name.

Once entered, the characters will display properly in any language.

Characters – Greek

%ALPHA A %BETA B %GAMMA  %DELTA  %EPSILON E

%ZETA Z %ETA H %THETA  %IOTA I %KAPPA K

%LAMBDA  %MU M %NU N %XI  %OMICRON O

%PI  %RHO P %SIGMA  %TAU T %UPSILON 

%PHI  %CHI X %PSI  %OMEGA 

%alpha  %beta  %gamma  %delta  %epsilon 

%varepsilon  %zeta  %eta  %theta  %vartheta 

%iota  %kappa  %lambda  %mu  %nu 

%xi  %omicron  %pi  %varpi  %rho 

%varrho ϱ %sigma  %varsigma  %tau  %upsilon 

%phi  %varphi  %chi  %psi  %omega 

Characters – Special

%and ∧ %angle ∢ %element ∈ %identical ≡

%infinite ∞ %noelement ∉ %notequal ≠ %or ∨

%perthousand


%strictlygreaterthan
≫

%strictlylessthan
≪

%tendto 
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