
Writer Guide

Chapter 88
  Working with Graphics

OpenOffice.org



Copyright
This document is Copyright © 2005–2008 by its contributors as listed in the section titled Authors. 
You can distribute it and/or modify it under the terms of either the GNU General Public License, 
version 3 or later (http://www.gnu.org/licenses/gpl.html), or the Creative Commons Attribution 
License, version 3.0 (http://creativecommons.org/licenses/by/3.0/) or later.

All trademarks within this guide belong to their legitimate owners.

Authors
Agnes Belzunce
John Kane
Vincenzo Ponzi
Gary Schnabl
Jean Hollis Weber
Michele Zarri

Feedback
Maintainer: Gary Schnabl
Please direct any comments or suggestions about this document to:
authors@user-faq.openoffice.org

Publication date and software version
Published 20 May 2008. Based on OpenOffice.org 2.3.1.

You can download an editable version of this document from 
http://oooauthors.org/en/authors/userguide2/published/

mailto:authors@user-faq.openoffice.org
http://creativecommons.org/licenses/by/3.0/
http://www.gnu.org/licenses/gpl.html
http://oooauthors.org/en/authors/userguide2/published/


Contents

Contents

Copyright................................................................................................................................................i

Authors....................................................................................................................................................i

Feedback.................................................................................................................................................i

Publication date and software version.....................................................................................................i

Graphics in Writer documents.....................................................................................................................1

Adding images to a document.....................................................................................................................1

Inserting an image from a file................................................................................................................1

Linking an image file........................................................................................................................2

Embedding linked images.................................................................................................................3

Inserting images from other sources.......................................................................................................3

Graphics program..............................................................................................................................3

Scanner..............................................................................................................................................4

OpenOffice.org Gallery.....................................................................................................................4

Modifying an image....................................................................................................................................5

Using the picture toolbar........................................................................................................................5

Filters................................................................................................................................................6

Color..................................................................................................................................................7

Setting the object transparency..........................................................................................................8

Adjusting the line, area, and shadow settings....................................................................................8

Cropping images.....................................................................................................................................8

Resizing an image..................................................................................................................................9

Rotating a picture.................................................................................................................................11

Other settings........................................................................................................................................11

Deleting a picture.................................................................................................................................12

Using Writer’s drawing tools.....................................................................................................................12

Creating drawing objects......................................................................................................................12

Setting or changing properties for drawing objects..............................................................................13

Resizing a drawing object....................................................................................................................14

Grouping drawing objects....................................................................................................................14

Positioning graphics within the text..........................................................................................................14

Arranging graphics...............................................................................................................................15

Working with Graphics i



Contents

Anchoring graphics..............................................................................................................................16

To Page............................................................................................................................................16

To Paragraph...................................................................................................................................16

To Character....................................................................................................................................16

As Character....................................................................................................................................16

To Frame.........................................................................................................................................16

Aligning graphics.................................................................................................................................16

Wrapping text around graphics.............................................................................................................17

Editing the contour..........................................................................................................................19

Example 1: page wrapping..............................................................................................................20

Example 2: simple contour wrapping in action...............................................................................21

Example 3: Wrap through and In Background................................................................................21

Adding captions to graphics......................................................................................................................22

Adding captions automatically.............................................................................................................22

Using the Caption dialog box...............................................................................................................23

Overriding the default positioning of captions.....................................................................................24

Adding captions manually....................................................................................................................25

Place the graphic and its caption in separate paragraphs.................................................................25

Use a table.......................................................................................................................................25

Adding an image to the Gallery.................................................................................................................25

Graphic file types supported......................................................................................................................27

Working with Graphics ii



Graphics in Writer documents

Graphics in Writer documents

When you create a text document using OpenOffice.org (OOo) Writer, you may need to include 
some graphic illustrations. Graphics are added to textual documents for a wide variety of reasons: 
from supporting the description provided in the text—such as that used in this Guide—to providing 
an immediate visual impact of the contents, such as what is often found in a newspaper.

Graphics in Writer are of three basic types:

• Image files, including photos, drawings, scanned images, and others
• Diagrams created using OOo’s drawing tools

• Charts created using OOo’s Chart facility

This chapter covers the first two types of graphic illustrations.

More detailed descriptions on working with drawing tools can be found in the Draw Guide and 
Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Adding images to a document

Images (also indicated as pictures in this guide) can be taken from a variety of sources. They may be 
downloaded from the Internet, scanned, created with a graphics program, or they may be photos 
taken with a digital camera.

Inserting an image from a file
In the case where the image is already available in a file stored on the computer, it can be 
immediately inserted in the Writer document. OOo can import various vector (line drawing) and 
raster (bitmap) file formats. The most common are GIF, JPEG or JPG, PNG, and BMP. See “Graphic
file types supported” on page 27 for a full list of supported graphic file types.

To insert an image from a file proceed as follows:

1) Determine the destination for the image. Place the cursor at or near the appropriate location in 
the document.

Note Do not worry too much about the exact placement of the image at this stage as this 
can be easily changed later as described in section “Positioning graphics within the
text” on page 14.

2) On the main menu, select Insert > Picture > From File. This displays the dialog box shown 
in Figure 1.

3) Navigate to the file to be inserted.

4) Select the file to insert and click Open.
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Adding images to a document

Figure 1: Insert picture dialog box

Note At the bottom of the Insert picture dialog box (Figure 1) are two check boxes. If the 
Preview check box is checked, the selected graphic file is previewed in a pane, as 
shown in , so you can verify that you have the correct file. The Link check box is 
discussed below.

Linking an image file
If the Link check box in the Insert picture dialog box is checked, Writer creates a link to the file 
containing the image, instead of saving a copy of the image in the document. The result is that the 
figure is displayed in the document, but when the document is saved, it contains only a reference to 
the image file—not the image itself. The document and the image remain as two separate files, and 
they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

• Advantage – Linking can reduce the size of the document when it is saved because the image 
file itself is not included. The file size is usually not a problem on a modern computer with a 
reasonable amount of memory, unless the document includes many large graphics files. Writer 
can handle quite large files.

• Advantage – You can modify the image file separately without changing the document 
because the link to the file remains valid, and the modified image will appear when you next 
open the document. This can be a big advantage if you (or someone else, for example a 
graphic artist) is updating images, perhaps by including new information or (as in the case of 
updating an existing computer manual) recapturing screens when the software changes.

• Disadvantage – If you send the document to someone else, or move it to a different computer, 
you must also send the image files, or the receiver will not be able to see the linked images. 
You need to keep track of the location of the images and make sure the recipient knows where 
to put them on another machine, so the Writer document can find them. For example, you 
might keep images in a subfolder named Images (under the folder containing the Writer 
document); the recipient of the Writer file needs to put the images in a subfolder with the 
same name (under the folder containing the Writer document).
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Adding images to a document

Note When inserting the same image several times in the document it would appear to be 
beneficial to create links; however, this is not necessary as OOo will embed in the 
document only one copy of the image file.

Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish. To 
do so:

1) Open the Writer document in OOo.
2) Choose Edit > Links from the menu bar.

3) The Edit Links dialog box (Figure 2) shows all the linked files. In the Source file list, select 
the files you want to change from linked to embedded.

4) Click the Break Link button.
5) Save the Writer document.

Figure 2: The Edit Links dialog box

Note Going the other way, from embedded to linked, is not so easy—you must delete and 
reinsert each image, one at a time, selecting the Link check box when you do so.

Inserting images from other sources
You can insert images from sources other than a file. The possible sources for images are:

• Graphics program
• Scanner

• OOo Gallery

Graphics program

You can use many different graphics programs to edit a graphic file. From these programs, you can 
select, copy, and paste an image or part of a graphic into an OOo document. Figure 3 shows an 
example of this procedure, which can be recreated with these steps:

1) In the graphic program window, select an area of the image to be copied.
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2) Move the cursor over the selected area and press Control+C to copy.

Figure 3. Using a graphics program

3) Switch to the OOo Writer window.

4) Click to insert the cursor where the graphic is to be inserted.
5) Press Control+V to paste.

Scanner
If a scanner is connected to your computer, OOo can call the scanning application. The scanned item 
will then be added into the OOo document page as an image. To start this procedure, on the main 
menu select Insert > Picture > Scan > Select Source.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct 
size. You may get better results by scanning material into a graphics program and cleaning it up there 
before inserting the resulting image into Writer.

OpenOffice.org Gallery
The Gallery is available in all components of OOo. For an introduction to the Gallery, see Chapter 14 
(Working with the Gallery) in the Getting Started guide.

You can select a graphic from the Gallery and drag it into the document. The Gallery icon is located 
in the right side of the Function Bar. Proceed as follows:

1) Click on the Gallery icon .

2) Select the theme containing the image you want to insert.
3) Click on the image with the left mouse button and, holding the button pressed, drag the image 

into the document.
4) Release the mouse button.
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Figure 4 shows an example of an image dragged from the Gallery.

Figure 4. Inserting an image from the Gallery

Modifying an image

When you insert a new image, besides some lucky exceptions, it will need to be modified to make it 
more suitable for fitting in the documents. The placement of the picture relative to the text is 
discussed in section “Positioning graphics within the text” on page 14, while this section will 
describe the use of the picture toolbar, resizing, and cropping, as well as a workaround to rotate a 
picture.

Using the picture toolbar
When you insert a suitable graphic image or select one already present in the document, the Picture 
toolbar appears. This toolbar can be either floating or docked. Figure 5 shows what the Picture 
toolbar looks like when it is floating. Two other toolbars can be opened from this one: the Graphic 
Filter toolbar, which can be torn off and placed elsewhere on the window and the Color toolbar, 
which opens as a separate floating toolbar.

From these toolbars, you can apply small corrections to the graphic or obtain special effects.

Note For more sophisticated adjustments, it is better to use an image manipulation 
program, such as GIMP. GIMP is an open-source graphics program which can be 
downloaded from http://www.gimp.org/downloads/.
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Modifying an image

Filters
Table 1 provides a short description of the available filters, however the best way to understand them 
is to see them in action. Feel free to experiment the different filters and filters settings remembering 
that, you can undo all the changes by pressing Ctrl + Z, Alt + Backspace or by selecting Edit > 
Undo.

Note: Graphics mode (3) can be Default, Grayscale, Black/White, or 
Watermark.

Figure 5. Picture toolbar plus tear-off Graphic Filter toolbar and 
floating Color toolbar

  1 From File
  2 Filter
  3 Graphics mode
  4 Color
  5 Transparency
  6 Flip Horizontally
  7 Flip Vertically
  8 Graphics Properties
  9 Invert
10 Smooth
11 Solarization
12 Aging
13 Charcoal Sketch
14 Relief
15 Mosaic
16 Posterize
17 Pop Art
18 Sharpen
19 Remove Noise
20 Red
21 Green
22 Blue
23 Brightness
24 Contrast
25 Gamma
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Modifying an image

Table 1: Graphic filters and their effects

Icon Name Effect

Invert
Inverts the color values of a color image, or the brightness values of 
a grayscale image.

Smooth Softens the contrast of an image.

Sharpen Increases the contrast of an image.

Remove 
noise

Removes single pixels from an image.

Solarization
Mimics the effects of too much light in a picture. A further dialog 
box opens to adjust the parameters.

Aging
Simulates the effects of time on a picture. Can be applied several 
times. A further dialog box will open to adjust the aging level.

Posterize
Makes a picture appear like a painting by reducing the number of 
colors used.

Pop Art Modifies the picture dramatically.

Charcoal Displays the image as a charcoal sketch.

Relief
A dialog box is displayed to adjust the light source that on turn will 
create the shadow and, hence, the relief effect.

Mosaic Joins groups of pixels into a single area of one color.

Color
Use this dialog box to modify the individual RGB color components of the image (red, green, blue) 
as well as the brightness, contrast, and gamma of the image. If the result is not satisfactory, again you 
can press Control+Z to restore the default values.

Figure 6: The color adjustment dialog box
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Setting the object transparency

Modify the percentage value in the Transparency box  on the Picture toolbar to make 
the image more transparent. This is particularly useful when creating a watermark or when wrapping 
the image in the background.

Adjusting the line, area, and shadow settings
These settings are not very commonly used for images, with the exception of the shadow setting that 
applies a shadow to the image.

Figure 7 provides examples of some of the changes available on the Picture toolbar.

Original Image Mirrored 
Vertically

Mirrored 
Horizontally

Light 50%

Contrast 50% Red 50% Green 50% Blue 50%

Figure 7. Some graphic effects that can be applied from the Picture toolbar

Cropping images
When you are only interested in a section of the image for the purpose of your document, you may 
need to crop parts of it. To start cropping the image right click on it and select Picture from the drop-
down menu. In the dialog box shown, select the Crop page (Figure 8).
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Figure 8: The options available when cropping a picture

In the Crop dialog box, you can control the following parameters:

• Keep scale / Keep image size buttons: when Keep scale is selected (default), cropping the 
image does not alter the scale of the picture. When Keep image size is selected, cropping 
produce enlargement (for positive cropping values), shrinking (for negative cropping values), 
or distortion of the image so that the image size remains constant.

• Left, Right, Top, and Bottom: the function of these boxes changes according to the choice 
made between Keep scale and Keep image size. In both cases, when a value is entered in one 
of these boxes, the image is cropped by that amount. For example, a value of 3cm in the Left 
box will cut 3 cm from the left side of the picture.

When Keep scale is selected, the size of the image also changes, so in this example the width 
will be reduced by 3 cm. If Keep image size is selected instead, the remaining part of the 
image is enlarged (positive values for cropping) or shrunk (negative values for cropping) so 
that the width and height of the image remains unchanged.

Note that the Width and Height fields change as you enter the values when in this mode. Use 
the thumbnail next to these fields to determine the correct amount by which to crop.

Resizing an image
It is possible, and quite likely, that the inserted image will not fit perfectly into the document because 
it is too big or too small. In these cases you will need to resize the image.

1) Click the picture, if necessary, to show the green resizing handles.

2) Position the pointer over one of the green resizing handles. The pointer changes shape giving 
a graphical representation of the direction of the resizing.

3) Click and drag to resize the picture.
4) Release the mouse button when satisfied with the new size.

The corner handles resize both the width and the height of the graphic object simultaneously, while 
the other four handles only resize one dimension at a time.
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Tip To retain the original proportions of the graphic, Shift+click one of the corner 
handles, then drag. Be sure to release the mouse button before releasing the Shift key.

Be aware that re-sizing a bit-mapped (raster) image will adversely affect the resolution, causing 
some degree of blurring. It is better to externally size your picture correctly before insertion into 
your presentation, if possible.

Figure 9 shows three examples of an image inserted into a document and resized.

Figure 9. Three examples of  resized images, plus the original image

More accurate resizing can be performed using either the Crop page of the Picture dialog box of 
Figure 8 or, for images, the Type page of the Picture dialog box. In the Crop page it will be 
sufficient adjusting the following settings; alternatively you may use the settings in the crop section 
as explained above:

• Scale Width and Height: specify in percentages the scaling of the picture. The size of the 
image changes accordingly. For a scaled resizing both values should be identical.

• Image size: specify the size of the image in your preferred unit of measurement. The image 
enlarges or shrinks accordingly.

• Original size: when clicked, restores the original image size.

In the Type page of the Picture dialog box, check the Relative check box to toggle between 
percentage and actual dimension. For a scaled resizing check the Keep ratio check box. As for the 
Crop page, clicking on the Original Size button restores the original image size.
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Rotating a picture
Writer does not provide the tool for rotating a picture; however, there is a very simple workaround to 
perform this operation:

1) Open a new Draw or Impress document.
2) Insert the image you want to rotate. To perform this operation you can reuse all the 

mechanisms described in Adding images to a document on page 1, although care should be 
taken of some slight variations in the position of the menu entries and icons.

3) Selecting the image should bring up the picture toolbar which where you can select the 

Rotate icon .

4) Rotate the image as desired. Use the red handles at the corners of the picture and move the 
mouse in the direction you wish to rotate. By default the picture rotates around the center, but 
you can change the pivot point by moving the black crosshair that appears in the middle of the 
image.

Tip To restrict the rotation angle to multiples of 15 degrees keep the Shift key pressed 
while rotating the image.

5) Select the rotated picture by pressing Ctrl+A, then copy the image to the clipboard with Ctrl
+C.

6) Finish by going back to the location of the Writer document where the image is to be inserted 
and pressing Ctrl+V.

Other settings
Taking a closer look of the Picture dialog box shown in Figure 8 you will notice that it consists of 
eight pages. The use of the Crop page is described in this section while the use of the Type and of the 
Wrap pages is explained in “Positioning graphics within the text” on page 14. The other pages serve 
the following purposes:

• Options: use this page to associate a descriptive name to the picture (as you want it to appear 
in the Navigator), display alternative text when the mouse hovers over the picture as well as to 
protect some of the picture settings from accidental changes. You can also prevent the picture 
from being printed by deselecting the corresponding option.

• Borders: use this page to create borders around the picture. The Borders dialog box  is exactly 
the same used for defining table or paragraph borders.

• Background: changes the background color of the picture. This setting will only produce the 
desired results for images supporting a transparent color. 

• Hyperlink: in this page you can associate an hyperlink to the picture. It is also possible to 
create an image map so that only certain areas of the picture will respond to a mouse click and 
will open the associated URI (Uniform Resource Identifier) in the default browser. More 
information on image maps can be found in the Impress Guide.

• Picture: use this page to flip the picture as well as to display the original location of the file in 
case the image is linked rather than embedded.

• Macro: allows you to associate a macro to the picture. You can choose among the predefined 
macros or write your own.
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Deleting a picture
To delete a picture:

1) Click on the picture, if necessary, to show the green resizing handles.

2) Press Delete.

Using Writer’s drawing tools

You can use Writer’s drawing tools to create graphics, such as simple diagrams using rectangles, 
circles, lines, text, and other predefined shapes. You can also group several drawing objects to make 
sure they maintain their relative position and proportion.

You can use the drawing tools to place drawing objects directly on a page in your document, or you 
can insert the drawing objects into a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations 
produced by other programs, but this is not recommended because:

• You cannot include images in a group with drawing objects, so they may get out of alignment 
in your document.

• If you convert a Writer document to another format, such as HTML, the drawing objects and 
the graphics will not remain associated; they will be saved separately.

In general, if you need to create complex drawings, it is recommended to use OpenOffice.org Draw 
which includes many more features such as layers, styles, and so on.

Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 10), by clicking 
View > Toolbars > Drawing.

If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to a 
convenient place on the window.

1 Select
2 Line
3 Rectangle
4 Ellipse

5 Freeform Line
6 Text
7 Callouts
8 Basic Shapes

  9  Symbol Shapes
10  Block arrows
11  Flowcharts
12  Callouts

13 Stars
14 Points
15 Fontwork Gallery
16 From File
17 Extrusion On/Off

Figure 10. The Drawing toolbar

To use a drawing tool:
1) Click in the document where you want the drawing to be anchored. You can change the 

anchor later, if necessary.
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Using Writer’s drawing tools

2) Select the tool from the Drawing toolbar (Figure 10). The mouse pointer changes to a 

drawing-functions pointer .

3) Move the cross-hair pointer to the place in the document where you want the graphic to 
appear and then click-and-drag to create the drawing object. Release the mouse button. The 
selected drawing function remains active, so you can draw another object of the same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the 
arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and weight, anchoring, and others) of 
the drawing object using either the Drawing Object Properties toolbar (Figure 11) or the 
choices and dialog boxes reached by right-clicking on the drawing object.

Setting or changing properties for drawing objects
To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 10), click the Select tool.
2) On the Drawing Object Properties toolbar (Figure 11), click on the icon for each property and 

select the value you want for that property.
3) For more control, or to define new attributes, you can click on the Area or Line icons on the 

toolbar to display detailed dialog boxes.

The default you set applies to the current document and session. It is not retained when you close the 
document or close Writer, and it does not apply to any other document you open. The defaults apply 
to all the drawing objects except text objects.

1 Line
2 Arrow Style
3 Line Style
4 Line Width

5 Line Color
6 Area
7 Area Style / Filling
8 Rotate

  9 To Foreground
10 To Background
11 Bring to Front
12 Send to Back

13 Alignment
14 Change Anchor
15 Ungroup
16 Group

Figure 11. Drawing Object Properties toolbar

To change the properties for an existing drawing object:
1) Select the object.

2) Continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of the 
drawing object:

1) Right-click on the drawing object and then click Position and Size from the pop-up menu. 
The Position and Size dialog box is displayed.

2) Choose any properties, as required.
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Resizing a drawing object
The same considerations made for resizing an image apply also to resizing an object. Select the 
object, click on one of the eight handles around it and drag it to its new position. For a scaled 
resizing select one of the corner handles and keep the Shift button pressed while dragging the handle 
to its new position.

For a more sophisticated control on the size of the object, select from the main menu Format > 
Object > Position and Size. The Position and Size dialog box allows you to set the width and height 
independently. If the Keep ratio check box is selected then the two dimensions change so that the 
proportion is maintained allowing for a scaled resizing. 

Grouping drawing objects
To group a drawing object:

1) Select one object, then hold down the Shift key and select the others you want to include in 
the group. The bounding box expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of the objects and click either 
Format > Group > Group or right-click and then click Group > Group on the pop-up menu.

Note You cannot include an embedded or linked graphic in a group with drawing objects.

Positioning graphics within the text

When you add a graphic to a text document, you need to choose how to position the graphic with 
respect to the text and other graphics. The positioning of graphics is often rather time consuming and 
may be very frustrating for non experienced and experienced users alike. As Writer is a word 
processor rather than a desktop publishing product there are some limitations to the flexibility in 
positioning images and it takes time to get things exactly as you would like them. Starting from 
OpenOffice.org version 3.0, this area will be considerably improved by the inclusion of a new option 
that allows a “loose anchoring”.

Positioning of a graphics is controlled by working on four areas:

• Arrangement referring to the placement of a graphic on an imaginary vertical axis. 
Arrangement controls how graphics are stacked upon each other or relatively to the text.

• Alignment refers to the vertical or horizontal placement of a graphic in relation to the chosen 
anchoring point.

• Anchoring refers to the reference point for the graphics. This point could be the page, or frame 
where the object is, a paragraph, or even a character.

• Text wrapping refers to the relation of graphics to surrounding text, which may wrap around 
the graphic on one or both sides, be overprinted behind or in front of the graphic, or treat the 
graphic as a separate paragraph or character.

The settings for each of the four control areas above can be accessed in a number of different ways 
depending on the nature of the graphics:

1) From the menu Format where you can find the menu entries Alignment, Arrange, Wrap, 
and Anchor. (Both for images and drawing objects).

2) By the drop down menu displayed, then right clicking on the graphics.
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3) From the Frame toolbar shown in Figure 12 for images with the Graphics frame style 
applied.

4) From the Type and Wrapping pages of the Picture dialog box for images. Note that you cannot 
control the arrangement via the dialog box. To open the Picture dialog box, click on the image 
to select it and then click Format > Picture. Alternatively, you can right click on the graphic 
and then click Picture on the pop-up menu.

5) From the Position and Size page of the Position and Size dialog box for drawing objects. To 
open the Position and Size dialog box, click on the drawing object to select it and then click 
Format > Object > Position and Size. Alternatively, you can right click on the graphic and 
then click Position and Size on the pop-up menu. Note that you can only control the 
alignment and anchoring.

1 Apply Style   6 Center Horizontal 11 Borders 16 Bring to Front
2 Wrap Off   7 Align Right 12 Line Style 17 Send to Back
3 Page Wrap   8 Top 13 Line Color (of the border) 18 Change Anchor
4 Wrap Through   9 Center 14 Background Color 19 Link Frames
5 Align Left 10 Bottom 15 Frame Properties 20 Unlink Frames

Figure 12. Frame toolbar (graphical control of positioning for images)

Arranging graphics
Arrange a graphic object means to determine its vertical position relatively to other graphic objects 
or text. Arranging is only relevant when objects are overlapping. You can choose between four 
different settings plus a special setting for drawing objects:

Figure 13: The Arrange menu

• Bring to Front: when this option is chosen the graphics is drawn on top of any other graphics 
or text.

• Bring Forward: selecting this option brings the object one level up in the stack. Depending 
on the number of overlapping objects you may need to apply this option several times to 
obtain the desired result.

• Bring Backward: the opposite of Bring Forward, it sends the selected object one level down 
in the objects stack.

• Send to Back: sends the selected graphics at the bottom of the z-axis so that other graphics 
and text tend to cover it.

• To Background / To Foreground: only available for drawing objects, moves the drawing 
object behind or in front of the text respectively.
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Positioning graphics within the text

Anchoring graphics
You can anchor graphics as a character or to a page, paragraph, or character. You can also place 
graphics in a frame and anchor the frame to a page, paragraph, or character. Which method you 
choose depends on what you are trying to achieve.

Here are the ways you can anchor graphics or drawing objects:

To Page
The graphic keeps the same position in relation to the page margins. It does not move as you add or 
delete text or other graphics. This method is useful when the graphic does not need to be visually 
associated with a particular piece of text. It is often used when producing newsletters or other 
documents that are very layout intensive.

Caution If you plan to use a document within a master document, do not anchor graphics 
To Page because the graphics will disappear from the master document. See 
Chapter 13 (Working with Master Documents) for more information.

To Paragraph
The graphic is associated with a paragraph and moves with the paragraph. It may be placed in the 
margin or another location. This method is useful as an alternative to a table for placing icons beside 
paragraphs.

To Character
The graphic is associated with a character but is not in the text sequence. It moves with the paragraph 
but may be placed in the margin or another location. This method is similar to anchoring to a 
paragraph but cannot be used with drawing objects.

As Character
The graphic is placed in the document like any other character and, therefore, affects the height of 
the text line and the line break. The graphic moves with the paragraph as you add or delete text 
before the paragraph. This method is useful for keeping screenshots in sequence in a procedure (by 
anchoring them as a character in a blank paragraph) or for adding a small (inlined) icon in sequence 
in a sentence.

To Frame
If the graphic has been placed in a frame, you can anchor the graphic in a fixed position inside the 
frame. The frame can then be anchored to the page, a paragraph, or a character, as required.

Aligning graphics
Once you have established the anchor point of the graphics, you can decide the position of the 
graphics relatively to this anchor: this is called aligning the graphics. There are six options to choose 
from: three for aligning the graphics horizontally (left, center, right) and three for aligning the 
graphics vertically (top, center, bottom). If you want to have a finer control on the alignment, then 
you will need to refer to the dialog box shown in Figure 14.
For both the horizontal and vertical position, start by picking the reference point in the right hand 
side drop down menu, then select in the first drop down menu among Left, Right or Center. If you 
select the value From left (or From top for the vertical positioning) you can specify in the edit box 
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in the middle the amount in your selected unit of measurement. In the example in Figure 14 the 
upper-left corner of the image will be placed at 3 cm from the left margin of the page horizontally 
and on the top margin vertically.

Figure 14: Fine tuning the alignment with the Picture dialog box

Wrapping text around graphics
The Wrap setting determines the relation between the text and the graphic. Several possibilities are 
provided:

• No Wrap: with this option the text is placed above and below the image but not around it. 
This is the wrapping type used for the figures in this guide.

• Page Wrap or Optimal Page Wrap: the text flows around the image. Moving the image 
around the page causes the text to be rearranged to fill the space to the left and right of it. 
Optimal Page Wrap will prevent text to be placed to the side of the image if the spacing 
between the image and the margin is less than 2 cm.

• Wrap Through: Wrap Through superimposes the image to the text. That is, the image is 
above the text. This option has to be used in conjunction with the image-transparency setting 
in order to make the text under the picture visible.

• In Background: similar to Wrap Through, but in this case the image is placed below the text 
so there may be no need to retouch the transparency to make the text visible.

Note The No Wrap option found in the pop up menu of a picture is equivalent to the Wrap 
Off menu item in the Format > Wrap menu.
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The wrap format is normally selected after the anchoring and the alignment of the picture have been 
decided. To set the position of an image to the the desired wrap format, follow these steps:

1) Select a graphic by clicking on it.

2) Right-click to display the context menu and move the mouse pointer to Wrap to display the 
available wrap formats. Alternatively you can select Format > Wrap from the main menu.

3) Select the desired wrap format.

Note When selecting anchoring as character, you can only adjust the distance between the 
image and the text, but no wrapping option is displayed.

In order to fine tune the wrapping options you need to access the Picture dialog box and select the 
Wrap page shown in Figure 15. For images you can open this dialog box by selecting Format > 
Picture from the main menu or simply Picture from the pop-up menu that opens when right clicking 
on the image. For drawing objects, you can access the Wrap page by selecting Format > Wrap > 
Edit in the main menu of simply Wrap > Edit from the pop-up menu that opens when right clicking 
on the drawing object. This dialog box is divided in three sections.

Figure 15: The advanced wrap format options dialog box (shown for an image)

In the top part you can select among the above mentioned wrap types plus two additional wrap 
formats that prevent the text from filling the area to the left (After) or to the right (Before) of the 
picture. Use the Spacing section of the dialog box to adjust the spacing between the image and the 
text. The contents of the Options section of the dialog box may change depending on the selected 
wrap format.

• New Paragraph: check this box if you want OOo to start a new paragraph after the image 
even if it could still wrap around the image.

• In background: this option becomes available if Through Wrap is selected and moves the 
image in the background.
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• Contour: selecting this option the text wraps around a custom contour rather than around the 
edge of the picture. This option is only available for Page or Optimal Page Wrap.

• Outside only: forces the text to wrap on the outside of the image, even if the contour contains 
open areas within the shape.

Editing the contour
This option is only available for image wrapping. If you select wrapping around a drawing object, 
OOo automatically creates a contour. You can access the Contour Editor by selecting Format > 
Wrap > Edit Contour or by right-clicking on the image and selecting Wrap > Edit Contour from 
the pop-up menu .

The dialog box of Figure 16 opens with the image loaded in the main window. Use the tools to draw 
the region of the image you do not want to be covered by the text—such area will be shaded.

Figure 16: The Contour Editor in action

Some familiarity with drawing tools is required to create complex contours; however, note that in 
general circumstances, there is no need for high accuracy. Figure 16 shows the actual contour used 
for “Example 2: simple contour wrapping in action” on page 21 and as you can see the shape of the 
line around the edge of the sphere is far from perfect.

When you are done, click on the Apply button to save the contour. If you are not satisfied with the 
result ,you can select the contour line and press the Delete key to restart, or you can undo the 
previous steps, or you can click the Edit Points button and adjust the contour shape point by point.

For simple images the AutoContour button will do a decent job. If the contour has to be drawn 
around an area with the same or a similar color, you can select this region using the eyedropper. 
Select this tool, then click on a point in the image having the desired color. OOo automatically 
selects all the points which have the same or a similar color. The similarity level can be changed by 
modifying the value in the tolerance box (100% = perfect match).
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Caution
While all the positioning techniques discussed in this section apply equally to 
frames, contour wrapping is not possible.

Example 1: page wrapping
In Figure 17, you can see an example of page wrapping in action. To obtain this, do the following:

1) Insert the image in the document, then anchor it to the first paragraph. To move the anchor, 
select the image and move it until the anchor symbol is at the beginning of the paragraph. Do 
not worry about the position as that will be fixed in the next step.

2) Align the image so that the left margin of the image is in line with the paragraph indentation. 
This can be done with the mouse or using the advanced settings. In the example, the image is 
placed at 1 cm from the left of the paragraph area.

3) Change now the wrap to Page Wrap. It starts out OK; however, there is still too little space 
between the image and the text. To correct it, access the Wrap dialog box and set the gap 
between the image and text to 0.2 cm both in the Right and Bottom boxes.

4) The last touch is to again change the position so that the image is below the first line of the 
paragraph. Again, you can use the mouse to drag the image or use the advanced settings, 
which require a bit of trial and error. It turns out that the particular line height used in this 
guide—0.75 cm from the top margin of the paragraph—is a good value.

Figure 17: Example of image with Page Wrap formatting
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Example 2: simple contour wrapping in action
In this example we again apply page wrapping as in example 1, but this time enabling the contour 
option. We will work on an image and on a drawing object as the contour option works slightly 
differently in the two cases.

The example of Figure 18 has been built following the steps below, which you can use to practice:

1) Create some text (a very quick way to do that is to use the dummy text AutoText. That is, type 
DT and then press the F3 key).

2) Insert an image of your choice and anchor it to the first paragraph. Adjust the alignment as 
desired then change the wrap type to Page Wrapping.

3) Right-click on the picture to select the option Wrap > Contour, then right-click again—this 
time selecting Wrap > Edit Contour from the pop-up menu.

4) Use the technique discussed in “Editing the contour” on page 19 to create a custom contour 
and select Apply. If needed, adjust the spacing between the edge of the image and the text.

5) Insert now an AutoShape of your choice (a rotated triangle in the example) and proceed as in 
point 2 above.

6) Enable the contour wrap by selecting Format > Wrap > Contour from the main menu. As 
discussed previously, OOo automatically generates the contour. You may need to adjust the 
distance between the drawing object and the text.

Figure 18: Image and drawing object with contour wrapping

Example 3: Wrap through and In Background
This example shows how to use an image as a watermark by wrapping it through the text and 
adjusting the transparency. This is not the best way to create watermarks and it is presented here only 
for its illustration purposes. If you need to create a watermark, it is best to use a Fontworks object 
wrapped in the background.
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Figure 19: Transparent image added over the text

The Wrap Through option inserts an image overlapping the text which as a result will be hidden. In 
order to make the text appear, it is necessary to change the transparency of the picture; this way the 
words under the image become visible although they may be difficult to read and will appear lighter 
than the rest of the text.

To reproduce the example of Figure 19, create some dummy text, then insert the image of your 
choice. Anchor the image (to the page in the example) and select the wrap through option from the 
Format > Wrap menu or right clicking on the image and selecting Wrap > Wrap Through from 
the pop up menu. Move the image in the desired position. The Picture toolbar should be displayed 
when the image is selected. Change the transparency to a suitable value (in the example this is 40%) 
so that the text can be read. In the example, a shadow effect is applied to the text (Format > 
Character then select Shadow in the Font Effects page.

You can obtain a better result if you set a graphic’s wrap to In Background. In this case all the text 
will be clearly readable, with characters that have the same intensity as long as the background is not 
too dark. Also in this case you may want to adjust the transparency of the image.

Adding captions to graphics

You can add captions to graphics in three ways: automatically, by using the Caption dialog box, or 
manually.

Adding captions automatically
You can set up OOo to add captions automatically whenever you insert a graphic, a table, or other 
objects into a document. You can choose which objects are captioned automatically, what the 
sequence name is for each caption (for example, “Table” or “Illustration”), and the position of the 
caption.
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To set up automatic captions:
1) Click Tools > Options. On the Options dialog box, click on the + sign next to 

OpenOffice.org Writer to show a list of options.
2) Select AutoCaption. Now you can see several choices at the right of the dialog box for 

adding captions automatically.
3) Choose which objects you want to be automatically captioned and specify the characteristics 

of the captions.

For more information, see “AutoCaption options” in Chapter 2 (Setting up Writer).

When you insert a graphic, if automatic captioning is enabled, the graphic will be placed in a frame 
along with a caption containing the default sequence name for graphics―Illustration. Position the 
cursor in the caption area and type the text for the caption. You can change the sequence name by 
selecting one from the drop-down Category list.

Note You can specify where to place an automatic caption for any object except a picture; 
picture captions can only be automatically placed below the picture. If you need a 
caption above the picture (for example, for data plots in scientific publications), you 
must add the captions manually, as described in “Adding captions manually” on 
page 25.

Tip A common sequence name—Figure—is not one of the names provided: <None>, 
Drawing, Illustration, Table, and Text. If you want the name “Figure” or any 
other custom name for your graphics, do the following:

1) Open the Options – OpenOffice.org Writer – AutoCaption dialog box, as 
described above.

2) In the Add captions automatically when inserting section, select 
OpenOffice.org Writer Picture. This actives the Caption area in the dialog 
box for pictures (graphics).

3) Under the Category drop-down list, enter the name that you want added 
(say, Figure), by overwriting any sequence name in the list. (Overwriting a 
term does not delete it from the drop-down list.) You can also set some 
options for the number style and for a separator between the name and the 
number, if desired. Click OK to save the changes.

Using the Caption dialog box
To add captions using the Caption dialog box:

1) Insert the graphic, then select it and click Insert > Caption.
2) Under Properties on the Caption dialog box (Figure 20), make your selections for the 

Category, Numbering, and Separator fields (Illustration, Arabic (1 2 3), and a colon (:), 
respectively, for the example in Figure 20) and type your caption text in the Caption text box 
at the top. Whatever text you enter for the caption appears in the box at the bottom, after the 
sequence name, number, and separator.

3) Click OK. The graphic and its caption are placed in a frame, as shown in Figure 21.
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Figure 20. Defining the caption for an illustration

Tip In the Category box, you can type any name you want, for example, Figure. OOo 
will create a numbering sequence using that name.

Illustration 1. An example

Figure 21. An example of a graphic and its caption contained in a frame.  
The outer box shows the edge of the frame; this border is normally set to be 
invisible.

Overriding the default positioning of captions
The default positioning for picture captions is Below, and that position cannot be changed using the 
Caption dialog. However, you can override the positioning manually, as follows:

1) Follow the instructions in “Using the Caption dialog box” on page 23 to create the caption.
2) Right-click on the picture (not the frame surrounding picture and caption) and make sure that 

Anchor > To paragraph is selected.
3) Left-click on the picture and drag it below the caption.

Tip You may wish to adjust the spacing above and below the caption text, to fine-tune 
the appearance of the picture and its caption.
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Adding captions manually
If you need to save as .DOC files or export in other formats, you may find that captions applied as 
described above (either automatically or using the Caption dialog box) are lost during the export. To 
avoid export problems, or as another way to put captions above pictures or below them (the usual 
case), you can add a caption manually, in either of two ways:

• Place the graphic and its caption in separate paragraphs.
• Use a table.

Place the graphic and its caption in separate paragraphs
Insert the graphic and anchor it to its paragraph as a character. Press Enter to create a new paragraph 
for the caption.

1) In the caption paragraph, type, for example, Figure and add a space.

2) To insert the figure number automatically, click Insert > Fields > Other (Ctrl+F2) and select 
the Variables tab.

3) Select Number range in the Type list. Select Figure in the Selection list and choose, for 
example, Arabic (1 2 3) in the Format drop-down list. Click the Insert button.

4) A number will appear after the word “Figure” in the caption. Now, type the text of the 
caption.

Tips If you are manually adding captions to a lot of figures using this method, you might 
want to make an AutoText entry containing, for example, Figure and a space, the 
figure-number field, and an optional separator and a space after it.

You can also place the caption paragraph before (above) the picture paragraph. Using 
AutoText can be a convenient way to deal with the lack of automatic captioning 
above pictures.

To ensure the picture and its caption stay together on the page: if the picture is going 
above the caption, define the text flow of the Figure paragraph style as Keep with 
next paragraph and the next style as Caption. Conversely, if the caption is going 
above, define the Caption paragraph style as Keep with next paragraph and the next 
style as Figure.

Use a table
Create a one-column, two-row table. Place the picture in one row and type the caption in the other 
row—or use two or more rows for the caption and other text. This method can be especially useful 
for pictures with numbered legends, such as Figure 12 in this chapter.

Adding an image to the Gallery

You may wish to add to the Gallery any images that you use frequently, for example, a company 
logo. You can then very easily insert these graphics into a document later.

To add images to the Gallery, proceed as follows:
1) Open the Gallery.

2) Select the theme where you want to add images, or you can create a new theme. Note that you 
can add images only to “My Theme” or to any other theme that you have created; these are 
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indicated by a green icon in the list of themes. You cannot add images to the built-in themes, 
indicated by an icon of another color.

To create a new theme:
1) Click the New Theme button above the list box of Themes. The Properties of New Theme 

dialog box opens, which is similar to the one shown in Figure 22.
2) Select the General tab (not shown) and type a name for the new theme in the text box.

3) Select the Files tab, skip step 3, and continue with step 4.
4) Right-click on the desired theme and select Properties in the pop-up menu. This displays a 

window from which to select the files to be added (see Figure 22).

Figure 22. Gallery properties dialog box

5) On the Files page, click the Find Files button. The Select path dialog box opens.
6) You can enter the path for the file’s directory in the Path text box, or you can navigate to 

locate the file’s directory. Use the File type drop-down list to help limit the search.
7) Click the Select button to start the search.

A list of graphic files is then displayed in the window. You can use the File type filter again to 
further limit the search.

8) Select the files to add. To select more than one file, hold the Control key down while you 
click on each file.

9) Finally, click Add.

10) When you have finished working with the Gallery, you can click on its icon  to close it.

Note This procedure assumes that the graphic files for the themes already exist. You may 
need to import some graphics or to create your own onto your computer if the 
existing files are insufficient.
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Note Similar to the file search function on various operating systems, Find Files searches 
for graphic files in any subfolders of the directory selected in step 5.

Graphic file types supported

OpenOffice.org Writer can open the file types listed in Table 1. Many of these file types are 
hyperlinked to Wikipedia for their definitions and other information.

Table 1. Graphic file types supported by OpenOffice.org Writer

File extension File type

BMP Windows Bitmap

DXF AutoCAD Drawing Interchange 
(Exchange) Format

EMF Enhanced Metafile

EPS Encapsulated PostScript

GIF Graphics Interchange Format

JPG, JPEG, JFIF, JIF Joint Photographic Experts Group

MET OS/2 Metafile

PBM Portable Bitmap

PCD Kodak Photo CD

PCT Macintosh QuickDraw PICT

PCX Zsoft PC Paintbrush

PGM Portable Graymap

PNG Portable Network Graphics

PPM Portable Pixelmap

PSD Adobe Photoshop Document

RAS Sun Raster Image

SGF StarWriter Graphics Format

SGV StarDraw 2.0

SVM StarView Metafile

TGA Truevision Targa

TIF, TIFF Tagged Image File Format

WMF Windows Metafile

XBM X Bitmap

XPM X PixMap
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