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What is a template?

What is a template?

A template is a model that you use to create other documents. For example, you can create a template 
for business reports that has your company’s logo on the first page. New documents created from this 
template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of 
styles, and user-specific setup information such as measurement units, language, the default printer, 
and toolbar and menu customization.

All documents in OpenOffice.org (OOo) are based on templates. You can create a specific template 
for any document type (text, spreadsheet, drawing, presentation). If you do not specify a template 
when you start a new document, then the document is based on the default template for that type of 
document. If you have not specified a default template, OOo uses the blank template for that type of 
document that is installed with OOo. See “Setting a default template” on page 7 for more 
information.

This chapter shows you how to:

• Use a template to create a document

• Create a template

• Edit a template

• Use Extension Manager to install new templates

• Set a default template

• Organize templates

Using a template to create a document

To use a template to create a document:

1) From the main menu, choose File > New > Templates and Documents. The Templates and 
Documents window opens. (See Figure 1.)

2) In the box on the left, click the Templates icon if it is not already selected. A list of template 
folders appears in the center box.

3) Double-click the folder that contains the template that you want to use. A list of all the 
templates contained in that folder appears in the center box.

4) Click the template that you want to use. You can preview the selected template or view the 
template’s properties:

• To preview the template, click the Preview icon. A preview of the template appears in the 
box on the right.

• To view the template’s properties, click the Document Properties icon. The template’s 
properties appear in the box on the right.

5) Click Open. The Templates and Documents window closes and a new document based on the 
selected template opens in OOo. You can then edit and save the new document just as you 
would any other document.
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Using a template to create a document

Figure 1. Templates and Documents window

Creating a template

You can create your own templates in two ways:

• From a document

• Using a wizard

Creating a template from a document
To create a template from a document:

1) Open a new or existing document of the type you want to make into a template (text 
document, spreadsheet, drawing, presentation).

2) Add the content and styles that you want.

3) From the main menu, choose File > Templates > Save. The Templates window opens (see 
Figure 2).

4) In the New template field, type a name for the new template.

5) In the Categories list, click the category to which you want to assign the template. (The 
category is simply the template folder in which you want to save the template. For example, 
to save the template in the “My Templates” folder, click the My Templates category.)

To learn more about template folders, see “Organizing templates” on page 8.

6) Click OK. OOo saves the new template and the Templates window closes.
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Creating a template

Figure 2. Saving a new template

Any settings that can be added to or modified in a document can be saved in a template. For 
example, below are some of the settings (although not exhaustive) that can be included in a Writer 
document and then saved as a template for later use:

• Printer settings: which printer, single sided / double sided, and paper size, and so on

• Styles to be used, including character, page, frame, numbering and paragraph styles

• Format and settings regarding indexes, tables, bibliographies, table of contents

Creating a template using a wizard
You can use wizards to create these types of templates:

• Letter

• Fax

• Agenda

• Presentation

• Web page

For example, the Fax Wizard steps you through the following choices:

• Type of fax (business or personal)

• Document elements like the date, subject line (business fax),  salutation, and complementary 
close

• Options for sender and recipient information (business fax)

• Text to include in the footer (business fax)
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Creating a template

To create a template using a wizard:

1) From the main menu, choose File > Wizards > type of template required (Figure 3).

Figure 3. Creating a template using a wizard

2) Follow the instructions on the pages of the wizard. This process is slightly different for each 
type of template, but the format is very similar.

3) In the last section of the wizard, you can specify the name and location for saving the 
template. The default location is your user templates directory, but you can choose a different 
location if you prefer.

4) Finally, you have the option of creating a new document from your template immediately, or 
manually changing the template. For future documents, you can re-use the template created 
by the wizard, just as you would use any other template.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s 
styles to documents that were created from that template. (Note that you can only reapply styles. You 
cannot reapply content.)

To edit a template:

1) From the main menu, choose File > Templates > Organize. The Template Management 
window opens (see Figure 4).
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Editing a template

Figure 4. Template management window

2) In the box on the left, double-click the folder that contains the template that you want to edit. 
A list of all the templates contained in that folder appears underneath the folder name.

3) Click the template that you want to edit.

4) Click the Commands button and choose Edit from the drop-down menu.

5) Edit the template just as you would any other document. To save your changes, choose File > 
Save from the main menu.

The next time you open a document that was created from the changed template, the following 
message appears.

Figure 5. Apply current styles message 

Click Yes to apply the template’s changed styles to the document. Click No if you do not want to 
apply the template’s changed styles to the document. Whichever option you choose, the message box 
closes and the document opens in OOo.
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Adding templates with Extension Manager

Adding templates with Extension Manager

The Package Manager was introduced in OOo 2.0.4 and renamed the Extension Manager in OOo 2.1. 
This feature provides an easy way to install collections of templates, graphics, macros, or other add-
ins that have been “packaged” into files with a .OXT extension. This page lists many of the available 
templates: http://extensions.services.openoffice.org/.

1) After you download a package, select Tools > Extension Manager from the menu bar. In the 
Extension Manager dialog (Figure 6), click Add.

Figure 6: Installing a package of templates

2) A file browser window opens. Find and select the package of templates you want to install 
and click Open.The package begins installing. You may be asked to accept a license 
agreement.

3) When the package installation is complete, the templates are available for use through File > 
New > Templates and Documents and the extension is listed in the Extension Manager 
(Figure 7). If you select one of the packages, other buttons (Remove, Disable, Export, 
Updates) become active.
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Adding templates with Extension Manager

Figure 7: Newly-added package of templates

Setting a default template

If you create a document by choosing File > New > Text Document (or Spreadsheet, Presentation, 
or Drawing) from the main menu, OOo creates the document from the Default template for that type 
of document. You can, however, set a custom template to be the default. You can reset the default 
later if you choose.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in the 
Template Management window.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template Management 
window (Figure 4) opens.

2) In the box on the left, double-click the folder containing the template that you want to set as 
the default, then select the template.

3) Click the Commands button.

4) From the drop-down menu, choose Set As Default Template. The next time that you create a 
document by choosing File > New, the document will be created from this template.
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Setting a default template

Resetting the default to OOo’s in-built Default 
template
To re-enable OOo’s Default template for a document type as the default:

1) In the Template Management window, in the box on the left, click any folder.

2) Click the Commands button and choose Reset Default Template from the drop-down menu. 
The next time that you create a document by choosing File > New, the document will be 
created from OOo’s Default template for that document type.

Organizing templates

OOo can only use templates that are in OOo template folders. You can create new OOo template 
folders and use them to organize your templates, and import templates into those folders. For 
example, you might have one template folder for report templates and another for letter templates. 
You can also export templates.

To begin, choose File > Templates > Organize from the main menu. The Template Management 
window (Figure 4) opens.

Note All the actions made by the Commands button in the Template Management window 
can be made as well by right-clicking on the templates or the folders.

Creating a template folder
To create a template folder:

1) In the Template Management window, click any folder.

2) Click the Commands button and choose New from the drop-down menu. A new folder called 
Untitled appears.

3) Type a name for the new folder, and then press the Enter key. OOo saves the folder with the 
name that you entered.

Deleting a template folder
You cannot delete template folders supplied with OOo or installed using the Extension Manager; you 
can only delete template folders that you have created.

To delete a template folder:

1) In the Template Management window, click the folder that you want to delete.

2) Click the Commands button and choose Delete from the drop-down menu. A message box 
appears and asks you to confirm the deletion. Click Yes.
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Organizing templates

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Management window, double-click the folder that contains the template you 
want to move. A list of all the templates contained in that folder appears underneath the folder 
name.

2) Click the template that you want to move and drag it to the desired folder. If you do not have 
the authority to delete templates from the source folder, this action copies the template 
instead of moving it.

Deleting a template
You cannot delete templates supplied with OOo or installed using the Extension Manager; you can 
only delete templates that you have created.

To delete a template:

1) In the Template Management window, double-click the folder that contains the template you 
want to delete. A list of all the templates contained in that folder appears underneath the 
folder name.

2) Click the template that you want to delete.

3) Click the Commands button and choose Delete from the drop-down menu. A message box 
appears and asks you to confirm the deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an OOo 
template folder.

To import a template into a template folder:

1) In the Template Management window, double-click the folder into which you want to import 
the template.

2) Click the Commands button and choose Import Template from the drop-down menu. A 
standard file browser window opens.

3) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected folder.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Management window, double-click the folder that contains the template you 
want to export. A list of all the templates contained in that folder appears underneath the 
folder name.

2) Click the template that you want to export.

3) Click the Commands button and choose Export Template from the drop-down menu. The 
Save As window opens.

Working with Templates 9



Organizing templates

4) Find the folder into which you want to export the template and click Save.
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