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What is Draw?

What is Draw?

Draw is a vector graphics drawing program. It offers a series of powerful tools that enable you to 
quickly create all sorts of graphics. Vector graphics store and display an image as vectors (two points 
and a line) rather than a collections of pixels (dots on the screen). Vector graphics allow for easier 
storage and scaling of the image.

Draw is perfectly integrated into the OpenOffice.org suite, and this makes exchanging graphics with 
all components of the suite very easy. For example, if you create an image in Draw, reusing it in a 
Writer document is as simple as copying and pasting. You can also work with drawings directly from 
within Writer and Impress, using a subset of the functions and tools from Draw.

Draw’s functionality is very extensive and complete. Although it was not designed to rival high-end 
graphics applications, Draw possesses more functions than the majority of drawing tools that are 
integrated into office productivity suites.

A few examples of drawing functions might whet your appetite: layer management, magnetic grid 
point system, dimensions and measurement display, connectors for making organization charts, 3D 
functions enabling small three-dimensional drawings to be created (with texture and lighting effects), 
drawing and page style integration, and Bézier curves, to name a few.

This chapter introduces some of Draw’s features, but it does not attempt to cover all of the them. See 
the Draw Guide and the application Help for more information.

The Draw workplace

The main components of the Draw interface are shown in Figure 1.

You can surround the drawing area with toolbars and information areas. The number and 
position of the visible tools vary with the task at hand or user preferences. Therefore, your 
setup may appear a little different. For example, many people put the main Drawing toolbar 
on the left-hand side of the workspace, not at the bottom as shown here.

You can split drawings in Draw over several pages. Multipage drawings are used mainly for 
presentations. The Pages pane, on the left side of the Draw window in Figure 1 gives an overview of 
the pages that you create. If the Pages pane is not visible on your setup,you can enable it from the 
View menu (View > Page Pane). To easily make changes to the page order, drag and drop one or 
more pages.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand side of the workspace. These 
show the size of a selected object on the page (see the gray double lines, highlighted in ). When no 
object is selected, they show the location of the mouse pointer, which helps to accurately position 
drawing objects. You can also use the rulers to manage object handles and guide lines, making it 
easier to position objects. The page margins in the drawing area are also represented on the rulers.

You can change the margins directly on the rulers by dragging them with the mouse.
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The Draw workplace

Figure 1. Initial Draw window

Figure 2: Rulers show the size of the selected object

To modify the units of measurement of the rulers, 
right-click on one of the rulers. The two rulers can 
have different units.
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The Draw workplace

Status bar
The Status bar is located at the bottom of the workspace. The middle part of the Status bar shows 
Draw-specific fields, as identified in Figure 4.

For details on the contents and use of these fields, please refer to the Draw Guide.

Note The sizes are given in the current measurement unit (not to be confused with the 
ruler units). This unit is defined in Tools > Options > OpenOffice.org Draw > 
General, where you can also change the scale of the page. Another way to change 
the scale is to double-click on the number shown in the status bar.

Figure 4: Items on the Draw status bar

Toolbars
The various Draw toolbars can be displayed or hidden according to your needs.

To display or hide the toolbars, click View > Toolbars. On the menu that appears, choose which 
toolbars you want to display.

You can also select the buttons that you wish to appear on the corresponding toolbar. On the View > 
Toolbars menu, select Customize, click on the Toolbars tab, select the toolbar you want to change, 
and then select the desired buttons for that toolbar. Each toolbar has a different list of buttons. See 
Chapter 4 (Menus and Toolbars) for more information.

Many toolbar buttons are marked with a small arrow beside the button. The arrow indicates that this 
button has additional functions. Click the arrow and a submenu or floating toolbar appears, showing 
its additional functions (see Figure 5).

You may wish to keep this submenu displayed on your screen, but in a different position. You can 
make a submenu into a floating toolbar. To do so, click the area at the top of the submenu, drag it 
across the screen, and then release the mouse button. Floating toolbars can be docked on an edge of 
the screen or within one of the existing toolbar areas at the top of the screen, as described in 
Chapter 4.
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The Draw workplace

Figure 5. An arrow next to a button indicates additional functions

Note Most buttons marked with the small arrow can become floating toolbars. The floating 
toolbar capability is common to all components of the OpenOffice.org suite.

Click the arrow on the title bar of a floating toolbar to display additional functions (see Figure 6).

Figure 6. An arrow on a floating toolbar indicates additional functions

The tools available in the various toolbars are explained in the following sections.

Standard toolbar
The Standard toolbar looks like this:

It is the same for all parts of OpenOffice.org.

Line and Filling toolbar
The Line and Filling toolbar lets you modify the main properties of a drawing object. See page 19 for 
details.
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The Draw workplace

If the selected object is text, the toolbar changes to the one shown below, which is similar to the 
Formatting toolbar in Writer.

Drawing toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions 
for drawing various geometric and freehand shapes and organizing them on the page.

Color Bar
To display the Color Bar, use View > Toolbars > Color Bar. The toolbar then appears at the bottom 
of the workspace.

This toolbar lets you rapidly choose the color of the objects in your drawing. The first box in the 
panel corresponds to transparency (no color).

You can access several specialized color palettes in Draw, as well as change individual colors to your 
own taste. This is done using the Area dialog, reached by choosing Format > Area or the pouring 
can icon on the Line and Filling toolbar.

On the Area dialog, choose the tab marked Colors.

Figure 7. Changing the color palette
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The Draw workplace

To load another palette, click on the Load Color List button (circled). The file selector dialog asks 
you to choose one of the standard OOo palettes (files bearing the file extension *.soc). For example, 
web.soc is a color palette that is adapted to creating drawings that are going to appear in Web pages. 
The colors will correctly display on workstations with screens displaying at least 256 colors.

The color selection box also lets you individually change any color by modifying the numerical 
values in the fields provided to the right of the color palette. You can use the color schemes known as 
CMYK (Cyan, Magenta, Yellow, Black), RGB (Red, Green, Blue) or HSB (Hue, Saturation, 
Brightness).

For a more detailed description of color palettes and their options, see Chapter 8 (Tips and Tricks) in 
the Draw Guide.

Figure 8. Defining color schemes

Options toolbar
The Options toolbar lets you activate or deactivate various drawing aids. The Options toolbar is not 
displayed by default. To display it, select View > Toolbars > Options. The most important options to 
learn when starting to work in Draw are enclosed in red. The functions of the various icons are 
described in Table 1.

Figure 9: Options toolbar
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The Draw workplace

Table 1: Functions on the Options toolbar

Icon Function

Rotation Mode after Clicking Object

Display (or hide the) Grid

Display (or hide the) Guides

Display (or hide Guides) When Moving

Snap to Grid

Snap to Guides

Snap to Page Margins

Snap to Object Borders

Snap to Object Points

Allow Quick Editing

Select Text Area Only

Double-click to edit Text

Simple Handles

Large Handles

Create Object with Attributes

Picture Placeholders

Contour Mode

Text Placeholders

Line Contour Only

Exit All Groups

Positioning objects with snap functions

In Draw, objects can be positioned to grid points, to special snap points and lines, to object frames, to 
single object points, or to page edges. This function is known as Snap. In this manner objects can be 
very accurately positioned in a drawing.

If you want to use the snap function, it is much easier to work with the highest practical zoom value. 
It is possible to use two different snap functions at the same time, for example snap to a guide line 
and to the page edge. It is best, however, to activate only those functions that you really need.
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Positioning objects with snap functions

This section describes the snap-to-grid function. For more information about this and the other snap 
functions, see Chapter 8 (Tips and Tricks) and Chapter 10 (Advanced Draw Techniques) in the Draw 
Guide.

Snap to grid
Use this function to move an object exactly to a grid point (see ). This function can be switched on 
and off with View > Grid > Snap to Grid and on the Options toolbar with the icon .

Figure 10: With snap to grid, objects align to 
the grid precisely.

Showing the grid
Make the grid visible under View > Grid > Display Grid. Alternatively turn the grid on and off with 
the icon  on the Options toolbar.

Configuring the grid
The color, spacing, and resolution of the grid points can be individually chosen for each axis.The 
spacing between the lines is defined in the Grid options dialog under the Drawing area of the OOo 
options (Tools > Options > OpenOffice.org Draw > Grid). In the dialog shown in Figure 11, you 
can set the following parameters:

• Vertical and horizontal spacing of the dots in the grid. You can also change the unit of 
measurement used in the general Draw options (Tools > Options > OpenOffice.org Draw > 
Grid > General).

• The resolution is the size of the squares or rectangles in the grid. If the resolution is 
Horizontal 1cm, Vertical 2cm, the grid consists of rectangles 2cm high and 1cm wide.

• Subdivisions are additional points that appear along the sides of each rectangle or square in 
the grid. Objects snap to subdivisions as well as to the corners of the grid.

• The pixel (pix element) size of the snap area defines how close you need to bring an object to 
a snap point or line before it will snap to it.
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Positioning objects with snap functions

Figure 11. Setting grid options

Changing the color of the grid points
The default grid dots are light gray, which can be hard to see. To improve visibility, go to Tools > 
Options, then OpenOffice.org > Appearance (Figure 12).

Figure 12: Changing the grid color

In the Drawing / Presentation section, you can change the color of the grid points. On the Color 
Settings pulldown menu, select a more suitable/visible color, for example black.

Positioning objects with helper lines

To simplify the positioning of objects it is possible to make visible guiding lines—extensions of the 
edges of the object—while it is being moved. These guiding lines have no snap function.

The guiding lines can be (de-)activated under Tools > Options > OpenOffice.org Draw > View > 
Guides when moving, or by clicking on the icon on the Options toolbar.
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The basic drawing shapes

The basic drawing shapes

Draw provides a wide range of shapes, located in palettes accessed from the Drawing Toolbar. This 
chapter describes only a few of the basic shapes; see the Draw Guide for a complete description of 
the shapes available. These shapes include rectangles and squares; circles, ellipses, and arcs; 3D 
objects; curves; lines and arrows; text; and connectors.

Drawing a straight line
Let’s start by drawing the simplest of shapes: a straight line. Click on the Line icon on the Drawing 

Toolbar  and place the mouse cursor at the point where you wish to start drawing. Drag the mouse 
while keeping the button pressed down. Release the mouse button when you want to stop drawing 
the line. 

A blue or green handle point appears at each end of the line, showing that this is the currently 
selected object. The colors depend on the default selection mode (green for simple selection and blue 
when in point edit mode).

Figure 13: Drawing a straight line

Hold down the Shift key while drawing the segment to force the line to be drawn at a multiple of 45° 
from the horizontal.

Hold down the Control key (Ctrl in PCs) to  snap to the nearest grid point.

Hold down the Alt key to draw the line symmetrically from the start point (the line extends out to 
both sides of the start point equally). This lets you draw straight lines by starting from the middle of 
the line.

The line just drawn has the default attributes (such as color and line type). To change the line 
attributes, click on the line to select it and then use the tools in the Line and Filling toolbar; 
or for more control, right-click on the line and choose Line to open the Line dialog.

Drawing an arrow
Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines: Lines with arrowheads. 
They are shown in the information field on the status bar only as lines. Click on the Line Ends with 
Arrow icon  to draw an arrow.
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The basic drawing shapes

Drawing a rectangle or square
Drawing rectangles is similar to drawing straight line segments, except that you use the 
Rectangle button   from the Drawing Toolbar. The (imaginary) line drawn with the 
mouse corresponds to the diagonal of the rectangle. In addition, you will see the outline of 
the future rectangle change in shape as you drag the mouse around. The outline is shown as a 
dashed line until you release the mouse button, when the rectangle is drawn.

Figure 14: Drawing a rectangle

Hold down the Shift key to draw a square. Hold down the Alt key to draw a rectangle starting from 
its center. To combine the effects, hold down both the Shift and Alt keys simultaneously.

Drawing a circle or ellipse

To draw an ellipse (also called an oval) or circle, use the Ellipse Button  from the Drawing 
Toolbar (a circle is simply an ellipse where the two axes are the same length). The ellipse drawn is 
the largest ellipse that would fit inside the (imaginary) rectangle drawn with the mouse.

Figure 15: Drawing an ellipse

There are three other ways to draw an ellipse or circle:

• Hold down the Shift key while drawing to force the ellipse to be a circle.

• Hold down the Alt key to draw a symmetrical ellipse or circle from the center instead of 
dragging corner to corner.

• Hold down the Ctrl key while drawing to snap the ellipse or circle to grid lines.

Getting Started with Draw 11
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The basic drawing shapes

Note If you first press (and hold) the Control key before clicking on any of these buttons 
(Line, Rectangle, Ellipse, or Text), the chosen object appears directly on the page 
with a default size, shape, and color. All of these can then be changed.

Writing text

Use the Text tool  to write text and select the font, color, size, and other attributes. Click on an 
empty space in the workspace to write the text at that spot or drag an area to write inside the dragged 
frame. Press Enter to drop to the next line.

When you have finished typing text, click outside the text frame. Double-click on the text at any time 
to edit it.

When you type text, the upper toolbar includes the usual paragraph attributes: indents, first line, and 
tab stops.

You can change the style of all or part of the text. The Styles and Formatting window also works here 
(select Format > Styles and Formatting or press F11 to launch), so you can create Graphics styles 
that you can reuse for other text frames. Graphics styles affect all of the text within a text frame. To 
style parts of the text, use direct formating with the toolbar.

Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object. 
You can rotate the frame and write the text at any angle. These options are available by right-clicking 
on the object.

Use the Callout tool, located on the Drawing toolbar, to create callouts (also known as captions or 
figure labels).

If you double-click on an object or press F2 (or the Text icon in the Drawing toolbar) when an object 
is selected, text is written in the center of the object and remains within the object. Nearly any kind 
of object contains such an additional text element. These texts have slight differences to those in text 
frames concerning position and hyphenation.

For more about text, see Chapter 2 (Drawing Basic Shapes) and Chapter 10 (Advanced Draw 
Techniques) in the Draw Guide.

Using connectors
Connectors are a type of line or arrow whose ends stick to glue points on other objects. When 
you move the other object, the connector moves with it. Draw has a range of advanced 
connector functions. You can change connector types using the context menu.

Connectors are particularly useful for making organizational charts. You can reorganize the blocks of 
your chart and all the connected objects stay connected.

Glue points are different from handles (the small blue or green squares around an object). Use the 
handles to move or resize an object; use the glue points to attach connectors to an object.
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The basic drawing shapes

Figure 16: Four gluepoints

Gluepoints are different from handles (the small blue or green squares around an object). Use the 
handles to move or resize an object; use the gluepoints to attach connectors to an object.

You can add more gluepoints, and customize gluepoints, using the toolbar of the same name. 

Gluepoints become visible when you click the Gluepoints icon  on the Drawing toolbar and then 
move the end of a connector over the object.

Figure 17 shows two Draw objects and a connector.

Figure 17: A connector between two 
objects

For more about connectors and gluepoints, see Chapter 9 (Organization Charts, Flow Diagrams, and 
More) in the Draw Guide.

Selection modes
There are three selection modes: moving and changing size, rotating, and editing points.

The default mode for selecting objects depends on whether the Points button on the Drawing toolbar 

is active (appears lit)  or not inactive (appears dark or dimmed) .

In standard mode (when you begin a new drawing), the Points button is not active, and the default 
mode is for selections to be moved or changed in size; these selections are indicated by small green 
squares.
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Selection modes

When the Points button is active, the default mode is for selections to be edited; these selections are 
indicated by blue squares. Some objects will have one or more extra handles, which are larger or 
colored differently. This is explained in more detail in the Draw Guide.

Selections for rotating objects are indicated by small red circles and a symbol representing the center 

of rotation. To choose these selections, click on the Effects drop-down button   from the 
Drawing toolbar.

Changing the selection mode
To go from one mode to another, you can do one of the following:

• Toggle the Points button on the Drawing toolbar to switch from the simple selection mode to 

the Points mode . You can also use the keyboard shortcut F8 (Points).

• Choose the Effects drop-down button from the Drawing toolbar  to activate the Rotation 
mode for a selected object.

• If you often work in Rotation mode, you can choose the Rotation Mode after Clicking 

Object button  from the Options bar, you can cycle through normal and rotation modes 
just by clicking on the object. This can be more convenient than clicking the object, then 
clicking the Rotate button from the Drawing Toolbar.

Selecting objects

Direct selection
To select an object, the easiest way is to click directly on it. For objects that are not filled, you have 
to click directly on the object's outline to select it.
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Selecting objects

Selection by framing
You can select several objects by using the mouse to drag a large 
rectangle around the objects, as shown. For this to work, the 
Select  icon on the Drawing toolbar must be active.

Only objects that lie entirely within the rectangle are selected.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. To select an 
object that is covered by another object, hold down the Alt key and click the object. To select an 
object that is covered by several objects, hold down the Alt key and click through the objects until 
you reach the required underlying object. To cycle through the objects in reverse order, hold down 
the Alt+Shift keys when you click. To help in making accurate selections, you can check the number 
and type of the selected objects, shown at the left of the status bar.

Note There may be some variation in the use of the Alt key on different operating systems. 
In general the Alt key on a Windows computer functions as described above, but on a 
Linux system it usually does not. If the Alt key on your system does not operate as 
described above, use the Tab key method described below.

To select an object that is covered by another object using the keyboard, press Tab to cycle through 
the objects, stopping at the object you wish to select. To cycle through the objects in reverse order, 
press Shift+Tab. This may not be practical if you have a large number of objects in your drawing.

When you click on your selected object, its outline will appear briefly 
through the objects on top of the selected object.

In the illustration to the right, the square located beneath the circle was 
selected in this way (the circle was made transparent in order to see the 
square).

Arranging objects
In a complex drawing, you may have objects stacked up, one on top of the other, with the 
result that a particular object is hidden by one or more other objects above it. You can 
rearrange the stacking order of objects (move an object to the front or to the back of the 
stack) by selecting the object, clicking Modify > Arrange and selecting the appropriate 
Bring Forward or Send Backward option, or by right-clicking the object and selecting 
Arrange from the context menu, then selecting from the list of Bring Forward or Send 
Backward options.

On the Drawing toolbar, the Arrange tear-off menu on the  button contains the above options. A 
keyboard shortcut is Shift+Ctrl++ to bring an object to the top, and Shift+Ctrl+− to send an object 
to the bottom.

Draw also provides tools for aligning multiple objects; details are given in the Draw Guide.
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Selecting objects

Selecting several objects
To select or deselect several objects one by one, press the Shift key and click on the various objects 
to be selected or deselected. One click on an object selects it; a second click deselects it.

Moving and dynamically adjusting an object’s 
size

There are several ways of moving or changing the size of an object. The method described here will 
be called dynamic in the sense that it is carried out using the mouse.

When you dynamically change an object, remember to check the central area of the status bar at the 
bottom of your screen. This area shows detailed information about the ongoing manipulation. For 
example, during a resizing manipulation, you will see the following information displayed. This 
information changes when the mouse is moved.

Dynamic movement of objects
To move an object, select it and then click within the object’s border 
and hold down the left mouse button while moving the mouse. 
During movement, the shape of the object appears as dotted lines to 
help with repositioning. 

To drop the object at its new location, let go of the mouse button. 
During movement, the shape of the object appears as dotted lines to 
help with repositioning.

Dynamic size modification of objects
To change the size of an object (or group of selected objects) with 
the mouse, you need to move one of the handles located around the 
selection. As shown in the following illustration, the outline of the 
resulting new object appears as a dotted line.

The results differ depending on which handle you use. If you choose a corner handle,  you will resize 
the object along two axes at the same time. If you use a side handle, the objects will only be resized 
along one axis.

Note If you press the Shift key at the same time as you carry out the resizing operation, 
the size change will be carried out symmetrically with respect to the two axes; this 
enables you to keep the aspect (height/length) ratio of the object.
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Special effects

Special effects

With Draw, you can apply many special effects to objects and groups of objects. This section 
describes a few of these effects. Others include distorting, shadows, and transparency. See the Draw 
Guide for examples of the many effects available.

Rotation
Rotating an object lets you move the object around an axis. To do this dynamically, use the red 
handles, as you do when changing the size of the object.

Note Rotation works in a slightly different way for 3D objects because the rotation 
occurs in 3D space and not in one plane. See Chapter 7 (Working with 3D Objects) 
in the Draw Guide regarding rotation when Edit Points mode is active.

To rotate an object (or a group of objects), drag the red corner handle points of the selection with the 
mouse. The mouse cursor takes the shape of an arc of a circle with an arrow at each end. A dotted 
outline of the object being rotated appears and the current angle of rotation is dynamically shown in 
the status bar.

Rotations are made about an axis which is displayed as a small symbol. You can move the axis of 
rotation with the mouse, as shown below.

Figure 18: Rotating an object

If you hold down the Shift key during the rotation, the operation will be carried out in increments of 
15°.

Inclination and perspective
To slant or shear objects, use the red handles located at the midpoint of an edge of the selected 
objects. The mouse pointer changes to a  when the pointer hovers over one of these midpoint 
handles. Not every object can be slanted—basic shapes can be rotated but not slanted.

The slant axis is the point directly opposite the midpoint handle to be used for shearing the object. 
This point stays fixed in location; the other sides and edges move in relation to it as the mouse is 
dragged (make sure that the  handle icon is showing before dragging).

As with rotation, you can set the inclination to occur as steps of 15° by pressing the Shift key while 
moving the handle.
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Special effects

Duplication
Duplication makes copies of an object while applying a set of changes (such as color or 
rotation) to the duplicates. The result of a duplication is a new group.

To start duplication, click on an object or group and choose Edit > Duplicate. The dialog shown in 
Figure 19 appears.

Figure 19: Duplicating an object

The options above applied to a blue rectangle produce the following result.
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Special effects

Cross-fading
Cross-fading transforms a shape from one form to another, with OpenOffice.org handling all of the 
intermediate transitions. The result is a new group of objects including the two end points and the 
intermediate steps.

To carry out a cross-fade, select both objects (hold the Shift key while selecting each object in turn) 
and then choose Edit > Cross-fading The following dialog appears.

On the dialog choose the number of increments (transition steps). You probably want to have 
Cross-fade attributes and Same orientation both checked. The end result is shown in Figure
20.

Figure 20: Cross-fading example

Editing objects

To change an object’s attributes (such as color and border width), you can use the Line and Filling 
toolbar or the right-click menu.

If the Line and Filling toolbar is not visible, you can display it using View > Toolbars > Line and 
Filling. From here you can edit the most common object attributes. You can also open the Line 
dialog by clicking on the   icon and the Area dialog by clicking on the  icon to see more 
options.

1  Styles and Formatting 4  Line Style 7      Area
2  Line 5  Line Width 8–9  Area Style / Filling 
3  Arrow Style 6  Line Color 10    Shadow

When an object is selected, you can right-click on the object to bring up a context menu (Figure 21). 
The entries with an arrow contain a submenu.

Getting Started with Draw 19



Editing objects

Figure 21: Right-click on a selected object to see the context menu.

Most often the property you want to change is the line’s style (solid, dashed, invisible), its color or 
width. These options are all available from the Line and Filling toolbar. You can also edit these 
properties from the Line dialog. You can also define new line and arrow styles (see the Draw Guide 
for details).

The OOo term for the inside of an object is Area fill. The area fill of an object can be a uniform 
color, a gradient, or an image. Most often you will want to use one of the standard fill options, 
whether it is a color, a gradient, or an image. These options are all available from the Line and 
Filling toolbar. You can also define new area fills (see the Draw Guide).

Inserting pictures from other sources

You can add pictures from several sources:

• The Gallery—see Chapter 14 (Working with the Gallery)

• Directly from a scanner (Insert > Picture > Scan)

• Images created by another program, including photographs from a digitial camera (Insert > 
Picture > From File)

Draw provides tools for working with bitmap images such as photographs: the Picture toolbar and 
the bitmap image management palette. See the Draw Guide for details and examples.
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Exchanging objects with other programs

Exchanging objects with other programs

To save a Draw image in a foreign format, use File > Export. Draw can save to many graphic file 
formats, as listed in Chapter 3 (File Management).

You can also export Draw files to HTML, PDF, or Flash. PDF export is the same as for any part of 
OpenOffice.org, as described in Chapter 3 (File Management). Flash export creates a .swf file.

HTML export uses a conversion wizard that creates as many web pages as there are pages in your 
Draw document. You can optionally choose to display the pages in frames with a navigator and can 
set an index page. For more information, see Chapter 16 (Creating Web Pages: Saving Documents as 
HTML Files).
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