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Designing a presentation

Designing a presentation
In addition to careful planning of the content (as discussed in Chapter 1), you need to plan the 
appearance of the presentation. It is best to do this after you have developed an outline, 
because the outline will determine some of the requirements for the slides’ appearance. For 
example:

• What color combinations (background and text) will both look good and be easy for 
your audience to see?

• Would a picture help your audience understand the contents better?

• Do you want a particular picture (for example a company logo) to appear on all the 
slides?

• Would the audience benefit from having the slides numbered so that they can quickly 
refer to one of them?

• Do you want a background graphic or gradient? If so, you need to pick something that 
does not interfere or clash with your content, for example, colors used in charts.

• Will you need one slide master or more than one? If one slide design does not suit all of 
the content, you might need more than one slide master.

You can change the appearance of slides as you develop the presentation, but planning ahead 
will save you time in the long run.

What are slide masters?
A slide master is a slide that is used as the starting point for other slides. It is similar to a page 
style in Writer: it controls the basic formatting of all slides based on it. A slide show can have 
more than one slide master.

Note OOo uses three terms for this one concept. Master slide, slide master, and master 
page all refer to a slide which is used to create other slides. This book uses the term 
slide master, except when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or 
gradient; objects (such as logos, decorative lines, and other graphics) in the background; 
headers and footers; placement and size of text frames; and the formatting of text.

All of the characteristics of slide masters are controlled by styles. The styles of any new slide 
you create are inherited from the slide master from which it was created. In other words, the 
styles of the slide master are available and applied to all slides created from that slide master. 
Changing a style in a slide master results in changes to all the slides based on that slide master; 
it is, however, possible to modify each individual slide without affecting the slide master.

Note Although it is highly recommended to use the slide masters whenever possible, there 
are occasions where manual changes are needed for a particular slide, for example to 
enlarge the chart area when the text and chart layout is used. 
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What are slide masters?

Slide masters have two types of styles associated with them: presentation styles and graphic 
styles. The pre-packaged presentation styles can be modified, but new presentation styles 
cannot be created. However, not only can the pre-packaged graphic styles be modified, but 
new graphic styles can also be created.

What are styles? Why use them?

A style is a set of formats that you can apply to selected items in your presentation to quickly 
change their appearance. When you apply a style, you apply a whole group of formats at the 
same time. For example, a style defines the font, type size, indents and spacing, tab stops, and 
other characteristics of text; and the area fill and line style of a frame or other object.

Using styles gives you more control over the entire presentation. Although you can manually 
change each slide one element at a time, any manual changes you make apply only to that one 
slide. If you have several slides with the same elements, you would have to change those 
elements of each slide if you wanted your slides to have a consistent appearance. When you do 
this manually, how can you be sure you changed every slide that needs to be changed?

However, if you assign a style to each of the elements you add to your slides, changing the 
style for that element changes all the slides containing it. Thus, by using styles, you can 
eliminate most of the work required for changing manually created slides.

Tip Press F11 to open the Styles and Formatting window. You can dock or undock this 
window by holding down the Control key while double-clicking the top of the window 
between the icons (see Figure 1). Press F11 to close the Styles and Formatting window 
when you do not need it.

Figure 1: Styles and Formatting window
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What are styles? Why use them?

Tip At the bottom of the Styles and Formatting window is a drop-down list. You can 
choose to show all styles or other groups of styles, for example applied styles or (in 
the case of Graphics styles), custom styles.

Presentation styles
Presentation styles affect three elements of a slide master: the background, background objects 
(such as icons, decorative lines, and text frames), and the text placed on the slide. Text styles 
are further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline 
styles are used for the different levels of the outline to which they belong. For example, 
Outline 2 is used for the subpoints of Outline 1, and Outline 3 is used for the subpoints of 
Outline 2.

As described earlier, the pre-packaged presentation styles can be modified, but new 
presentation styles cannot be created.

Graphic styles
Graphic styles affect many of the elements of a slide. Notice that text styles exist in both the 
presentation and graphic style selections. What styles to use and when to use them is described 
later in this chapter.

There are 15 pre-packaged graphic styles to choose from. You can create additional styles or 
modify the pre-packaged styles.

Working with slide masters

Impress comes with five pre-packaged slide masters. They are shown in the Master Pages 
section of the Tasks pane (Figure 3). This section has three subsections: Used in This 
Presentation, Recently Used, and Available for Use. Click the + sign next to the name of a 
subsection to expand it to show thumbnails of the slides, or click the – sign to collapse the 
subsection to hide the thumbnails.

Each of the slide masters shown in the Available for Use list is from a template of the same 
name. If you have created your own templates, or added templates from other sources, slide 
masters from those templates will also appear in this list. See “Working with templates” on 
page 15 for more about templates.

Creating slide masters
You can create a new slide master in a similar way to modifying the default slide master.

To start, enable editing of slide masters by View > Master > 
Slide Master.

On the Master View toolbar (Figure 2), click the New 
Master icon (highlighted in the figure).
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Working with slide masters

A second slide master appears in the Slides pane. Modify this slide master to suit your 
requirements. It is also recommended that you rename this new slide master. To do that, right-
click on the slide in the Slides pane and select Rename master from the popup menu.

When you are done, close the Master View toolbar to return to normal slide editing mode.

Applying a slide master
In the Tasks Pane, be sure the Master Pages section is 
showing (Figure 3).

To apply one of the slide masters to all slides in your 
presentation, click on it in the list.

To apply a different slide master to one or more selected 
slides:

1) In the Slide Pane, select the slides you want to 
change.

2) In the Tasks Pane, right-click on the slide master 
you want to apply to the selected slides, and click 
Apply to Selected Slides on the pop-up menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix 
multiple slide masters that may belong to different 
templates (the use of templates is explained later in 
“Working with templates” on page 15). For example, you 
may need a completely different layout for the first slide 
of the presentation, or you may want to add to your 
presentation a slide from a different presentation (based 
on a template available on the hard disk).

The Slide Design dialog makes this possible. Access this 
dialog either from the menu bar (Format > Slide design) 
or from the pop-up menu that appears when right-clicking 
on a slide in the Slides pane.

The main window in the dialog shows the slide masters 
already available for use. To add more:

1) Click the Load button.

2) Select in the new dialog the template from which 
to load the slide master. Click OK.

3) Click OK again to close the slide design dialog.

The slide masters in the template you selected are now shown also in the Master Pages section 
of the Tasks pane in the Available for use subsection.
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Working with slide masters

Note The slide masters you have loaded will also be available the next time you load the 
presentation. If you want to delete the unused slide masters, click the corresponding 
checkbox in the Slide Design dialog. Due to a bug, if the slide master was not used in 
the presentation, it is removed from the list of available slide masters anyway.

Tip To limit the size of the presentation file, you may want to minimize the number of 
slide masters used.

Modifying a slide master

The following items can be changed on a slide master:

• Background (color, gradient, hatching, or bitmap)

• Background objects (for example, add a logo or decorative graphics)

• Size, placement, and contents of header and footer elements to appear on every slide

• Size and placement of default frames for slide titles and content

Refer to Figure 6 for a graphical representation of many of these elements.

Before working on the slide master, make sure that the Styles and Formatting window is open. 
See page 2 for instructions on doing this.

To select the slide master for modification:

1) Select View > Master > Slide Master from the menu bar. This unlocks the properties 
of the slide master so you can edit it.

2) Click Master Pages in the Tasks pane. This gives you access to the pre-packaged slide 
masters.

3) Click on the slide master you want to modify among the ones available (Figure 3).

4) Make changes as described in this chapter, then click the Close Master View icon on 
the Master View toolbar. Save the file before continuing.

Caution Any changes made to one slide when in Master View mode will appear on all 
slides using this slide master. Always make sure you close Master View and 
return to Normal view before working on any of the presentation slides. 
Select View > Normal from the menu bar, or clicking Close Master View in 
the Master View toolbar to return to the normal slide view.

The changes made to one of the slides in Normal view (for example changes to the bullet point 
style or the color of the title area and so on...) will not be overridden by subsequent changes to 
the slide master. There are cases, however, where it is desirable to revert a manually modified 
element of the slide to the style defined in the slide master: to do that, select that element and 
choose Format > Default Formatting from the menu bar.
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Modifying a slide master

Sometimes you may want to try several of the available layouts to see which one is more 
suitable for your contents. Applying a layout only requires that you open the Layouts section 
of the Tasks pane and double-click on the new layout. Alternatively you can right-click on the 
desired layout thumbnail and select Apply to selected slide from the pop-up menu.

Choosing and applying the background

Background can be applied to a number of elements in Impress: the page, a default text area, a 
graphic object and so on. The procedures to apply a background are always the same.

The following procedure is used to apply a background to the page.

1) To begin, do one of the following:

• Select Format > Page from the menu bar and choose the Background tab.

• Make sure the Presentation Styles icon is selected in the Styles and Formatting 
window (Figure 1), right-click Background and select Modify from the pop-up 
menu.

2) Select the type of fill you want for your background from the five choices, as shown in 
Figure 4: None, Color, Gradient, Hatching, or Bitmap.

Figure 4: Background choices

A list of choices for the selected fill type then appears (see Figure 5 for an example). 

3) Select one of the items on the list and click OK. The fill you have chosen is added to the 
slide master, replacing any previously selected fill.

Tip You can make custom additions to each type of background, with the obvious 
exception of None. After you create new fills, they are listed in the Background 
dialog along with the fills provided with OOo. For example, the last color in Figure 5, 
Test Blue, is a custom color. See Chapter 6 for more information.
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Choosing and applying the background

Figure 5: Background colors

Adding background objects
This section describes how to add background objects and graphic elements (such as a logo, 
decorative lines, and so on). OOo supports a large number of picture formats.

Whenever you want the same graphic element to appear on every slide of your presentation, 
the easiest and quickest solution is to use the slide master. Not only it will save time while 
creating the presentation, but also when you decide to either modify the graphic element or 
reposition it on the slide. If the graphic element was added to each slide, the same operations 
would have to be performed on each individual slide of the presentation.

One of the most common activities when preparing a presentation is to add a picture to the 
slide master. To insert a picture already available on the hard disk, follow these steps:

1) Choose View > Master > Slide Master from the menu bar.

2) Select from the menu bar Insert > Picture > From File.

3) Navigate to the directory where your picture is and select it. If you want to see a 
preview, select the corresponding checkbox in the file browser dialog.
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Choosing and applying the background

Caution OOo offers the option to insert a picture as a link to the file rather than embedding it in 
the document. This can be useful when a presentation is not intended to be distributed 
elsewhere, and where it will remain in the same hierarchical directory structure. For 
example, it could be created on a notebook computer, from which the presentation will 
be given to, typically, a group of clients.

If the presentation file is to be distributed, however, the picture should be embedded to 
avoid the “missing picture” syndrome when the presentation is finally given on a 
different computer.

Once the picture is inserted, you may need to reposition it and modify its size. How to do that 
is explained in Chapter 4 (Adding and Formatting Pictures).

Tip If you want the image to blend with the background, you can set the background color 
of the picture as transparent. Select the picture, then chose Tools > Eyedropper from 
the menu bar. Check the first checkbox and then move the mouse on the picture and 
click on the color you would like to make transparent. This color appears next to the 
checkbox. Make sure that Replace with... is set to Transparent and click Replace.

In addition to pictures you can add a number of other background objects, for example 
decorative lines, text and shapes. Figure 6 is an example of a slide master with a custom 
background gradient, a background picture, another picture in the top right corner, some 
decorative lines and some customized presentation styles.

Figure 6: Example of a complex slide with several modifications
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Choosing and applying the background

Modifying the size and shape of default text areas
When a slide master is opened for editing, it contains five areas, as shown in Figure 7:

• Title area for AutoLayouts

• Object area for AutoLayouts

• Date area

• Footer area

• Slide number area

Figure 7: Slide master showing five editable areas

Click with the left mouse button on any of these areas to display eight green squares (handles) 
around the rectangle. Use these handles to modify the size and position of the area.

1) To change the position, move the mouse towards one of the edges, away from the 
green handles, until the cursor changes shape1, then click the left mouse button and 
drag the area to the desired position.

2) To modify the shape and size of one of the rectangular area, use one of the 8 green 
handles. Use the handles in the corners to modify both the sides of the rectangle 
simultaneously; the handles in the middle of the sides modify only one dimension at a 
time. The shape of the mouse cursor usually changes when over the handle, giving a 
clear visual indication of how it will affect the shape of the rectangular area.

1 The shape of the cursor to move and resize objects is operating system specific, therefore no image is provided. 
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Choosing and applying the background

Tip To keep the ratio between the sides of the rectangular area constant, move the mouse 
to one of the 4 green handles at the corner of the area and keep the Shift key pressed 
while dragging the handle with the mouse. 

To more accurately control the shape and size as well as the position of the default text area, 
instead of using the mouse it is better to access the Position and Size dialog. To do that, first 
select the rectangular area by clicking on any point inside it, then either press F4 or from the 
main menu select Format > Position and Size. The dialog shown in Figure 8 is displayed.

The functions of this dialog are explained in the Draw Guide, so only a short description of the 
most important fields is provided in this chapter.

Figure 8: The Position and Size dialog

Use the Position section to specify the X (horizontal) and Y (vertical) position of the 
rectangular area. The values represent the distance of the base point (selected on the right hand 
side) relative to the top left corner of the slide.

Use the Size section to specify the width and height of the rectangular are. Select as the base 
point the part of the rectangular area that remains fixed. The default setting (top left corner) 
means that the when resizing the area, the position of the top left corner of the area will not 
change.

You can also use the Rotation tab of the dialog to rotate one of the axes by 90 degrees to obtain 
a modern looking layout. In general it is preferable to use only right angles for ease of editing, 
although the program does not impose restrictions on the values that can be used.
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Choosing and applying the background

Further modifications to the default text areas

Besides the shape, size and position, it is also possible to modify other aspects of the 5 areas of 
the slide master, such as the background, add a border, alignment relative to the slide and 
position relative to other objects.

While background style and line style of an area can be accessed from the Format menu, in 
order to access the Alignment and Arrange menus you need to either open the Drawing toolbar 
or use the context menu. To display the Drawing toolbar (Figure 9), select it in 
View > Toolbars; to open the context menu, right-click on the edge of the rectangular area 
after selecting it. On the Drawing toolbar, click the arrow next to the Alignment or Arrange 
icon (highlighted in Figure 9) to display choices. See the Draw Guide for details.

Figure 9: The Drawing toolbar

The date area, footer area, and slide number area do not automatically appear on every slide, 
even though you have defined them. In order to show them, you need to close the Master View 
and select the desired field from the menu: Insert > Page number or Insert > Date and time. 
This procedure is explained in detail in Chapter 8 (Adding and Formatting Slides, Notes, and 
Handouts).

Adding text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text 
objects to the master page for your slides to act as a header or a footer.

1) Choose View > Master > Slide Master from the menu bar.

2) On the Drawing toolbar (see Figure 9), select the Text icon.

3) Click once and drag in the master page to draw a text object, and then type or paste your 
text into the object or add fields as described below.

4) Choose View > Normal when you are finished.

To add a field, such as the date or page number, to a text object in the header or footer, choose 
Insert > Fields. and select the required field from the submenu. If you want to edit a field in 
your slide, select it and choose Edit > Fields.

The fields you can use in Impress are:

• Date (fixed)
• Date (variable) —updates automatically when you reload the file
• Time (fixed)
• Time (variable)—updates automatically when you reload the file
• Author—First and last names listed in the OpenOffice.org user data
• Page number (slide number)
• File name 
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Choosing and applying the background

Tips To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field, 
choose Format > Page and then select a format from the list in the Layout Settings 
area. 

To change the author information, go to Tools > Options > OpenOffice.org > 
User Data.

Working with styles

This section describes how to create, modify, apply and delete styles in Impress. If you are 
familiar with styles in Writer, you will find both similarities and differences in Impress. The 
presentation styles are similar to paragraph styles in Writer and are used in a very similar 
fashion. You cannot create new presentation styles but you can fully configure the existing 
ones. Note that, as for the Heading styles in Writer, the Outline styles are hierarchically linked, 
so a change in the Outline 1 will cascade through all the other Outline levels.

In Impress you will also find the graphic styles very useful. As the name suggests, graphic 
styles define the characteristics of a graphic object (including a text object). If, for example, 
you need to create a organization chart diagram in one of the slides of your presentation, you 
will surely want all the boxes to have consistent appearance, meaning same line style, same 
font type, maybe same shadow and so on. The easiest way to achieve this result with the 
minimum effort is to create a graphic style for the boxes and apply it to each box. The major 
benefit is that if later on you decide to modify, say, the background color of the boxes, all you 
need to do is modify the style.

Creating graphics styles
As discussed above you cannot create new presentation styles. You can create a new graphics 
style in two ways:

• Using the Style dialog

• From a selection

Creating a new style using the Style dialog

Choose the Graphics icon at the top of the Styles and Formatting window.

To link a new style with an existing style, first select that style, and then right-click and select 
New.

When styles are linked, then when you change the base style (for example, by changing the 
font from Times to Helvetica), all the linked fonts will change as well. Sometimes this is 
exactly what you want; other times you do not want the changes to apply to all the linked 
styles. It pays to plan ahead.

The style dialog is shown in Figure 10. It has 14 tabs, each with several options. If you are 
familiar with styles in Writer, you will find that you already know how to set many of these 
options. When you are finished making changes, click OK to save those changes.
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Working with styles

Figure 10: Dialog to create a new graphics style

Creating a new style from a selection

You can create a new style from manually formatted text or graphics:

1) Select the item you want to save as a style.

2) In the Styles and Formatting window, click the New Style from Selection icon, 
highlighted in Figure 11.

Figure 11: New Style from Selection

3) In the Create Style dialog (Figure 12) that pops up, type a name for the new style. The 
list shows the names of existing custom styles of the selected type. Click OK to save 
the new style.

Figure 12: Naming a new style created from a selection
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Working with styles

Modifying styles
To change an existing style, right-click on it in the Styles and Formatting window and choose 
Modify from the pop-up menu. (For Presentation styles, Modify is the only choice.)

The dialog for the modification of a graphic style is the same as the one for creating a graphic 
style (Figure 10); while the dialog for modifying a presentation style is simpler and more 
similar to the one to modify a paragraph style in Writer.

Make the required changes to the style and when finished click OK to save them.

Updating a style from a selection

To update a style from a selection:

1) Select an item that has the format you want to adopt as a style.

2) In the Styles and Formatting window, select the style you want to update (single-click, 
not double-click), and then click the Update Style icon (see Figure 13).

Figure 13. Updating a style from a selection

Tip Any changes you make to a style are effective only in the document on which you are 
working. The changes do not go into any associated template. If you want the changes 
to apply to more than one document, you need to change the template (see “Working
with templates” on page 15).

The Update Style button is available for both presentation and graphic styles.

Applying styles
In Impress you can apply styles in two ways, both starting from the Styles and Formatting 
window. First click on one of the icons at the top left (Graphics Styles or Presentation Styles) 
to display a list of styles in the category you want. Then do one of the following:

• Position the insertion point in the paragraph or graphic and double-click on the name of 
the style you want to apply.

• Click the Fill Format mode icon . The mouse pointer changes to this icon. Position 
the moving icon on the paragraph to be styled and click the mouse button. This mode 
remains active until you turn it off, so you can apply the same style to several 
paragraphs. To quit Fill Format mode, click the Fill Format mode icon again or press 
the Esc key.
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Working with styles

• When Fill Format mode is active, a right-click anywhere in the document undoes the 
last Fill Format action. Be careful not to accidentally right-click and thus undo actions 
you want to keep.

Tip At the bottom of the Styles and Formatting window is a dropdown list (in Figure 1 the 
window shows All, meaning the list includes all available styles. You can choose to 
show all styles or other groups of styles, for example applied styles or (in the case of 
graphics styles) custom styles.

Deleting styles
You cannot remove (delete) any of OOo’s predefined styles, even if you are not using them.

You can remove any user-defined (custom) styles; but before you do, you should make sure 
the styles are not in use. If an unwanted style is in use, you will want to replace it with a 
substitute style.

To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting 
window and click Delete on the pop-up menu. Click Yes in the message box that pops up.

Assigning styles to shortcut keys
OOo provides a set of predefined keyboard shortcuts which allow you to quickly apply styles 
while typing in a document. You can redefine these shortcuts or define your own, as described 
in Appendix A (Keyboard Shortcuts).

Working with templates

All documents in OpenOffice.org (OOo) are based on templates. However, Impress is a little 
different from other OOo components, in that it starts with the Presentation Wizard unless you 
have elected to turn the Wizard off.

When you choose File > New > Presentation from the menu bar, if the Presentation Wizard is 
active, the Wizard offers several choices for a new presentation, one of which is From 
template.

If you have turned the Presentation Wizard off, when you start a new presentation by choosing 
File > New > Presentation from the menu bar, OOo uses the default presentation template. If 
you have not defined your own default template, OOo uses an inbuilt blank template supplied 
with the program.

Using templates supplied with OOo
OOo comes with five presentation templates. Two are in the Presentations folder and three are 
in the Presentation backgrounds folder. The difference between them is that “Presentation” 
templates include a series of slides with sample titles and topics, while “Presentation 
background” templates have only backgrounds and background objects. Both types have 
predefined presentation and graphics styles.

Using Slide Masters, Styles, and Templates 15



Working with templates

You can create a new presentation from a previously saved presentation template by choosing 
File > New > Templates and Documents from the menu bar. This opens the Templates and 
Documents – Templates window. To open a new presentation based on a template, double-
click that template’s name in the list.

Using templates from other sources
If you have created your own templates, or imported templates from another location, they are 
probably stored in the My Templates folder in the Templates and Documents – Templates 
window. Templates installed using the Extension Manager may be installed in their own 
folders. You can use them in the same way as the templates installed with OOo.

See page 21 for information on importing templates into OOo.

Installing templates using the Extension Manager

The Package Manager was introduced in OOo 2.0.4 and renamed the Extension Manager in 
OOo 2.1. This feature provides an easy way to install collections of templates, graphics, 
macros, or other add-ins that have been “packaged” into files with a .OXT extension.

1) After you download a package, select Tools > Extension Manager from the menu bar. 
In the Extension Manager dialog (Figure 14), click Add.

Figure 14: Installing a package of templates

2) A file browser window opens. Find and select the package of templates you want to 
install and click Open.

3) On the Extension Manager dialog (Figure 15), select the package you just added and 
click Enable.
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Figure 15: Enabling a newly-added package of templates

The slide masters from the templates will now appear in the list of Available Master Pages in 
the Tasks Pane (Figure 3).

Setting a default template
You can set a custom presentation template to be the default template. You can reset the default 
later if you choose.

Setting a custom template as the default

You can set any template to be the default, as long as it is in one of the folders displayed in the 
Template Management window.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 16) opens.

2) In the box on the left, double-click the folder containing the template that you want to 
set as the default, then select the template.

3) Click the Commands button.

4) From the drop-down menu, choose Set As Default Template. The next time that you 
create a document by choosing File > New, the document will be created from this 
template.
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Figure 16. Template Management window

Resetting the default to OOo’s in-built Default template

To re-enable OOo’s Default presentation background template as the default:

1) From the main menu, choose File > Templates > Organize. The Template Management 
window (Figure 16) opens.

2) In the box on the left, click the Presentation Backgrounds folder.

3) Click the Commands button.

4) From the drop-down menu, choose Reset Default Template.

Creating your own templates
To create a template from a presentation:

1) Open the presentation that you want to use for a template.

2) From the main menu, choose File > Templates > Save. The Templates window opens 
(see Figure 17).

4) In the New template field, type a name for the new template.

5) In the Categories list, click the folder in which you want to store the template. This is 
usually the My Templates folder, unless you have created other folders.

To learn more about template folders, see “Organizing templates” on page 20.

6) Click OK. OOo saves the new template and the Templates window closes.
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Figure 17. Saving a new template

Modifying a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the 
template’s styles to documents that were created from that template.

Note You can only reapply styles. You cannot reapply content.

To edit a template:

1) From the main menu, choose File > Templates > Edit. A standard file browser window 
opens.

2) Find and select the template that you want to edit, and then click Open. The selected 
template opens in Impress.

3) Edit the template just as you would any other presentation. To save your changes, 
choose File > Save from the main menu.

The next time that you open a document that was created from the changed template, the 
following message appears.

Figure 18. Apply current styles message 

Click Yes to apply the template’s changed styles to the document. Click No if you never want 
to apply the template’s changed styles to the document. Whichever option you choose, the 
message box closes and the document opens in OOo.
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Caution If you choose No in the message box shown in Figure 18, that message will not appear 
again the next time you open the document after changing the template it is based on. 
You will not get another chance to update the styles from the template, although you 
can use the macro given in the Note below to re-enable this feature.

Note Automatic updating from a template did not work in OOo2.0.2. This bug was fixed in 
OOo 2.0.3. To re-enable updating in files created using OOo 2.0.2:

1) Use Tools > Macros > Organize Macros > OpenOffice.org Basic. Select the 
document from the list, click the +, and select Standard. If Standard has a + beside 
it, click that and select a module.

2) Name the macro. For example, you could call it FixDocument. If the Edit button is 
active, click it. If the Edit button is not active, click New, type a module name in the 
pop-up dialog, and click OK.

3) In the Basic window, enter the following:
Sub FixDocument
TemplateName = ThisComponent.DocumentInfo.Template
  if TemplateName <> "" then
  ThisComponent.DocumentInfo.Template = TemplateName
  end if
End Sub

4) Click the Run BASIC icon, then close the Basic window.

5) Save the document.

Next time you open this document, the update from template feature will be restored.

Organizing templates
OOo can only use templates that are in OOo template folders. You can, however, create new 
OOo template folders and use them to organize your templates. For example, you might have 
separate template folders for templates for different purposes or projects. You can also import 
and export templates.

To begin, choose File > Templates > Organize from the main menu. The Template 
Management window (Figure 16) opens.

Note All the actions made by the Commands button in the Template Management window 
can be made as well by right-clicking on the templates or the folders.

Creating a template folder

To create a template folder:

1) In the Template Management window, click any folder.

2) Click the Commands button.

3) From the drop-down menu, choose New. A new folder called Untitled appears.

4) Type a name for the new folder, and then press the Enter key. OOo saves the folder with 
the name that you entered.
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Deleting a template folder

You cannot delete the template folders supplied with OOo or installed using the Extension 
Manager; you can only delete folders that you have created.

To delete a template folder that you have created:

1) In the Template Management window, click the folder that you want to delete.

2) Click the Commands button.

3) From the drop-down menu, choose Delete. A dialog appears and asks you to confirm 
the delete. Click Yes. 

Moving a template

To move a template from one template folder to another template folder:

1) In the Template Management window, double-click the folder that contains the template 
you want to move. A list of all the templates contained in that folder appears underneath 
the folder name.

2) Click the template that you want to move and drag it to the desired folder. If you do not 
have the authority to delete templates from the source folder, this action copies the 
template instead of moving it.

Deleting a template

You cannot delete the templates supplied with OOo or installed using the Extension Manager; 
you can only delete templates that you have created.

To delete a template:

1) In the Template Management window, double-click the folder that contains the template 
you want to delete. A list of all the templates contained in that folder appears 
underneath the folder name.

2) Click the template that you want to delete.

3) Click the Commands button.

4) From the drop-down menu, choose Delete. A dialog appears and asks you to confirm 
the deletion. Click Yes. 

Importing a template

If the template that you want to use is in a different location, you must import it into an OOo 
template folder.

To import a template into a template folder from another location on your computer:

1) In the Template Management window, click the folder into which you want to import 
the template.

2) Click the Commands button. From the drop-down menu, choose Import Template. A 
standard file browser window opens.

3) Find and select the template that you want to import and click Open. The file browser 
window closes and the template appears in the selected template folder.
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Exporting a template

To export a template from a template folder to another location:

1) In the Template Management window, double-click the folder that contains the template 
you want to export. A list of all the templates contained in that folder appears 
underneath the folder name.

2) Click the template that you want to export.

3) Click the Commands button.

4) From the drop-down menu, choose Export Template. The Save As window opens.

5) Find the folder into which you want to export the template and click Save. OOo exports 
the template to the selected folder, and the Save As window closes.
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