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Overview

Overview

This chapter summarizes the differences in use between OpenOffice.org Writer 2.0  and 
Microsoft Word (various versions). The information in this chapter builds upon the 
information given in Chapter 4, “General Differences in Use between OpenOffice.org and 
Microsoft  Office”.

The Writer interface

The main Writer workspace is shown in Figure 1. The menus and toolbars are similar to those 
in Word, with the exceptions described in this chapter.

Figure 1: The main Writer workspace in Print Layout view

Views

Word has 4 or 5 views, depending on the version (here with the 5 views of Word 2003) 
called:

Normal: Recommended view (by Microsoft) for doing most of your typing and editing. 
Writer has no real equivalent view.

Print Layout: This shows the document (more or less) as it will print. This is the closest 
equivalent to the Print Layout view in Writer.

Web Layout: In theory, this shows the document as if viewed on-line. Writer’s equivalent is a 
view option called Web Layout. To access this view, select View > Web Layout.
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Views

Reading Layout: Reading Layout view formats your screen to make reading your document 
more comfortable. Writer has no real equivalent view, but you can go to View > Zoom to 
choose the view that will fit the best for you on your screen.

Outline: For working with heading hierarchies. Outline view displays the document in outline 
form. Headings can be displayed without the text. If you move a heading, the accompanying 
text moves with it. Writer has the Navigator, which is detailed later in this chapter.

Writer also has an HTML source view that only shows when editing an HTML document. To 
access this view, select View > HTML Source.

When field codes are turned on, Writer displays less information about the field than does 
Word. To get detailed information, right-click the field > Fields (or select the field > Edit > 
Fields).

Status bar

The status bar is similar to Word’s except it does not show the current location of the cursor 
on the page (row number and number of characters across). It does however show the 
position within a table in spreadsheet style format; for example, Top left cell =A1.

Navigator

Word does not have a similar concept to the Navigator and, in the author’s opinion, it is such 
a useful tool it is worth taking the time to learn more about it.

To launch the Navigator (Figure 2), press F5 or click the Navigator icon on the Standard 
toolbar. 

Figure 2: The Navigator
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Navigator

To get a detailed description of what each of the buttons does, press Shift+F1 and hover the 
cursor over the buttons.

The Headings at the top of the list box in the Navigator are the closest equivalent to Word’s 
Outline View.

With the List Box on there is a drop-down list box at the bottom of the Navigator. With this 
list box it is possible to select any of the open Writer documents so that their contents are 
available for dragging and dropping. What happens when the selection is dropped is 
determined by the drag mode specified by the Drag Mode button. Click the arrow next to the 
Drag Mode button to see the available options (Insert as: Hyperlink, Link, or Copy).

When viewing a master document, the Navigator is quite different. For more details, see the 
Chapter 13, “Working with Master Documents” in the Writer Guide.

Note Graphics, indexes, OLE objects, and references cannot be dragged and dropped 
when in the Insert as link or Insert as Copy modes.

Formatting and Styles

For a more detailed guide on using styles, see “Use templates and styles” on page 14 and the 
Chapter 13, “Working with Styles” in the Getting Started guide, or Chapter 6, “Introduction 
to Styles” and Chapter 7, “Working with Styles” in the Writer Guide.

Use Shift+F1 to check out the different buttons on the Styles and Formatting window 
(Figure 3). Use the bottom list box to change the style group that is displayed. For example, 
Applied Styles only shows those styles that have been used in the document.

Figure 3: Styles and Formatting window
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Keyboard

When some text has a character attribute at the end of a paragraph (say bold or a hyperlink) 
but the new text does not require that attribute, press the right arrow key before typing.

Deleting paragraph marks: pressing Delete at the end of a paragraph effectively moves the 
text of the following paragraph into the current paragraph, and the paragraph formatting of 
the top paragraph remains. Press Backspace at the start of a paragraph and the format of the 
lower paragraph remains.

TIP An aid to remember this is: the format of the paragraph that has the cursor will be 
the format of the combined paragraph, unless the current paragraph is empty; in that 
case, backspacing will leave the previous paragraph’s formatting.

Control+Home when in tables: In Word, Control+Home always positions the cursor to the 
top of the document; in Writer Control+Home first positions the cursor at the start of the cell, 
then at the start of the table and then the start of the document. Control+End has similar 
behavior.

How to select multiple parts of the text
To copy, cut, format, or delete parts of the text in different areas of the document, use:

• Control+selection with one click, double-click or sliding.

or

1) Click once on the field “STD” (STanDard) in the status bar.
The field now shows “EXT” (EXTended selection).

2) Another click and it changes to “ADD” (ADD to selection).

Note The ADD mode is the equivalent to Control + click and EXT is equivalent to 
Shift+click.

Multiple selections and tables
The following limitations apply when selections involve tables:

• It is possible to have multiple selections within a cell, or even parts of other cells, but 
only one selection is possible that involves at least one entire cell.

• A selection that starts in a table cannot extend beyond the table.

• A selection that starts outside a table will include the entire table (that is, a selection 
cannot start outside a table and also contain a portion of a table).
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Keyboard

Comparison of shortcut keys
Table 1: Word vs Writer different default shortcut keys (incomplete)

Function Word standard 
shortcut

Writer standard 
shortcut

Underline words not spaces Control + Shift + W No equivalent
Thesaurus Shift + F7 Control + F7
Show/hide non-printing 
characters

Control + Shift + * Control + F10

Hanging indent Control + T No standard equivalent
“Unhang” indent Control + Shift + T No standard equivalent
Indent Control + M No standard equivalent
UnIndent Control + Shift + M No standard equivalent
Superscript Control + Shift = Control + Shift + P
Subscript Control + = Control + Shift + B
Remove character formatting Control + Space bar Right-click > Default
Remove paragraph 
formatting

Control + Q Right-click > Default

Jump to previous edit point Shift + F5 Need to use the reminders on 
the Navigator

Shift paragraph up No equivalent Control + Up
Shift paragraph down No equivalent Control + Down
Find Control + F Control + F
Replace Control + H Control + F

See AltKeyHandler.sxw (available from http://homepages.paradise.net.nz/hillview/OOo/) for 
macros that extend Writer’s key shortcut ability – including the indent functionality similar to 
that provided in Word.

Mouse use

Some differences are:

• No quick selection of paragraphs or lines by clicking to the left of the paragraph.

• Control+click does not select a sentence, but a triple-click does (a quadruple-click 
selects the paragraph).

Differences in Use between Writer and Word 5
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Tables

Tables

Selections involving tables
Tables are like one special paragraph so when selecting text using the keyboard (Shift+arrow) 
from, say, above the paragraph, the whole table is selected followed by the line below it.

The location for displaying the table grid when a table has no borders is not particularly 
intuitive: use Tools > Options > OpenOffice.org > Appearance and select the Table 
boundaries checkbox.

Heading rows
By default new tables have a heading row. This default behavior can be changed by Tools > 
Options > OpenOffice.org Writer > Table.

When creating a new table using Table > Insert Table, you can choose to turn on or off the 
heading row, by checking Heading in Options > OpenOffice.org Writer > Table

Whether the top row(s) repeat at the start of each new page can be altered by selecting the 
relevant top row(s) > Table > Repeat on each page. This does not change the format of the 
rows, only whether they repeat at each page break.

Adjusting column widths and row heights using the 
keyboard
The different methods of adjusting the column width available via Tools > Options > 
OpenOffice.org Writer > Table are:

• Fixed: Overall width of the table stays the same, but the adjoining column shrinks or 
grows correspondingly.

• Fixed Proportional: The current column and the end column change by 
corresponding amounts, keeping the overall width the same.

• Variable: Only the current column changes so the overall width of the table changes.

Use Alt and the arrow keys as follows to adjust the width of columns (or height of rows):

• Alt and arrow keys adjusts the right side (bottom for rows).

• Alt+Shift and arrow keys adjusts the left side (top for rows).

• Alt+Control+left or right arrow keys adjusts the current cell only.
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Copying and pasting cells in a table
Writer never inserts new rows or columns when pasting data, it always overwrites the 
contents of the cells. This makes it clear as to what will happen. To avoid overwriting cells, 
first insert the required number of rows or columns.

Inserting and deleting rows or columns
If you use Table > Insert > Row or Table > Insert > Column or right-click > Insert Row or 
Insert Column, you can choose whether to insert before or after the current row or column.

The icons on the Table toolbar insert below for rows and to the right for columns (opposite of 
Word).

Note This is a surprising inconsistency as Calc inserts above and to the left.

In Linux, to insert rows or columns using the keyboard: Alt+Insert > arrow key (this is hold 
down Alt and Insert keys together, release the keys, then press the arrow key). To delete rows 
or columns using the keyboard: Alt+Delete > arrow key. The insertion or deletion is in the 
direction of the arrow key. For example, Alt+Insert > Up inserts a row above the current row.

Equal row heights and column widths
On the Table toolbar there is a long click button called Optimize. The Optimize button 
becomes active when more than one cell is selected. This presents a tear-off menu for easily 
adjusting row heights and column widths to being the same.

Splits and merges
Merge cells last, as you would in Word.

To merge cells: Select cells to be merged > Table > Merge cells (or use the Merge cells 
button on the Table toolbar).

To split cells: Select merged cells > Table > Split cells (or use the Split cells button on the 
Table toolbar).

To split a table (horizontally): Table > Split Table.

To join two tables, they need to be one below the other, then Table > Merge Table. If there is 
a table above and below the current table you will be prompted for which one you wish to 
join.
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Sorting
To sort a table:

1) Select the cells to be sorted; do not include the headings. The option to sort only 
becomes available when something is selected.

2) Tools > Sort.

Unlike Word, the sort dialog uses column number rather than the names of the column.

Entering numbers and formulas
Unlike Word, tables in Writer can work much more like spreadsheets. For example, 
calculated values change as the data is input (no more selecting and pressing F9 to update 
calculated results).

With number recognition turned on, when entering a number Writer will automatically format 
the number according to a specified number format. To change this behavior, right-click 
when the cursor is in a table and click on Number Recognition to deselect it.

To change the number format, select the cells, Table > Number Format.

To enter a formula like SUM():

1) Select the cell where the result is to go.

2) Press F2 to display the Formula bar.

3) Click and hold the Formula button to display the formula menu.

4) Select the desired function (list separator is for separating constants, for example 
=mean 5 | 12 | 20).

5) Click and drag on cells to input ranges.

6) Press Enter to finish.

To enter a formula like “this cell plus that cell minus that cell”:

1) Select the cell where the result is to go.

2) Press F2 to display the Formula bar.

3) Click on a cell.

4) Type or select the desired operator.

5) Click on the next cell.

6) Repeat steps 4 and 5 until done.

7) Press Enter to finish.
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Creating a table from a data source
To create a table from a data source:

1) Display the Data source viewer (F4).

2) In the Data explorer window, navigate to the desired table or query.

3) Drag the name of the table or query into the document.

4) Select the desired fields and set other properties as required in the dialog.

Charts in Writer

Charts copied from a Calc spreadsheet and pasted into a Writer document are, by default, 
embedded objects. Unlike doing this in Microsoft Office, only the relevant data for the chart 
is embedded. In Microsoft Office copying and pasting a chart also embeds it, but if the Excel 
workbook was 8 MB in size (not unrealistic for a spreadsheet) then each chart pasted into a 
Word document would increase the Word document by 8 MB.

Linking of charts does not exist.

Customizing the user interface

Most functions are found in similar places in both programs, but a few are slightly different, 
and the degree of control varies. Table 2 summarizes where to find the setup choices.

Table 2: Customizing the user interface

To do this In Word In Writer
Change measurement system Tools > Options > 

General
Tools > Options > OpenOffice.org 
Writer > General

Turn off Auto completion Not applicable Tools > AutoCorrect. In the Word 
completion tab, deselect Enable 
word completion.

Turn on/off Help Agent Help > Microsoft 
Word Help > Options

Tools > Options > OpenOffice.org 
> General

Set up document window 
(rulers, status bar, default 
toolbars, etc)

View > select required 
items

View > select required items

Customize toolbars Tools > Customize Tools > Customize
Customize menus Tools > Customize Tools > Customize
Display font names in their font 
(in toolbar drop-down font list)

Tools > Customize > 
Options

Tools > Options > OpenOffice.org 
> View, select Show preview of 
fonts
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Customizing the user interface

To do this In Word In Writer
Always show full menus 
(include unavailable and little-
used items)

Tools > Customize > 
Options

Tools > Options > OpenOffice.org 
> View, select Show inactive menu 
items

Show/hide ScreenTips 
(ToolTips) on toolbars

Tools > Customize > 
Options

Tools > Options > OpenOffice.org 
> General

Always create backup copy Tools > Options > 
Save

Tools > Options > Load/Save > 
General, select Always create 
backup copy

Autosave every x minutes Tools > Options > 
Save

Tools > Options > Load/Save > 
General, select Save AutoRecovery 
information every , and choose a 
time in the Minutes list

Show paragraph marks, tabs, 
etc.

Tools > Options > 
View

Tools > Options > OpenOffice.org 
Writer > Formatting Aids, select 
required items

Change file locations Tools > Options > File 
Locations

Tools > Options > OpenOffice.org 
> Paths

Change user information Tools > Options > 
User Information

Tools > Options > OpenOffice.org 
> User Data

Set up AutoCorrect and 
AutoFormat options

Tools > AutoCorrect 
Options

Tools > AutoCorrect > Options, 
select required items

Write, edit, and review documents

Most writing, editing, and reviewing techniques in OOoWriter are similar to those in 
Microsoft Word, but the details often vary.

Table 3: Write, edit and review documents

To do this In Word In Writer
Jump quickly to other parts of 
a document

Edit > Go to Edit > Navigator (or F5), 
double-click on required heading, 
figure, table, etc.

Choose language for spelling 
checker

Tools > Language > Set 
Language

Tools > Options > Language 
Settings > Language. (Note: 
OpenOffice.org has no grammar 
checker.)

Ignore some text when 
checking spelling

Select text; Tools > 
Language > Set Language 
> Do not check (or) 
Format > Style > Modify> 
Format > Language

Select text; right-click, 
Character > Font > Language = 
[None] or the real language of the 
selected text, if that is foreign.
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Write, edit, and review documents

To do this In Word In Writer
Recheck spelling Tools > Spelling & 

Grammar > Recheck 
Document

Always rechecks

Find and replace text, 
formatting, and styles

Edit > Replace > More; 
choices as needed

Edit > Find & Replace; details 
are a bit different

Use wildcards in find and 
replace

Edit > Replace > More > 
select Use Wildcards 
checkbox

Edit > Find & Replace, click on 
the More Options and select 
Regular expressions; wildcards 
themselves are different. See the 
section on Regular expressions in 
Chapter 4, “General Differences 
in use between Microsoft Office 
and OpenOffice.org”.

Choose, create, or edit a 
custom dictionary

Tools > Options > 
Spelling & Grammar > 
Custom Dictionaries

Tools > Options > Language 
Settings > Writing Aids

Create exception (exclude) 
dictionary

File > New, type words, 
Save As > text only, file 
extension .EXC

As for custom dictionary, but 
after clicking on the New button, 
select Exception (-) in the New 
Dictionary dialog

Track changes (choose 
options)

Tools > Options > Track 
Changes

Tools > Options > 
OpenOffice.org Writer > 
Changes

Protect document for editing Tools > Protect Document Edit > Changes > Protect 
Records
(Password needs to be at least 5 
characters)

Mark and track changes (Word 2000) Tools > 
Track Changes > 
Highlight Changes

Edit > Changes > Record

Insert comments associated 
with a change

Highlight text; Insert > 
Comment

Edit > Changes > Comment

Insert notes (comments not 
associated with a change)

Highlight text; Insert > 
Comment

Insert > Note

Show changes as pop-up text Options > View > 
Screentips

Tools > Options > 
OpenOffice.org > General

Merge documents Tools > Merge Documents Edit > Changes > Merge 
Document

Accept or reject changes View > Toolbars > 
Reviewing

Edit > Changes > Accept or 
Reject

Change document properties File > Properties File > Properties
Get a word count Tools > Word Count Tools > Word Count
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Write, edit, and review documents

To do this In Word In Writer
Create AutoText entry Select text; Insert > 

AutoText > New
Edit > AutoText (or) Control+F3

Insert AutoText Type shortcut and press 
F3

Type shortcut and press F3; or 
type Name and press Enter. 
Writer distinguishes between the 
“name” and the “shortcut” of an 
autotext. Word does not.

AutoText in Writer always ends with a paragraph mark. So for a short in-line shortcut, it is 
better to use AutoCorrect.

Control page layout

This section covers such things as margins, headers, and footers.

Writer and Word have somewhat different notions of page layout.

Word’s notion of page layout
Page layout is a property of the document as a whole. If you change the page layout (for 
instance, set the document to landscape), it changes for the entire document. You can then 
arrange for specific sections to have a different layout.

Writer’s notion of page layout
Page layout is a property of the page style (for example, First Page, Index and Default). If you 
change the page layout for one page style (for instance, set Default to have a header with page 
numbers), only that style will be affected.

Using page styles gives Writer some very useful features. For instance, you can define the 
First Page page style so that, after you have typed the first page, the style switches to Index 
(or any other style you choose). You can then set Index so that it is followed by Default.

Comparison for page layout
Table 4: Control page layout

To do this In Word In Writer
Define margins File > Page Setup > Margins Format > Page > Page
Specify different headers 
and footers on first, odd, 
and even pages

File > Page Setup > Layout > 
Headers and Footers section

Format > Page, select 
required items 
Define different page styles for 
First, Left (even), and Right 
(odd) pages, using Header and 
Footer tabs
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Control page layout

To do this In Word In Writer
Edit headers and footers View > Headers and Footers, 

then you can type or insert fields; 
you can also double-click in 
existing header or footer regions

After you have specified 
Header and Footer areas for a 
page, they are always active. 
Single-click to type or insert 
fields

Change from roman to 
arabic page numbers in 
the footer of a page

Insert a section break, deselect 
“Same as Previous” in the second 
section, define a new footer with 
page numbers restarting at 1 in 
Arabic numerals

Insert a manual page break and 
apply a different page style

Use paragraph styles for 
page layout

Can define paragraph styles with 
offset from left margin, with 
heading styles aligned left or 
right

Can define paragraph styles 
with offset from left margin, 
with heading styles aligned 
left or right

Use columns for page 
layout

Insert continuous sections to 
switch from single to multiple 
columns on one page

Format > Page > Columns 
(or)
Insert > Section > Columns 
(or) Format >  Columns

Use frames or text boxes 
for page layout

Frames are used in Word 97 but 
mostly replaced by text boxes in 
Word2000 and 2002; can be 
linked to flow text from one to 
next, as in a newsletter

Insert > Frame (can link 
frames to flow text from one 
to next, as in a newsletter); 
“text boxes” are fields, not 
positioning devices

Use tables for page layout Table > Insert > Table (use dialog 
to format)

Insert > Table (use dialog to 
format)

Put portrait headers on 
landscape pages

Use rotated text box linked to 
header

Use rotated text in a frame

Set first page number to 
greater than 1

Insert > Page Numbers > Format In first paragraph on first 
page, Format > Paragraph > 
Text Flow > Breaks, select 
Insert and With Page Style, 
choose the page style, specify 
the page number

View and edit facing 
pages

File > Print Preview; click Zoom 
button to enable editing

File > Page Preview; cannot 
edit when previewing,

Reduce page count by 1 File > PagePreview, click 
ShrinkToFit button.

See 
http://homepages.paradise.net.
nz/hillview/OOo/ShrinkToFit.
sxw.
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Use templates and styles

Table 5: Use templates and styles

To do this In Word In Writer
Find which template is 
associated with a document

Tools > Templates and Add-
ins

File > Properties > General 
tab.

Specify default template "Normal" template is default File > Templates > Organize 
lets you set any template as 
default

Create a new template File > Save As, set type to 
Document Template (.DOT)

File > Templates > Save

Edit a template File > Open, choose template File > Templates > Edit
Copy styles between 
templates

Tools > Templates and Add-
ins > Organizer

File > Templates > Organize. 
There, you can copy styles with 
drag and drop between templates.

Create a new document 
from a template

File > New (opens a list of 
templates)

File > New > Templates and 
Documents

Apply a different template 
to a document

Tools > Templates and Add-
ins > Attach, select template, 
Open

Start a new document based on 
the different template; copy 
contents of old document into 
new document.

Apply a style to text (Word 2000) Select from 
Style List or Style dialog
(XP) Can also use task pane.

Format > Styles and 
Formatting (or press F11), 
double-click the style in list; 
after the second use, paragraph 
styles appear in Apply Style list 
on the Formatting toolbar.

Change a style definition (Word 2000) Format > Style 
> Modify; (XP) can also 
select in task pane and click 
Modify

Select a style in the Styles and 
Formatting window, right-click, 
and choose Modify.

Create a new style Format > Style > New Right-click in Styles and 
Formatting window, then click 
New.

Use outline numbering Format > Style, select style > 
Format > Numbering

Tools > Outline Numbering

Drop caps Format >Drop Cap
One character only, can not 
be part of a style.

Format > Paragraph > Drop 
Caps tab
Drop caps can be part of a style. 
Can be >= 1 char or word.
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Use templates and styles

Font size
When a style is based on another style, it is possible to set the font to being a percentage of 
the font size of the original style. In the font size field simply type the number followed by a 
percentage sign, for example 120%. This way, changes to the underlying style will be better 
reflected in this style. To change it back to being an absolute font size type the number 
followed by the characters “pt”, such as 12pt. It is also possible to specify how many points 
larger or smaller, for example +2pt for 2 points larger, or -2pt for two points smaller.

Space between paragraphs and page breaks before
In Writer, some paragraph properties behave differently to the way they behave in Word. 
Specifically:

• Space before if at the top of a page is ignored.

• Space between paragraphs: the greatest of space above and space below for the two 
paragraphs is applied.

• Page break before: if at the top of a page, does not create a blank page.

This makes using styles possible without having to apply direct paragraph formating to fix 
issues afterwards.

Fields

For a comparison of fields between Writer and Word, see Chapter 2, “Sharing Files with 
Microsoft Office Users”.

Table 6: Use of fields

To do this In Word In Writer
Insert a field Insert > Field

(or) CTRL + F9 for blank 
field

Insert > Fields and choose the 
requested field.

Define a number range field Insert > Field, use SEQ 
(sequence)

Insert > Fields > Other > 
Variables tab, then Number 
range in the Type area

Insert a bookmark Select text; Insert > 
Bookmark

Select text; Insert > Bookmark

Insert a cross-reference to a 
bookmark

Insert > Cross Reference, 
choose Bookmark as type

Insert > Cross Reference > 
Bookmark1

1 For macros that aid in working with references see http://homepages.paradise.net.nz/hillview/OOo/. For a more 
detailed discussion on references, see the latest document available from 
http://www.openoffice.org/issues/show_bug.cgi?id=28058.
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Fields

To do this In Word In Writer
Insert a cross-reference to a 
heading

Insert > Cross Reference, 
choose Heading as type

Either bookmark the heading or 
use Insert > Cross Reference > 
References tab > Set Reference 
to mark the heading, then Insert 
> Cross Reference > References 
tab >  Insert Reference.

Insert a cross-reference to a 
figure or table

Insert > Cross Reference, 
choose type

Insert > Cross Reference > 
References tab >  Insert 
Reference > Figure (or Table)

Use conditional content Use IF or other fields, or 
styles (all workarounds)

Insert > Fields > Other > 
Variables (among other ways)

Work with large or complex documents

Major differences exist in the use of master documents. The table does not attempt to 
summarize all these differences.

Table 7: Work with large or complex documents

To do this In Word In Writer
Create a table of contents, list 
of figures, or an alphabetic 
index

Insert > Index and 
Tables

Insert > Indexes and Tables > 
Indexes and Tables

Insert index entries ALT + SHIFT + X Insert > Indexes and Tables > 
Entry 

Create a bibliographic 
database

Need to use other 
package

Tools > Bibliography Database

Insert bibliographic references 
into text

Link to field in database Insert > Indexes and Tables > 
Bibliography Entry

Insert footnotes and endnotes Insert > Footnote Insert > Footnote 
Insert other files Insert > File, choose 

Insert or As Link
Insert > File

Cross-reference between 
documents

Use Includetext fields Currently have to remember the 
name of the set reference. Reference 
will show correctly when in master 
document. (Or use the 
OutlineCrossRef3-fr-3 macro 
available from http://ooomacros.org/ 
user.php#113812.

Use master documents Some experts do not 
recommend using Master 
Documents in Word.

File > Send > Create Master 
Document; use the Navigator (F5) 
to insert subdocuments.
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Work with graphics

Work with graphics

Most graphics work should be done outside Word or Writer, with the graphic files embedded 
or linked to the Word or Writer file. However, you can do some simple graphics using the 
drawing tools in Word or Writer. This table covers the basics.

Table 8: Work with graphics

To do this In Word In Writer
Create Drawing objects (Word 2000) View > Toolbars > 

Drawing; (XP) Insert > Picture 
> New Drawing

Click Show Draw Functions 
icon in the Standard toolbar.

Combine graphics objects 
and drawing objects

(Word 2000) Edit > Picture > 
Reset Picture Boundary; (XP) 
Use drawing canvas

Place all objects in a frame

Insert graphics files into a 
text document (embed or 
link)

Insert > Picture > From File, 
choose Insert or As Link

Insert > Picture > From File

Anchor graphics Format > Picture > Layout > 
Advanced > Picture Position

Use icons on the Drawing 
Object Properties or Frame 
toolbar (these toolbars replace 
the Formatting toolbar when a 
drawing object or frame is 
selected) or right-click and 
choose from pop-up menu, or 
click Format > Picture

Wrap text around graphics Format > Picture (or Object) > 
Layout

Use icons on the Frame 
toolbar, or right-click and 
choose from pop-up menu, or 
click Format > Picture > 
Wrap

Crop graphics Format > Picture > Crop, (or) 
click Crop tool on Picture 
toolbar

Format > Picture > Crop
(No tool for dragging crop 
area)

Create captions for 
graphics

Select graphic; Insert > 
Reference > Caption

Select graphic; Insert > 
Caption

Annotate graphics Use drawing objects; group, or 
place in frame or on drawing 
canvas (XP)

Place all objects in a frame

Insert watermark Format > Background > Printed 
Watermark > Picture (or Text) 
Watermark

Format > Page  > 
Background tab
or create drawing object, 
Wrap > In  Background, 
Anchor > To Page
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Mail Merge

Mail Merge

Mail merging is significantly different in Writer to Word. See Chapter 11, “Using Mail 
Merge” in the Writer Guide.

Envelopes

Adding an envelope
Insert > Envelope

Removing an envelope
1) Place the cursor at the beginning of the envelope page.

2) If the Styles and Formatting window is not open, press F11 or use Format > Styles 
and Formatting to display it.

3) Change to the Page Styles option.  It is the fourth icon from the left.

4) Double-click on Default.

5) Remove the remaining elements that make up the envelope.

Page styles

Modify a page style
In Writer all pages have a page style. To modify the page style of the page where the cursor is 
positioned, use Format > Page.

Caution As the page style is being changed, all pages with this style will be changed as well.

Create a style
To create a new page style:

1) If the Styles and Formatting window is not currently displayed, press F11 to display it.

2) Click Page Styles in the Styles and Formatting window (fourth icon from left).

3) Right-click in a free area of the Styles and Formatting window > New.
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Page styles

The Page Style dialog
Click Format > Page. The Page Style window opens.

Organizer tab

Name: Nothing tricky here, simply a name to help the user remember what the settings are 
for.

Next style: This setting specifies what page style to use at the next page break (manual or 
automatic) for any page that has this page style. Set it to a different page style when the page 
style is only for one page (such as the first page of each chapter), otherwise this should be the 
same as Name to keep the same page style for the following pages.

Page tab

Paper format : Format is the paper size, the other settings have the same names in Word (on 
the paper size tab of page setup).

Margin : Same as for Word. Each setting represents the distance from the edge of the page, 
but see “Header and footer tabs”  as the location of headers and footers relative to the 
margins is different.

Layout settings: Page layout is for specifying whether the page style is mirrored  (used for 
left and right pages). There are more options here than in Word, but there is not a different 
first page option, that is because it is handled by the Next style setting as mentioned above in 
Organizer tab. Format refers to the format of page numbers. Register true is to make the text 
line up better at the top of the page (see help for more details).

Background tab

For specifying a background color or graphic (watermark). (An alternative to this with more 
flexibility is to create a drawing object, then use Arrange > To Background, Anchor > To 
Page.)

Header and footer tabs

Headers and footers are printed between the margins of the page rather than in the top or 
bottom margins as they are in Word. Another way of saying this is that for the top of a page 
the area between the edge of the page and the top margin is always blank, next is the header, 
and after the header, the main text area for the page.

Height: AutoFit height allows the header or footer to grow and shrink depending on their 
contents.

Spacing specifies the distance between the header/footer and the main text area on the page. 
Dynamic spacing allows the header/footer to expand into the area between the header/footer 
and the main text area.

The left and right margins are indenting from the margins of the page and cannot have 
negative values.
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Page styles

The More button is for specifying borders and backgrounds for the header/footer area. In 
some versions of Word this approach was used to create a watermark. Since it is possible to 
have graphics in the background of the main document, this is not the required way of having 
a watermark in Writer.

Borders, columns and footnote tabs

These tabs are for specifying the borders (lines around the outside), number and widths of 
newspaper style columns and defining the area for footnotes (if any) for the page style.

Page breaks and page numbering

Changing the style used for a page and changing 
the numbering sequence
To insert a page break and change page style or page numbering, method 1:

1) Press Control+Enter.

2) Cursor will be in the first paragraph of the new page.

3) Format > Paragraph > Text Flow tab.

4) Breaks will be enabled.

5) Select With Page style, specify the page style to use and specify the page number to 
start from.

To insert a page break and change page style or page numbering, method 2:

1) Insert > Manual Break

2) By default it will specify Page breaks.

3) Choose the page style in the Page style list.

4) Select Change page number.

5) Enter the new starting page number.

To insert page numbering
1) Define a page style with header or footer turned on.

2) Position the cursor in the header or footer (use the mouse or the shortcut keys 
Control+PageUp for Header or Control+PageDown for footer).

3) Optionally type: Page <space>.

4) Insert > Fields > Page Number.

5) Optionally type <space> of <space>, then click Insert > Fields > Page Count.
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Page breaks and page numbering

To insert a field that calculates a different page count (for example, when you have a title 
page but want to have the remaining pages say page 1 of 2 (instead of page 1 of 3 ):

1) Press F2 to display the text formula bar.

2) Type =page – 1.

3) Press Enter.

Note Unfortunately this field does not automatically update, so press F9 to update it 
before printing.

Page numbers on portrait and landscape pages in 
the same place and orientation

1) Create a style for landscape pages. Set the margins for the landscape style such that 
they correspond with the portrait style when rotated (top = left, bottom = right, left = 
bottom and right = top). For page numbering on left, turn on headers; on right – 
footers. Select Use dynamic spacing.

2) Create a style for the landscape header or footer based on the style for the portrait 
header or footer. (In the Styles and Formatting window, select the style that is used 
for the portrait header or footer > right-click > New.) Change the font position to 270°. 
If the page numbering is on the bottom choose left alignment, for the top choose right.

3) Insert the page break and choose the page style just created (see above); do not change 
the numbering.

4) In the relevant header/footer (as per step 1) insert the page number field.

Conditional text

In Word the only way to have conditional text is with the “if” field2. The equivalent in Writer 
is the field “Conditional text”.

To insert a conditional field in Writer: Insert > Fields > Other > Functions > Conditional 
text or Control+F2 > Functions > Conditional text.

There is also a field “Hidden text” that hides the text when the condition is true.

Working with the relevant fields for conditional text, both in Word and in Writer, means that 
only small amounts of text can be conditional. However, there are times when having whole 
paragraphs or sections of text be conditionally hidden is very convenient. Some examples:

A test so that the same document can be used for the test itself and for the model answers.

Technical documents where the same document with variations can be used for similar 
models of equipment.

2 To the best of the Author’s knowledge.
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Conditional text

Writer provides a field for conditionally hiding paragraphs and the ability to conditionally 
hide sections. Here is an example to show how this could be done:

1) Ensure that hidden text is viewable: Tools > Options > OpenOffice.org Writer > 
Formatting Aids, select both “Fields: Hidden text” and “Fields: Hidden paragraphs”.

Note Conditionally hidden sections are not visible regardless of these settings if the 
condition for hiding them is true.

2) At the top of the document: Insert > Fields > Other > Variables.

3) Name: DocType. Value: Model Answers.

4) At the start of a one paragraph answer: Insert > Fields > Other > Functions > 
Hidden Paragraph. For the condition type DocType == “Test” (To make this easier to 
insert repeatedly, create an autocorrect entry).

5) For longer answers: Enter the model answer, select it, Insert > Section, select Hide, 
and enter DocType == “Test” for the condition.

6) To print the document for a test, double-click the field at the top of the document 
created in steps 2 and 3, and change the value to Test. Print as usual.

Note 1 The field “Input list” has a name but this is not a variable so its value cannot be 
used in the condition.

Note 2 To keep adding sections, it is easier if the selection does not include the last 
paragraph. But if the last paragraph is selected, simply move to the end of the 
document (Control+End ) and then press Alt+Enter.

Master documents

OOo Help covers the basics of using master documents, or see “Work with large or complex
documents” on page 16, or for even more information see Chapter 13, “Working with Master 
Documents” in the Writer Guide.

It is possible to insert cross-references across subdocuments but the names of the references 
must be typed in rather than selected from a list.

Use Insert > Fields > Other > References.

A macro to help insert references to headings, including references across documents that 
will be subdocuments in a master document, is available in a document called 
OutlineCrossRef3-fr-3.zip available from http://ooomacros.org/user.php#113812.

Note There is no way to have a landscape page in a subdocument remain as a landscape 
page when included in the master document. The workarounds are to have the 
landscape page be part of the master document rather than a subdocument or to have 
the entire subdocument as landscape.
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