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Introduction
This chapter describes how to do the following in Writer, Calc, Draw
and Impress:
• Create hyperlinks within a document and to other documents

such as web pages, PDFs, and other files.
• Save documents as web pages (HTML documents).
When creating a document that you plan to deliver as a web page, you
need to consider the following:
• In an HTML document, hyperlinks are active (clickable) but other

cross-references inserted by OOo are not active links.
• An object such as a image is saved as a separate file. However, if
that object has been placed in a frame (for example, with an
associated caption), it is not saved and does not appear in the
HTML document; instead, the name of the frame appears.

Inserting hyperlinks
When you type text (such as a website addresses or URL) that can be
used as a hyperlink, and then press the spacebar or the Enter key, OOo
automatically creates the hyperlink and applying formatting to the text
(usually a color and underlining). If this does not happen, you can
enable this feature using Tools > AutoCorrect > Options and
selectingthe URL Recognition option.
If you do not want OOo to convert a specific URL to a hyperlink,
choose Edit > Undo Insert from the menu bar or press Control+Z
immediately after the formatting has been applied.

Note
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Hyperlinks between documents can be set as relative or
absolute, using the Save URLs relative to option in Tools >
Options > Load/Save > General.
Relative linking is only possible when the document you are
working on and the link destination are on the same drive, and
you need to create the same directory structure on your hard
disk as will apply on the destination website.
OOo uses absolute path names internally, so when you move
your mouse cursor over a hyperlink, the tooltip displays the
absolute reference even when it is set to be a relative link.
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You can also insert hyperlinks using the Navigator and the Hyperlink
dialog, and you can modify all hyperlinks using the Hyperlink dialog, as
described in this section.

Using the Navigator
The easiest way to insert a hyperlink to another part of the same
document is by using the Navigator:
1) Open the documents containing the items you want to crossreference.
2) Open the Navigator (by clicking its icon, choosing View >
Navigator, or pressing F5.
3) Click the arrow next to the Drag Mode icon, and choose Insert
as Hyperlink. (See Figure 1.)
4) In the list at the bottom of the Navigator, select the document
containing the item that you want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a
hyperlink.
6) Drag the item to where you want to insert the hyperlink in the
document. The name of the item is inserted in the document as an
active hyperlink.

Figure 1: Inserting a hyperlink using the Navigator
When using the Navigator to hyperlink to an object such as a graphic,
to have the hyperlink show useful text such as Figure 6, you need to
give such objects useful names instead of leaving them as the default
names (“Graphics6”), or you need to edit the resulting link text using
the Hyperlink dialog, as described below.
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You can also use the Navigator to insert a hyperlink from one
document (the source) to a specific place in another document (the
target). Open the Navigator in the target document and drag the item
to the spot in the source document where you want the hyperlink to
appear.

Using the Hyperlink dialog
To display the dialog, click the Hyperlink icon
on the Standard
toolbar or choose Insert > Hyperlink from the menu bar. To turn
existing text into a link, highlight it before opening the dialog.
On the left hand side, select one of the four types of hyperlink:
• Internet: a web address, normally starting with http://
• Mail & News: for example an email address.
• Document: the hyperlink points to another document or to
another place in the current document.
• New document: the hyperlink creates a new document.

Figure 2. Hyperlink dialog showing details for Internet links
The top right part of the dialog changes according to the choice made
for the hyperlink type. A full description of all the choices, and their
interactions, is beyond the scope of this chapter. Here is a summary of
the most common choices.
For an Internet type hyperlink, choose the type of hyperlink (choose
between Web, FTP or Telnet), and enter the required web address
(URL).
6
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For a Mail and News type hyperlink, specify whether it is a mail or
news link, the receiver address and for email, also the subject.
For a Document type hyperlink, specify the document path (the Open
File button opens a file browser); leave this blank if you want to link to
a target in the same document. Optionally specify the target in the
document (for example a specific slide). Click on the Target icon to
open the Navigator where you can select the target, or if you know the
name of the target, you can type it into the box.
For a New Document type hyperlink, specify whether to edit the newly
created document immediately (Edit now) or just create it (Edit later)
and the type of document to create (text, spreadsheet, etc.). The
Select path button opens a directory picker.
The Further settings section in the bottom right part of the dialog is
common to all the hyperlink types, although some choices are more
relevant to some types of links.
• Set the value of Frame to determine how the hyperlink will open.
•
•
•

•

This applies to documents that open in a Web browser.
Form specifies if the link is to be presented as text or as a button.
Text specifies the text that will be visible to the user.
Name is applicable to HTML documents. It specifies text that will
be added as a NAME attribute in the HTML code behind the
hyperlink.
Event button: this button will be activated to allow OOo to react
to events for which the user has written some code (macro). This
function is not covered in this book.

Editing hyperlinks
To edit a hyperlink, click anywhere in the link test and then open the
Hyperlink dialog by clicking the Hyperlink icon on the Standard
toolbar or choosing Edit > Hyperlink from the menu bar. Make your
changes and click Apply. If you need to edit several hyperlinks, you
can leave the Hyperlink dialog open until you have edited all of them.
Be sure to click Apply after each one. When you are finished, click
Close.
The standard (default) behavior for activating hyperlinks within OOo is
to use Ctrl+click. This behavior can be changed in Tools > Options >
OpenOffice.org > Security > Options, by deselecting the option
Ctrl-click required to follow hyperlinks. If clicking in your links
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activates them, check that page to see if the option has been
deselected.
To change the color of hyperlinks, go to Tools > Options >
OpenOffice.org > Appearance, scroll to Unvisited links and/or
Visited links, pick the new colors and click OK. This will change the
color for all hyperlinks in all components of OOo.
In Writer and Calc (but not Draw or Impress), you can also change the
Internet link character style or define and apply new styles to selected
links.

Saving Writer documents as web pages
Writer’s HTML capabilities include saving existing documents in HTML
format, creating new documents as HTML (not described here), and
creating several different types of web pages using a wizard.
The easiest way to create HTML documents is to start with an existing
Writer document. You can get a good idea of how it will appear as a
web page by using View > Web Layout. However, web layout view
will not show you which features will or won’t save correctly to HTML.
Some considerations are described in the introduction to this chapter.

Saving a document as a single web page
To save a document as a single web page (HTML format), select Save
As from the File menu and specify HTML Document as the file type.

Note

Writer does not replace multiple spaces in the original
document with the HTML code for non-breaking spaces. If you
want to have extra spaces in your HTML file or web page, you
need to insert non-breaking spaces in OOo. To do this, press
Control+Spacebar instead of just Spacebar.

Saving a document as a series of web pages
Writer can save a large document as a series of web pages (HTML
files) with a table of contents page. To do this:
1) Decide which headings in the document should start on a new
page and make sure all those headings have the same style (for
example, Heading 1).
2) Select File > Send and click on Create HTML Document.
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3) In the dialog (Figure 3), type the file name to save the pages
under. Also specify which style indicates a new page (as decided
in step 1).
4) Click Save to create the multi-page HTML document. (For those
who may be interested, the resulting HTML files conform to the
HTML 4 Transitional.)

Figure 3. Creating a series of web pages from one document

Creating web pages using a Wizard
OOo’s Web wizard allows you to create several types of standard web
pages. To use it:
1) Select File > Wizards > Web Page. On the first page of the
Wizard, choose settings and click Next. If this is your first web
page, the only choice is <default>.

Saving Writer documents as web pages
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2) Choose or browse to the document you would like to format. The
Title, Summary and Author information is picked up from the
document’s properties; if necessary, edit it. Click Next.

3) Chose a layout for the web site by clicking on the layout boxes.
Click Next.
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4) Chose the information to be listed and the screen resolution. Click
Next.

Saving Writer documents as web pages
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5) Select a style for the page. Use the drop-down list to choose
different styles and color combinations. You can browse to a
background image and icon set from the Gallery. Click Next.

6) Enter general information such as Title and HTML Metadata
information. Click Next.

7) Chose where to save the file and preview the page if you wish.
Click Finish.
12
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To edit or view the document’s underlying HTML code, click View >
HTML Source or click the HTML Source icon
on the Main
toolbar.

Saving Calc spreadsheets as web pages
Calc can save files as HTML documents. As for Writer, use File > Save
As and select HTML Document, or File > Wizards > Web Page.
If the file contains more than one sheet, the additional sheets will
follow one another in the HTML file. Links to each sheet will be placed
at the top of the document. Calc also allows the insertion of links
directly into the spreadsheet using the Hyperlink dialog.

Saving Impress presentations as web
pages
You can export presentations as Macromedia Flash files: select File >
Export and choose Macromedia Flash for the file type.
You can also convert presentations into a series of web pages, as
described below.
Note

Saving as web pages (HTML format) does not retain animation
and slide transitions.

Saving Impress presentations as web pages
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1) To begin, select File > Export and choose HTML Document as
the file type.
2) Create a folder for the files, supply a name for the resulting
HTML file, and click Save. The HTML Export Wizard opens.

Note

Depending on the size of your presentation and the number of
graphics it contains, the HTML export function creates many
HTML, JPG, and GIF files. If you simply save to your desktop
(not in a specific folder), these separate HTML and graphics
files will be all over your desktop. So be sure to create a folder
to hold all the files.

3) Choose the design for all of the pages, either from an existing
design or by creating a new one. If you have not previously saved
a design, the Existing Design choice is not available.

4) Click Next to select the type of web pages to create.
•
Standard HTML: one page for each slide, with navigation links
to move from slide to slide.
•
Standard HTML with frames: one page with a navigation bar
on the left-hand side; uses slide title as navigation links. Click
on links to display pages in right-hand side.
•
Automatic: one page for each slide, with each page set with
the Refresh meta tag so a browser automatically cycles from
one page to the next.
•
WebCast: generates an ASP or Perl application to display the
slides. Unfortunately OOo has no direct support for PHP yet.
14
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5) Decide how the images will be saved (PNG, GIF, or JPG) and what
resolution to use.
When choosing a resolution, consider what the majority of your
viewers might have. If you use a high resolution, then a viewer
with a medium-resolution monitor will have to scroll sideways to
see the entire slide—probably not desirable.

6) If Create title page was chosen in step 4, supply the information
for it on the next page. The title contains an author name, e-mail
address and home page, along with any additional information
you want to include.
This page of the Wizard does not display if Create title page was
not chosen.

Saving Impress presentations as web pages
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7) Choose the navigation button style to use to move from one page
to another. If you do not choose any, OOo will create a text
navigator.

8) Select the color scheme for the web pages. Available schemes
include the document’s existing scheme, one based upon browser
colors, and a completely user-defined scheme. You can save a new
scheme so that it will appear on the first page of the HTML export
wizard.
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9) Click Create to generate the HTML files. If this is a new design, a
small dialog pops up. If you might want to reuse this design, you
can give it a name and save it. Otherwise, click Do Not Save.

Saving Draw documents as web pages
Exporting drawings from OpenOffice.org’s Draw application is similar
to exporting a presentation from Impress. Use File > Export and
select HTML Document as the file type.
When using the wizard, you can choose to create the web page at any
time by clicking the Create button.

Saving Draw documents as web pages
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