Chapter 5
Combining Multiple Objects
Copyright

This document is Copyright © 2005–2011 by its contributors as listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/3.0/), version 3.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

Agnes Belzunce  Daniel Carrera  Martin Fox
Wolfgang Uhlig  Jean Hollis Weber  Claire Wood
Linda Worthington  Jared Kobos  Hazel Russman

Feedback

Please direct any comments or suggestions about this document to:
odfauthors-discuss@lists.odfauthors.org

Acknowledgments

This chapter is based on an original French document written for OpenOffice.org 1.x by Michel Pinquier (translated into English by Alex Thurgood) and previous content revised by Jim Taylor. The chapter was revised for OpenOffice.org 2.0 by Linda, Daniel, Jean, and Agnes, and later translated into German by Wolfgang Uhlig. The German revisions were then translated into English and updated for OpenOffice 3.3 by Martin Fox.

Publication date and software version

Published 5 August 2011. Based on OpenOffice.org 3.3.

Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows/Linux</th>
<th>Mac equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>OpenOffice.org &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click</td>
<td>Open context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open Styles &amp; Formatting window</td>
</tr>
</tbody>
</table>
# Contents

Copyright.................................................................................................................... 2  
Note for Mac users........................................................................................................ 2  
Introduction: grouping and combining objects.......................................................... 4  
Grouping objects.......................................................................................................... 4  
  Grouping by common selection.................................................................................. 4  
  Maintaining groups and undoing groups................................................................... 4  
  Editing individual objects in a group........................................................................ 5  
Nesting groups............................................................................................................. 5  
Combining objects........................................................................................................ 5  
  Connecting lines...................................................................................................... 6  
Merging, subtracting, or intersecting shapes............................................................... 6  
  Merge........................................................................................................................ 7  
  Subtract..................................................................................................................... 7  
  Intersect..................................................................................................................... 7  
  Practical example....................................................................................................... 7  
Aids for positioning objects.......................................................................................... 8  
  Moving an object to the front or to the back............................................................ 8  
  Aligning objects....................................................................................................... 10  
  Distributing the distance and space between objects............................................. 11  

Combining Multiple Objects
Introduction: grouping and combining objects

Using Draw, you can combine drawing objects together in two distinct ways: grouping and combining. These two methods allow you to treat multiple objects as one unit, or to merge objects to form a new shape.

Grouping is like putting objects in a container. You can move them as a group and apply global changes to them. A group can always be undone and the objects that make up the group can always be manipulated separately.

A combination is a permanent fusion of objects leading to a new object. The original objects are no longer available as individual entities and the operation is not reversible.

Tip

To select multiple objects, click on each object while holding down the Shift key or click the Select icon (on the Drawing toolbar) and draw a rectangle around the objects.

Grouping objects

Grouping by common selection

When several objects are selected, any operations you carry out are applied to all of the objects. For example, you can rotate a group of objects in its entirety. Groups obtained through common selection of several objects are undone as soon as you click outside the group. However, you can choose to maintain a grouping so that the selected objects will remain together after they are deselected.

Maintaining groups and undoing groups

To group objects, first select the objects, then right-click and choose Group from the pop-up menu. You can also use the keyboard shortcut Control+Shift+G or choose Modify > Group from the menu bar.

When objects are grouped, any editing operations carried out on that group are applied to all members of the group. If you click on one member of the group, the whole group is selected.

Figure 1: Grouping objects using the right-click menu

The objects of a group retain their own individual properties. To undo a group, right-click and choose Ungroup from the pop-up menu, use the keyboard shortcut Control+Alt+Shift+G or choose Modify > Ungroup from the menu bar.

Combining Multiple Objects
**Editing individual objects in a group**

You can edit a member of a group individually without breaking the group. To do this, right-click and choose *Enter group* or double-click on the group.

![Figure 2: When you enter a group, objects outside the group cannot be selected and appear pale](image)

Once inside the group, click on any object to edit it.

![Figure 3: Editing an object inside a group](image)

To leave this mode, right-click and choose *Exit group* or double-click outside the group.

**Nesting groups**

You can create “nested” groups, or groups of groups. In this case, Draw keeps the initial group hierarchy. If you ungroup a group made of other groups, you are left with individual groups that you can then ungroup further, until only single objects remain.

**Combining objects**

In contrast to grouping functions, *combinations* create a new object; it is not possible to edit an individual constituent afterwards. Select a collection of objects, then right-click and choose *Combine* from the pop-up menu or use the keyboard shortcut *Control+Shift+K*. The result of this operation is shown in Figure 4.

![Figure 4: Combining objects](image)
At first glance, the appearance of the combined objects can seem rather surprising. However, once you understand the rules governing combination in Draw, it will become clearer.

- The attributes (for example, area fill) of the resulting object are those of the object furthest back. In this example, it is the circle.
- Where the objects overlap, the overlapping zone is either filled or empty depending on the number of overlaps. When the number of overlaps is even, you get an empty space; when the number is odd, you get a filled area.

![Image](image.png)

*Figure 5: Odd numbered overlaps are filled, even numbered overlaps are empty*

**Tip** You can reorder objects before combining them so that they are further back or further forward: right-click on the object and select *Arrangement* from the pop-up menu. See also “Aids for positioning objects” on page 8.

An object which is a combination can be broken up again by selecting **Modify > Split** or using the keyboard shortcut *Control+Alt+Shift+K*. The combination can also be broken up into its constituent parts by selecting **Modify > Break**. These are not an exact equivalent to ungrouping, as the objects were converted to Bézier curves when they were combined. An object which is split will, for example, have an ellipse converted to a Bézier curve.

A object which is broken will consist of a set of base level objects (for example, a rectangle will be broken into 4 separate lines) and the original formatting—line thickness, colors, and area properties—is not retained.

**Connecting lines**

Lines may be connected by selecting them and using **Modify > Connect**. The connections established are based on joining the ends of pairs of lines with minimum separation. Once a group of lines is connected, you can “close” the remaining gap by selecting the line, right-clicking and choosing **Close Object**. The resultant object is filled with the default fill. If you modified the line properties (color, weight) these are retained in the resulting polygon.

**Merging, subtracting, or intersecting shapes**

After you have selected more than one object, the Merge, Subtract, and Intersect functions can be reached in the **Modify > Shapes** menu or though the group’s right-click menu under the heading **Shapes**.
**Merge**

When you merge objects, the new object covers the entire surface of the original objects (it is the *union* of the objects). In the same way as combining, the fill of the merged object is determined by the fill of the object furthest in the background. Other properties are not taken over into the new object.

**Subtract**

When you subtract, the front object is subtracted from the object behind it.

**Intersect**

When you intersect two objects, you get only the area covered by both objects.

---

**Tip**

For more information on moving objects to the front or back, see page 8.

**Practical example**

The following example shows how you can use the merge functions to create a complex shape—a knife with a wooden handle.

1) Draw an ellipse and then a rectangle overlapping half of its width.

2) Select both shapes, right-click, and choose *Shapes > Subtract* from the pop-up menu. The result should resemble the shape to the right:

3) Draw another rectangle and put it over the top half of the ellipse. Then subtract again.
4) Draw a small ellipse covering just the lower right corner and subtract again.

5) The knife blade is now complete. To make the handle, draw a rectangle and an ellipse as shown.

6) Merge the shapes together.

7) Group this image with the previous one.

Aids for positioning objects

Draw has various tools to help you arrange the objects with respect to each other. Here we explore some of the more important ones.

Moving an object to the front or to the back

When you combine or merge objects, the end result varies drastically depending on which object is “in front” and which one is “behind”. In Figure 6 you can see the difference.

Figure 6: Subtracting objects: the result varies depending on which object is in front.

If you imagine several objects stacked one on top of the other, the one referred to as “Front” is the one on top of the stack. The one referred to as “Back” is the one on the very bottom of the stack.

First select an object, then on the Drawing toolbar, long-click on the Arrange icon to open the Position toolbar. This toolbar can be torn off and made to float.

Combining Multiple Objects
Figure 7: The floating Position toolbar

1. Bring to Front
2. Bring Forward
3. Send Backward
4. Send to Back
5. In Front of Object
6. Behind Object
7. Reverse

Brings the selected object to the front of the group.

Brings the selected object one step forwards.

Sends the selected object one step backwards.

Sends the selected object to the back of the group.

Moves the selected object in front of another chosen object.

Moves the selected object behind another chosen object.

Click first on the object you want to change in position. Next click on the icon and then move the mouse over the other object. The mouse cursor

Aids for positioning objects
changes into a hand and the outline of the second object becomes a dashed line (see below). Clicking on this object completes the rearrangement of position.

reverses the order of the selected objects (this option is grayed out if only one object is selected).

**Aligning objects**

Select two objects and long-click on on the Drawing toolbar to open the **Align** toolbar. This toolbar can be torn off and made to float. The tools help you position objects with respect to each other.

**Figure 8: The floating Align toolbar**

**Align left.**

**Center horizontally.**
If you have selected only one object, clicking the various buttons on the Align toolbar positions the object in relation to the drawing page.

**Distributing the distance and space between objects**

Select at least three objects. Now you are able to select the option *Distribution* on the *Modify* menu or from the right-click menu. The Distribution dialog contains a number of options, described below.

![Distribution dialog](image)

*Figure 9: Distribution of spacing between objects*
**Horizontal distribution**

**None.** Does not distribute the objects horizontally.

**Left.** The left edges of the objects are evenly spaced from one another.

**Center.** The horizontal centers of the objects are evenly spaced from one another.

**Spacing.** The horizontal spacing between the objects is evenly distributed.

**Right.** The right edges of the objects are evenly spaced from one another.

**Vertical distribution**

**None.** Does not distribute the objects vertically.

**Top.** The top edges of the objects are evenly spaced from one another.

**Center.** The vertical centers of the objects are evenly spaced from one another.

**Spacing.** The vertical spacing between the objects is evenly distributed.

**Bottom.** The bottom edges of the objects are evenly spaced from one another.

Figure 10 shows four objects before distribution of horizontal spacing.

![Figure 10: Before distribution](image)

The result of the selections made in Figure 9 is shown in Figure 11.

![Figure 11: After distribution: change to equal horizontal spacing, no vertical change](image)