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Introduction

Introduction
Charts and graphs can be powerful ways to convey information to the reader. OpenOffice.org 
Calc offers a variety of different chart and graph formats for your data.

Calc allows you to customize charts and graphs to a considerable extent. Many of these 
options enable you to present your information in the best and clearest manner.  For readers 
who are interested in effective ways to present information graphically, an excellent 
introduction to the topic is Cleveland, W. S. (1985), The elements of graphing data, 
Wadsworth Advanced Books and Software.

Creating a chart
We  will use the small table of data in Figure 1 to demonstrate what we can do with Calc's 
charting and graphing capabilities.

Figure 1: Table of data for charting examples

To create a chart, first highlight (select) the data to be included in the chart, as shown in 
Figure 2.
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Creating a chart

Figure 2: Selecting data for plotting

Next, open the AutoFormat Chart dialog using one of two methods.

• Click on a cell in the area of the spreadsheet where you want the chart to appear, and 
then select Insert > Chart from the menu bar as shown in Figure 3.

Figure 3: Insert chart from menu bar

• Or, click on the Chart icon on the main toolbar (Figure 4) and then click in a cell in 
the area of the spreadsheet where you wish the chart to be.
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Creating a chart

Figure 4: Insert chart from menu tool bar

Either method  will bring up the Auto format Chart dialog (Figure 5).

Using the AutoFormat Chart dialog

Figure 5: AutoFormat Chart: Screen 1

Data range and labels
The data range includes the numbers that we wish to chart. The checked boxes indicate that 
Calc has recognized that the entries in the first column and the first row are not numbers and 
it is suggesting that we may want to use them to supply labels (names). We will accept the 
suggestion.

The labels in the First column will be used to label the x-axis and the labels in the first row 
will be used in the Legend. If we did not want to use these labels we could uncheck the boxes 
and Calc would just ignore the column and the row in creating the chart. 

To select the type of chart or graph required, click Next.
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Using the AutoFormat Chart dialog

Note If the AutoFormat Chart dialog was opened from the Insert menu, the Chart 
results in worksheet option is available.  From this list box you can select the 
sheet on which the new chart will reside. Opening the dialog from the toolbars 
requires you to select a location for the new chart before it is opened, so this list 
box is not available. Since the data range is specified in Absolute references no 
matter where the new chart is placed in the current spreadsheet, it will update as 
the data change in the source ranges.

Figure 6: Choose a chart type

Calc offers a choice of 13 different main chart types, a mixture of 2-dimensional and faux 3-
dimensional types.  Only 8 of the 13 types are shown; scroll down to see the other selections.

On the Choose a chart type (Figure 6) page, select one by clicking on its icon. To view a 
preview of the chart that displays the title, labels and legend, select the Show text elements 
in preview checkbox at the left of the dialog. This preview will update every time you select 
a different type of chart, and provides you with a good idea of what your finished chart will 
look like. 

The current selection, shown with a border around it, is the Columns chart. The selected 
chart’s name is shown just below the icons.  For the moment, we will stick with the Columns 
chart and click on Next again.

This takes us to the Choose a Variant page (not shown here) where we have a choice of five 
different types of column chart. Again we need to scroll down to see all the choices. We will 
stay with the suggested format, Normal, and click on Next again.
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Using the AutoFormat Chart dialog

Chart and axis titles, and legend
As shown in Figure 7, we can set titles for the chart and the axes on this page. Since the 
option box  for Chart Title is already checked, type in a new title Equipment Rentals. Accept 
the Legend option.

The default for the axes is No Label, shown by the unchecked boxes and the grayed out text. 
Check the option boxes and add the x-axis label Months and the y-axis label Volume.

Figure 7: Title, legend and axes labels 

Strangely enough, this page also allows us to change the way we are plotting the data by 
letting us use the rows as data series rather than the columns.

Next click on Create to get a column chart complete with title and and axes labels and the 
default legend.

Figure 8: Basic column chart with title and axes
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Using the AutoFormat Chart dialog

Selecting data ranges
In the example in Figure 3 we selected a  contiguous data range by highlighting it and then 
proceeding to insert a chart. To plot any non-contiguous columns of data we can select the 
data by selecting the first data series and then selecting the next series while holding down 
the Ctrl key.

You can also type in the columns. The columns must be separated by a semi-colon. Thus if 
we wanted to Chart B3: B11 against G3:G11 we can write the selection range as 
B3:B11;G3:G11. 

The two data series you are selecting must be in separate columns or rows. Otherwise Calc 
will assume that you are adding to the same data series. This last, however, can be handy if 
you are doing a column or bar chart but only want to chart some of the data.  For example we 
would do this if we only wanted to compare January with June.

Examples of different chart types
We will use the same data that we used to create the chart in Figure 8 to illustrate some of the 
other charts that Calc can produce.

Columns (2D & faux 3D)

These chartscreate vertical columns to represent data. The columns can be normal, stacked, 
or by percent. 

Figure 10: Column chart with 3D 
perspective
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Examples of different chart types

A useful variation of a column chart is the Combined chart, which presents data in both line 
and column format, as shown in Figure 11.

Figure 11: Combined column and line chart

In 3D mode the data can also be represented by cylinders and cones. It is very difficult to see 
any reasonable use of any of the faux 3D chart forms if the intention is to accurately convey 
information.

Bars (2D & 3D) 
These charts provide the same features as columns, but they are horizontal.

Figure 12: 2D bar chart
Figure 13: 3D perspective bar chart
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Examples of different chart types

Lines (2 & 3 D)
These charts are another way of displaying the same data against a set of categories as a bar 
chart. The choice of which to use, a bar or a line, depends on the purpose of the chart.

Figure 14: Normal 2D line chart
Figure 15: Line chart - deep

In general the faux 3-D charts do not convey information very well and should be avoided if 
your need is to accurately transmit information.

Pies (2D & 3D)
Pie charts can be used for showing the parts of a whole. The pie chart can be separated or 
keep as a solid circle.

Figure 16: 2D pie chart–Offset 2 
(exploded pie chart)      

Figure 17: 2D pie chart–normal

Pie charts can effectively present information in some cases, particularly when there are only 
2 or 3 pieces in the pie. However, they are not usually a good choice for presenting data as 
the number of pieces in the pie increases. A bar chart may often be a better choice.
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Examples of different chart types

Note When producing a pie chart, we often find that we want to chart a row of values 
rather than a column. To do this, select the relevant row(s) (one for the values, and 
once for the labels) and select Data series in rows on the Display page ( the fourth 
or last page) of the AutoFormat Chart dialog.

Net
Net charts provide a circular graph with a separate Y axis for each item on the X axis. Points 
within a data series are connected with a polygon. This type of chart is also known as a polar 
area or honeycomb chart.

Figure 18: Net or honeycomb chart

XY graphs
XY Graphs are used to show the relationship of one or more variables to other variables. An 
XY graph assumes that the variables are continuous rather than categorical. This is an 
important difference between an XY graph and a Line chart which assumes that the x-axis 
variable is categorical. An example of an XY graph is Figure 20 on page 11.
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Modifying the appearance of the chart

Modifying the appearance of the chart
Calc gives you considerable control over how a chart or graph is presented. To illustrate this 
we will work through an example based on the XY graph which was created from a small 
table of weather data, freshly invented for this purpose and shown in Figure 19.

Figure 19: XY graphing data - basic 
weather data

A simple scatter plot
To begin we will construct a a simple scatter plot:

1) Select (highlight) the data to be graphed.

2) Insert > Chart > Next.

3) Select the XY chart > Next.

4) Accept the symbols only selection > Next.

5) Add a title: Weather Conditions.

6) Check the box beside the x-axis label to accept the label  Wind speed (km/hr).

7) Check the box beside the y axes label and type in a title. Percent Cloud Cover.

8) Uncheck the legend box (we do not need a legend for only one y-variable).

9) Click Create. 

This gives us the graph in Figure 20. This basic graph could use some improvements.
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Modifying the appearance of the chart

Figure 20: XY graph -  scatter plot

Moving and resizing a chart
To move a chart, click and hold down the left mouse button and drag the chart across the 
window. (If the chart is in Edit mode, you need to click the very edge of the chart in order to 
move it.)

To resize the chart, click and hold down the left mouse button on one of the green handles 
and drag the mouse. Dragging on a handle on one of the corners of the chart will increase or 
decrease the height and/or width. Hold down the Shift key while dragging to increase or 
decrease the height and width in proportion. Dragging on a handle on the side of the chart 
increases its width and on the top or bottom of the chart increases its height.

Figure 21: Chart handles for sizing a chart
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Modifying the appearance of the chart

Changing axes scales
The numbers on the y-axis of our example chart are cluttering things up and it makes sense to 
start the y-axis at zero percent cloud cover. To do this:

1) Right-click with the cursor inside the graph and select Edit (See Figure 22).You can 
also double-click on the graph to place it in Edit mode.

Figure 22: Chart editing menu

2) From the menu bar, select Format > Axis> Y Axis and select the Scale tab. 

3) Set the Minimum value to 0 and Major Interval to 5. Leave the other settings as they 
are.

These changes produce the graph shown in Figure 23. This is a bit better, but the scale 
on the x-axis could be improved.
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Modifying the appearance of the chart

Figure 23: XY graph with modified y-axis scale

4) Again right-click in the chart and select Edit. Then from the menu bar, select Format 
> Axis > X Axis. Leave the Minimum value at 10 km/hr but reset the maximum value 
to 40 km/hr and the major interval to 5.

Figure 24 looks better and  is much less cluttered.

Figure 24: XY graph with modified x- and y- axis scales

We could have reset the Minimum value to 0 as we did with the y-axis but we would have 
ended up with a lot of unused space on the left side of the graph. Try it and see what you 
think. Graphs do not need to start from a (0,0) origin.
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Modifying the appearance of the chart

Modifying the data area of the chart

Grid lines and background

The horizontal grid lines are a distraction and the gray background is unnecessary. To remove 
them:

1) Right-click on the chart and select Edit.

2) On the menu bar, select Edit > Grid > Y-Axis Main Grid > Invisible to remove the 
grid.

3) Select Format > Chart Wall > Area > None to remove the gray background. This 
looks better.

Defining the data area

To finish off the graph we will enclose the entire data wall of the graph. To do this, select 
Edit > Chart Wall, select the Lines tab and select Continuous from the drop-down Style 
menu. Figure 25 shows the result.

Figure 25: XY chart with enclosed chart wall area

It is possible to do much of this editing from the pop-up menu shown in Figure 22 when you 
right-click on the graph. Also, the spreadsheet toolbar is context sensitive; when you click on 
Edit in the pop-up menu, the toolbar at the top of the spreadsheet changes to gives a number 
of chart editing icons as shown in Figure 26.

Figure 26: Context sensitive chart editing icons on main 
tool bar
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Modifying the appearance of the chart

Fitting a regression line to the data
So far we have been working with a simple scatter plot, but if we look at the data points on 
the graph, it looks like there is a fairly strong relationship between wind speed and the 
amount of cloud cover. Let’s add a regression line to this graph and see what we get. 

1) Right-click in the graph and select Edit.

Note From now on,  we will omit ‘right click in the chart’ in our instructions. Unless 
otherwise specified, the command Edit assumes that this has been done and that we 
are selecting Edit from the pop-up menu that we first saw in Figure 22.

2) Select Insert > Statistics and then Linear Regression.

The linear regression line is now on the graph. This freshly invented data does show that 
cloud cover increases as the wind speed picks up. However, to make the graph look a little 
better, we should have increased the y-axis from a maximum of 50 to 55 or even 60.

Figure 27: XY graph with linear regression line

Note Calc will graph four different kinds of regression line: Linear, logarithmic, 
exponential and power. If you need the coefficients for these lines, you must use the 
statistical functions to calculate the regressions.

Multiple data series
Thus far we have only graphed one variable against another but there are many circumstances 
where we wish to graph more than one y-variable against the same x-variable.  For our 
weather graph we might want to compare the cloud cover at two different cities. We now 
have data from two cities. The original city was Toronto, Canada. Now a friend has sent us 
the same type of data for Madrid, Spain. 
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Modifying the appearance of the chart

To update our table we will insert a new row in the spreadsheet for a new heading, add some 
new column labels and the data from Madrid. Figure 28 presents our new data table.

Figure 28: XY graphs : Modified weather data table for Toronto 
and Madrid

Let’s see how Toronto and Madrid compare. To do this we will add another data series to our 
existing graph. To makes things a bit easier to see, let’s get rid of that regression line for the 
moment. Select Insert > Statistics > No Regression.

To add the new column of data, right-click on the graph, select Modify Data Range and 
select the entire table again by dragging with the mouse and then click Create.  We now have 
our two data series, but which one is which?  We need a legend. Select Insert > Legend. The 
result is in Figure 29. 

Figure 29: XY scatter plot with two data series
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Modifying the appearance of the chart

Editing and moving elements of the graph or chart

In Figure 29 the legend has a gray background and it uses too much space on the right-hand 
side of the figure. We can change the background of the legend by Format > Legend > Area 
and choosing a color. We will pick white.

There are two ways to move the legend. When we inserted the legend we were offered a 
choice of four different positions for the legend, Top, Bottom, Left, Right. 

It is also possible to move various elements of a chart or graph; the main chart area, the 
legend, the main title or the axes labels by clicking on Edit, selecting them with the mouse 
and dragging them. This is what we did inFigure 30, moving the main body of the graph and 
the x-axis label up and to the right and then moving the legend and the title.

Figure 30: XY scatter plot with moved graph elements

XY – Line graph

As shown in Figure 19 we also can have line graphs. To do this using the data from the table 
in Figure 28:

1) Select the data and labels to be used as shown in the graph (Figure 31).

2) Create the line graph by clicking on the Chart icon in the main menu bar (see Figure
4), selecting the XY chart and then the Lines with Symbols variant.

3) Add the Title and axes labels as we have done for the scatter plot example above.

Ideally we would have simply changed the Chart Type from Scatter plot to Line with symbol, 
but Calc currently does not seem to sort a data series that is added to a graph.
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Modifying the appearance of the chart

Figure 31: Data selected to create an XY-Line with 
symbols graph

This produces the line graph in Figure 32. 

Figure 32: XY-line graph 

Secondary y-axes

You may want to have a chart or graph with more than one y-axis.  This can be very useful 
when you wish to compare trends in two or more data series but where the y-axis scales are 
very different. 

We will use a table of made-up data (Figure 33) showing the number of hikers and the 
average temperature (in Celsius) in a park over a 6-month period to demonstrate this.
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Modifying the appearance of the chart

Figure 33: Table of data to illustrate the 
use of a secondary y-axis

Plotting the data in this table produces a chart that gives a view of the trends in temperatures 
and the number of hikers per month, but the scale is such that we cannot easily see the 
changes in temperature since the temperature line is rather crushed down in the bottom of the 
chart. 

Figure 34: Line chart with a single y-axis

We have done some basic formatting, but we did not add a y-axis label because we have two 
different data series (Temp and Hikers) with two different kinds of scale, Degrees Celsius, 
and Number of Hikers.

A better approach is to graph the two data series, Temp and Hikers, against two y-axes. To do 
this:

1) Right-click on the chart and select Edit. 

2) Double-click on the data series you wish to plot against a different y-axis, select 
Option > Align to second y-axis and click OK. 

The result is shown in the chart in Figure 35.
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Modifying the appearance of the chart

Figure 35: Line chart with primary and secondary y-axes

This change in the plotting scale for the Temp gives a much better idea of the relationship 
between the temperature and the number of hikers in the park. It seems to suggest that most 
hikers are wimps and don’t hike in cold weather. 

Minor formatting

Changing line colors

Double-click on a line to format it. You can also double-click on the data points to format 
them to some extent.

In Figure 32 notice that the yellow line for Madrid is quite hard to see. To change the color of 
that line, select  Edit, hover the cursor over the line until Data Series Madrid appears, and 
then double-click on the line. Then under the Line tab, pick a better color. In Figure 36 we 
have picked sea blue.
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Modifying the appearance of the chart

Figure 36: Changing the color of the plotting lines and symbols

We can also use this approach to have one data series as a scatter plot and another as a line 
We also can change the plotting symbols and lines on the same screen. See Figure 37 for 
some ideas.

Figure 37: Various line and symbol options 

Creating Charts and Graphs 21



Modifying the appearance of the chart

Modifying axes scales

We used the data in Figure 33 and selected  it as we did in Figure 2 to plot Monthly Rentals: 
Canoes vs Boats as an XY scatter plot. We have used the standard Calc defaults, except we 
added a Title to the graph.

Figure 38: XY scatter plot of data from Figure 33

Figure 38 is not all that good as a graph. We are going to make a number of changes to 
improve its appearance:

• Change the x-and y-axes so that the data points that now are lying right on the edges of 
the graph are easier to see.

• Add x- and y- axis labels and a subtitle.

• Get rid of the legend since it is not needed in this situation.

Some of these we have already seen above.

To change the axes scales:

1) Double-click on the graph or Right Click > Edit.

2) Select Format > Axis > X Axis or Right Click > Axis > X Axis.

3) Uncheck the Automatic boxes.

4) Input 5 for minimum, 20 for maximum, and 5 for major interval.

5) Repeat steps 1–3 for the y-axis and input 16 for the minimum, 32 for the maximum, 
and 4 for the major interval.
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Modifying the appearance of the chart

Adding subtitles, and axis labels

To add a subtitle and add axis labels:

1) Double-click on the graph or Right Click > Edit.

2) Select Insert > Title.

3) Check the box next to Subtitle and enter Year to Date.

4) For the axis labels, check the box next to the appropriate axis and enter Canoe for the 
x-axis and Boat for the y-axis.

Removing the legend

In this graph, the legend is unnecessary. To remove it:

1) Double-click on the graph or Right Click > Edit.

2) Select Insert > Legend and uncheck Display.

All of this produces the graph in Figure 39 which is a great improvement, but in a graph like 
this it would be very valuable to know that each data point represented. 

Figure 39: Modified XY chart showing added axes labels,  
subtitle and modified axes scales

Data labels

While it appears that canoe and boat rentals do not move smoothly together, we do not have 
the monthly data to make better use of the information in the graph. To see what each point in 
the graph in Figure 39 represents, we can add labels to the individual points, that is, we will 
add the names of the months to the individual data points  To do this:

1) Double-click on the graph or Right Click > Edit.

2) Select Insert > Data Labels.
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Modifying the appearance of the chart

3) Check the Label Text box.

This gives the graph in Figure 40.

Figure 40: XY graph with data labels

Axis labels

Calc offers several ways to adjust axis labels. Figure 41 has used the data from Figure 33 to 
create a column chart and rotated the labels roughly 45 degrees by going Format > X Axis > 
Label and rotating the text. Other tabs allow you to modify fonts and other formattin.

Figure 41: Column chart with rotated axis labels
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Modifying the appearance of the chart

Error bars

You can fit various types of error bars to a data series in a column/bar chart or an XY graph. 
To do this:

1) Select a data series by Edit and then select one of the data series and double-click as 
when selecting a line for editing.

2) Then go Insert > Statistics and  click on the error type and symbol type desired.

The result is shown in Figure 42.

Figure 42: Bar chart with series error bars 

Note that these error bars are calculated on the entire data series; that is, the error bars are 
equal at each point of the chart. 
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